15:30:59 <abompard> #startmeeting standup
15:30:59 <zodbot> Meeting started Tue Jan 14 15:30:59 2020 UTC.
15:30:59 <zodbot> This meeting is logged and archived in a public location.
15:30:59 <zodbot> The chair is abompard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:30:59 <zodbot> The meeting name has been set to 'standup'
15:31:13 <abompard> #topic Roll call
15:31:24 <sfinn> Hi all , how is everyone?
15:31:27 <abompard> You know the drill, say you're here by typing .hello2
15:31:30 <abompard> .hello2
15:31:31 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
15:31:36 <scoady> .hello2
15:31:37 <zodbot> scoady: scoady 'Stephen Coady' <scoady@redhat.com>
15:31:39 <sfinn> hello2
15:31:40 <abompard> hey sarah
15:31:45 <abompard> There's a dot in front
15:31:55 <sfinn> .hello2
15:31:56 <zodbot> sfinn: sfinn 'Sarah Finn' <sfinn@redhat.com>
15:31:59 <abompard> nice :-)
15:32:12 <abompard> OK, who wants to go first?
15:32:18 <scoady> I can :)
15:32:24 <abompard> #topic scoady
15:32:28 <abompard> go ahead! :-)
15:33:15 <scoady> I got free ipa running in a container (finally) and after some serious struggle with SELinux and podman. But its working and I'm fairly sure I could get it running for anyone else through docs.
15:33:31 <relrod> hello
15:33:48 <scoady> So now I just need to create a podman-compose file with both securitas and free-ipa and we should have an environment
15:34:12 <abompard> cool!
15:34:58 <abompard> is it all scoady?
15:35:08 <scoady> sorry yes thats me
15:35:15 <abompard> cool. Who's next?
15:35:23 <relrod> I'll go
15:35:27 <abompard> #topic relrod
15:35:38 <abompard> you have the floor
15:36:22 <relrod> I talked with puiterwijk and Christian from the IPA team and worked out the best way forward for dealing with our current IPA boxen. The idea is basically: Wait until RHEL 8.2 comes out (Real Soon Now) and then install an IPA box on it, set it up as a replica, then tear down the current el7 env
15:36:56 <relrod> EL8.2 will have the version of IPA we need with the group sponsor stuff, etc
15:37:07 <relrod> EOF
15:37:12 <abompard> cool, thanks!
15:37:32 <abompard> Sarah, do you want to go next or should I?
15:37:40 <abompard> sfinn: ^
15:37:42 <sfinn> You work away
15:37:45 <abompard> OK :-)
15:37:49 <abompard> #topic abompard
15:37:52 <sfinn> Great work scoady !
15:38:25 <abompard> Some of my PRs were merged, thanks to relrod who reviewed them
15:39:05 <abompard> I've started working on a couple minor things like getting our docs in readthedocs.org for example
15:39:20 <abompard> it's setup but I don't have the permissions to setup the webhook to rebuild on each commit
15:39:44 <abompard> so I'll need relrod again do either set it up or give me the permissions to set it up
15:40:16 <abompard> I've also opened a ticket about using MyPy and I'd love to have the team's input on that
15:40:29 <abompard> #link https://github.com/fedora-infra/securitas/issues/69
15:40:51 <sfinn> sounds good relrod , how soon is soon? Ballpark date? Are we blocked on IPA until then? What impact will that have, in sense are we blocked on working on other user stories until that is resolved?
15:41:35 <abompard> I've also started investigating what we can do for unit testing with VCR and whatnot, at ryanlerch's request
15:41:40 <abompard> And that's all for me I think
15:42:00 <sfinn> What is the ticket number for MyPy ticket?
15:42:17 <abompard> sfinn: it's number 69, that's the link I pasted (for convenience :-) )
15:42:46 <abompard> #topic Questions
15:42:49 <abompard> (I guess)
15:42:52 <sfinn> Ah just saw that there , thanks a mill.
15:43:11 <sfinn> Can you all review and add comments on the ticket
15:43:14 <abompard> (we don't have a meeting structure yet so feel free to set topic)
15:43:23 <sfinn> I'll go next#
15:43:32 <abompard> #topic sfinn
15:45:16 <sfinn> I need to review wireframes for ryanlerch and draft a guide on how we do that. I will get it done by COB today. relrod I am hoping to catch up with you tomorrow to look at backlog for next sprint, on our call later we can look at times that suit.
15:46:13 <sfinn> Looking at our board now we have 3 in progress, 2 blocked and 1 to do.. and lots in review for me :).. regarding blocked tickets , any moment on these since yesterday
15:46:24 <sfinn> movement
15:46:56 <abompard> sfinn: yes, one of my PRs that was blocking the other was merged, so they got unblocked
15:47:15 <abompard> the block item that's assigned to me is waiting on setup by the CentOS CI folks
15:47:43 <abompard> as for the other one, it's Ryan's
15:47:55 <sfinn> Great can you move it to in progress if work needs to be done or testing or review lane which ever suits it's current status
15:48:05 <abompard> and I think he's blocked by the developer environment ticket that scoady is working on
15:48:33 <sfinn> OK scoady I think you made progress with that today, did you?
15:48:36 <abompard> For my item (#63) there isn't much we can do
15:48:48 <abompard> (except maybe ping them again?)
15:49:45 <skylink> [securitas] sfinn85 commented on issue #63: Ok , lets create a subtask for this ,is that possible on github? https://da.gd/y5Wk
15:49:57 <scoady> sfinn, I did. Hoping to at least have something that ryan can use when he comes online in the morning - not sure if it will unblock him though
15:50:16 <sfinn> Cool thanks abompard , I commented on the task, we might create a subtask for it
15:50:26 <abompard> sfinn: sure
15:50:42 <sfinn> cool, thanks scoady .. fingers crossed :)!
15:50:58 <sfinn> Thanks for the efforts everyone.. A1 !
15:51:14 <abompard> Yeah thanks!
15:51:37 <abompard> Let's close the standup here shall we?
15:51:40 <sfinn> I am conscious of time, can we do our update on our user stories and share link here?
15:51:48 <sfinn> on our stand up tomorrow
15:52:26 <abompard> sfinn: I'm not sure I understand what you have in mind?
15:52:48 <abompard> you mean every day we comment on the issues themselves?
15:52:56 <sfinn> So before the stand up, add a comment with the status on the user story. On the stand up, when it's you turn share link to the user story, we will review the comment and discuss here if it needs discussion
15:53:51 <sfinn> Yep,its basically what ye are flagging here but on the actual story as a comment.. thoughts?
15:54:18 <abompard> sfinn: I can try and do that, but it feels like it will "pollute" the issue with statuses
15:54:52 <abompard> I've never tried it so maybe I'm wrong there
15:55:11 <scoady> yeah I am trying to see advantages/disadvantages. you obviously have keeping the history in mind. we can try it and see how it goes?
15:55:33 <sfinn> Let's have a go and see , its all about at any point the user story has the latest update.
15:55:50 <abompard> sure
15:56:27 <sfinn> So when Ryan logs on tomorrow, he can go directly to his ticket, see Stephens comment instead of looking through this channel or private convo
15:56:59 <sfinn> Chat tomorrow , thanks all
15:57:08 <scoady> see you late
15:57:09 <scoady> r
15:57:18 <abompard> but ryan's ticket is not stephen's ticket, so... anyway, let's try it :-)
15:57:38 <abompard> #agreed before the stand up, add a comment with the status on the user story. On the stand up, when it's you turn share link to the user story, we will review the comment and discuss here if it needs discussion
15:57:42 <abompard> #endmeeting