09:16:59 <abompard> #startmeeting standup
09:16:59 <zodbot> Meeting started Wed Jan 15 09:16:59 2020 UTC.
09:16:59 <zodbot> This meeting is logged and archived in a public location.
09:16:59 <zodbot> The chair is abompard. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:16:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:16:59 <zodbot> The meeting name has been set to 'standup'
09:17:05 <abompard> .hello2
09:17:06 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
09:17:12 <ryanlerch> .hello ryanlerch
09:17:13 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
09:17:18 <abompard> (actually it works the same but it'll be recorded ;-) )
09:17:39 <sfinn> scoady, just filled me in on zodbot.. pretty cool
09:17:40 <scoady> .hello2
09:17:43 <zodbot> scoady: scoady 'Stephen Coady' <scoady@redhat.com>
09:17:47 <jrichardson> .hello2
09:17:47 <zodbot> jrichardson: jrichardson 'James Richardson' <jamricha@redhat.com>
09:17:56 <abompard> hello everyone :-)
09:18:02 <sfinn> OK, who would like to go first?
09:18:19 <abompard> ryanlerch what about you?
09:18:23 <ryanlerch> sure!
09:18:35 <abompard> #topic ryanlerch
09:19:07 <ryanlerch> so, this morning i tried to get freeipa working in the container using scoady 's instructions
09:19:28 <ryanlerch> aaaand, i could not get ti working
09:19:34 * scoady runs
09:20:12 <ryanlerch> i do, now however have an almost working vargant box with freeipa, securitas and freeipa-fas installed
09:20:21 <scoady> ryanlerch, do you want to sync up after this to see what went wrong?
09:20:22 <scoady> oh, wow
09:20:50 <ryanlerch> so after the meeting will file that as a PR, and then work on the tests a biut more
09:21:05 <ryanlerch> that is me done
09:21:10 <abompard> Thanks ryanlerch
09:21:14 <abompard> any questions?
09:21:33 <sfinn> No all good from my side, thanks Ryan
09:21:50 <sfinn> I will go next
09:21:56 <abompard> #topic sfinn
09:23:01 <sfinn> I reviewed the user stories in the review lane and added comments. Also what is the actual email for devel email list I need to reach out to flag this project?
09:23:21 <abompard> devel@lists.fedoraproject.org
09:23:43 <sfinn> Perfect thanks a mill. That's it from me
09:23:46 <scoady> I can go next
09:23:51 <abompard> #topic scoady
09:24:50 <scoady> My update is similar to yesterday in that I got the two containers up locally. DNS is tricky with freeipa so if Ryan's solution doesn't have problems there I'm happy to go with that. Thanks for that ryanlerch and sorry my container instructions didn't work for some reason
09:25:56 <scoady> eom
09:25:59 <abompard> OK thanks. Questions?
09:26:08 <jrichardson> I can go next
09:26:15 <abompard> #topic jrichardson
09:27:52 <jrichardson> Hi everyone, just wanted to introduce myself to the group. I'm a mature student here in Waterford doing my internship. I've been leaning into FreeIPA this week as well as a side project working with Sonarqube. Looking forward to helpng out soon
09:28:11 <abompard> very cool, welcome jrichardson
09:28:17 <jrichardson> thanks
09:28:34 <abompard> Alright I'll go next, it'll be short
09:28:39 <abompard> #topic abompard
09:28:54 <abompard> Since yesterday's standup I had mostly... a meeting ;-)
09:29:04 <abompard> I've also investigated possible use of VCR for unit tests
09:29:10 <abompard> to mock out freeipa
09:29:13 <abompard> I think we can use it
09:29:41 <abompard> I just need to make sure it won't mock the requests that the testing client does to the flask backend, otherwise the tests would be pretty useless
09:29:55 <abompard> but they must have thought of that
09:30:08 <abompard> and I'm not even sure that the testing client does actual requests
09:30:14 <abompard> so it should be fine
09:30:33 <abompard> Depending on the freeipa setup we end up with in our dev environment, I'll setup VCR
09:30:45 <abompard> it seems pretty easy
09:31:11 <abompard> #link for reference: https://vcrpy.readthedocs.io/en/latest/usage.html
09:31:22 <abompard> and that's all for me
09:31:26 <ryanlerch> awesome, abompard we can chat on all this more after the meeting?
09:31:34 <abompard> absolutely ryanlerch
09:31:38 * ryanlerch has questions :)
09:31:42 <abompard> great :-)
09:31:51 <abompard> Anybody else? Or more questions?
09:31:54 <sfinn> Great to have you on the team  jrichardson. Cool sounds good, thanks abompard, thanks for sharing the ref! Sorry another quick update from me, I reached out to Rick yesterday, he will review the backlog and prioritise the user stories for the next sprint in the next day or two, ahead of our sprint planning call. I'm also thinking of looking at an alternative plan/time for sprint planning, that it is not outside working hours for most. Leave it with me :)
09:32:03 <ryanlerch> i haver a quick note for the end too
09:32:25 <scoady> great thanks sfinn
09:32:26 <jrichardson> cheers sfinn
09:32:28 <abompard> Oh that'd be great
09:32:44 <abompard> #action relrod will review and prioritize the user stories backlog
09:33:02 <abompard> #action sfinn is looking at an alternative time for sprint planning
09:33:12 <abompard> #topic open floor
09:33:18 <sfinn> No prob :).. anyone blocked on anything they are unsure of how to go about unblocking?
09:33:19 <ryanlerch> tomorrow is my last day before a week of PTO
09:33:23 <abompard> ryanlerch: go ahead with the quick note
09:34:03 <ryanlerch> that is my note
09:34:11 <abompard> #info ryanlerch will be on PTO for a week starting tomorrow evening (his TZ)
09:34:50 <ryanlerch> depending on the state of the tests PR, i might have to hand that over to someone tomoorw night
09:34:57 <ryanlerch> EOM
09:35:07 <sfinn> Thanks ryanlerch .. lets reach out this morning on the user stories for review to see if we can move them to done
09:35:13 <abompard> ryanlerch: OK. I may be able to take it
09:35:19 <abompard> if noone else wants it
09:35:40 <scoady> yeah i can help too, seeing as you've blitzed the dev environment :)
09:35:52 <abompard> #action sfinn and ryanlerch to sync on user stories under review
09:36:00 <sfinn> Love it.. Team work makes the dream work!
09:36:27 <sfinn> OK will we wrap it up.. 6 mins over :)
09:36:33 <abompard> OK!
09:36:37 <abompard> #endmeeting