14:07:26 <mkonecny> #startmeeting Fedora Infrastructure Sustaining Daily Standup Meeting
14:07:26 <zodbot> Meeting started Wed Mar 11 14:07:26 2020 UTC.
14:07:26 <zodbot> This meeting is logged and archived in a public location.
14:07:26 <zodbot> The chair is mkonecny. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:07:26 <zodbot> The meeting name has been set to 'fedora_infrastructure_sustaining_daily_standup_meeting'
14:07:26 <mkonecny> #chair cverna mkonecny siddharthvipul jednorozec mboddu
14:07:26 <zodbot> Current chairs: cverna jednorozec mboddu mkonecny siddharthvipul
14:07:26 <mkonecny> #info meeting is 30 minutes MAX. At the end of 30, its stops
14:07:26 <mkonecny> #info agenda is at https://board.net/p/fedora-infra-daily
14:07:32 <mkonecny> Now it's correct
14:07:37 <mboddu> .hello mohanboddu
14:07:38 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
14:07:38 <siddharthvipul> \o/
14:07:42 <mboddu> mkonecny: Yup :)
14:07:43 <siddharthvipul> .hello siddharthvipul1
14:07:44 <zodbot> siddharthvipul: siddharthvipul1 'Vipul Siddharth' <siddharthvipul1@gmail.com>
14:07:47 <jednorozec> .hello humaton
14:07:48 <zodbot> jednorozec: humaton 'Tomáš Hrčka' <thrcka@redhat.com>
14:07:56 <mkonecny> .hello zlopez
14:07:57 <zodbot> mkonecny: zlopez 'Michal Konečný' <michal.konecny@packetseekers.eu>
14:08:34 <mkonecny> #topic Item needing reviews
14:08:48 <mkonecny> https://github.com/fedora-infra/mbbox/pull/9
14:08:51 <mboddu> Oh, I have one, but its wip right now
14:09:06 <mkonecny> This one is currently in review lrossett and siddharthvipul are looking at it
14:09:12 <mboddu> https://pagure.io/releng/compose-tracker/pull-request/34
14:09:16 * cverna[m] is around now
14:09:23 <mkonecny> hi cverna[m]
14:09:24 <mboddu> cverna[m], jednorozec : ^
14:09:26 <siddharthvipul> #action /me will review mbox:9
14:09:44 <cverna[m]> mboddu: can look at that later :)
14:09:53 <praiskup> abompard, some message storm is in my client now, thanks
14:10:06 <abompard> praiskup: link is up again, message should be flowing
14:10:13 <mboddu> cverna[m]: FYI, its still WIP, I need to add arch and unit tests
14:10:18 <cverna[m]> abompard++
14:10:29 <mkonecny> Anything else needing review?
14:10:31 <jednorozec> mboddu, I can look at it in the evening.
14:10:37 <mboddu> s/arch/arch level filtering/
14:10:50 <mboddu> Thanks jednorozec
14:11:52 <mkonecny> moving on
14:11:53 <mkonecny> #topic Work In Progress
14:12:27 <siddharthvipul> I hit some issues with kickstarter links for os (more arches in cico)
14:12:41 <mkonecny> We had meeting with lrossett and siddharthvipul today about mbbox progress
14:12:41 <cverna[m]> bodhi 5.2 for me and i started working on the fedora-messaging message schema for koji
14:12:43 * jednorozec while writing unit tests I have realized multiple flaws in my FMC service approach. Re-factoring in progress. RelEng tickets.
14:12:47 <siddharthvipul> so working on that, I am pretty sure it will be solved soon
14:13:12 <mkonecny> I finished the Operator SDK dev env and we will start working on operator implementation soon
14:14:18 <mkonecny> #topic Blockers
14:14:50 <mkonecny> I have one question, does koji and mbs release a container build?
14:15:04 <mkonecny> This could be a potential blocker for one task in mbbox
14:15:47 <cverna[m]> I don't think so
14:15:53 <mboddu> mkonecny: release a container build?
14:16:06 <mboddu> cverna[m]: Only bodhi can release them out
14:16:07 <cverna[m]> if by container build you mean a container image ready to use
14:16:15 <mboddu> Sorry, mkonecny ^^
14:16:30 <mkonecny> mboddu: Building a container image when releasing a new version
14:16:40 <cverna[m]> mkonecny:  ok so for sure no
14:17:14 <mkonecny> Ok, if we create a Dockerfile, we should do it, it will make automatic upgrades using operators much easier
14:17:42 <mkonecny> It will be also nice to have it somewhere public
14:17:57 <cverna[m]> mkonecny: we should check we the koji developers if that's something they are interested in
14:18:05 <cverna[m]> mkonecny: we could contribute that upstream
14:18:17 <mkonecny> cverna[m]: good idea
14:18:33 <mkonecny> I will create a new tasks for this in mbbox project
14:18:48 <cverna[m]> +1
14:20:22 <mkonecny> I have one other thing to consider, should we go with ansible or python operator with mbbox
14:20:39 <mkonecny> As far as I see the ansible one is most documented
14:21:17 <cverna[m]> it is hard to say without knowing more :)
14:21:39 <cverna[m]> I guess python will be a bit more flexible, but is it needed ?
14:22:09 <mkonecny> It's not official and the API is not very well documented
14:22:57 <cverna[m]> ok then let's go with ansible then :)
14:22:58 <mkonecny> The output will be the same for both ansible and python, we will have a bunch of custom resource definitions (CRD) files
14:23:33 <mkonecny> Which is literally the definition of whole operator
14:24:05 <mkonecny> I'm also for the ansible, it shouldn't be hard to switch in the future
14:24:29 <mkonecny> Ok, this is everything from me
14:24:44 <mkonecny> Anybody else has any blocker or thing to discuss?
14:25:36 <cverna[m]> yeah, I ll try to attend as much the standup as I can but here in Poland they are closing all the school for 2 weeks
14:25:57 <cverna[m]> because of COVID-19 which means I ll have the 2 kids at home full time ;P
14:25:58 <mkonecny> Same here in czech, but I don't have any kids
14:26:25 <cverna[m]> so yeah it might take some time for me to answer :)
14:26:30 <mkonecny> I could run the meeting, if you aren't around
14:26:43 <mkonecny> No problem
14:26:49 <fm-admin> pagure.issue.comment.added -- jimbair commented on ticket fedora-infrastructure#8736: "Communishift Volume Claim" https://pagure.io/fedora-infrastructure/issue/8736#comment-632489
14:26:53 <cverna[m]> thanks ;)
14:27:04 <mkonecny> #topic Ending meeting
14:27:04 <mkonecny> #info Thank you all for coming. See you next business day.
14:27:05 <cverna[m]> that's all from me
14:27:09 <smooge> thanks
14:27:12 <mkonecny> #endmeeting