18:33:38 <mmcgrath> #startmeeting FAB
18:33:38 <zodbot> Meeting started Tue Aug 17 18:33:38 2010 UTC.  The chair is mmcgrath. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:33:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:33:38 <abadger1999> heh :-)
18:33:41 <mmcgrath> we can at least do that.
18:33:46 <mizmo> ubuntu - goals = whatever mr shuttleworth wants
18:33:56 <mizmo> debian - goals = we'll get somewhere eventually in an organic way
18:33:58 <mmcgrath> #link http://toshio.fedorapeople.org/orgchart.svg
18:34:05 <mizmo> gnome - goals = oh boy
18:34:15 <abadger1999> Perhaps -- we could try to think of good examples instead of counter examples? ;-)
18:34:22 <mmcgrath> abadger1999: sorry did you think the board should or should not be setting goals for the OS.
18:34:24 <mizmo> gnome has a similar polished product vs bucket of parts issue
18:34:33 <mizmo> abadger1999, what i'm trying to point out is that i don't think any floss projects do it right
18:34:38 <abadger1999> <nod>
18:34:42 <mizmo> so proprietary models i think is all we can look to inode0
18:34:45 <mizmo> fwiw
18:34:47 <abadger1999> Does anyone do it better?  Or better in some area?
18:34:59 <mizmo> maybe firefox
18:35:14 <mizmo> firefox ends up with a well marketed and polished product in the end
18:35:17 <mizmo> but i dont know how they get there
18:35:20 * inode0 is about as sad as inode0 can get hearing that from the Fedora Board
18:35:30 <mizmo> inode0, im not speaking for the board im speaking for myself
18:35:37 <mmcgrath> inode0: the board isn't actually here :)
18:35:40 <mizmo> inode0, if you have any examples pleas feel free to offer them up
18:35:55 * mizmo doesn't know enough about firefox to use that
18:36:08 <mizmo> chromium of course is another example of doing it wrong
18:36:16 <mizmo> it seems like if you have a strong vision you do the floss bits wrong
18:36:28 <mmcgrath> mizmo: I've got a blog post coming later this week about that very thing :)
18:36:37 <mizmo> mmcgrath, is it either/or ? :(
18:36:51 <mmcgrath> naw, just a comment on the current state of the stack.
18:37:02 <nirik> could we perhaps enumerate the places/things our current model fails at? ie, what needs to be fixed?
18:37:13 <mmcgrath> where lots of places are using core free(bsd)ish and them getting more proprietary as they get closer to the user.
18:37:15 <nirik> - no clear idea which body to go to for something?
18:37:30 <mizmo> - there is no clear vision as to what fedora actually is, so designing a nice website and other marketing collateral is a nightmare
18:37:42 <mmcgrath> mizmo: I'm convinced we won't ever get that.
18:37:42 <inode0> we are an example of doing it wrong too - so stop discarding everything in the world that isn't perfect please
18:37:45 <rbergeron> I think it would be wise to actually frame strategy in way where the community can actually participate in the steps leading up to the decisions of the strategy.
18:37:51 <rbergeron> that includes things like:
18:38:08 <rbergeron> * figuring out who we are today - which includes figuring out data, talking to people, actually listening...
18:38:28 <mmcgrath> I think we should just start over.
18:38:33 <rbergeron> * talking about the various places we want to be 2 years from now, and 5 years from now - and letting people who want to run off on those tangents do so, and present those elements.
18:38:42 <mmcgrath> once we get to Fedora 15, call it off.  Re name, re brand, re org and re-do everything.
18:38:58 <mizmo> rbergeron, to an extent a lot of that has been done
18:39:00 <rbergeron> when we know what we want to do - where we want to be 5 years from now - figure out what those steps are to doing that.
18:39:18 <mizmo> the problem is there are at least 3 main opinions on where we want to be 5 years from now and it's not exactly something that can be reconciled
18:39:26 <mizmo> we have tons of data on where we are at now
18:39:51 <inode0> see this one point we get ourselves into trouble - I don't want you or anyone else deciding today where "we" want to be in 5 years
18:40:02 <rbergeron> has that been presented in a concise fashion - so that we know who we are, and we know what is logical and feasible to get us to where we want to be in some period of time?
18:40:10 <mmcgrath> inode0: do you want us to have no 5 year plan at all?
18:40:33 <inode0> it would have to be a pretty fluffy plan
18:40:41 <rbergeron> All I've seen is that we have a user base and a vision - that doesn't define concrete goals - doesn't define any milestones.
18:40:43 <mizmo> inode0, certainly folks 5 year visions can be (and have been) discussed and clustered into the 3 main groups i mentioned
18:40:50 * rbergeron notes that pretty much every 5 year plan at every company changes every year
18:40:58 <mizmo> rbergeron, we don't have a vision, where have you seen that?
18:41:02 <inode0> because we have no idea where the community or technology will drive things in 5 years
18:41:04 <rbergeron> and it's not really 5 years, more like 3
18:41:22 <nirik> mizmo: what are the 3 main groups as you see them?
18:41:25 <mizmo> inode0, if nobody decides it, then nothing happens, then we are debian
18:41:28 <mizmo> inode0, i dont think we want to be debian
18:41:40 <mizmo> nirik, #1 hackers desktop #2 consumer's desktop #3 bucket of parts
18:41:43 <inode0> mizmo: how did we get here without one?
18:41:53 <mizmo> inode0, by ambling around in an unsustainable manner
18:41:59 <skvidal> mizmo: mmm legos
18:42:04 <rbergeron> okay, i retract the word vision - mission is what i mean
18:42:09 <mmcgrath> it worked much better when we were much smaller
18:42:19 * nirik wonders if we lost abadger1999 on this tangent.
18:42:24 <mizmo> inode0, we can keep ambling about in an unsustainable manner but since it's unsustainable it'll all dry up unless we do something
18:42:30 <abadger1999> nirik: Yep.
18:42:34 <nirik> abadger1999: what issues do you see in our current model that need fixing?
18:42:45 <inode0> mmcgrath: that is fine, scale doesn't mean we turn into a micromanaged from the top corporate structure though
18:42:55 <abadger1999> So we've been on this tangent for 10 minutes, can we sum up one thing to do and move on?
18:42:55 <inode0> if it does I don't much care
18:42:59 <mmcgrath> but does it mean we should be goal less?
18:43:28 <abadger1999> Like -- be on the lookout for governance ideas that are *good* in other FOSS projects.
18:43:34 <mizmo> abadger1999, summary: we have no idea what our goals or nor do we agree on what they should be. this is impeding progress on a number of fronts and resulting in contributor dissatisfaction and burnout
18:43:35 <nirik> abadger1999: yeah.
18:43:46 <mmcgrath> abadger1999: but most other FOSS projects are tiny compared to us
18:43:58 <mizmo> oh and we can't agree on how to set goals or who should set them
18:44:04 <abadger1999> mmcgrath: We'll figure out if scalability is a factor after the idea is pointed out :-)
18:44:33 <abadger1999> Okay so nirik's question is: problems with the current model.
18:44:40 <abadger1999> #topic problems with the current model
18:44:40 * rbergeron notes that goals are important - but our goals should define our target audience - and not vice versa.
18:44:40 <nirik> the problem if we pick one of those 3 groups you mentioned: the other 2 groups get shafted.
18:44:57 <abadger1999> mmcgrath: Could you chair all of us?
18:45:28 <mmcgrath> #chair nirik
18:45:28 <zodbot> Current chairs: mmcgrath nirik
18:45:28 <rbergeron> abadger1999: I think something reasonable to do would be for people to actually look at the governance models of other groups and list out points of what is good and bad .
18:45:30 <mmcgrath> #chair abadger1999
18:45:30 <zodbot> Current chairs: abadger1999 mmcgrath nirik
18:45:31 <mmcgrath> #chair inode0
18:45:31 <zodbot> Current chairs: abadger1999 inode0 mmcgrath nirik
18:45:35 <mmcgrath> #chair mizmo
18:45:35 <zodbot> Current chairs: abadger1999 inode0 mizmo mmcgrath nirik
18:45:38 <mmcgrath> #chair rbergeron
18:45:38 <zodbot> Current chairs: abadger1999 inode0 mizmo mmcgrath nirik rbergeron
18:45:42 <mmcgrath> #chair skvidal
18:45:42 <zodbot> Current chairs: abadger1999 inode0 mizmo mmcgrath nirik rbergeron skvidal
18:45:46 <mmcgrath> did I miss anyone?
18:46:17 <abadger1999> #action look at the governance models of other groups and list out points of what is good and bad
18:46:51 <nirik> I'm not against changing our governance... but I'd like it to be worth while and have a chance of addressing issues. Of course we need to know what those issues are..
18:46:52 <rbergeron> I think to have a list of what items there are to be observed might be a good way to have apples to apples comparisons - and not keep going down ratholes.
18:46:57 <mmcgrath> not to be a negative nancy, does anyone here have any confidence we'll have any changes organizationally in the next couple of years?
18:47:02 * mmcgrath doesn't
18:47:14 <mmcgrath> we've been working on it for a couple of years already with no changes.
18:47:23 <abadger1999> #topic Issues with the current model
18:47:25 <rbergeron> Having a list of what people think is wrong with our current governance model - and it doesn't have to be concensus at this point - just a freakin list - would be valueable.
18:47:43 <rbergeron> Something with sentences that are fairly short - and not a mailing list thread that is 100 pages long.
18:47:49 <nirik> well...
18:48:00 <mmcgrath> #idea no one is responsible for planning what n+1 should be.  much less n+2 or n+3.
18:48:01 <nirik> * confusion as to which body to address for some issues.
18:48:01 <rbergeron> #1) Do we have a problem
18:48:06 <mmcgrath> 1) yes
18:48:14 <rbergeron> #2) What are the problems
18:48:23 <mmcgrath> 2) people don't want what we're building.
18:48:32 <mizmo> 2) we don't even know what we're building
18:48:41 <abadger1999> #info confusion as to which body to address for some issues.
18:48:44 <mizmo> 2) there's apparently no clear ownership of who gets to decide what we build
18:48:58 <nirik> "a Linux-based operating system that provides users with access to the latest free and open source software, in a stable, secure and easy to manage form"
18:49:12 <abadger1999> #info confusion  as to which body to run for/vote for in order to influence the action taken on an issue
18:49:13 * inode0 just wants to make the observation that it isn't the governance model that is the root cause the problems - changes might help, but aren't a solution
18:49:21 <mmcgrath> nirik: conflicting ideas there.
18:49:36 <nirik> mmcgrath: yep.
18:49:40 <mmcgrath> secure and easy for one, and latest and stable :)
18:49:43 <nirik> so that means someone has to decide the tradeoff
18:49:49 <mizmo> nirik, if only it were that simple :(
18:50:06 <mmcgrath> yeah, we're not really in charge of our future there unfortunately
18:50:07 <abadger1999> mizmo: Can I rephrase you're #2 as Who decides what we're building?  I think we're more thinking about the structure than the actual plan for the distro.
18:50:14 <nirik> mizmo: yeah, I know we have had this discussion before. ;)
18:50:16 <mmcgrath> that makes it difficult for Fedora like it does with no other distribution.
18:50:21 <mizmo> abadger1999, sure
18:50:45 <abadger1999> #info Who decides what we're building?
18:51:11 <abadger1999> #info who mediates the tradeoffs when aspects of the vision conflict
18:53:14 <nirik> can we expand on the 'Who decides what we're building?' In what sense? you mean who are we building for? or specific packages? or ?
18:53:25 <abadger1999> I want to put something in about should someone be representing the contributors?
18:53:27 * rdieter stumbles in. hi.  reading backlog.
18:53:31 <rbergeron> and #3 - how do other communities circumvent these problems - what are good and bad points of governance models and strategy decision making in other communities - how can we pluck the good parts and apply them to fedora - while still retaining a sense of being our own project - without adopting strategies and visions that do not differentiate us in some way?
18:53:44 <rbergeron> wow, that's like, 3, 4, 5, 6, 7 - 12, etc
18:53:54 <mizmo> i think in general its a challenge
18:53:59 <mizmo> i dont think anyone has solved it
18:54:24 <mizmo> its open design
18:54:46 <abadger1999> #info Who is charged with listening to contributor concerns and making sure they're addressed?
18:54:56 <rbergeron> nobody :)
18:55:09 <abadger1999> Right -- that's why it's an issue with the current system :-)
18:55:29 <mmcgrath> #info Who's charged with telling contributors their concerns won't be addressed.
18:55:34 <nirik> well, depends on the concern?
18:55:34 <mmcgrath> we can't please everyone.
18:55:34 <inode0> we've talked about an ombudsman before
18:55:36 <mizmo> the board does that
18:55:45 <mmcgrath> I've never seen the board actually do that :)
18:55:45 <mizmo> i hear contributor concerns quite frequently and bring them up in board meetings
18:55:57 <mizmo> for example, the private content in our phone meetings - and we worked out a solution to it
18:56:10 <nirik> I think if it's a technical thing fesco could, and if it's a more general thing board, and if they don't like the fesco answer they can go to the board?
18:56:19 * rbergeron notes that strategy in companies is somewhat different, yet somewhat similar - there is a chairman, there is a board - and there are shareholders who wield significant voting power to kick people out if they feel the company is going in the wrong places.
18:56:22 <abadger1999> #info the idea that the board is for strategy and fesco for tactical (when fesco is elected) seems prone to disaster.
18:56:36 <mmcgrath> in what way?
18:56:48 <mmcgrath> neither group should be charged with both.
18:57:43 <inode0> I don't have a problem with fesco being charged with both
18:57:51 <sgallagh> Perhaps the strategists should be elected by the constituency, but the tacticians should be at least partially appointed by the strategists
18:57:53 <mmcgrath> I do
18:57:55 <inode0> why is that a problem?
18:57:58 <mmcgrath> no oversite of any kind
18:58:06 <inode0> there can still be oversight
18:58:08 <mmcgrath> so if they're doing a crappy job, a good job, no one will even be looking.
18:58:15 <sgallagh> Term limits?
18:58:25 <rdieter> does strategy necessarily have to come from the top ?  Can't it come from SIGs/groups doing the work?
18:58:26 <abadger1999> mmcgrath: Just before we started logging with zodbot, mizmo nirik and I arrived at the conclusion that having one volunteer group decide on vision and expecting a different volunteer group implement it means that when the two groups conflict, the implementation won't get done or won't get done well.
18:58:28 <mmcgrath> besides, FESCo hasn't shown any ability to put forth strategy anyway.
18:58:30 <inode0> the board can have oversight
18:58:35 <mizmo> is fesco is a group of folks who are technical, i think charging fesco with both strategy and tactical is a bad idea
18:58:42 <mmcgrath> not that the board has done much better.
18:59:01 <mmcgrath> abadger1999: why is that a conflict, that sounds like an org charg.
18:59:04 <mmcgrath> err org chart.
18:59:05 <mizmo> abadger1999, mmcgrath: if the board does strategy and fesco does tactics, and each has a different conflicting vision, no useful work will be done was the point i made
18:59:17 <rdieter> kinds means that fedora in general has to be closer to the "bucket of parts" characterization
18:59:21 <mmcgrath> except that in that scenario fesco doesn't have a vision.
18:59:30 <mmcgrath> fesco works hard to turn board's plans into reality.
18:59:37 <nirik> it's hard to steer the boat from the engine room, but also hard to do so from the wheelhouse when the engine room people don't give you any power or someone weighs the anchor. ;)
18:59:38 <inode0> we are speaking in the abstract, fesco can be whatever we frame them to be once we know what they are supposed to be :)
18:59:40 <mmcgrath> that's how the infrastructure team works now generally.
19:00:17 <mmcgrath> we have some of our own goals and stuff but we're mostly here to facilitate the needs of others.
19:00:23 <abadger1999> mmcgrath: Diffference with infrastructure -- we aren't elected.
19:00:26 <mizmo> rdieter, i dont understand your point re bucket of parts?
19:00:27 <mmcgrath> when jesse says jump, I say how high.
19:00:30 <abadger1999> Instead we show up and work on what we want.
19:00:34 <mmcgrath> abadger1999: but we have a lot of volunteers.
19:00:37 <abadger1999> With certain people paid to fill in the gaps.
19:00:43 <mmcgrath> elected or not we're here to help.
19:00:57 <rdieter> mizmo: way back at the beginning...
19:01:00 <rdieter> you mentioned, [13:46] <mizmo> nirik, #1 hackers desktop #2 consumer's desktop #3 bucket of parts
19:01:01 <abadger1999> mmcgrath: With the board vs fesco, we've elected both bodies to be decision making entities.
19:01:15 <sgallagh> Might I suggest a completely different approach?
19:01:16 <mmcgrath> not quite
19:01:26 <nirik> abadger1999: wlel, partially in the case of the board (partially elected)
19:01:41 <mizmo> rdieter, right, but i dont get the point youre trying to make around that? "kinds means" <=?
19:01:48 <mmcgrath> I'm going on the record right now to say this:  We don't have what it takes to solve this problem.
19:02:00 <rbergeron> what do we need?
19:02:03 <nirik> mmcgrath: pessimist. ;)
19:02:14 <mmcgrath> rbergeron: I wish I knew, but we've been going on for years without progress.
19:02:20 * rbergeron grins
19:02:21 <mmcgrath> and it dawns on me I don't see any progress on the horizon.
19:02:37 <mmcgrath> meanwhile our own users have spoken, they don't want what we've got.
19:02:37 <rdieter> mizmo: my point was the work to any of that happen (including vision), doesn't come from the top or even fesco for the most part, but from individual teams, contributors, and SIGs.
19:02:45 <rdieter> to make any of that happen
19:03:07 <rdieter> maybe vision is a bad term here
19:03:22 <rdieter> plans for F+1, F+2, F+3 then.
19:03:25 <sgallagh> What if FESCo was not a unified body but a selection of positions being filled to accomplish a particular goal decided upon by the Board?
19:03:37 <mizmo> rdieter, to make any of what happen?
19:03:53 <rdieter> I thought part of your point was that fedora lacked vision and direction.
19:04:03 <rdieter> am I wrong?
19:04:38 <sgallagh> Instead of nine individual committee members, have three goals (per Fedora release) each with three members of FESCo voted in to oversee that those goals are met
19:04:47 <nirik> sgallagh: a bunch of czars? updates / package maintainer relations / features / etc?
19:04:59 <sgallagh> nirik: That could also work
19:05:02 <abadger1999> Okay -- seems like we're ready to move on from issues.
19:05:03 <nirik> sgallagh: an example goal being?
19:05:10 <abadger1999> Shall we move to brainstorming?
19:05:23 <abadger1999> #topic pie in the sky brainstorming
19:05:43 <mmcgrath> #idea - Kill Fedora after 15.  Re org, re brand, re design, re do everything from the ground up.
19:06:04 <sgallagh> Fedora 15: 1) Improve boot times, 2) Improve the quality of 3D support in video 3) Re-review packages to ensure they haven't gone out of compliance
19:06:05 <sgallagh> For example
19:06:06 <nirik> mmcgrath: how does that help? do you think we could have a better goal then?
19:06:20 <nirik> sgallagh: the problem with that is that we can't force that to happen.
19:06:25 <mmcgrath> nirik: beats me, I just know status quo isn't better
19:06:38 <nirik> sgallagh: I don't know anything about 3d graphics card programming. How can I make that happen in a specific release?
19:06:43 <walters> mmcgrath: i think we are providing something useful
19:06:46 <mmcgrath> I think FESCo and the boards history needs to be destroyed.
19:06:53 <mmcgrath> and completely re-thought.
19:07:12 <mmcgrath> no history, no what they did before.  Something completely different from what they are today.
19:07:14 <walters> mmcgrath: not that things couldn't be fixed, but we need fewer things that cause regressions
19:07:23 <sgallagh> nirik: That would be the duty of three FESCo folks to interface with the Nouveau and ATI xorg teams
19:07:26 <mmcgrath> if you want to talk about the OS, yes.  I agree.
19:07:33 <walters> oh
19:07:46 <mmcgrath> regressions are bad.  cowboy developers are bad too.  we've got lots of it.
19:07:47 <sgallagh> nirik: Also, those were just off-the-cuff examples.
19:07:48 <abadger1999> sgallagh: Would we vote those slots or assign them?
19:07:49 <mizmo> rdieter, yes i believe fedora lacks vision and direction
19:07:53 <rdieter> mmcgrath: nuclear option.  you're evil.
19:07:57 <walters> mmcgrath: so by "kill fedora" you mean...what exactly?
19:07:57 <nirik> sgallagh: the problem is that this is not a company. I can't take my budget and hire someone to work on goal X. If someone doesn't show up, we are just stuck.
19:08:04 <abadger1999> If you think we should vote them, what is the advantage there?
19:08:19 <sgallagh> abadger1999: I think that the board should propose a set of, say 10 goals and the community should vote on which three go into a release
19:08:28 <mmcgrath> rdieter: aren't you getting bored by now?  We've gone through this 15 times now.  The extras core merge was interesting.  But our dwindling numbers just make things dull.
19:08:44 <mmcgrath> walters: exactly that.  Fedora didn't exist before it was created, it can not exist after it's gone.
19:08:46 <nirik> fesco has only the power to say no, and the ability of it's members (and to a lesser extent the ability to ask for people to do something nicely)
19:09:01 <rdieter> mizmo: ok, I'm just saying that said vision/direction should come from those doing the work to produce stuff (desktop team, sigs), not necessarily from the board
19:09:24 <mizmo> rdieter, i dont determine the vision for the united states of america, i elect a president and representatives....
19:09:30 <mmcgrath> walters: I'm more advocating that small incremental changes aren't working for us here.
19:09:31 <rdieter> mizmo: unless said vision will magically help said groups get their work done better, be more efficient
19:09:49 <mmcgrath> so we need a large drastic change, since the topic is pie in the sky brainstorming.  I went straight to the sky.
19:09:50 <mizmo> rdieter, i dont really think a huge crowd of people is an efficient way to work out a cohesive and achievable vision for a product
19:09:52 <rbergeron> #idea instead of fixing governance models - instead of band-aiding a target audience that clearly people disagree with - have a separate (non-fesco, non-board) volunteer group figure out (a) what the best method is for the community to develop a strategy and vision - how to best get buy-in in development of a strategic plan from as many community members as possible - and figure out a timeline to executing the delivery of that plan...
19:10:04 <nirik> mmcgrath: I'm not opposed to the idea, if we can see that a new setup would help us with current issues or has a chance to, etc.
19:10:22 <abadger1999> rbergeron: Good idea.
19:10:30 <rdieter> mizmo: ok, I'd venture we disagree on that you see fedora as a single product or don't necessarily agree on the definition of what that produce is.
19:10:37 <inode0> mizmo: and see where that gets us
19:10:39 <mmcgrath> #idea get rid of the board and fesco.  Re create groups we actually need with clearly defined roles.  It might be 5 groups it might be 1 group.
19:10:39 <rdieter> man that came out bad.
19:10:57 <sgallagh> nirik: FESCo has the power to say no, correct. Which means they CAN say "no, we shouldn't accept this brand-new feature right now, this release's stated goal is stability" (for example)
19:11:02 <mizmo> rdieter, we cant even agree on what fedora is
19:11:09 <nirik> sgallagh: yep.
19:11:09 <mizmo> rdieter, this is crowd thinking
19:11:20 <mizmo> this fiefdom wnat sthis, that fiefdom wants that
19:11:30 <mizmo> i'll call them 'fedora dialects'
19:11:44 * inode0 largely agrees with rdieter
19:12:03 <rbergeron> I think our major problem is that (a) we have lack of community buy-in, and (b) I think we have some feelings in the community that the Board is not listening to the community.  If people aren't buying in, and they feel like they are not being heard, and they feel like they are shut out of participating in development of anything - they will never buy in.  Allow people to participate in parts of the process - even if they feel that the
19:12:07 <rdieter> ok, fair enough.  I tend to think that's fedora's strenth, it's diversity and fiefdom's.  esp in how they all work together
19:12:24 <sgallagh> Another pie-in-the-sky idea: why not stop producing Fedora as a distro entirely, and start giving more creative control to the individual SIGs for doing spins?
19:12:32 <abadger1999> mizmo: So something that I've been thinking lately that ties into this is that Ubuntu could not be successful without being able to build on Debian.
19:12:40 <abadger1999> #idea  Another pie-in-the-sky idea: why not stop producing Fedora as a distro entirely, and start giving more creative control to the individual SIGs for doing spins?
19:12:52 <sgallagh> Make "Fedora" a developer's tool, with a set of distros meeting each of the subgroup's needs
19:12:58 <mizmo> rdieter, fedora's strength is that is is a bazaar and a bucket of parts. fedora's weakness is that nobody outside of fedora wants that or cares about it
19:13:08 <rbergeron> how is that a weakness?
19:13:11 <rbergeron> do we need people to want us?
19:13:24 <mmcgrath> rbergeron: much to my dismay we do.
19:13:32 <sgallagh> Where by subgroups I mean the three groups mizmo mentioned before
19:13:32 * nirik for one doesn't want a narrow vision, but if fedora does, perhaps bite the bullet and folks not under that vision can look elsewhere for what they want. (which would be very sad, IMHO)
19:13:33 * mmcgrath argued that point a while back but ultimately decided I was wrong
19:13:36 <abadger1999> mizmo: Which, translated into Fedora would mean... We have a Fedora that's like Debian, perhaps we need to build an Ubuntu on top of that.
19:13:37 <mizmo> rbergeron, my goal in life is to make computers more useful for people via free software. if we don't care if people outside of fedora care about fedora, i quit
19:13:50 <mizmo> rbergeron, becausei obviously cannot achieve my personal goals with fedora in that case
19:13:50 <mmcgrath> nirik: what if that narrow vision was "fedora core as a platform"
19:13:56 <mizmo> and i dont like wasting my life
19:13:58 <mmcgrath> for other releases.
19:14:26 <nirik> mmcgrath: I'm not sure what that means, so not sure what I would say... ;)
19:14:54 * jsmith joins the discussion late
19:15:00 <rdieter> inode0: :)
19:15:01 <nirik> abadger1999: thats an interesting thought...
19:15:03 <mizmo> abadger1999, maybe
19:15:04 <rbergeron> so we cater to people outside the distro before we cater to our own?
19:15:09 <mizmo> abadger1999, mccann is proposing 'GNOME OS'
19:15:24 <jsmith> I think we need to realize that Fedora is more than the sum of its parts
19:15:25 <sgallagh> nirik: basically treat Fedora itself as a series of packages and have varying SIG-based distros atop that (similar to what Ubuntu does with Debian as a platform)
19:15:33 <mmcgrath> nirik: eh, I just thought it through to its natural conclusion and decided it was a crappy idea.
19:15:45 <nirik> sgallagh: yeah, so xfedora, lfedora, gnofedora ? ;)
19:15:53 <abadger1999> mizmo: <nod>  I heard that and I kinda like that if we can figure out how to do the Fedora is upstream of your distro better than Ubuntu/dDebian (or OLPC-Fedora :-(
19:16:04 <mmcgrath> nirik: I was thinking about making crit path packages and stripping it down even further.  To some core "linux" thing.  That stayed stable but generally new.  Then the sigs build upon that in their own silos.
19:16:06 <sgallagh> Well, you wink, but I'm not sure that's a bad idea
19:16:29 <walters> mmcgrath: isn't that effectively the current state?
19:16:51 <jsmith> No, not really
19:16:52 <sgallagh> walters: No, the current state is that we have a single silo from which you pull everything
19:16:59 * nirik goes to get coffee/lunch before the fesco meeting in 15min.
19:17:11 <sgallagh> There's a little bit of this idea in the livecd spins
19:17:21 <mizmo> abadger1999, we certainly put a lot of effort into making it easy to make things with fedora
19:17:23 <sgallagh> But I think we're talking about treating the different spins as projects in their own right
19:17:39 <abadger1999> nirik: Thanks nirik -- I'll need to bug you about the goals and operations idea later.
19:17:40 <sgallagh> And bringing Fedora itself into more of a developer's playground.
19:17:43 <mmcgrath> walters: no, we don't have the silos.  We have everyone stepping on eachothers toes trying to make one product with several conflicting goals.
19:17:46 <mizmo> to walters point how is it different htan spins
19:18:20 <nirik> I like the idea of spins where someone can try my thing out, but I hate them in that they are a weird and different way to install, and add complexity and choices.
19:18:20 <rdieter> at least it now clearly defines what feodra is
19:18:31 <nirik> abadger1999: anytime.
19:18:35 <rdieter> it is the upstream from which products/spins flow
19:18:37 * nirik goes for a bit...
19:19:42 <skvidal> mizmo: you're saying mccann is proposing gnome-os as the 'goal' of fedora?
19:20:20 <rdieter> skvidal: kudos for not letting that one slip by. ha.
19:20:27 <skvidal> ?
19:20:27 <abadger1999> I think he's proposing, a gnome-os distribution, based on fedora.
19:20:30 <mizmo> skvidal, i am guessing it will have nothing to do with fedora
19:20:43 <skvidal> mizmo: okay - then I think I missed some context
19:20:45 <abadger1999> Oh, well maybe with no fedora in it :-(
19:20:53 <skvidal> what was that apropos of?
19:21:11 <skvidal> hmm
19:21:12 <jsmith> In general, I'm wary of going down the "Fedora is just a set of repos" path
19:21:13 <skvidal> or rather
19:21:16 <skvidal> of what was that apropos
19:21:25 <walters> has anyone asked the people paying for fedora whether they're happy and/or what they would change?
19:21:39 <mizmo> skvidal, well we were talking about distros being a downstream of another distro and my guess is gnome os will be a downstream of some distro (not sure which one) - just trying to point out that it's a solution others are looking at too
19:21:39 <mmcgrath> jsmith: if we went the google route and did everything via the web, we'd even have windows users as Fedora users :)
19:22:03 <skvidal> walters: whom would you ask?
19:22:14 <jsmith> mmcgrath: Is the cure worse than the disease?
19:22:25 <skvidal> walters: b/c I think you'll get a different answer based on which portion of the org-chart you talk to
19:22:32 <inode0> do you mean the volunteers paying for it with their time?
19:22:34 <mizmo> walters, fedora is for fedora contributors
19:22:42 <mizmo> so i guess that is who youwould ask skvidal
19:22:42 <walters> skvidal: maybe, in any case it'd be data
19:22:52 <skvidal> walters: data?
19:22:54 <walters> mizmo: i don't think that's agreed on
19:22:59 <walters> skvidal: ask all of them
19:22:59 <mizmo> walters, i think that's the status quo though
19:23:04 <mizmo> walters, not something i'm really thrilled about
19:23:12 <walters> or some of them, ordered by how much money/time/people/whatever
19:23:20 <mmcgrath> jsmith: naw, it's just the future is all :)  Fedora itself will never make headway on devices, pads, phones, etc.  But if we had a strong web presence (like google apps but free) then we'd be positioned to be eveywhere.
19:23:35 <mizmo> inode0, im not a volunteer anymore. does that mean fedora isn't for me?
19:23:37 <sgallagh> walters: Outside of Red Hat, I don't think very many people are paid to work on *Fedora*
19:23:38 <skvidal> mizmo: honestly? I'd ask spot what pain he gets above him about what fedora is doing and what things he's being pushed to do
19:23:49 <sgallagh> I think people are paid to work on upstream projects
19:24:01 <inode0> mizmo: nope, I just want to know who walters is talking about when he suggests asking those paying for it
19:24:04 <sgallagh> And we want to build an environment that encourages them to do that THROUGH Fedora
19:24:13 <walters> inode0: like the money for fudcons
19:24:26 <skvidal> mizmo: b/c there's no good way to ask 'volunteers' really.
19:24:35 <mizmo> skvidal, i think the answer would be, 'boy would it be nice to have the mindshare we used to have'
19:24:37 <skvidal> mizmo: and zero way to ask users
19:24:37 <jsmith> mmcgrath: Right... but is being everywhere really our end game?  Are our developers/contributors passionate about building web-apps?
19:24:41 <skvidal> mizmo: used to have?
19:24:46 <skvidal> mizmo: you mean like with rhl?
19:24:49 <mizmo> skvidal, red hat linux days yep
19:25:07 <abadger1999> walters: So the way I understand it, that would be asking RH management what they get from Fedora.
19:25:11 <mizmo> more mindshare = more people using fedora as a development platform = more apps for fedora users = a better distro
19:25:13 <mmcgrath> jsmith: I think our current end game won't matter by the time we get there, we're about to get steamrolled in the next 5 years or so by companies like google.
19:25:13 <jsmith> mmcgrath: Personally, I'm fine if Fedora never makes headway on cell phones or music players.  That's not where we're concentrating our efforts.
19:25:23 <skvidal> mizmo: I think I've made pitches for that case before - but that tack is fraught with monsters
19:25:26 <abadger1999> Which, hopefully, we've been doing a good job of telling them for 6 years :-)
19:25:31 <walters> abadger1999: yes, or well not what they get, but how happy they are
19:25:36 <skvidal> jsmith: we're concentrating?
19:25:48 <skvidal> jsmith: where are we concentrating?
19:25:48 <mizmo> skvidal, which monsters?
19:26:09 <mizmo> are they susceptible to my zony laser?
19:26:17 <jsmith> skvidal: Wouldn't you say we're concentrating on x86-compatible machines?
19:26:19 <skvidal> mizmo: rhel-ish monsters, I suspect.
19:26:25 <skvidal> jsmith: that's not much of a focus
19:26:40 <skvidal> jsmith: that's like saying "we're targeting 'people'"
19:26:58 <skvidal> mizmo: b/c a big sell of rhl was the 3yrs of support/security for free :)
19:27:02 <mizmo> skvidal, targeting people works in grand theft auto
19:27:07 <walters> abadger1999: they might have said, but at least i personally have no idea really...
19:27:17 <jsmith> skvidal: Well, that was in response to mmcgrath saying we weren't making headway on "devices, pads, phones, etc."
19:27:31 <abadger1999> walters: Okay -- what does asking them if they're happy with what Fedora provides them give us?
19:27:41 * abadger1999 trying to make a # idea out of this.
19:27:44 <mizmo> skvidal, i think support/security for 1 year on the desktop is agreeable
19:27:50 <walters> abadger1999: i dunno; just data at first, maybe we can use that data for something
19:27:50 <mizmo> skvidal, there are ways to make that more palatable for users
19:27:53 <skvidal> jsmith: okay - well I have a laptop and a I have a server and i suspect that there  are a lot of people who would suggest tht those two do not have the same requirements
19:27:57 <mizmo> (there must be ways) i should say
19:27:58 <inode0> targeting people is sort of taken already I think
19:27:59 <rbergeron> i don't know, but if someone wants to finish packaging limesurvey for me I'd be happy to ask lots of questions ;DDDDD
19:28:10 <skvidal> mizmo: I suspect it is not - not when the 1yr is full of giant breakages and holes
19:28:31 <jsmith> skvidal: I see your point.  And my server probably doesn't have the same requirements as your server, either...
19:28:44 <skvidal> mizmo: and further - that takes us back where we were
19:28:56 <skvidal> if we cannot tell packagers: "YOU CANNOT PUSH THAT TO THE STABLE RELEASE"
19:29:03 <skvidal> then we cannot stabilize the releases
19:29:15 <skvidal> otherwise we get kde doom and firefox doom and whatever else
19:30:00 <skvidal> mizmo: so as I see it
19:30:03 <skvidal> you want mindshare back
19:30:24 <skvidal> 1. stabilize/QA before a release - yay we can do that now
19:30:40 <jsmith> mmcgrath: That's not to say we can't or shouldn't find other niches that need filling -- I just don't know if it makes sense to change our entire focus to building web apps
19:30:44 <skvidal> 2. make a stable release TRULY stable - no intentional backports-of-doom
19:30:56 <skvidal> 3. increase the support lifetime
19:31:12 <skvidal> jsmith: I agree with mmcgrath fwiw
19:31:14 * mmcgrath doesn't think "cloud" or web based computing is a niche
19:31:25 <sgallagh> skvidal: 1 and 2 make sense. I don't think 3 is really possible.
19:31:25 <mmcgrath> html5 is going to completely change the game.
19:31:28 <skvidal> jsmith: the desktop doesn't matter much anymore - people are using the desktop to access online resources
19:31:38 <walters> skvidal: and you think if you were stuck in an elevator with an ubuntu enthusiast, that'd be enough for you to sell him or her on fedora?
19:31:39 <sgallagh> Most of Fedora's developers find sustaining boring.
19:31:42 <mizmo> skvidal, but instead of #3 increase support life time, can you instead do - make it way easier to upgrade when it's time?
19:31:55 <skvidal> walters: I don't think a gun could sell an ubuntu enthusiast on fedora
19:32:03 <skvidal> walters: but thatr has NOTHING to do with it being a good or bad idea
19:32:03 * mmcgrath doesn't currently have a single resource open that is accessing local data except for the local time :)
19:32:09 <sgallagh> mizmo: The problem with that is that not every upstream writes an upgrade script for their tool
19:32:10 <mizmo> skvidal, actually ive converted at least a couple over identi.ca
19:32:18 <skvidal> mizmo: from ubuntu?
19:32:19 <walters> skvidal: oh agreed, i'm not saying it's a bad idea
19:32:21 <mizmo> skvidal, yep
19:32:25 <skvidal> mizmo: hold on
19:32:29 <mmcgrath> I've got email, irc, web, chat, streaming radio and a couple of remote virt-manager connections :)
19:32:29 <skvidal> you converted people from ubuntu
19:32:29 <sgallagh> So we're talking about requiring every package maintainer to test dist-upgrade on each of their packages
19:32:32 <skvidal> to identi.ca?
19:32:39 * skvidal tries to understand that conversion process
19:32:39 <sgallagh> I would feel very bad for spot in that case
19:32:41 <jsmith> mmcgrath: You've got me curious -- if you were king for a day, which web app would you write first?
19:32:41 <mizmo> skvidal, no, i converted them from ubuntu to fedora over identi.ca
19:32:46 <skvidal> mizmo: ah, okay
19:32:48 <mizmo> skvidal, i convinced them to try fedora out
19:32:53 <skvidal> mizmo: great
19:32:55 <skvidal> did they stay?
19:33:01 <mmcgrath> jsmith: I'd get developers focusing on free versions of what google offers
19:33:12 <walters> hmm
19:33:26 <walters> mmcgrath: but web apps *require* a business model
19:33:27 <skvidal> jsmith: king for a day? open authentication framework so apps can auth like googleapps do
19:33:40 <skvidal> walters: not really - you can host your own o nthe cloud
19:33:41 <walters> you can't just toss up a server, take people's data, and then disappear when someone gets bored
19:33:49 <skvidal> walters: we're not hosting the apps
19:33:52 <skvidal> we're providing the app
19:33:54 <walters> oh
19:33:55 <abadger1999> *mugshot*
19:33:55 <skvidal> that the USER can host
19:33:59 <abadger1999> :-)
19:34:02 <skvidal> abadger1999: no one wants to repeat that
19:34:04 <walters> abadger1999: yes
19:34:09 <jsmith> abadger1999: Thanks for reminding us... I think.
19:34:10 <walters> though we didn't take people's data
19:34:16 <walters> just aggregated
19:34:19 <mmcgrath> jsmith: the problem then, of course, is out googling google.
19:34:23 <walters> if you're talking about email though, that's a whole other story
19:34:29 <skvidal> walters: the point is this - give people the choice to control their own app and their own data
19:34:31 <skvidal> in the cloud
19:34:42 <skvidal> and not be linked to google exclusively
19:34:45 <jsmith> mmcgrath: With volunteers, mind you :-)
19:34:52 * rbergeron will happily take some help in the cloud department, yo
19:35:02 <sgallagh> skvidal: That would be great... show me the upstream communities that are lining up to do this.
19:35:15 <mmcgrath> jsmith: if I could make a wish.  it'd be that openoffice.org was just that :)
19:35:39 <skvidal> sgallagh: never said they were - my point is that if fedora has eng resources to put on something
19:35:42 <skvidal> that should be the focus
19:35:53 <skvidal> sgallagh: we create upstream communities for other projects all the time
19:36:01 <skvidal> sgallagh: we've done it for a variety of projects that DO thrive
19:36:07 <sgallagh> skvidal: *Fedora* doesn't really have eng resources that we can direct. That's our "herding cats" problem right there.
19:36:16 <sgallagh> Fedora contributors work on what they want to work on
19:36:16 <mmcgrath> sgallagh: but Red Hat does.
19:36:17 <skvidal> sgallagh: it has at least the people who work for spot
19:36:18 <walters> red hat does
19:36:34 <mmcgrath> it's an uphill battle, but we could get there I think.
19:36:39 <walters> personally i'd like to see red hat having a heavier hand
19:36:39 <sgallagh> We can start projects, sure. But that doesn't mean anyone not @redhat.com is going to join them
19:36:48 <skvidal> sgallagh: it never does
19:36:52 <skvidal> but it means that is possible
19:36:54 <skvidal> that's how we START
19:36:57 <skvidal> that's how things GROW
19:37:02 <skvidal> I can assure you of this
19:37:02 <mmcgrath> it's better then google starting projects and forcing only @google.com to join them.
19:37:04 <skvidal> if we don't start
19:37:04 <sgallagh> skvidal: I disagree. That's how we shrink
19:37:06 <skvidal> it'll NEVER happen
19:37:16 <skvidal> sgallagh: huh?
19:37:21 <mmcgrath> what we're doing now is causing us to shrink
19:37:26 <mmcgrath> we've been shrinking for a few years
19:37:28 <sgallagh> If we start telling the community "Red Hat has decided that this is how things ought to be", we have people emigrating rapidly to other distros
19:37:31 <sgallagh> It's happened before
19:37:33 <walters> mmcgrath: where is that data again?
19:37:56 <sgallagh> The community at large is already afraid of Red Hat's level of influence in Fedora
19:37:57 <abadger1999> Okay -- just to interject here -- we started off talking about ways to make the Fedora governance model better and now we're talking about ways to make what Fedora produces better.
19:38:05 <sgallagh> nonsensical though that might be
19:38:17 <skvidal> sgallagh: then you obviously don't phrase it like that
19:38:28 <abadger1999> Other than mizmo, jsmith, and smooge, none of us are on the Board where our current governance model would suggest this sort of decision would be made :-)
19:38:29 <skvidal> sgallagh: a better way is to start a project, host it and start showing it off
19:38:42 <abadger1999> Do we want to continue with this or go back to talking about governance?
19:38:43 <jsmith> abadger1999: I think we've gone from "Let's make the fruit taste better" to "here's how we should prune, mulch, and spray for bugs" to "Let's scrap the apple tree and grow cucumbers"
19:38:48 <mmcgrath> walters: compare week 12 - http://fedoraproject.org/wiki/Statistics  to week 12 of Fedora 9 - http://fedoraproject.org/wiki/Legacy_statistics
19:39:19 <jsmith> abadger1999: That's not to say I don't like cucumbers -- it's just interesting to follow the path of the discussion
19:39:24 <rbergeron> mmcgrath, skvidal: make a plan - show how that growth helps rht, fedora, any other companies that want to join in.  how many users - why is it better than google owning it - etc
19:39:27 <mizmo> abadger1999, i think the problem with talking about governance is that how do you decide on governance for a thing you don't know what it is
19:39:40 <sgallagh> skvidal: I'm not saying we can't do more of that. I'm saying we shouldn't advocate leaving the existing contributors behind.
19:39:44 <skvidal> rbergeron: why is it better than google owning it should be obvious
19:39:48 <mizmo> abadger1999, if fedora is meant to be x, governance should be x'. if fedora is meant to be y, maybe y' governance would make more sense
19:40:07 <skvidal> mizmo: +1
19:40:10 <mmcgrath> walters: sorry not Fedora 9, Fedora 6
19:40:16 <sgallagh> mizmo: +1
19:40:34 <jsmith> mizmo: +1
19:40:37 <skvidal> you don't have a democracy if you need an empire built
19:40:38 <mizmo> thats why the convo keeps coming back to what fedora is
19:40:51 <abadger1999> mizmo: Well -- we know that there's building a linux distribution.  And we know that there's managing the people that make that linux distribution.  We are presently having a debate about whether adding "have a web services presence" and "should we build more than one linux distribution" to that mix.
19:40:59 <rdieter> mmcgrath: the power of zod
19:41:09 <mizmo> abadger1999, i dont think it should be building a linux distribution
19:41:11 <sgallagh> skvidal: But to date, it's also the only government that keeps an empire from collapsing (rapidly)
19:41:27 <skvidal> sgallagh: umm
19:41:29 <abadger1999> mizmo: But would you agree that that's *surrently* in there?
19:41:30 <walters> mmcgrath: hm is there a page that compares Fx side by side?
19:41:31 <mizmo> i think the reason folks are suggesting web services is because we're trying to spread free software
19:41:36 <abadger1999> s/surrently/currently/
19:41:39 <rbergeron> skvidal: obvious to you and me and most people, pretty oblivious sometimes to people who hold pursestrings :)
19:41:46 <mizmo> abadger1999, i think some of us are building a distro while others are trying to build an OS
19:41:51 <sgallagh> skvidal: Despots carve out empires. Senates keep them there when the despot dies/leaves
19:41:54 <mmcgrath> walters: I don't think anyone's done the work
19:41:56 <mizmo> you can't spread free software via a desktop distro anymore
19:42:02 <skvidal> sgallagh: umm - I think that's off in the weeds
19:42:19 <jsmith> mizmo: I disagree...
19:42:39 <sgallagh> skvidal: My point was that if we tried to convert to a totalitarianism, we'd lose a lot of contributors who would suddenly feel like they have no voice
19:42:43 <mizmo> jsmith, who wants to produce a floss desktop so people can log into pandora and google mail and remember the milk?
19:42:44 <walters> mmcgrath: if i'm reading this right, f13 is 96% of f12?
19:42:57 * smooge tries to catch up
19:43:01 <smooge> man you talk a lot
19:43:05 <mizmo> jsmith, that's not spreading free software, that's enabling closed software
19:43:14 <walters> smooge: yeah, i'm very close to going back to working on code =)
19:43:16 <skvidal> sgallagh: if only specific people would leave I'd be happy :)
19:43:17 <sgallagh> walters: Could you please use more antecedents?
19:43:22 <mizmo> sgallagh, i dont think anyone is advocating totalitarianism, happily
19:43:29 <mizmo> :)
19:43:31 <sgallagh> skvidal: I'm guessing after this conversation, I'm probably one of them :)
19:45:45 <skvidal> jsmith: a desktop for a lot of folks these days is a maximized firefox or chrome windo
19:45:47 <mizmo> i guess for some people
19:45:50 <walters> mizmo: i mentioned this before but i think you're ignoring the server-future aspect of fedora
19:45:50 <mizmo> fedora is 'having fun with friends'
19:45:58 <mizmo> but for others it's 'spreading free software'
19:46:00 <skvidal> walters: server-future?
19:46:01 <mizmo> walters, server future?
19:46:09 <walters> a place to land improvements in the linux server
19:46:12 <skvidal> walters: this is rhel++?
19:46:15 <walters> yes
19:46:39 <skvidal> walters: we've not been behaving like it is server-future, really?
19:46:45 <walters> not very well, no
19:46:59 <skvidal> why bother with all the extra crap we've been tacking on around fedora if we want to create a good server
19:47:03 <sgallagh> walters makes an excellent point. Even if we do start talking about Fedora as a development platform for open web apps, we also need to talk about Fedora as a platform for hosting those apps
19:47:17 <mizmo> i dont think fedora is a good platform to host apps on
19:47:32 <walters> well, i'm not suggesting actually running it in production
19:47:34 <sgallagh> mizmo: Is that something we should change? Strategically, I mean.
19:47:40 <walters> but think of it like a staging server
19:47:47 <mizmo> sgallagh, if we'd like fedora's funding to not dry up, likely not
19:47:50 <walters> just you deploy to production in a few years =)
19:48:10 <sgallagh> mizmo: I'm not talking about Fedora as a stable server. I'm talking about it as proto-RHEL
19:48:16 <mizmo> staging servers should be a lot closer to production than fedora is to rhel walters
19:48:24 <walters> yes i know
19:48:25 <mizmo> dont you think?
19:48:27 <sgallagh> A place to develop new server technologies for eventual use in RHEL hosting those apps
19:48:37 <walters> mizmo: yes, but i'm just using it as a loose analogy
19:48:44 <walters> here is the point
19:48:45 <mizmo> who is doing that development walters, sgallagh
19:48:59 <sgallagh> mizmo: We already have communities doing things like that
19:49:01 <mizmo> cuz most shops are worried about yesterday and don't have the luxury of future planning like that i think
19:49:10 <sgallagh> JBoss, Django, ruby-on-rails, etc.
19:49:14 <walters> i work at ibm/dell/whatever and want to land some improvement across the OS (which spans kernel/upower/tuned/whatever) - i commit that in fedora first
19:49:42 <walters> or actually add red hat to the first list there
19:50:31 <smooge> mizmo, actually Fedora has a larger mindshare than I would say Red Hat Linux. The problem is that the number of people using Linux has grown exponentially and other orgs were able to leap frog because thats the nature of the innovators market
19:50:32 <skvidal> walters: and you have a fist fight getting into fedora b/c it targets the server and isn't helpful for the desktop
19:51:12 <walters> skvidal: that's the point - if something in a change conflicts with the desktop, we have an open forum to debate and fix it
19:51:13 <sgallagh> skvidal: And now we're kind of circling back to my original suggestion of Fedora as a bit bucket with SIG-based child distros doing the releases instead of core Fedora
19:51:59 <skvidal> sgallagh: which doesn't work
19:52:03 <skvidal> when you talk about a central core
19:52:07 <skvidal> and what the core is targetting
19:52:23 <skvidal> case in point - we've added lots of stuff to the core which doesn't make sense if we're NOT producing a desktop
19:52:34 <skvidal> we've talked about this many times before
19:52:36 <skvidal> in many locales
19:52:40 <sgallagh> I'm not talking about reducing Fedora back to Fedora Core
19:52:46 <skvidal> I'm not either
19:52:52 <skvidal> I'm talking about critpath
19:53:14 <skvidal> I'm talking about pkgs where you can either do X or you can do Y but you can't split the difference w/o a whole lot of extra work
19:53:24 <skvidal> and shipping BOTH of those is just a recipe for confusion to the user
19:53:43 <sgallagh> skvidal: Could you give an example?
19:53:56 <skvidal> sgallagh: pulseaudio? PackageKit?
19:54:01 <skvidal> the initial versions of NetworkManager
19:54:10 <skvidal> some folks might even say modern versions of NM
19:54:32 <skvidal> time will tell whether upstart and systemd fall into that category, too
19:54:55 <mizmo> we did ship both nm and some old network stack config ui as recently as f8
19:55:02 <mizmo> holy crap was that confusing
19:56:30 <mizmo> i dont feel progress has been made :(
19:56:55 <skvidal> mizmo: we shipped both as recently as f12
19:57:08 <mizmo> skvidal, yukkkk
19:57:26 <walters> i'm unclear what the point of this tangent is
19:57:28 <mizmo> i dont have the old network config ui by default anymore at least
19:57:39 <walters> a bucket of parts/multiple implementations leads to confusion/brokeneness?
19:57:41 <skvidal> I think, to use an analogy, you cannot have guns and butter
19:57:42 <mizmo> fedora's governance is being called into questions.
19:57:57 <smooge> ConsoleKit, PackageKit, systemd usually come up in my "Dear God what are you Fedorans doing to my OS" list
19:58:00 <mizmo> but you can't really propose better unless you know what the governance is FOR
19:58:03 <skvidal> if we don't know what we're targetting with the default install/distro then we are not targetting anything at all
19:58:11 <mizmo> smooge, most innovation is treated that way
19:58:15 <mizmo> when it first comes out
19:58:19 <skvidal> mizmo: and sometimes it is correct
19:58:22 <smooge> and so does much crap
19:58:34 <smooge> its the issue of trying to figure out which is which
19:58:50 <mizmo> smooge, the best designs ellicit the strongest reactions
19:59:00 <smooge> no I would not say that..
19:59:02 <mizmo> it's bad to keep people quiet
19:59:08 <skvidal> mizmo: umm
19:59:08 <mizmo> that means you're being mediocre
19:59:20 <mizmo> you can't make a difference in the world if you coast
19:59:23 <skvidal> mizmo: explosively bad design elicits strong reactions, too
19:59:31 <skvidal> mizmo: so we grow forever?
19:59:36 <skvidal> mizmo: nothing about sustainability in there?
19:59:42 <walters> ok, i set 4pm as my deadline to return to code; but i may periodically look in
19:59:45 <mizmo> skvidal, i'm not saying strong reaction => good design, i'm saying good design => strong reaction
19:59:50 <smooge> I am about to pull in Godwin's law on that.. but I think my headache medicine isn't working well
19:59:56 <mizmo> skvidal, grow what? the size of the distro?
20:00:02 <mizmo> skvidal, the reach of the distro? the user base?
20:00:09 <mizmo> skvidal, i don't think we are sustainable right now
20:00:11 <skvidal> mizmo: we rethink and throw away what we've done in the past forever?
20:00:18 <skvidal> constantly adding new code and tossing out ALL of the old?
20:00:51 <mizmo> skvidal, i think refactoring or rewriting stacks from the past makes sense if its meant to enable something
20:00:52 <skvidal> mizmo: so all the developer hours working on the thing before are just wasted?
20:00:58 <smooge> I am having a hard time keeping up with which thread we are shreading at the moment.. could I ask for an indulgence of a few lines until an EOF?
20:00:59 <mizmo> eg pulseaudio enables a lot of things the old alsa stack could not
20:01:11 <mizmo> skvidal, no they're not, you always learn from mistakes made
20:01:38 <mizmo> to liken it to sketching
20:01:57 <skvidal> mizmo: umm - I think assuming  that successful, deployed codebases made mistakes is a fair bit of coder hubris
20:02:06 <mizmo> you don't sketch a perfect head, then sketch perfect arms, all the way down to the feet in one scan. that is a horrible drawing discipline and necessarily limits your progress as an artist
20:02:09 <skvidal> and accounts for a lot of wasteful, repetitive code production
20:02:24 <mizmo> rather you sketch out EVERYTHING very roughly, just stick figures or scribbling, and work out finer details in levels across the sketch
20:02:30 <mizmo> maybe 20 total passes over the entire image
20:02:52 <skvidal> mizmo: but no one has to link to and work with your image
20:03:06 <skvidal> no one has processes in place that rely on your image WORKING a certain way
20:03:23 <mizmo> skvidal, should the world just stop?
20:03:25 <skvidal> no one has hundreds of thousands of processes in place and completed counting on consistence
20:03:29 <skvidal> mizmo: if only it would
20:03:32 <mizmo> it can't
20:03:48 <mizmo> if it did id be riding a horse instead of driving an 89 honda prelude
20:03:52 <mizmo> i think i might prefer the horse tho
20:04:17 <mizmo> all those horse hitches and saddle shops and horse-y drinking well things, all gone
20:04:29 <skvidal> all I've been saying
20:04:36 <skvidal> is that there is a goal for servers
20:04:38 <sgallagh> Well, is there any reason that Fedora couldn't institute a policy that there should be bugfix-only updates in a released Fedora? That all new features belong in Fn+1 ?
20:04:38 <skvidal> and a goal for desktops
20:04:45 <smooge> We are wanting to produce a better product, and our 'problem' if there is one is that we are using the wrong tool for everything. In market acceptance turns, Fedora is a product made for and by the Innovators who make up 1-3 % of the 'market' because they are people who don't care if it works just as long as its doing something newer. RHEL/CentOS is meant for later stage markets where things are supposed to work 90-99% of the t
20:04:45 <smooge> ime. What we are missing is the middle section where people take innovations and make them something mass market
20:04:47 <skvidal> and those two things do not necessarily have the same criteria
20:05:02 <skvidal> sgallagh: get the board (or whomever) to approve that
20:05:08 <mizmo> skvidal, yeh i agree
20:05:09 <skvidal> sgallagh: that's been the CENTRAL PROBLEM
20:05:13 <sgallagh> skvidal: I've been trying
20:05:23 <skvidal> jsmith: make it so
20:05:35 <skvidal> jsmith: propose it to the board
20:05:39 <skvidal> if it gets voted against
20:05:41 <skvidal> VETO it
20:05:44 <mizmo> sgallagh, i really wish that was a policy
20:05:44 <skvidal> and push it through anyway
20:05:45 <skvidal> poof
20:05:47 <skvidal> problem solved
20:05:51 <skvidal> it is law
20:05:52 <mizmo> releases are supposed to be stable
20:05:52 <smooge> No problem made worse
20:06:01 <mizmo> sgallagh++
20:06:03 <skvidal> and fesco or whomever will either choose to implement it
20:06:05 <skvidal> or they won't
20:06:16 <skvidal> if the volunteers or devels don't want that
20:06:20 <skvidal> then I'll guess we'll know
20:06:24 <skvidal> but discussing it on the list?
20:06:26 <skvidal> ridiculous
20:06:32 <skvidal> kofler will make sure it will never stop ranting
20:06:36 <skvidal> having a vote?
20:06:36 <sgallagh> I think it's more likely to happen now that we have the no-frozen rawhide
20:06:37 <skvidal> of whom?
20:06:46 <smooge> The problem is that you are trying to sell a Lamborghini as a pickup truck
20:07:00 <sgallagh> We can encourage the use of the semi-baked Fn+1 to be for dropping in new, tested features
20:08:12 <skvidal> sgallagh: you can't ENCOURAGE it
20:08:22 <skvidal> you have to either ALLOW or DISALLOW it
20:08:25 <skvidal> if you just encourage it
20:08:28 <sgallagh> Perhaps it was a poor choice of words
20:08:31 <skvidal> then people will do whatever the hell they want to do
20:08:51 <sgallagh> We set policy that this is what it's intended for
20:09:20 <sgallagh> wild, crazy new ideas go to rawhide. When they hit beta/rc/ready for more public testing they should go to the pre-release branch
20:09:48 <skvidal> okay
20:09:52 <skvidal> go pitch that to kofler
20:09:55 <skvidal> lemme know how it goes
20:09:55 <sgallagh> Once the pre-release branch hits beta, it's restricted to bugfixes for the rest of its lifecycle
20:10:16 <skvidal> "Our "culture" is the way it is for a reason, it cannot ever be changed. The
20:10:16 <skvidal> stricter freezes just make it a PITA to do development." -- Kevin Kofler
20:10:18 <sgallagh> skvidal: I'm idealistic, not foolish :)
20:10:56 <skvidal> then how do you want to put it in place and enforce it?
20:11:42 <skvidal> if a developer breaks that rule? What does the board do?
20:11:49 <skvidal> if you want to have rules
20:11:54 <sgallagh> updates after beta require the signoff of a proventester, and the proventesters are set a policy to follow
20:12:01 <skvidal> and you KNOW some folks will not follow them either by design or by mistake
20:12:09 <skvidal> you have to have some way to stopping them and enforcing the rules
20:12:19 <skvidal> if you do not enforce the rules then they do not matter
20:12:34 <sgallagh> The only way to enforce the rules would be to have a trusted set of gatekeepers
20:12:37 <sgallagh> Such as proventesters
20:13:12 <skvidal> so
20:13:15 <skvidal> we have a proventester
20:13:19 <skvidal> who goes off the reservation
20:13:21 <skvidal> what do we do
20:13:28 <sgallagh> They lose their proventester status
20:13:36 <sgallagh> We have a policy to allow them to reapply sometime in the future
20:13:41 <skvidal> great
20:13:52 <skvidal> that's the policy that the board needs to pass and STAND BY
20:14:02 <sgallagh> Agreed
20:14:13 <skvidal> this is what many folks have been asking for for quite a while
20:14:19 <skvidal> and what many other folks have been threatening to leave over
20:14:36 <skvidal> go thee forth and make it law
20:14:50 <sgallagh> When's the next election?
20:14:54 * sgallagh throws his hat in the ring
20:15:04 <skvidal> why wait?
20:15:18 <skvidal> jsmith: ^^^^ sgallagh seems to think the above is going to pass muster - make it so, please
20:15:38 <sgallagh> skvidal: Sarcasm is not helpful.
20:15:48 <skvidal> sgallagh: who is being sarcastic?
20:15:52 <skvidal> I'm not
20:16:02 <skvidal> I tried to get a policy like this through fesco
20:16:13 <jsmith> skvidal: Please have him make a proposal to the advisory-board list
20:16:20 <sgallagh> I think that some people *might* leave because of this, but I suspect it's a much smaller group than those who would *say* they'd leave
20:16:21 <skvidal> and you'd thought I was suggesting slaughtering kittens to fuel my helicopter
20:16:31 <skvidal> sgallagh: I just want specific people to leave.
20:18:08 <sgallagh> jsmith: I will write up that proposal tomorrow (I need to disappear soon)
20:18:25 <jsmith> sgallagh: Thanks
20:18:45 <skvidal> jsmith: I suspect that the conversation as to sgallagh's proposal will go like this
20:18:59 <skvidal> "well, that's a good policy for fedora, if fedora is about a stable release"
20:19:07 <skvidal> "is that what fedora is about?"
20:19:17 <skvidal> <loop to beginning of conversation>
20:19:35 <mizmo> if fedora isn't about putting out stable releases i dont see it being much use for anything
20:19:47 <jsmith> skvidal: To that end, I'm (slowly) working on presenting my vision of Fedora to the Board... If they approve, we'll then work on getting buy-in from FESCo, SIGs, etc.
20:19:51 <mizmo> who wants to use something that will never be stable?
20:19:53 <sgallagh> You're right, I think we need to get the Board to agree that released Fedoras are about stability, and branched and rawhide are about new hotness
20:20:05 <skvidal> mizmo: and I think you'll get a fist fight from some folks
20:20:10 <skvidal> mizmo: on just that subject
20:20:31 <mizmo> skvidal, i may be short but im strong
20:20:31 <sgallagh> I forget, is 'branched' branched from Fn-1 or from rawhide currently
20:20:34 <skvidal> jsmith: great. I look forward to seeing progress
20:20:37 <smooge> mizmo, actually its all about what MARKET you are developing for and what that MARKET expects to be 'stable'/
20:20:44 <mizmo> i also have dagger-like fingernails
20:20:52 <sgallagh> I strongly recommend that it be branched from the previous stable release, if not already
20:21:06 <mizmo> smooge, changing major point releases of a desktop environment in a stable release is not stable by any stretch of the imagination to any market
20:21:17 <mizmo> it would be one thing if we had a two month release cycle
20:21:19 <smooge> Oh I know people who love that
20:21:22 <skvidal> mizmo: umm - your opponents use strident and unrelenting mailing list posts as their ammunition
20:21:28 <mizmo> at any given point you only need wait 6 months or less for the new release
20:21:42 <skvidal> mizmo: which, according to some, is way too long
20:21:46 <smooge> and I know a lot more people who hate it. But they don't use that desktop
20:21:48 <sgallagh> mizmo: Less, if we follow my approach of branched coming from the previous stable
20:21:52 <mizmo> skvidal, people abusing mailing lists should be moderated
20:21:54 <skvidal> mizmo: go back and read the logs from fesco from the last 2yrs
20:22:00 <skvidal> mizmo: we don't habve moderators naymore
20:22:06 <skvidal> I was the last moderator who DID anything
20:22:06 <sgallagh> Then they can put their new desktop in there early and it would still be semi-stable for early adopters
20:22:10 <skvidal> and when I did
20:22:16 <skvidal> I was hung out to dry by the board
20:22:17 <mizmo> skvidal, someone has the password to go into mailman no?
20:22:27 <skvidal> mizmo: yes. Afaict, it's just me
20:22:40 <skvidal> mizmo: I removed myself from the moderators admin list today
20:22:43 <skvidal> mizmo: it includes
20:22:49 <skvidal> jwboyer - who has quit fedora entirely
20:22:53 <mizmo> sgallagh, it's a good idea
20:22:53 <skvidal> spot b/c he's spot
20:22:55 <skvidal> jsmith
20:23:12 <skvidal> and stickster
20:23:19 <skvidal> do you think spot has time to play moderator?
20:23:32 <rdieter> skvidal: jwboyer all gone?  /me sad.
20:23:33 <skvidal> and if the board won't back a decision to moderate someone abusing the lists
20:23:35 <skvidal> then what's the point
20:23:41 <skvidal> rdieter: he quiet a couple of weeks ago
20:23:52 <skvidal> rdieter: he was completely fed the fuck up
20:24:00 <skvidal> rdieter: he still lurks but is not involved
20:24:27 <rdieter> I know he had some grumbles, but was unaware of any deal-breakers.  sorry to hear that.
20:24:50 <skvidal> rdieter: /msg him - he'll probably talk to you
20:25:04 <skvidal> mizmo: so, go ahead and moderate the mailing lists.
20:25:06 <rdieter> k, will do soon
20:25:07 <skvidal> mizmo: good luck
20:26:12 <skvidal> I'm not being a fatalist but unless the board choose to defend their decisions and are willing to ENFORCE their rules, then we're all barking about nothing
20:26:24 * mizmo cannot stand talking about doing things
20:26:28 * mizmo prefers doing things
20:26:36 <skvidal> me too.
20:26:59 <skvidal> good luck
20:28:29 <sgallagh> mizmo: +1
20:28:47 <sgallagh> Ok, I've gotta run for today. Be well, everyone
20:51:35 * nirik gets back from fesco meeting... tries to read scrollback.
21:19:39 <mizmo> #endmeeting