15:34:01 <stickster> #startmeeting Hackfest deliverables
15:34:01 <zodbot> Meeting started Fri Apr 28 15:34:01 2017 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:34:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:34:01 <zodbot> The meeting name has been set to 'hackfest_deliverables'
15:34:09 <maxamillion> .hello maxamillion
15:34:10 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:34:16 * nirik waves for the camera
15:34:17 <jcline> .hello jcline
15:34:19 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
15:34:21 <bowlofeggs> hahah hackenfesten
15:34:21 <puiterwijk> hello
15:34:25 <pingou> o/
15:34:25 <bowlofeggs> .hello bowlofeggs
15:34:26 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
15:34:26 <stickster> #chair pingou tflink maxamillion bstinson tflink bowlofeggs jcline smooge puiterwijk nirik
15:34:26 <zodbot> Current chairs: bowlofeggs bstinson jcline maxamillion nirik pingou puiterwijk smooge stickster tflink
15:34:40 <stickster> #chair relrod
15:34:40 <zodbot> Current chairs: bowlofeggs bstinson jcline maxamillion nirik pingou puiterwijk relrod smooge stickster tflink
15:34:46 <stickster> .hello pfrields
15:34:47 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
15:34:53 <tflink> .hello tflink
15:34:54 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:35:06 <bowlofeggs> here's the link we're supposed to ponder: https://fedoraproject.org/wiki/CI_and_Infrastructure_Hackathon_2017#Deliverables
15:35:08 * stickster thinks we can probably skip the rest of roll call ;-)
15:35:15 <stickster> #link https://fedoraproject.org/wiki/CI_and_Infrastructure_Hackathon_2017#Deliverables
15:35:43 <nirik> so, I made a new page for the openshift stuff... we can fold it in, or just link to it.
15:35:45 <stickster> #topic Higher level concept and what we want
15:36:08 <bowlofeggs> could/should there be a BDR deliverable? is "we talked about it and learned more" a deliverable?
15:36:17 <maxamillion> bowlofeggs: BDR?
15:36:17 <stickster> gimme a sec
15:36:38 <puiterwijk> maxamillion: Bidirectional Data Replication. Postgres HA system we're thinking of using
15:36:38 <nirik> bowlofeggs: or decided a plan of action moving forward probibly/
15:36:44 <jcline> maxamillion, bi-directional replication for Postgres
15:36:46 <bowlofeggs> maxamillion: it's postgres replication system and we've been discussing/debating it for fedora apps
15:37:00 <tflink> maxamillion: I hope you got all of that :)
15:37:06 <stickster> OK, hang on folks, let me outline some bits here first, for why we're doing this :-)
15:37:09 <bowlofeggs> hahaha
15:37:19 <stickster> So I'm highly confident that having everyone together for the week will produce results.
15:37:47 <stickster> At the same time, keep in mind we are spending several $K's of Fedora event budget. So we have an obligation to come out of the hackfest with more than just joint understanding and some plans
15:37:58 * puiterwijk notes that everyone deciding we're going yak farming is also a result
15:38:03 <stickster> lol
15:38:35 <stickster> I expect we'll have some discussion and whiteboarding, etc. and pull plans into wiki pages or documents elsewhere, so everyone can refer back to the agreed plans and so forth.
15:38:44 <tflink> https://www.yakzz.com/yak-for-sale/
15:38:50 <puiterwijk> tflink++
15:39:01 <stickster> But on top of that I think we should have several deliverables of concrete code and changes.
15:39:14 <stickster> OK, here endeth the bracketing concept :-)
15:40:00 <stickster> #info Summary: discussions are needed, but we need to show some results in code as well by end of week :-)
15:40:07 <maxamillion> tflink: I did :)
15:40:10 <stickster> #topic Let's talk deliverables
15:40:22 <pingou> 2.5KUSD for a 1 year old female yak sounds good to me
15:40:33 <nirik> we should also try and present stuff to the community in some cases and get feedback before actually deciding anything...
15:40:36 <nirik> at least in some cases.
15:41:01 <stickster> nirik: I expect some branches where we have decisions like that, and some where we should JFDI.
15:41:04 <maxamillion> nirik: +1
15:41:06 <bowlofeggs> i want a pingou book signing as a deliverable
15:41:13 <nirik> stickster: right. :)
15:41:16 <pingou> bowlofeggs: oupsy
15:41:21 <bowlofeggs> nirik: +1
15:41:31 <nirik> anyhow, should we go over each topic and add stuff? or ?
15:42:08 <maxamillion> nirik: +1
15:42:11 <stickster> nirik: since you've written up stuff for openshift, let's start elsewhere and come back to that
15:42:18 <nirik> ok
15:42:29 <bowlofeggs> i'd like an OIDC related deliverable
15:42:51 <stickster> CI pipeline is something where having tflink & bstinson on hand should allow us to plan + do some infra work in that direction
15:42:53 <maxamillion> bowlofeggs: OIDC?
15:42:54 <puiterwijk> bowlofeggs: that's part of the first day where I'm going to explain all the auth(n/z) stuff
15:42:57 <stickster> OpenID Connect
15:42:58 <puiterwijk> maxamillion: OpenID Connect
15:43:01 <maxamillion> rgr
15:43:31 <bowlofeggs> deliverable: we reconfigure red hat tower's door locks to use oidc
15:43:33 <maxamillion> puiterwijk: what's the desired deliverable from that item?
15:43:49 <puiterwijk> maxamillion: Well, my side of things is "give a short explanation"
15:43:52 <nirik> We might also go over existing docs and organize / make sure we have them? as a deliverable?
15:43:54 <puiterwijk> What bowlofeggs there wants, ask him
15:43:58 <bstinson> in general, i'd like to work on communication into fedora-land from ci.centos.org (hello fedmsg!)
15:44:21 * nirik sees that docs are already on the wiki page. great.
15:44:33 <jcline> I'd like to see us leave with a set of best practices and guides for oidc in apps
15:44:36 <puiterwijk> nirik: I've tried to document our OIDC stuff
15:44:36 <bowlofeggs> puiterwijk: i think a good deliverable could be to convert some existing simple app to oidc as a reference conversion, perhaps? or is that too ambitious?
15:44:49 <bowlofeggs> or, is that already done?
15:44:51 <puiterwijk> bowlofeggs: I already did that recently... about three times
15:44:54 <bowlofeggs> ah ok
15:44:56 <tflink> it might be interesting to start farming work out to centos ci infra but I'm not sure this hackfest is the best place to do that
15:45:03 <stickster> bstinson: Can you explore that in more detail?  i.e. what do we need to do in terms of fedmsg code, deployment, etc. that would benefit from several folks
15:45:10 <stickster> tflink: on the contrary, it is
15:45:11 * puiterwijk notes we're talking about all the subjects and all the days throguh eachother
15:45:25 <stickster> tflink: we need to stop sizing up the pool and start diving in ;-)
15:45:40 <puiterwijk> bstinson: I'm not sure we need to work on that in the hackfest.. As said before: I can just give you a cert, and that should be ready
15:45:49 <maxamillion> tflink: I say add it to https://fedoraproject.org/wiki/CI_and_Infrastructure_Hackathon_2017#Deliverables
15:46:15 <stickster> Let me ask this -- would it make sense for us to split up topics by day, or rather split up into teams and work on different things throughout?
15:46:15 <nirik> hum, I see mikem mentioned a lot on the CI days, but not listed as an attendee. Is he going to be available?
15:46:35 <bstinson> puiterwijk: we're hoping to get more extensive in some of the messaging that we emit, and we don't want to have to come back every time with more cert requests
15:46:38 <pingou> he is joining on Tue and Wed afternoon
15:46:44 <stickster> Let me ask this -- would it make sense for us to split up topics by day, or rather split up into teams and work on different things throughout?
15:46:47 <stickster> oops, sorry
15:46:56 <pingou> bstinson: you need only one actually, maybe 2 w/ staging
15:47:02 <puiterwijk> bstinson: we can just get you a cert once, and then add different topics you can send
15:47:20 <puiterwijk> What pingou says
15:47:23 <nirik> stickster: I wonder... perhaps we could take tuesday morning on CI and tuesday afternoon on Openshift and hash out plans, and then divide into teams to work on things the later days?
15:47:24 <pingou> bstinson: potentially, one per app sending messages
15:47:35 <stickster> nirik: That doesn't sound like a bad idea
15:47:38 <bowlofeggs> stickster: i think teams could help with some topics
15:47:46 <bowlofeggs> maybe some days teams and some days all together?
15:48:17 <bstinson> sure, that's what we're working through. maybe this is an 'over-lunch' topic rather than an acutal deliverable
15:48:18 <maxamillion> bowlofeggs: +1
15:48:30 <puiterwijk> Note that with AuthN/AuthZ, there's some stuff that is interesting only for developers, some that's only for sysadmins and some for both
15:48:32 <pingou> mikem joining on Tue afternoon, I'd split from that part
15:48:32 <maxamillion> I think it makes sense to break out where applicable and get everyone together where applicable
15:48:40 <puiterwijk> maxamillion: +1
15:48:41 <fm-apps> github.issue.comment -- dustymabe commented on issue #55 on fedora-infra/fedimg https://github.com/fedora-infra/fedimg/pull/55#issuecomment-298034563
15:48:53 <nirik> pingou: ah, then perhaps reverse that order I said.
15:49:31 <pingou> nirik: I was planning to divide more morning/afternoon (since mikem comes only in the afternoon), but I'm not essential to the openshift part I think
15:49:31 <bowlofeggs> hahah our meeting notes are gonna have comments from fm-apps
15:49:40 <pingou> fm-apps++
15:49:50 <nirik> monday: Auth and possibly BDR discussions? tuesday morning: openshift planning, tuesday afternoon: CI planning, wed, thur, openshift and CI both
15:50:05 <pingou> fri morning recap?
15:50:06 <stickster> nirik: thanks, I was about to pull that together too
15:50:12 <stickster> nirik: +1
15:50:25 <nirik> well, some of the openshift policy stuff really needs app authors input I think... how we want to do workflow, etc.
15:50:26 <bowlofeggs> +1
15:50:33 <stickster> pingou: Friday >= lunchtime recap
15:50:38 <nirik> implementation not so much
15:50:51 * tflink is potentially interested in being a guinea pig if we go forward with openshift as a production service
15:50:56 <pingou> stickster: I would do >, just to be sure we have lunch :-p
15:51:07 <nirik> tflink: cool. ;) what app(s)?
15:51:11 <maxamillion> similarly to pingou's note, I'm probably not essential to the CI topic but would like to involved in the openshift topic
15:51:23 <tflink> nirik: taskotron, mostly. blockerbugs would be a more simple candidate
15:51:24 <maxamillion> so that might be a good place to split
15:51:29 <stickster> tflink: There's absolutely a point to getting openshift out there btw... it's not just about test drive, it's about shortening our app develop -> prod pipeline
15:51:34 <fm-apps> pagure.issue.assigned.added -- smooge assigned ticket fedora-infrastructure#4576 to codeblock https://pagure.io/fedora-infrastructure/issue/4576
15:51:40 <nirik> tflink: oh yeah... bb has no db right? it just polls ?
15:51:52 <tflink> nirik: it has a db
15:51:55 <stickster> pingou: +1
15:51:55 <tflink> or blockerbugs
15:51:59 <tflink> which bb?
15:52:09 <nirik> blockerbugs=bb
15:52:13 <tflink> actually, both have a db
15:52:23 <fm-apps> pagure.issue.comment.added -- smooge commented on ticket fedora-infrastructure#4576: "fedoracommunity.org ssl is invalid" https://pagure.io/fedora-infrastructure/issue/4576#comment-438873
15:52:24 <nirik> ok, nevermind, sidetrack
15:52:25 <tflink> but the sync is a separate process from the web UI
15:52:33 <stickster> *rathole
15:52:37 <nirik> anyhow: https://fedoraproject.org/wiki/Infrastructure/OpenShift is the page I setup with tons of questions. ;)
15:52:38 <stickster> let's get back to deliverables please
15:53:14 <stickster> We should have actual Openshift engineers joining us Thu afternoon, from the ops side (deployment/maintenance/etc.) so we can bounce ideas off them and ask questions
15:53:20 <nirik> for CI: deliverable: roadmap to CI milestones
15:53:50 <nirik> I don't know if it's practical to get anything working... run a test from Fedora to CentOS CI?
15:53:58 <stickster> nirik: pingou: I was thinking more along the lines of trying to rig up test pipeline
15:54:20 <pingou> stickster: rig up?
15:54:55 <stickster> Rig up = write/attempt. Can we get some proof of concept work done toward the eventual integrated form of CI for Fedora content
15:55:10 <bowlofeggs> is there any chance these CI resources could be used to test the fedora apps themselves? like, could i have a fancy jenkins setup for bodhi in there and make that a deliverable, or when we say CI do we really mean testing fedora builds (rpms/containers/whatever)?
15:55:22 <maxamillion> stickster: oh? who all is joinin gon Thu?
15:55:24 <maxamillion> joinging*
15:55:28 <stickster> maxamillion: refer to wiki
15:55:28 <maxamillion> omg, I can't type
15:55:29 <pingou> so the pipeline being described at: https://fedoraproject.org/wiki/FedoraAtomicCI/pipeline
15:55:32 <maxamillion> stickster: +1
15:55:33 <stickster> oh wait, openshift is not there yet
15:55:39 * nirik also notes that CI plays into the openshift discussion too, as the 'ideal' workflow has things being CI'ed in several places.
15:55:44 <stickster> we have a group of folks like mwoodson coming
15:55:50 <pingou> it is missing some pieces for the Fedora side that I'll be adding shortly
15:55:54 <maxamillion> stickster: it is not
15:55:54 <stickster> it's all informal, no dog & pony show
15:56:04 <maxamillion> stickster: rocking, that's my old team :)
15:56:07 <stickster> nice!
15:56:09 <maxamillion> stickster: sorry, side track
15:56:16 <bstinson> bowlofeggs: there are a few angles that we're hoping to help with. we're happy to take workloads from individual projects as well (outside of the Atomic/Package/etc. pipeline)
15:56:27 <maxamillion> stickster: they're a good crew +1
15:56:27 <pingou> bstinson: the later
15:56:40 <pingou> sorry that was meant for bowlofeggs
15:56:54 <pingou> bowlofeggs: when we speak about CI we speak about Fedora Atomic Host packages CI
15:57:04 <pingou> but bstinson can help you with jenkins in general :)
15:57:11 <stickster> pingou: can you name a few things that the team could write in concert with you while together, that would start to pull together the concepts for CI into reality in Fedora and CentOS infra?
15:57:28 <bowlofeggs> pingou: cool. bstinson: i'll catch up with you later about that ☺
15:57:42 <pingou> basically, we need a place to map test results to bodhi updates
15:57:52 <pingou> test results are linked to a commit (repo + hash)
15:58:12 <pingou> so we need to go from bodhi update -> koji: retrieve the repo + hash info and create the mapping
15:58:27 <stickster> pingou: is this a new app/service?
15:58:34 <pingou> stickster: likely
15:58:46 <pingou> I hope we can capitalize on resultsdb for part of what we need
15:58:57 <pingou> but if not, that will also be part of the API
15:59:19 <pingou> the pipeline will be building and testing every changes made to dist-git
15:59:33 <pingou> but since only a subset of these changes end up in bodhi (where the gating will be done)
15:59:52 <pingou> we need a way to circle back from a bodhi update to a dist-git commit to find the test results associated with this commit
16:00:05 <bowlofeggs> wasn't there going to be some kind of policy database that tells us whether an update is good or bad?
16:00:10 <pingou> then there is the question of the gating in bodhi itself
16:00:35 <pingou> bowlofeggs: it could be it as well, but since PE doesn't exist either, it's a new app regardless :)
16:01:08 <bowlofeggs> the gating part probably isn't too hard if we have some service we can ask "is the update good 2 go"
16:01:20 <bowlofeggs> and we'd want UI feedback too of course
16:01:27 <bowlofeggs> also probably not too bad
16:01:31 <pingou> bowlofeggs: my thought was even more: the service itself updates the flag in bodhi
16:02:33 <bowlofeggs> oh yeah, we talked about that - using fedmsgs
16:02:35 <bowlofeggs> hahah i forgot
16:02:37 <bowlofeggs> yeah that's good
16:02:52 <bowlofeggs> we'd probably just make a new update state
16:02:59 <pingou> or more :)
16:03:05 <bowlofeggs> yeah
16:03:13 <maxamillion> FESCo meeting is starting and I'm chair so I'll try my best to keep up
16:03:19 <bowlofeggs> like "pending testing" --> "tested" (or "testing skipped")
16:03:21 <maxamillion> the reschedule was not ideal :/
16:03:21 <pingou> test_queue, test_running, test_failed/passed, test_ignored
16:03:28 <bowlofeggs> yeah
16:03:29 <bowlofeggs> +1
16:03:52 <jcline> So a finite state machine for updates
16:03:55 <pingou> so we'll need to grill tflink as well to know if we can leverage resultsdb or need to write ciresultsdb :)
16:04:01 <bowlofeggs> so i think we could have a fedmsg consumer, database changes, and ui changes as a deliverable
16:04:28 <bowlofeggs> i think adamw has been using resultsdb for openqa tests, so i'd think we could do that too?
16:04:30 <pingou> bowlofeggs: let's do DB change, UI and API (be it internal API)
16:04:48 <bowlofeggs> pingou: cool
16:04:49 <stickster> OK, sorry for lag -- was pinged away for a moment
16:04:52 <bowlofeggs> jcline: yep ☺
16:04:53 <pingou> bowlofeggs: not entirely sure yet, but I certainly hope so
16:05:06 <stickster> can we translate the above to a deliverable statement?
16:05:24 <pingou> Adjust bodhi for CI: DB change, UI and API (be it internal API)
16:05:42 <bowlofeggs> pingou: +1
16:05:48 <pingou> Bodhi shall be adjusted by the end of the FAD, otherwise no one leaves the building
16:05:51 <stickster> #info Deliverable: Adjust bodhi for CI: DB change, UI and API (internal or not)
16:05:54 <bowlofeggs> hahaha
16:06:02 <bowlofeggs> or at least there's a PR submitted ☺
16:06:13 <tflink> where was the discussion on what is needed for resultsdb/ciresultsdb/somthingelsedb? is there something I can read?
16:06:32 <bowlofeggs> tflink: bodhi needs soem place to ask "is this update ok to be released"
16:06:33 <pingou> #info Deliverable: Have a clear roadmap on how to adjust koji for the future needs of CI
16:06:39 <bowlofeggs> like an overall boolean yes/no
16:06:55 <tflink> isn't that policydb?
16:06:55 <pingou> bowlofeggs: I still don't think bodhi will ask anything
16:07:06 <bowlofeggs> pingou: hahah yes i keep getting that backwards
16:07:10 <pingou> tflink: not yet, I had the discussion just a couple of hours ago
16:07:13 <bowlofeggs> bodhi will be told by "something"
16:07:15 * tflink suspects that he's ratholing the discussion
16:07:24 <bowlofeggs> tflink: not at all, it's valuable
16:07:30 <pingou> tflink: I'll be adjusting the wiki and send you the diff
16:07:32 <jcline> Well people have planned out policyengine/db/whatever they want to call it
16:07:39 <bowlofeggs> we don't need this "soemthing" to exist to make our bodhi deliverable
16:07:43 <tflink> pingou: sounds good
16:07:48 <jcline> It seems like it would be good to get on the same page as those people
16:07:52 <bowlofeggs> we can just define the fedmsgs we need and document them and do our part
16:07:57 <bowlofeggs> the "something" can be done later
16:08:16 <pingou> jcline: the way CI sees the tests currently make PE moot
16:08:49 <pingou> ok, let's make this clear: PE only makes sense in an environment where tests are allowed to fail
16:09:02 <stickster> jcline: tflink: threebean and some of his crew will be in RDU from what I heard, but I don't think we expect them around in our hackfest due to other obligations
16:09:05 <pingou> a test can fail and based on some policy you go over it or not
16:09:25 <pingou> the way CI sees the tests being run is boolean: tests fail or tests pass
16:09:28 <bowlofeggs> we should demand that threebean and tflink be available for the beer session, however
16:09:38 <pingou> if they fail, the entire testing failed, the build is blocked
16:09:42 * threebean pounds his fist on the table
16:09:52 <bowlofeggs> haha
16:10:03 <threebean> order, order!  :p
16:10:09 <smooge> threebean, shoe.. shoe
16:10:15 * threebean skitters away
16:10:16 <bowlofeggs> cool, well i think we can still do the bodhi deliverable without knowing what is going to send us the fedmsgs
16:10:17 <pingou> so that's one place where CI and taskotron see the world differently
16:10:47 <pingou> thus why PE makes sense for taskotron but isn't really required for the CI view
16:10:55 <bowlofeggs> we can treat the fedmsg as a black box, unless that is also one of the deliverables for this hackfest?
16:11:09 <pingou> bowlofeggs: yes, we (or I) can handle the service afterward
16:11:15 <bowlofeggs> cool
16:11:19 <bowlofeggs> sounds good
16:11:19 <tflink> pingou: not sure I agree with you but I know that there's info I'm missing so I'll save the questions for another time
16:11:30 <bowlofeggs> shall we move to another topic, or is there more to say about gating?
16:11:47 <pingou> tflink: we'll be sharing a room, I'm sure you'll be able to extra as much info as you want :)
16:11:52 <pingou> extract*
16:12:14 * pingou fears the "no shower until you answered my question"
16:12:17 <puiterwijk> tflink: just refuse pingou any sleep until he provided you all the info you need :D
16:12:28 <pingou> puiterwijk: thanks for the support man!@
16:12:35 <puiterwijk> pingou: you're most welcome
16:12:37 * tflink notes to bring something that can make noise
16:12:40 <pingou> ^^
16:12:48 <bowlofeggs> hahaha
16:13:22 <smooge> and take away his breakfast muffin
16:13:27 <pingou> I might try to write up some slides on all this to give a short presentation
16:13:37 <pingou> smooge: NNooooooo!!!111!
16:13:44 <pingou> everything but not the muffin
16:13:47 <pingou> (ok let's move on :))
16:15:18 <pingou> #info Deliverable: Find a clear solution and define a roadmap for storage of the mapping test results <-> bodhi update
16:15:39 <bowlofeggs> +1
16:15:45 <pingou> if we can do these three items for CI (Bodhi, Koji, mapping), we'll be good I think
16:15:57 <bowlofeggs> yeah this is gonna be good
16:16:19 <stickster> pingou: Do you feel like we'd be able to move on to implementing those after we define them?
16:16:33 <stickster> at the event, I mean
16:16:39 <bowlofeggs> i think we could implement the bodhi bits at the event
16:17:00 <bowlofeggs> though they'd have to be "turned off" until the rest was also implmented
16:17:04 * stickster would like to figure out how bstinson can best use his time while there
16:17:11 <pingou> stickster: bodhi yes (it's almost already defined), koji likely no (though I hope we can start on it), the mapping DB I hope we can get started on it
16:17:14 <stickster> I feel like it'll be hugely educational to information share
16:17:20 <fm-apps> pagure.issue.edit -- smooge edited the close_status and status fields of ticket fedora-infrastructure#4576 https://pagure.io/fedora-infrastructure/issue/4576
16:17:22 <stickster> pingou: Sounds reasonable to me.
16:17:53 <tflink> are we planning to have some form of remote participation for most of these discussions?
16:18:02 <pingou> #info Deliverable: Get ci.centos.org to speak on the staging fedmsg bus
16:18:09 <pingou> bstinson: how does that sound ^
16:18:17 <stickster> tflink: Only if there are people we need to rope in for them.
16:18:51 <stickster> tflink: do you have some folks who want to be there?
16:18:52 <bstinson> pingou: +1
16:18:55 <bowlofeggs> pingou: +1
16:18:56 * tflink thinks that jskladan might be good to rope in to some of these, especially around resultsdb
16:19:08 <stickster> tflink: in that case we can easily rig up remote dial-in
16:19:16 <pingou> tflink: which time zone is he in?
16:19:18 <stickster> we have the capability in the conf room
16:19:20 <tflink> he's on PTO this week but I'll talk to him next week about it
16:19:22 <tflink> pingou: brno
16:19:31 <pingou> ok, so morning discussion, that's fine w/ me
16:19:39 <bowlofeggs> totally different topic: could/should there be any container registry centos deliverable/discussion here?
16:19:47 <bowlofeggs> bstinson: ^?
16:20:32 <puiterwijk> bowlofeggs: I'd say no. Not seeing what the use of this hackfest ofr that would be.
16:20:41 <bowlofeggs> cool
16:20:56 <bstinson> probably not during this hackfest. but happy to have a hallway chat
16:21:08 <puiterwijk> Yep, agreed on that :)
16:21:16 <stickster> food fight at lunch?
16:21:36 <smooge> no. they do allow that
16:22:08 <pingou> they used to be fun :(
16:22:25 * bowlofeggs packs a few old bananas into his backpack just in case
16:23:28 <smooge> (╯°□°)╯︵ ┻━┻
16:23:51 <stickster> OK, has anyone been scribing on wiki yet?
16:25:04 <bowlofeggs> ┬─┬ノ( º _ ºノ)
16:25:20 <stickster> heh
16:25:46 <stickster> OK, sounds like not.  I will try to get the general gist right after my meetings end this afternoon.
16:26:03 <bowlofeggs> i think pingou made one edit, but not otherwise
16:26:09 <stickster> *: I'll ask you guys to check and edit that when I'm done
16:26:17 <bowlofeggs> we do have #info statmeents for deliverable ideas though which shoul dbehelpful
16:26:24 <stickster> yep, thanks to all for those
16:26:35 <stickster> I'll also be asking everyone at the hackfest to keep focused on things at hand
16:26:47 <stickster> In one sense, it *is* the time to rathole on technical details :-) so we will do some of that
16:27:00 <stickster> but let's avoid getting into the ratholes of trying to boil every ocean
16:27:26 <puiterwijk> Let's avoid boiling oceans to start with?
16:27:34 <bowlofeggs> haha
16:27:41 <smooge> ok my plans are the follows: get people frm the airport to the hotel
16:27:49 <smooge> get people in the morning from the hotel to the tower
16:27:59 <bowlofeggs> if we boil the atlantic away pingou and puiterwijk can walk home
16:28:22 <tflink> ooh, cost savings!
16:28:34 <smooge> and we can build that transatlantic "tunnel" finally
16:29:13 <stickster> smooge: that reminds me -- I will be arriving on Sunday evening and could pick up late airport folks
16:29:38 <stickster> #idea Could everyone make sure their travel times are noted on the wiki
16:29:45 <stickster> I think most are at this point.
16:29:59 <pingou> bowlofeggs: shall I prepare a backpack then?
16:30:08 <pingou> not sure suitcase on wheels would do fine there :/
16:30:14 <stickster> #idea could jcline bowlofeggs smooge meet us at the hotel at say 8:30am Monday, so we can coordinate getting everyone to the office?
16:30:28 <stickster> reminder: Courtyard Marriott *Midtown*
16:30:49 * pingou would note that most of us are arriving on Sun evening, just in case you want to shorten your week-end :-p
16:30:51 <smooge> how many people are at that hotel?
16:31:15 <jcline> 8 it looks like
16:31:24 <bowlofeggs> i can also pick up sunday airport people if desired. i don't have a taxi driver's license tho...
16:31:43 <bowlofeggs> stickster: yep
16:31:48 <jcline> My car can hold 4 people plus myself.
16:31:54 * stickster can carry 3 + self
16:32:12 <stickster> It seems like we'll have enough transport for everyone.
16:32:15 <bowlofeggs> i can do 4 + self with no luggage
16:32:20 <stickster> cool
16:32:27 <bowlofeggs> 3+self with luggage
16:32:53 * stickster notes that relrod is booked for his airfare correctly, so he's coming in Sunday, will likely stay at another hotel Mon night, and we'll pick him up Tue night to stay with us.
16:32:58 * nirik wonders how many eggs bowlofeggs travels with
16:32:58 <bowlofeggs> actually my 4 + self is uncomfortable though
16:33:03 <bowlofeggs> nirik: hahaha
16:33:17 <bowlofeggs> i should downgrade to 3 + self - nobody wants the middle seat
16:33:21 <stickster> OK folks, I'm going to #endmeeting -- I have another meeting at :00 and I'm starving for lunch in between (plus my dog is too, probably)
16:33:39 <stickster> #action stickster pull #info stuff into wiki and have the team check/edit/update
16:33:39 <jcline> +1 food time
16:33:46 <stickster> Thanks for the time everyone, and ttyl
16:34:01 <stickster> #info stickster will be at Summit next week along with maxamillion and kinda sparse around here
16:34:01 <smooge> thanks
16:34:03 <tflink> thanks for coordinating
16:34:08 <maxamillion> stickster: +1
16:34:08 <stickster> such as I did, sure
16:34:15 <stickster> #endmeeting