21:15:51 <jsmith> #startmeeting Fedora ARM Meeting
21:15:51 <zodbot> Meeting started Wed Jan 25 21:15:51 2012 UTC.  The chair is jsmith. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:15:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:15:57 <jsmith> #meetingname fedora_arm
21:15:57 <zodbot> The meeting name has been set to 'fedora_arm'
21:16:03 <jsmith> #topic Status updates
21:16:12 <jsmith> #info getting Huntsville builders up
21:16:27 <jsmith> #info it is necessary that the host is added in Koji before starting kojid
21:18:28 <jsmith> Going to test configs with one builder to test the configs
21:19:58 <jsmith> We'll see how it goes, and tweak from there
21:20:34 <jsmith> Looks like we're going to attempt a test with Trimslice 7 first
21:21:04 <jsmith> #action ctyler to give David koji admin access to activate the hosts
21:22:13 <jsmith> #info bconoboy working on setting up koji for some newer, heavier builders
21:23:17 <jsmith> #info jonmasters to look at a kernel issue on a new system
21:23:32 <ctyler> dmarlin_: admin access granted
21:24:14 <jsmith> Wondering whether to setup a new channel for "superheavybuilders"
21:27:07 <jsmith> #info Wiki page at https://fedoraproject.org/wiki/Architectures/ARM/Fedora17_rawhide#broken_on_arm
21:30:37 <jsmith> #action bconoboy to work with ctyler to grab the intermediate file from the seneca builder and submit that upstream
21:32:25 <jsmith> ctyler: Can you help track down /tmp/ccDSvw1j.out from cdot-panda-11-3-v7hl, and send it to bconoboy?
21:32:49 <ctyler> bconoboy: built root from 276157 is not available - koji wiped it already
21:33:04 <jsmith> :-(
21:33:17 <jsmith> Try building again, and grab it before it gets blown away?
21:33:31 <bconoboy> ctyler: if somebody can resbumit the build it'll cough it up in 30 minutes or your pizza is free
21:33:53 <ctyler> Free pizza, what's not to like.
21:34:40 * jsmith will resubmit
21:35:13 <jsmith> Resubmitted as 276879
21:35:19 <bconoboy> tnx
21:35:50 <pbrobinson> jsmith: what was that?
21:36:18 <ctyler> wait, I resubmitted too. Cancelling...
21:36:32 <jsmith> pbrobinson: Guile failed, and we needed the intermediate file from gcc's internal compiler error :-(
21:36:52 <jsmith> pbrobinson: but koji had cleared away the build root
21:36:52 <ctyler> hey pbrobinson, can you join the call?
21:36:56 <jsmith> pbrobinson: Can you join the call?
21:37:03 * jsmith was two seconds slower than ctyler
21:37:28 <pbrobinson> what are the call details?
21:37:48 <maxam_mac> pbrobinson: United Kingdom Dial-In #: 08006948057 access code 617-759-1337
21:37:49 <orc_fedo> #info  why is there a BR dragging in valgrind to the buildroot?
21:45:37 <jsmith> #info Two bugs -- one for guile, one for ICU
21:46:06 <jsmith> #action pbrobinson to re-open ICU bug to report failure, but might need extra input from people who know more
21:47:05 <jsmith> #action jonmasters to take a detailed look at the attributes
21:47:26 <jonmasters> pbrobinson: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=276111
21:47:27 <bconoboy> djdelorie: Does this failure look familiar? http://arm.koji.fedoraproject.org/koji/getfile?taskID=276111&name=build.log&offset=-4000
21:47:29 <jonmasters> pbrobinson: ??
21:48:02 <jsmith> jonmasters is hoping it's just a simple symbol export problem
21:48:34 <djdelorie> bconoboy: sorry, nope
21:50:21 <jsmith> #info Looks like boost is making progress -- boost developers are being responsive
21:51:06 <jsmith> #info valgrind isn't actually needed for the build root, :-)
21:51:31 * ctyler recalls reading that valgrind is supposed to fully support ARM now
21:52:59 <ctyler> 276879 is now building on both subarchs
21:57:05 <jonmasters> latest tile support just added to glibc. Once we're done with ARM, there's always Tile :P
22:02:46 * jsmith apologizes for not logging all of that -- trying to juggle tasks again
22:02:58 <ctyler> jonmasters: I'll join that effort after they start shipping a billion chips a year.
22:03:10 <jsmith> #info Discussion about package failures on the wiki, and add more packages as you find them!
22:03:26 <jsmith> #info Sync up again around 4:00pm Eastern Time tomorrow on IRC
22:05:22 <ctyler> Note: dgilmore, PaulW, maxam_mac, PaulW will be offline for a few hours later this evening
22:07:16 <jsmith> ctyler: While you're at it, make sure you take dgilmore to Tim Horton's and get him hooked on the donuts
22:11:32 <ctyler> jsmith: having troubles steering him away from the Starbucks though
22:12:48 <jsmith> ctyler: Seriously?!? He's not hooked on the double-double yet?
22:12:57 <jsmith> *le sigh*
22:16:14 <bconoboy> dgilmore: Hey, where did the subversion that the seneca builders are using come from?
22:16:27 <bconoboy> I only see it built in stage 4
22:16:45 <bconoboy> (it's a dependency for koji-builder)
22:20:27 <dgilmore> bconoboy: stage4
22:20:41 <bconoboy> what about for softfp?
22:20:46 <dgilmore> moji
22:21:02 <bconoboy> ah, have a pointer to the moji package?
22:31:23 <bconoboy> anyone have a armv5tel subversion package? bueller?
22:31:59 <dgilmore> bconoboy: under http://australia.proximity.on.ca/fedora-arm/15/arm/
22:32:13 <dgilmore> bconoboy: sorry im killing the io on my laptop right now
22:32:40 <bconoboy> dgilmore: thanks!
22:50:13 <ctyler> bconoboy: resubmitted that guile job, it failed, and I'm not seeing anything in the buildroot dir
22:50:47 <bconoboy> ctyler: Preprocessed source stored into /tmp/ccWMuhtP.out file, please attach this to your bugreport.
22:55:59 <ctyler> bconoboy: it's not there, /var/lib/mock/...../root/ is empty
22:56:36 <bconoboy> well, that's inconvenient
22:56:52 <bconoboy> is there any way I can get yum to pull down the same gcc you're building with?
22:58:46 <fossjon> cant bconoboy just create a local repo with that new gcc we're using too
22:58:50 <fossjon> and point mock at it??
22:58:57 <fossjon> so it pulls it in
22:59:27 <fossjon> i think thats what dsd and I did for gcc and what not
23:00:19 <ctyler> bconoboy: use http://arm.koji.fedoraproject.org/repos/f17-build/latest/
23:00:44 <fossjon> oh ya point mock to that
23:00:47 <fossjon> :)
23:01:09 <fossjon> copy the repo lines in one of the mock config files, change the baseurl= to that url above
23:01:45 <bconoboy> trying that
23:02:25 <fossjon> i think /etc/mock/fedora-17-arm.cfg or something like that
23:03:51 <bconoboy> have it running now, we'll see
23:04:06 <maxam_work> ARM TEAM Night OUT
23:04:10 * maxam_work is soooo ready to go out and have fun!!!
23:06:48 <jsmith> #endmeeting