20:11:55 <bconoboy> #startmeeting
20:11:55 <zodbot> Meeting started Wed Mar 14 20:11:55 2012 UTC.  The chair is bconoboy. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:11:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:12:11 <bconoboy> #meetingname Primary Arch Planning
20:12:11 <zodbot> The meeting name has been set to 'primary_arch_planning'
20:12:44 <bconoboy> #meetingtopic Finishing https://fedoraproject.org/wiki/Features/FedoraARM
20:13:10 <bconoboy> #topic Kernels to build
20:15:16 <bconoboy> http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=49660
20:15:40 <djdelorie> http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=58088
20:19:24 <bconoboy> #link Example time to build kernel 2.6.42 is 14+ hours, http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=49660
20:19:57 <bconoboy> #idea official kernel package should just be qemu kernel for speed reasons
20:23:11 <bconoboy> #idea Use koji flags to cause other arches to build per-arch kernels
20:34:24 <bconoboy> #topic Testing
20:34:40 <bconoboy> Looking at adding auto-qa support for arm
20:36:41 <jonmasters> We need a section on distribution - what are we distributing?
20:36:58 <bconoboy> #topic Distribution
20:37:01 <jonmasters> Suggest we say "default image is a collection of bits similar to existing Spin X", where X might be XFCE or Desktop
20:37:29 <jonmasters> We need a section on testing and autoqa. Paul W. will help here but we need to figure out how we will integrate into standard workflow
20:37:32 <jsmith> WORKSFORME
20:37:47 * jsmith has to leave now, unfortunately
20:37:57 <jonmasters> jsmith: have a good one!
20:38:09 <jsmith> jonmasters: Will do
20:38:15 <bconoboy> jsmith: feel free to join the call: (800) 451-867, 617-759-1337
20:38:31 <jsmith> bconoboy: I would, but I'm driving to do a presentation at a LUG meeting
20:38:31 <maxam> http://zenit.senecac.on.ca/wiki/index.php/Raspberry_Pi_Fedora_Remix
20:38:46 <jsmith> bconoboy: Probably better if I don't confcall and drive
20:41:27 <bconoboy> #idea The ARM standard is distributing dd-able images rather than an installer so we should too
20:45:58 <bconoboy> include tarballs of images
20:46:20 <bconoboy> #idea end goal is to have an installer, but not a pre-requisite for primary
20:46:39 <jonmasters> tiny images, minimal bits, installer comes later (in addition, not a replacement for images), but most boards benefit from the established distribution model of "image of card"
20:48:33 <bconoboy> #topic When are builds done-enough?
20:49:23 <bconoboy> #idea ftbfs primary packages are not administrative arm blockers
21:02:48 <bconoboy> #topic Supported package requirements
21:03:47 <bconoboy> #agreed Having desktop software built is sufficient (gnome, kde, xfce), don't need to provide framebuffer
21:11:02 <bconoboy> #topic Next Steps
21:11:22 <bconoboy> #agreed bconoboy to integrate today's discussion into the current feature proposal page
21:12:01 <bconoboy> #agreed mail pointer to revised document to fedora-arm, robyn
21:12:21 <bconoboy> #agreed jonmasters to check deadline for fesco review
21:12:59 <dgilmore> bconoboy: sorry was at the gym
21:13:18 <bconoboy> dgilmore: we're wrapping up now
21:15:19 <dgilmore> bconoboy: ok
21:16:04 <bconoboy> dgilmore: you might look at scrollback and see what was missed
21:16:18 <dgilmore> bconoboy: ok
21:17:38 <bconoboy> #endmeeting