16:01:15 <tflink> #startmeeting f19final-blocker-review-4
16:01:15 <zodbot> Meeting started Mon Jun 10 16:01:15 2013 UTC. The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:15 <tflink> #meetingname f19final-blocker-review-4
16:01:15 <tflink> #topic Roll Call
16:01:15 <zodbot> The meeting name has been set to 'f19final-blocker-review-4'
16:01:47 * kparal in active lurking mode
16:02:36 <tflink> active lurking mode?
16:03:40 <kparal> that's way better than a passive lurking mode. I might even participate in the discussion :)
16:04:54 <tflink> :-/
16:05:32 * jreznik is here
16:06:01 <kparal> no worries, I'm 90% present
16:06:40 <jreznik> but used one free hour without qa meeting to play football and got hit by the ball to the head and is not sure he will make it today till the end
16:06:51 * jreznik hopes his brain is still in the scull
16:07:12 <kparal> jreznik: sport is dangerous
16:07:12 <Viking-Ice> I'm here for the next 10 minutes ;)
16:07:25 <kparal> jreznik: way more dangerous than having meetings
16:07:31 <tflink> no matter how many times this happens, I still think of american football first when someone says football
16:07:39 <tflink> you'd think I'd know better by now
16:07:42 * jreznik is going to grab some ice
16:08:00 <jreznik> tflink: do you mean handegg? http://4.bp.blogspot.com/-u_EoVz2CPPc/T7jzJqF0RkI/AAAAAAAADak/AklIgH7tRx8/s1600/football-handegg.jpg
16:08:00 <tflink> kparal: some meetings are far more mentally dangerous
16:08:07 <Viking-Ice> is it not only americans that do not call football by it's real name
16:08:31 <kparal> jreznik: :D
16:08:57 <tflink> jreznik: something like that, I suppose.
16:09:11 <adamw> morning folks
16:09:13 <tflink> Viking-Ice: I thought that it was known as football pretty much everywhere outside the US
16:09:14 <adamw> sorry to be late
16:09:22 <tflink> .fire adamw for being late
16:09:22 <zodbot> adamw fires adamw for being late
16:09:35 <Viking-Ice> tflink, yeah and you call it soccer
16:10:04 <tflink> Viking-Ice: there are other countries that call football something different?
16:10:46 <adamw> jreznik: the irony about that is that american football is directly derived from the "rugby football" code, as is still played in the UK and supervised by the "rugby football" union
16:11:05 <adamw> i would just love to see some of those smug 'handegg' posters go into a pub full of rugby players and suggest calling their game handegg. i'd pay money.
16:11:21 <jreznik> adamw: :D
16:11:31 <Viking-Ice> tflink, not that I'm aware of we all call it football here while american football is kinda of womens version of rugby
16:12:25 * kparal likes adamw's proposal and wants to watch
16:12:38 <tflink> Viking-Ice: that's rather sexist, no?
16:12:55 <tflink> anyhow, I suppose it's about time to get started with the _real_ fun
16:13:05 <tflink> any volunteers for secretarialization?
16:13:19 <Viking-Ice> tflink, depends on how you look at it
16:14:31 <adamw> sure
16:14:43 <tflink> adamw: thanks
16:14:55 <tflink> #topic Introduction
16:14:58 * jreznik can write only with one hand, holdimg bag with ice... no help from me
16:15:02 <tflink> Why are we here?
16:15:02 <tflink> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and freeze exception bugs.
16:15:19 <tflink> er, do we have enough people to even do the review?
16:15:29 <adamw> me, you, kparal, viking, jreznik?
16:15:47 <tflink> I count adamw and I, 90% of kparal but no jreznik and Viking-Ice for another 10 minutes or so
16:16:02 <adamw> true, and tflink/adamw/viking are all QA
16:16:14 * kparal boosts his capacity to 100%
16:16:30 * tflink continues with boilerplate, we can figure out people after that's done
16:16:33 <adamw> nirik: around?
16:16:39 <tflink> #info We'll be following the process outlined at:
16:16:39 <tflink> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:16:43 <tflink> #info The bugs up for review today are available at:
16:16:44 <tflink> #link http://qa.fedoraproject.org/blockerbugs/current
16:16:46 <nirik> somewhat, but updating/rebooting machines. ;)
16:16:54 <tflink> #info The criteria for release blocking bugs can be found at:
16:16:55 <tflink> #link https://fedoraproject.org/wiki/Fedora_19_Final_Release_Criteria
16:16:57 <tflink> #link https://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria
16:17:01 <tflink> #link https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria
16:17:02 <jreznik> tflink: /me will try to help
16:17:04 <tflink> #info Up for review today, we have:
16:17:37 <tflink> #info 15 Proposed Blockers
16:17:37 <tflink> #info 12 Accepted Blockers
16:17:37 <tflink> #info 15 Proposed Freeze Exceptions
16:17:37 <tflink> #info 18 Accepted Freeze Exceptions
16:17:41 <tflink> ew
16:17:45 <Viking-Ice> I need to run and pick up my new phone ( the shop closes at 17:00 45 minutes from now ) but can join again when I home ( which takes around 45 minutes to get to )
16:17:55 <Viking-Ice> later
16:17:58 <tflink> Viking-Ice: enjoy the new toy :)
16:18:10 <Viking-Ice> Galaxy s4 I hope so ;)
16:18:39 <tflink> I think we have enough for the unanimous ones
16:19:00 * dgilmore is here
16:19:24 <adamw> hi dgilmore, thanks
16:19:47 <tflink> cool, we have enough non-disabled people for 3 acks :)
16:20:07 <tflink> if there are no objections, we'll get started with the proposed blockers
16:20:28 <dgilmore> tflink: :) im disabled still. dont get the cast off till wednesday
16:20:35 <dgilmore> but lets start
16:20:53 <tflink> dgilmore: ah, forgot about that. I was referring to jreznik's football injury :)
16:21:23 <tflink> #topic (966761) storage configuration failed: Not enough free space on disks for automatic partitioning
16:21:27 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=966761
16:21:29 <tflink> #info Proposed Blocker, anaconda, NEW
16:22:42 <tflink> methinks we forgot to do the needed digging on this one
16:22:57 <tflink> I see no attempts to reproduce
16:23:39 <adamw> well, we were waiting on the needinfo for mark, i think, not reproduction attempts...
16:23:54 <dgilmore> tflink: he said he was able to reproduce
16:24:07 <dgilmore> https://bugzilla.redhat.com/show_bug.cgi?id=966761#c11
16:24:10 <adamw> i guess we do need to see if anyone else can hit it now, though
16:25:49 <dgilmore> yeah
16:25:49 * kparal running it
16:26:03 <tflink> proposed #agreed - This has been reproduced on ppc but it needs to be reproduced on PA before taking it as a blocker. will revisit when more information is available
16:26:23 <tflink> unless we want to wait for kparal's run to finish
16:26:50 <tflink> wasn't there also a question about whether ks was sequential or not - ie, the order or part and clearpart?
16:27:43 <adamw> ack
16:27:50 <dgilmore> ack
16:27:54 <adamw> possibly, but that's probably just me guessing stuff
16:28:27 <tflink> other ack/nak/patch?
16:28:29 <jreznik> ack
16:28:39 <tflink> #agreed - This has been reproduced on ppc but it needs to be reproduced on PA before taking it as a blocker. will revisit when more information is available
16:28:54 <tflink> #topic (972561) Anaconda fails find to a dependent package and crashes with Errno 256: "No more mirrors to try" on TC-2 DVD install. MATE and minmal tested so far.
16:28:57 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=972561
16:29:00 * kparal is experiencing technical difficulties
16:29:00 <tflink> #info Proposed Blocker, anaconda, NEW
16:29:01 <tflink> and before I forget
16:29:11 <tflink> #chair adamw jreznik kparal dgilmore
16:29:11 <zodbot> Current chairs: adamw dgilmore jreznik kparal tflink
16:29:36 <kparal> I got usual "no disks selected"
16:31:13 <dgilmore> i hit a simmiliar issue doing a arm network install but it was transient due to me hammering my internet connection at the time
16:31:20 <adamw> i suppose all these ks issues could all be manifestations of the same underlying bug...
16:31:53 <tflink> yeah, isn't one of them already accepted as a blocker?
16:32:19 <tflink> this sounds like an issue with an individual system ATM - reject or punt for more reproducers?
16:32:20 <kparal> tflink: yes, 969327
16:33:02 <kparal> "CPU memory: 512GB"?
16:33:54 <kparal> ask him to append logs in the least
16:34:34 <dgilmore> im good with waiting to collect more data
16:34:38 <kparal> minimal install started for me just fine
16:34:47 <tflink> isn't file part of @base?
16:35:55 <tflink> if so, -1. if this was widespread, we'd of heard more about it by now
16:36:05 <adamw> it could be a low memory condition
16:36:18 <adamw> but I couldn't reproduce it with the same amount of memory (though I can reproduce his other 512MB RAM bug)
16:36:21 <kparal> MATE also started installing fine
16:36:39 <adamw> so, punt. i asked him for more info in irc last night, but I can do it in the bug today
16:36:47 <dgilmore> i saw that issue, but on a network install
16:37:18 <kparal> he might have used online repos?
16:37:28 <kparal> updates-testing?
16:37:35 <kparal> ask to clarify
16:37:38 <adamw> possible, yeah
16:37:55 * adamw fires a quick net install
16:37:58 <dgilmore> could just be a weird io issue
16:38:22 <tflink> proposed #agreed 972561 - This sounds like a transient error, but would like to see more information from reporter before making a decision on blocker status. Will revisit once more information is available
16:38:23 <adamw> it's a somewhat strange error in general
16:38:30 <adamw> Packages/f/file... is clearly a path on the DVD
16:38:37 <adamw> but "No more mirrors to try" is a remote repo error
16:38:55 <adamw> but anyway, we need logs.
16:38:57 <kparal> ack
16:38:57 <adamw> ack
16:39:10 <jreznik> ack
16:39:56 <tflink> #agreed 972561 - This sounds like a transient error, but would like to see more information from reporter before making a decision on blocker status. Will revisit once more information is available
16:40:05 <tflink> #topic (890302) installer does not also try non-default device types when trying to create new /boot with full disk(s)
16:40:08 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=890302
16:40:10 <tflink> #info Proposed Blocker, anaconda, NEW
16:41:52 <tflink> is boot-from-btrfs a valid layout? from the anaconda dev comments, it sounds so
16:42:33 <adamw> yeah, i'd read it that way. though it seems that this should be trivial to work around
16:42:43 <adamw> create the subvol as just about any other mount point and then change its mount point
16:43:14 <kparal> might be good to invite some anaconda dev here?
16:43:39 * adamw does that thing
16:43:40 <tflink> I'm also noticing "I asked for /boot, without specifying a Desired Capacity value (left it blank.)."
16:44:12 <adamw> well, that ought to work okay
16:44:17 <adamw> it's a pretty normal thing to do for btrfs subvols
16:45:52 <adamw> hi dlehman
16:45:56 <adamw> thanks
16:46:00 <adamw> we're on https://bugzilla.redhat.com/show_bug.cgi?id=890302
16:47:19 * bcl says .* -1
16:47:25 <dlehman> we don't try multiple device types, ever
16:47:40 <adamw> bcl: ack, now let's go for a drink
16:48:08 <adamw> so as far as blocker status goes, this seems to qualify, but i suggested it'd be easy to work around: create the mount point as / or /home and then just change it
16:48:09 <dlehman> we don't create /boot on btrfs without the user explicitly asking for that exact thing for that specific mountpoint
16:48:32 <adamw> dlehman: which they can only do when changing the properties of an existing mount point, not when creating one, right?
16:48:37 <dlehman> right
16:49:03 <dlehman> we don't even need to offer btrfs /boot at all IMO
16:49:11 <dlehman> -1
16:49:12 <tflink> so this is the experience as designed
16:50:01 <adamw> i'm okay with -1 on the basis that it can be worked around, at least.
16:53:55 <adamw> welp, we can argue about whether it's a bug to be fixed or not separately, what matters here is blockeriness
16:53:58 <adamw> ack
16:54:07 <kparal> ack
16:54:18 <jreznik> ack
16:55:15 <tflink> #agreed 890302 - RejectedBlocker - While inelegant, this is as designed and is easily workaround-able by modifying an existing non-boot mountpoint. Therefore, it is rejected as a blocker for F19 final
16:55:26 <tflink> #topic (971191) DVD install option unavailable in TUI
16:55:26 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971191
16:55:26 <tflink> #info Proposed Blocker, anaconda, NEW
16:57:04 <dlehman> is there any argument for separate /boot on btrfs anyway?
16:57:13 <kparal> the Refresh option in TUI is mostly confusing
16:57:17 <adamw> dlehman: that's a point, i spose. but we're on the next thing now :)
16:57:29 <adamw> kparal: it's kinda needed for the hub because it changes state behind your back
16:57:32 <adamw> but anyhoo
16:57:44 <adamw> this bug is "DVD install option unavailable in TUI"
16:57:44 <kparal> adamw: well, don't print if you're not ready, it's as simple as that
16:58:03 <kparal> the same approach as for GUI can't be used for TUI
16:58:06 <adamw> kparal: then the user won't see anything for a while at start of install and won't be able to do stuff in other spokes while mirror discovery is happening
16:58:10 <adamw> but anyhoo
16:58:16 <kparal> "Please wait..."
16:58:18 <kparal> yes
16:58:31 <kparal> but the visual clues are simply not there
16:58:44 <bcl> kparal: geez, take a hint.
16:58:47 <adamw> on this specific bug...we need to be a bit more specific about the required functionality in each interface in the criteria, but for now i'd say we should only require pretty minimal functionality from the text installer
16:58:57 <bcl> adamw: I'm +1 for this.
16:59:08 <adamw> but i dunno, i'm willing to have my mind changed
16:59:22 <bcl> I don't know why you'd be using text with a DVD, but if you are we sure ought to actually do the install from it.
16:59:25 <adamw> bcl: so as long as we're having the full-fat text install interface, it should actually work?
16:59:34 <kparal> I think text install from DVD used to work, didn't it?
16:59:44 <adamw> oh, did it? i may be getting confused
16:59:58 <adamw> i was thinking that at 18 all we did was minimal netinstall. if dvd has always worked then sure, +1
16:59:58 <kparal> in F18 I believe so
17:00:08 <kparal> I can check
17:02:15 <kparal> yes, in F18 it installs from DVD, rather than downloading packages
17:02:28 * kparal will be back in 5 minutes
17:03:11 <adamw> ok, +1
17:03:16 <tflink> proposed #agreed 971191 - AcceptedBlocker - Violates the following F19 alpha release criterion for text installs using DVD media: "When using the DVD image, the installer must be able to use the DVD as a package source."
17:03:18 <jreznik> +1
17:03:31 <jreznik> ack
17:05:04 <adamw> ack
17:06:29 * tflink assumes ack from kparal
17:06:32 * kparal is back
17:06:43 <kparal> just a note, samantha said she doesn't consider this bug to me about install source
17:06:58 <kparal> but that's a minor issue I guess
17:07:01 <kparal> ack
17:07:04 <tflink> #agreed 971191 - AcceptedBlocker - Violates the following F19 alpha release criterion for text installs using DVD media: "When using the DVD image, the installer must be able to use the DVD as a package source."
17:07:29 <jreznik> kparal: she says she's aware of it
17:07:31 <tflink> ~ 1 hour in, 4 bugs covered
17:07:37 <tflink> #topic (972547) Anaconda hangs and crashes on netinstall on a system with 512MB of RAM allocated
17:07:40 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=972547
17:07:42 <tflink> #info Proposed Blocker, anaconda, NEW
17:08:16 <bcl> nope
17:08:32 <kparal> "Whether in regular graphics mode or basic graphics mode" -- what is that?
17:08:44 <tflink> kparal: nomodeset
17:08:50 <kparal> oh I see
17:08:59 <kparal> I didn't know DVD/netinst has it as well
17:09:01 <bcl> Note this is an attemp to do a 512M GUI install. text works fine (and actually I've had 512 work at various times, but it is slow due to lots of swapping)
17:09:06 <tflink> -1 per c#3 and c#5
17:09:24 <bcl> -1
17:09:29 <jreznik> -1
17:09:37 <adamw> tflink: we did spend the first half hour arguing about football
17:09:57 <kparal> -1, but we should adjust the docs if needed
17:09:58 <adamw> i'd be -1, but we can consider twiddling with the minimum requirements wording
17:10:07 <adamw> i wouldn't want to raise the hard floor in the installer because a DVD install works
17:10:45 <adamw> bcl: for me, 512MB graphical DVD reliably works, 512MB graphical netinstall reliably fails; presumably the load of reaching a mirror and doing mirror-y...stuff...before swap is available kills it
17:11:02 <tflink> proposed #agreed 972547 - RejectedBlocker - It is possible to do an install with the text interface with 512M ram or with the DVD. All installation methods are not guaranteed to work with minimum ram and thus, this is rejected as a release blocking bug for F19 final.
17:11:09 <kparal> also, he might be installing without a swap part
17:11:10 <adamw> ack
17:11:16 <jreznik> ack
17:11:18 <adamw> kparal: it fails before you can do partitioning
17:11:26 <kparal> ack
17:11:39 <tflink> #agreed 972547 - RejectedBlocker - It is possible to do an install with the text interface with 512M ram or with the DVD. All installation methods are not guaranteed to work with minimum ram and thus, this is rejected as a release blocking bug for F19 final.
17:12:58 <tflink> do we want to do the anaconda FEs while the devs are here?
17:13:31 <kparal> fine with me
17:13:40 <jreznik> ok
17:13:49 <jreznik> not a bad idea
17:14:02 <tflink> actually, lets do this blivit proposed blocker first
17:14:04 <tflink> #topic (969182) DeviceCreateError: ('Could not commit to disk /dev/mapper/mpatha, (py_ped_disk_commit)', 'mpatha3')
17:14:08 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=969182
17:14:10 <tflink> #info Proposed Blocker, python-blivet, NEW
17:15:20 <tflink> this sounds like something that would break any multipath system
17:15:23 <dlehman> +1
17:15:44 <dlehman> there is a verified non-invasive fix
17:15:46 <tflink> dlehman: am I reading this right or is there any reason to think this would be ppc-specific
17:15:55 <dlehman> not arch-specific AFAIK
17:16:01 <tflink> +1
17:16:04 <jreznik> +1
17:16:14 <dgilmore> +1
17:16:50 <adamw> +1
17:16:52 <tflink> proposed #agreed 969182 - AcceptedBlocker - Violates the following F19 final criterion for systems with multipath storage: "The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel)"
17:17:30 <dgilmore> ack
17:17:38 <adamw> ack
17:17:41 <jreznik> ack
17:17:41 <adamw> brb call of nature
17:17:43 <kparal> ack
17:17:45 <adamw> and yes, let's do anaconda proposed FEs
17:18:12 <tflink> #agreed 969182 - AcceptedBlocker - Violates the following F19 final criterion for systems with multipath storage: "The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel)"
17:18:20 <tflink> #topic (966253) SELinux is preventing /usr/sbin/ntpdate from read, write access on the chr_file /dev/mapper/control.
17:18:23 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=966253
17:18:26 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
17:19:49 <kparal> so, this is just a harmless warning, not enforced, right?
17:20:12 <tflink> this sounds kinda blockery to me
17:20:26 <tflink> unless you're doing a live install
17:21:12 <bcl> anaconda expects to be in permissive or disabled.
17:21:28 <tflink> bcl: even during a live install?
17:21:38 <bcl> especially during live install.
17:21:44 <bcl> (well any install)
17:22:26 <bcl> We should figure out how to fix this, but the problem is the environment isn't matching what we do for boot.iso
17:22:52 <adamw> tflink: one of the things 'liveinst' does is set enforcing off.
17:22:58 <kparal> when I boot live, I'm in Enforcing mode
17:23:03 <kparal> ah
17:23:04 <adamw> kparal: ^^^
17:23:20 <kparal> yes, you're right. just checked
17:23:53 <tflink> does this happen for kde or gnome? I would assume that it isn't limited to secondary DEs
17:24:00 <adamw> yeah, we should check
17:24:25 <adamw> the criterion we have is actually a 'polish criterion' - it's not intended to make sure that no AVCs are breaking anything, it's just that we think showing AVCs during install / firstboot / first log in is really bad
17:24:30 <adamw> and more encouragement to the 'turn off selinux' brigade
17:24:32 <bcl> oh, so this is just a report, not a crash.
17:24:50 <adamw> so if this avc is popping up during release-blocking desktop live installs I'm +1 *blocker* even if it doesn't actually break anything
17:24:59 <bcl> -1
17:25:10 <bcl> turn off the report daemon on live :)
17:25:19 <adamw> hah, nice try :)
17:25:23 <bcl> (that being said, I'll look into fixing it)
17:25:58 <adamw> the 'turn off selinux' brigade point is the important one: it _does_ look pretty bad for selinux if we can't even get our own house in order so that AVCs don't pop up when you're installing the OS.
17:26:46 <Viking-Ice> ;)
17:26:53 * adamw starts a quick desktop live install
17:29:11 <Viking-Ice> +1
17:29:40 <adamw> well, i'm not seeing this yet in a minimum-possible-actions live install...
17:29:48 <adamw> at 60% of 'installing software'
17:32:07 <adamw> completed the install, didn't get any notifications, and SELinux Alert Browser says "No Alerts"
17:32:13 <tflink> so +1 FE, no blocker?
17:32:18 <adamw> so I guess we need more details to pin down whether this happens reliably
17:32:21 <adamw> +1 FE at least for now
17:32:27 <jreznik> +1 FE for now, sure
17:32:29 <adamw> (assuming the fix isn't too crazy)
17:33:36 <tflink> proposed #agreed 966253 - AcceptedFreezeException - This is a polish issue; there should be no AVC denials during live install. If this were on a primary DE, it would be a blocker so accepted as a FreezeException. A tested fix would be considered past freeze.
17:33:50 <kparal> ack
17:33:59 <Viking-Ice> ack
17:34:03 <adamw> ack
17:34:20 <tflink> #agreed 966253 - AcceptedFreezeException - This is a polish issue; there should be no AVC denials during live install. If this were on a primary DE, it would be a blocker so accepted as a FreezeException. A tested fix would be considered past freeze.
17:34:29 <tflink> #topic (972592) Text install claims 'GNOME Desktop' is the default package set, but actually installs minimal (Final TC2)
17:34:32 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=972592
17:34:34 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
17:35:33 <kparal> this could qualify for a blocker
17:35:52 <adamw> yeah, i didn't want to over-propose, but if you folks think so...
17:36:00 <adamw> i also didn't check if you can actually get a GNOME install going at all
17:36:35 * kparal testing quick
17:36:45 <tflink> depends on whether you can acutally install gnome desktop from text, I think
17:37:15 <bcl> no, it says gnome but installs minimal.
17:37:50 <bcl> -1 from me. it does what you told it to, the label is just wrong.
17:38:13 <adamw> bcl: -1 blocker or -1 FE?
17:38:25 <adamw> bcl: and, um, I didn't 'tell it to do' anything. this is about the *default* behaviour
17:38:25 <bcl> -1 blocker
17:38:46 <bcl> oh, I thought this was a minimal kickstart...
17:38:51 <adamw> no, just interactive install.
17:39:49 <adamw> "Software selection" spoke lists "GNOME Desktop", but if you just complete "Install Destination" and set a root password and timezone and start the install, without going into that spoke at all, you get minimal.
17:39:53 <kparal> damn, it's downloading packages. I'm still waiting on the number of packages to be installed
17:39:55 <bcl> oh, there's another one like this then where you want minimal, get miminal, but the label is wrong. probably related.
17:40:20 <bcl> adamw: +1 blocker then. If you meant to do gnome and it said it would and it didn't...
17:40:42 <kparal> adamw: when I picked GNOME manually, I get GNOME
17:40:51 <kparal> just the default label is wrong, it seems
17:41:05 <tflink> also sounds like a dupe of another bug?
17:41:15 <adamw> bcl: we can argue that if you go into the spoke and explicitly pick it and it works, then the bug can be 'worked around'
17:41:34 <tflink> +1 FE, not as sure about blocker
17:41:34 <adamw> let's not argue for too long, though, it should be fixable and we should fix it, so let's pick one and go for it...
17:41:35 <bcl> adamw: 972182 is what I was thinking of.
17:42:03 <kparal> I'm also not strongly opinionated about the blocker call, since it's easy to work around
17:42:18 <adamw> bcl: yeah, probably related.
17:42:35 <adamw> i guess it's just stuck always showing 'GNOME Desktop' as the initial text for that spoke whatever the actual case is, or something.
17:43:04 <adamw> i'm definitely +1 FE, don't really mind whether we make it blocker or not.
17:43:23 <adamw> we could just accept FE for now and if somehow we get close to final and this isn't fixed, raise the alarm?
17:43:35 <kparal> ok
17:43:58 <bcl> adamw: when you make your note go ahead and assign to sbueno
17:44:06 <tflink> proposed #agreed 972592 - AcceptedFreezeException - While this could lead to installing a different package set than intended, it is relatively easy to workaround (manually select package set) and a tested fix would be considered past freeze.
17:44:35 <Viking-Ice> ack
17:44:38 <jreznik> ack
17:44:38 <kparal> ack
17:44:43 <tflink> #agreed 972592 - AcceptedFreezeException - While this could lead to installing a different package set than intended, it is relatively easy to workaround (manually select package set) and a tested fix would be considered past freeze.
17:44:49 <adamw> ack
17:44:51 <tflink> #topic (972265) When using a kickstart that specifies nothing about repo, 'closest mirror' doesn't seem to be usable
17:44:53 <adamw> bcl: I think I already did
17:44:54 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=972265
17:44:57 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
17:45:39 <kparal> this is a dupe of my older bug report?
17:45:43 <kparal> "url" is required
17:46:15 <adamw> no, this isn't about having it set properly in the kickstart
17:46:29 <adamw> it's about intentionally using a kickstart which only defines a package set, and wanting to set everything else interactively
17:46:36 <kparal> ah
17:46:37 <adamw> remember, this is what we're telling people who want multiple desktop installs to do
17:46:56 <adamw> and anyone who wants to set a package set at install time that you can't get through the GUI
17:47:03 <adamw> so i think it ought to be a case we care about
17:48:10 <tflink> +1 FE for preventing loud people with pitchforks
17:48:14 <bcl> hrm. seems an awful lot like the missing url variation.
17:48:37 <kparal> bcl: see a few lines above :)
17:48:40 <adamw> bcl: it may be similar / the same to the code, but the 'user experience' end is a bit different, i guess
17:48:57 <bcl> Yeah. I'll have to ponder that.
17:49:15 <adamw> note there's another issue with this workflow which we'll probably hit next, that's rather more of a PITA to deal with
17:49:23 <adamw> sneak preview!
17:49:42 * kparal claps his hands in anticipation
17:49:55 * bcl cringes
17:49:58 <adamw> so, i'm +1, i don't disagree with myself :)
17:50:04 <Viking-Ice> +1 here as well
17:50:18 <tflink> proposed #agreed 972265 - AcceptedFreezeException - This makes the recommended workflow for people installing multiple DEs and other non-standard package sets more difficult than it needs to be. A tested fix would be considered past freeze.
17:50:21 <adamw> of course, if anaconda decide in their Wisdom that this can't be fixed, we'd probably defer, but assuming there's something to be fixed, doing it for Final seems indicated.
17:50:22 <adamw> ack
17:50:42 <kparal> ack
17:52:02 <adamw> ack
17:52:07 <adamw> er, sorry, i already acked.
17:52:17 <tflink> adamw: you forgot your moustache
17:52:21 <adamw> whoopsie
17:52:30 * adamw dons moustache and beret
17:52:30 <adamw> le ack
17:52:35 <tflink> adamw: here you go - http://4.bp.blogspot.com/_lwmLZvKDhXQ/TDbCYd0GYOI/AAAAAAAAADY/E6c0FLzSiow/s1600/moustache+clearer+closer+crop.jpg
17:52:48 <tflink> #agreed 972265 - AcceptedFreezeException - This makes the recommended workflow for people installing multiple DEs and other non-standard package sets more difficult than it needs to be. A tested fix would be considered past freeze.
17:52:48 <adamw> hah!
17:53:09 <tflink> if I'm ever in italy, I want to try finding a can of that
17:53:23 <tflink> #topic (972266) Installation Destination spoke behaves strangely when installing from a minimal (packages only) kickstart
17:53:26 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=972266
17:53:29 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
17:53:44 <adamw> il acko
17:53:57 <adamw> yup, this is the other one.
17:54:04 <tflink> ouch
17:54:07 <adamw> same kind of bug with the 'installation destination' spoke, but rather more of a pain to deal with.
17:54:14 <tflink> technically workaround-able
17:54:59 <adamw> yeah, but you have to perform some contortions. the bootloader bit is especially tricky.
17:55:08 <bcl> weird.
17:55:27 <tflink> +1 FE
17:56:04 <Viking-Ice> +1 here as well
17:56:17 <kparal> since some organizations (Red Hat) prepare simple kickstarts with some basic data for their employees which can then do a network installation, this might be even blocker for them
17:56:43 <bcl> +1 FE
17:56:54 <kparal> I think there's usually some network preconfigured, ntp service and something like that, the rest is configured interactively
17:57:09 <adamw> oh, just for the record, these aren't 'single-source' bugs: robatino saw the same thing
17:57:16 <adamw> in fact he saw it first and I just confirmed it (and investigated a bit more)
17:57:41 <adamw> +1, obviosly
17:58:05 <tflink> proposed #agreed 972266 - AcceptedFreezeException - This makes an interactive install started with incomplete kickstart far more complicated than it needs to be, even though it is techinically workaround-able. A tested fix would be considered after freeze.
17:58:17 <jreznik> ack
17:58:27 <adamw> ack
17:58:27 <kparal> ack
17:58:34 <tflink> #agreed 972266 - AcceptedFreezeException - This makes an interactive install started with incomplete kickstart far more complicated than it needs to be, even though it is techinically workaround-able. A tested fix would be considered after freeze.
17:58:37 <Viking-Ice> ack
17:58:44 <tflink> #topic (970048) pre-selected language is cropped on the initial screen
17:58:47 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=970048
17:58:50 <tflink> #info Proposed Freeze Exceptions, anaconda, NEW
18:00:16 <tflink> that's an odd polish bug
18:00:35 <tflink> +1 FE as long as its earlier in freeze
18:00:49 <Viking-Ice> how risky is fixing this?
18:00:52 <tflink> I'm not sure about taking a fix for this late in freeze unless it's something simple
18:00:53 <adamw> pretty trivial, but +1 for pre-official-freeze or early-official-freeze
18:01:13 <adamw> isn't there an accent in the text string in question somewhere?
18:01:17 <adamw> that could be throwing it off
18:01:29 <kparal> there is
18:01:35 <bcl> well, scrolling to the top is never really a nice way to do things.
18:01:55 <kparal> Čeština (Česká Republika)
18:01:57 <Viking-Ice> is this just broken for auto detection or manual selection as well?
18:02:01 <adamw> yeah, it has a whole bunch of those funky accents you crazy czech kids use =)
18:02:04 <tflink> proposed #agreed 970048 - AcceptedFreezeException - This is a polish issue that looks bad on the first screen presented to a user outside of the US. A tested fix would be considered past freeze, but unlikely to be accepted late in freeze
18:02:17 <adamw> Viking-Ice: i'd assume only auto-selection because that's the only case where anaconda is trying to position the selected language specially like this
18:02:28 <adamw> Viking-Ice: otherwise the widget just behaves like a pretty normal list
18:02:36 <bcl> oh, I see, it moves it to the top entry instead of scrolling to its location.
18:02:41 <adamw> yeah, if I boot a VM and select 'Czech' it just gets highlighted
18:02:46 <adamw> no positioning weirdness
18:02:48 <kparal> ack
18:02:51 <adamw> ack
18:03:07 <Viking-Ice> ack
18:03:08 <tflink> #agreed 970048 - AcceptedFreezeException - This is a polish issue that looks bad on the first screen presented to a user outside of the US. A tested fix would be considered past freeze, but unlikely to be accepted late in freeze
18:03:09 <adamw> bcl: right, i think it changed since 18.
18:03:22 <tflink> OK, that's all the anaconda bugs
18:03:32 <bcl> adamw: yes, a bunch.
18:03:40 <tflink> back to the non-anaconda and non-blivet blockers!
18:03:43 <bcl> cool. see ya.
18:03:50 <tflink> bcl: thanks for the help
18:04:17 <tflink> #topic (971741) php and cups-php incompatibility
18:04:17 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971741
18:04:17 <tflink> #info Proposed Blocker, cups-filters, ASSIGNED
18:04:54 <Viking-Ice> hmm looks like this could be fixed with a zero day
18:05:14 <kparal> if you update from the network
18:05:21 <kparal> and not from DVD
18:05:26 <tflink> upgrade, not update, no?
18:05:31 <kparal> upgrade, right
18:05:51 <tflink> yeah, this could be fixed with an update
18:06:02 <adamw> there's the media-based upgrade case, though isn't that still basically broken?
18:06:39 <tflink> I don't think that cups-php is on the dvd, though
18:06:40 <Viking-Ice> -1
18:06:44 <kparal> it's fundamentally broken, but that's not probably your question :)
18:06:55 <adamw> tflink: as i'm reading it, cups-php is what you have one the system *to be upgraded*
18:07:10 <kparal> adamw: right
18:07:17 <adamw> it requires a specific version of cups and cups-libs (packages that are certainly on the DVD) and they aren't there in f19
18:07:17 <kparal> but the package doesn't exist anymore
18:07:44 <adamw> so any time you're upgrading an f18 system with cups-php installed, you'll hit this (unless it gets fixed, obviously)
18:07:59 <kparal> that's how I understand it as well
18:08:01 <adamw> oh, but cups-php isn't in the default package set, so -1. whee.
18:08:10 <adamw> we only support default package set upgrades.
18:08:15 <adamw> er, 'block on'
18:08:25 <tflink> FE?
18:08:28 <adamw> minimal, default GNOME, default KDE, anything else takes a hike
18:08:31 <tflink> eh, 0-day
18:08:37 <adamw> i'd be FE if media upgrade worked, but as it doesn't...-1/-1.
18:08:50 <Viking-Ice> -1/-1
18:09:25 <Viking-Ice> I suppose this breaks only php printing as well ( PHP::PRINT::IPP? )
18:09:53 <tflink> proposed #agreed 971741 - RejectedBlocker, RejectedFreezeException - While unfortunate, cups-php isn't part of any default package sets and thus does not qualify as a release blocking issue. This can be fixed as an update post-release and thus is rejected as a FreezeException for F19 final as well.
18:10:02 <Viking-Ice> ack
18:10:14 <adamw> ack
18:10:21 <jreznik> ack
18:10:24 <kparal> ack
18:10:33 <tflink> we have 50 minutes left until the 3 hour mark
18:10:36 <adamw> Viking-Ice: well, it'd just stop upgrade working until you futzed it somehow (probably by manually removing cups-php...which thinking about it is just what we want to do anyway, so there's even an easy workaround)
18:10:39 <adamw> how many blockers left?
18:10:42 <tflink> #agreed 971741 - RejectedBlocker, RejectedFreezeException - While unfortunate, cups-php isn't part of any default package sets and thus does not qualify as a release blocking issue. This can be fixed as an update post-release and thus is rejected as a FreezeException for F19 final as well.
18:10:47 <tflink> 9
18:10:56 <tflink> #topic (971763) disable updates-testing
18:10:56 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971763
18:10:56 <tflink> #info Proposed Blocker, fedora-release, ASSIGNED
18:10:59 <tflink> crap
18:11:02 <tflink> #undo
18:11:02 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0xb74fc10>
18:11:04 <tflink> #undo
18:11:04 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0xb74f0d0>
18:11:11 <tflink> #topic (971763) disable updates-testing
18:11:11 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971763
18:11:11 <tflink> #info Proposed Blocker, fedora-release, ASSIGNED
18:11:48 <kparal> my bad in requesting too early
18:11:59 <kparal> but we can formally take this as +1
18:12:13 <tflink> WFM
18:12:13 <Viking-Ice> yup we should not leave testing enabled for final ;)
18:12:15 <tflink> +1
18:12:20 <Viking-Ice> +1
18:12:27 <adamw> sure
18:12:56 <adamw> i think releng have this on one of their 'todo lists', but no harm having a blocker bug to track it too
18:12:56 <adamw> +1
18:13:42 <jreznik> +1, /me will track it too
18:13:43 <tflink> proposed #agreed 971763 - AcceptedBlocker - This is a normal part of the final release process and violates the following F19 final release criterion: "No notices or alerts about pre-release status should be present"
18:14:13 <adamw> ack
18:14:18 <adamw> er
18:14:19 <adamw> patch
18:14:32 <adamw> use criterion #25
18:14:39 <jreznik> ack
18:14:51 <tflink> point
18:15:03 <tflink> proposed #agreed 971763 - AcceptedBlocker - This is a normal part of the final release process and violates the following F19 final release criterion: "A Package-x-generic-16.pngfedora-release package containing the correct names, information and repository configuration for a final Fedora release (as opposed to a pre-release) must be present on ISO media while the appropriately versioned Package-x-generic-16.pnggeneric-release package must be
18:15:07 <adamw> .fire tflink criteria fail
18:15:07 <zodbot> adamw fires tflink criteria fail
18:15:10 <tflink> gah
18:15:18 <adamw> chop out the icon names. sorry about that.
18:15:27 <adamw> i think i'll drop the wikification in the Final criteria, if I didn't already.
18:15:34 <adamw> it doesn't really gain us anything.
18:15:42 <tflink> proposed #agreed 971763 - AcceptedBlocker - This is a normal part of the final release process and violates the following F19 final release criterion: "A fedora-release package containing the correct names, information and repository configuration for a final Fedora release (as opposed to a pre-release) must be present on ISO media while the appropriately versioned generic-release package must be available in the online release repository"
18:15:53 <kparal> ack
18:16:01 <tflink> adamw: but the wiki standards ...
18:16:04 <tflink> :-D
18:16:08 <jreznik> re-ack
18:16:14 <Viking-Ice> ack
18:16:19 <adamw> ackity ack ack
18:16:34 <tflink> #agreed 971763 - AcceptedBlocker - This is a normal part of the final release process and violates the following F19 final release criterion: "A fedora-release package containing the correct names, information and repository configuration for a final Fedora release (as opposed to a pre-release) must be present on ISO media while the appropriately versioned generic-release package must be available in the online release repository"
18:16:46 <tflink> #topic (972250) Release notes in Lost&Found KDE menu
18:16:46 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=972250
18:16:46 <tflink> #info Proposed Blocker, fedora-release-notes, ASSIGNED
18:19:08 <kparal> +1 FE
18:19:14 <Viking-Ice> +1 FE
18:19:15 <kparal> oh, proposed blocker
18:19:36 <adamw> so, as the non-revised criteria stand, this should be a +1
18:19:39 <tflink> yeah, but the relevent criterion is being proposed for de-blockerification
18:19:43 <adamw> but i'm of the opinion we're going a bit far in that criterion
18:19:59 <Viking-Ice> I dont think this warrant us blocking the release over
18:20:05 <kparal> I don't really see this in our current criteria
18:20:17 <adamw> hum, now i read it more closely you may be right
18:20:19 * adamw looks
18:20:42 <adamw> yeah...it doesn't really hit the old 'menu sanity' criteria anyway. it's not appearing twice, it's just not in the right place.
18:20:46 <kparal> I think we used to have "nothing in Other menu", but it's no longer there
18:21:03 <kparal> so -1 blocker
18:21:08 <adamw> we also have "The final branded release notes from the Documentation team must be present on ISO media" but it is _there_
18:21:22 <adamw> kparal: i think we killed that one when Shell came in, as it was pretty GNOME 2-specific.
18:21:37 <adamw> so yeah, even by the old criteria this is -1, but +1 FE since we're here.
18:21:56 <jreznik> -1/+1, Kevin maybe has a point but I'd say we have bigger issues sometimes :)
18:22:28 <tflink> proposed #agreed 972250 - RejectedBlocker, AcceptedFreezeException - This doesn't violate any of the F19 release criteria and thus is not a blocker for F19 final. However, a tested fix would be considered past freeze.
18:22:31 <adamw> yeah, the release notes are kinda important so it'd suck a bit to release like this, but i wouldn't hate myself.
18:22:35 <adamw> ack
18:22:39 <kparal> ack
18:22:42 <Viking-Ice> ack
18:22:45 <tflink> #agreed 972250 - RejectedBlocker, AcceptedFreezeException - This doesn't violate any of the F19 release criteria and thus is not a blocker for F19 final. However, a tested fix would be considered past freeze.
18:22:57 <tflink> #topic (971021) Some icons in collection bubbles are not visible
18:22:57 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971021
18:22:57 <tflink> #info Proposed Blocker, gnome-shell, ASSIGNED
18:23:58 <Viking-Ice> I'm +1 to this one
18:24:04 <Viking-Ice> ( being a blocker )
18:24:08 <kparal> the problem here is that you can't reach some app icons
18:24:14 <tflink> seriously, "it meets blocker bug criteria" but he doesn't say _which_ one?
18:24:20 <kparal> they are cut off
18:24:36 <kparal> well, we might use " All applications listed under the Applications menu or category must start successfully "
18:24:40 <kparal> the apps can't be started
18:25:22 <kparal> if there are just 3 rows of them, you at least see the name. if there would be 4 lines, you would probably not see the first row at all
18:25:30 <adamw> yeah, i wouldn't mind wiggling in under that criterion
18:25:41 <adamw> it was written for GNOME 2, this seems like a reasonable application of it to GNOME 3
18:25:47 <adamw> let me see what I wrote in the 'revised' criteria
18:26:05 <Viking-Ice> Personally I dont understand why they dont just list all the icons in the same place
18:26:12 <adamw> hum, "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.", so it sounds like it doesn't quite hit that.
18:26:40 <kparal> we can never cover every glitch that can happen
18:26:42 <tflink> adamw: how so?
18:26:54 <tflink> how do you start the apps you can't click on
18:27:03 <Viking-Ice> touche
18:27:11 <adamw> the re-worded criterion doesn't actually require that all apps 'can be launched'
18:27:18 <adamw> it just says that all apps that 'can be launched' must work
18:27:26 <tflink> oh, point
18:27:35 <adamw> i didn't actually think about a case like this bug, where some apps should be launchable but aren't
18:27:36 <Viking-Ice> it should say ever app that it shipped
18:27:43 <Viking-Ice> mean is
18:27:49 <adamw> so that's an inadequacy in my rewording, i guess
18:28:17 <adamw> Viking-Ice: the problem is that some are intentionally _not_ listed, like gnome-session-properties. but i can work on the wording later.
18:28:25 <adamw> what the hell is this 'colllection bubble' thing anyway?
18:28:29 <adamw> and how do you get to it?
18:28:30 <Viking-Ice> shipped and presented?
18:29:00 <kparal> adamw: a new feature of the new GNOME
18:29:04 <adamw> oh, I see it.
18:29:04 <Viking-Ice> it's there in all
18:29:09 <kparal> adamw: it's in the new menu instead of categories
18:29:18 <kparal> categories are old-school, it seems
18:29:41 <Viking-Ice> all the smart phones just list all icons/apps they decided to go another route with those collection bubbles
18:29:41 <adamw> it seems to be Utilities in English, not Tools.\
18:29:56 <adamw> Viking-Ice: you can actually group apps like that on Android
18:29:57 <adamw> anyhoo
18:30:14 <adamw> i guess I'm +1 under the spirit of the old criterion and I should improve the re-wording to cover this case
18:30:28 <kparal> +1
18:30:35 <Viking-Ice> still +q
18:30:39 <Viking-Ice> mean 1
18:31:30 <tflink> proposed #agreed 971021 - AcceptedBlocker - Causes certain apps to be non-launcable from the gnome-shell overlay and violates the following F19 final release criterion: "All applications listed under the Applications menu or category must start successfully"
18:31:47 <adamw> maybe say 'spirit of the following F19...', but sure, ack
18:31:52 <Viking-Ice> ack
18:32:01 <jreznik> ack
18:32:04 <kparal> ack
18:32:12 <tflink> adamw: either way is fine with me
18:32:40 <tflink> #agreed 971021 - AcceptedBlocker - Causes certain apps to be non-launcable from the gnome-shell overlay and violates the following F19 final release criterion: "All applications listed under the Applications menu or category must start successfully"
18:32:47 <tflink> #topic (961533) grub2 menu entry shows Schr?dinger?s Cat after a 'yum update'
18:32:50 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=961533
18:32:53 <tflink> #info Proposed Blocker, grub2, NEW
18:33:42 <adamw> eh, aesthetic issue, -1/+1
18:33:56 <adamw> it *works*, right?
18:34:09 <tflink> yep
18:34:09 <Viking-Ice> yeah it works agreed -1/+1
18:34:22 <tflink> I didn't think that we had a fork of grub2
18:34:30 <Viking-Ice> Arguable we should just have Fedora $Number in the grub menu
18:34:35 <Viking-Ice> ( or just Fedora )
18:35:11 <adamw> tflink: i think mads is referring to the use of grubby
18:35:21 <adamw> but imbw.
18:35:21 <tflink> proposed #agreed 961533 - RejectedBlocker, AcceptedFreezeException - This is a minor polish issue that doesn't violate any of the F19 release criteria but a tested fix would be considered after freeze.
18:35:25 <adamw> ack
18:35:27 <tflink> adamw: or grub-efi
18:35:36 <adamw> we don't use grub-efi any more, we use grub2's efi mode.
18:35:36 <Viking-Ice> ack
18:35:48 <jreznik> ack
18:35:48 <tflink> adamw: I know, but that's the closest thing I could think of
18:35:51 <Viking-Ice> btw does anyone care about the release name in the grub menu?
18:35:52 <adamw> 25 minutes left, how many more blockers to go?
18:36:01 <adamw> Viking-Ice: i'm still on the 'ditch the damn release names already' team
18:36:05 <adamw> but hey
18:36:07 <tflink> 5 blockers left
18:36:08 <kparal> ack
18:36:14 <tflink> #agreed 961533 - RejectedBlocker, AcceptedFreezeException - This is a minor polish issue that doesn't violate any of the F19 release criteria but a tested fix would be considered after freeze.
18:36:27 <tflink> I have a hard stop at the top of the hour, FWIW
18:36:34 <jreznik> adamw: the question is - do we really want to show them everywhere?
18:36:36 <Viking-Ice> adamw, I'm on that team as well ;)
18:36:43 <tflink> if we keep going past that, someone else is going to have to take over the meeting
18:36:47 <jreznik> it's fun to have release name but...
18:37:02 <tflink> #topic (971046) GError: Timeout was reached
18:37:02 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971046
18:37:02 <tflink> #info Proposed Blocker, polkit, ASSIGNED
18:37:04 <Viking-Ice> let's try to finish those 5 and leave it at that
18:37:04 <adamw> jreznik: well, my opinion contains an obvious sub-opinion on that topic =)
18:37:20 <tflink> actually, it's 4. I forgot about the blivit bug that we already covered
18:37:39 <adamw> this turns out to be PPC-specific, I think
18:37:45 <adamw> down to a crash in policykit on PPC or something
18:37:47 <adamw> so -1 blocker, +1 FE
18:38:10 <Viking-Ice> yup
18:38:38 <tflink> yep, same here: -1/+1
18:39:36 <tflink> proposed #agreed 971046 - RejectedBlocker, AcceptedFreezeException - This would be a release blocker on PA but appears to be PPC specific. Thus, rejected as a blocker but a tested fix would be considered after freeze.
18:39:42 <adamw> ack
18:40:08 <jreznik> ack
18:40:17 <kparal> ack
18:40:20 <Viking-Ice> aclk
18:40:46 <tflink> #agreed 971046 - RejectedBlocker, AcceptedFreezeException - This would be a release blocker on PA but appears to be PPC specific. Thus, rejected as a blocker but a tested fix would be considered after freeze.
18:40:53 <tflink> #topic (964006) cloud-init hostname service failing on initial boot
18:40:56 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=964006
18:40:58 <tflink> #info Proposed Blocker, selinux-policy, ASSIGNED
18:42:44 <tflink> it sounds like cloud images are showing AVC denials on setting the hostname
18:42:55 <adamw> there appears to be no explanation of why this is nominated as a blocker
18:43:09 <tflink> yeah, I was about to chide matt about that
18:43:16 <adamw> matthew miller simply set it as a blocker without explanation
18:43:30 <adamw> does anyone want to try and interpret why we should block on this or shall we just punt and ask?
18:43:43 <tflink> adamw: my explanation wasn't good enough?
18:44:11 <Viking-Ice> Dan is already on it ( which usually means it get fixed yesterday ;) )
18:44:29 <adamw> tflink: well, what's the practical consequence of that?
18:44:43 <adamw> tflink: consider most of us have zero experience with doing anything in EC2. or at least, I don't.
18:44:52 <Viking-Ice> however this is cloud spesific right
18:44:54 <tflink> it slows down, at least
18:45:06 <tflink> slows down boot, rather
18:45:16 <tflink> doesn't look like it prevents boot
18:45:33 <tflink> but we do have "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login"
18:46:01 <Viking-Ice> if I understand this correctly it's that clouds own tool that's triggering this
18:46:31 <tflink> yeah, I think this would be cloud image only (ec2, openstack etc.)
18:46:45 <jreznik> and it's not blocking - fe?
18:46:49 <Viking-Ice> and as such it should be fixable via zero day update
18:46:52 <Viking-Ice> -1/-1
18:47:07 <tflink> not sure it's so fixable with an update
18:47:24 <jreznik> -1/+1 as described above
18:48:11 <Viking-Ice> workaround would be to boot into permissive mode and update
18:48:13 <adamw> tflink: the AVC criterion as noted earlier is a polish criterion for the 'common case' install, i'm not sure how bad an AVC during a cloud deployment looks to users or what effect it'd have on our image...
18:48:23 <adamw> only 12 minutes left
18:48:23 <tflink> Viking-Ice: how exactly do you do that on ec2?
18:48:36 <adamw> which is why I don't want to spend too much time figuring out the justification for this one
18:49:14 <Viking-Ice> tflink, I would assume through console
18:50:00 <Viking-Ice> ( I have no idea how Amazon does things or we along with them )
18:50:06 <tflink> proposed #agreed 964006 - RejectedBlocker, AcceptedFreezeException - While this does slow down boot for cloud images, it does not violate any F19 release criteria and is rejected as a release blocking bug for F19 final. However, a tested fix would be considered after freeze.
18:50:41 <tflink> Viking-Ice: I don't think you can do that and even if you could, if you needed to do that for _every_ cloud instance, I'd never use the F19 AMIs
18:50:58 <tflink> I suspect that most other people wouldn't, either
18:51:10 <Viking-Ice> tflink, I see
18:51:19 <Viking-Ice> ack
18:51:19 <adamw> i can ack that, but maybe with a note that it can be re-proposed if we misread it
18:51:30 <tflink> it's akin to telling desktop users that they have to adjust their boot options every time they reboot
18:51:48 <tflink> #agreed 964006 - RejectedBlocker, AcceptedFreezeException - While this does slow down boot for cloud images, it does not violate any F19 release criteria and is rejected as a release blocking bug for F19 final. However, a tested fix would be considered after freeze.
18:52:10 <tflink> #topic (971392) systemd update breaks polkit-kde-auth
18:52:10 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=971392
18:52:10 <tflink> #info Proposed Blocker, systemd, NEW
18:52:46 <kparal> I just tried with Czech l10n, still works for me
18:53:06 <jreznik> and nobody from kde sig was able to reproduce it neither
18:53:29 <jreznik> the strange thing is - when kde polkit agent started on command line - it just works
18:53:31 <tflink> reject, ask him to repropose if more info/reproducers show up?
18:53:38 <Viking-Ice> agreed
18:53:47 <kparal> yes
18:53:49 <jreznik> so in really worst case, we have workaround
18:54:20 <jreznik> but seems like jiri is the only guy affected by this one for some reason
18:54:26 <Viking-Ice> kparal, was this Jiri own laptop ?
18:54:31 <Viking-Ice> ( which he upgraded )
18:54:37 <kparal> it was a clean install
18:54:50 <tflink> proposed #agreed 971392 - RejectedBlocker - While this sounds like it could be a blocker, other people are having difficulty reproducing the issue and thus, this is rejected as a release blocking bug for F19 final. Please re-propose as a blocker if more people are able to reproduce the issue.
18:55:03 <Viking-Ice> ack
18:55:10 <kparal> ack
18:55:16 <jreznik> patch, maybe add there's known workaround
18:55:38 <adamw> ack
18:55:53 <tflink> #agreed 971392 - RejectedBlocker - While this sounds like it could be a blocker, other people are having difficulty reproducing the issue and there is a known workaround. Thus, this is rejected as a release blocking bug for F19 final. Please re-propose as a blocker if more people are able to reproduce the issue.
18:56:00 <tflink> #topic (955236) [abrt] yum-3.4.3-83.fc20: cli.py:1945:removeGroups:AttributeError: 'InstalledGroup' object has no attribute 'groupid'
18:56:03 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=955236
18:56:05 <tflink> #info Proposed Blocker, yum, MODIFIED
18:56:05 <tflink> still no dev input on this
18:56:09 <tflink> reject?
18:57:12 <Viking-Ice> is this not fixed ( per maintainers comment )
18:57:20 <adamw> yeah, per what we said at the last meeting, it seems like this just isn't important enoguh to accept.
18:57:34 <adamw> Viking-Ice: the update isn't stable yet (or possibly not even submitted as an update yet)
18:57:47 <Viking-Ice> adamw, 0 day anyway
18:57:53 * adamw double checks
18:57:57 <Viking-Ice> he's removing not installing
18:58:06 <tflink> proposed #agreed 955236 - RejectedBlocker - This doesn't violate any of the F19 release criteria and is thus rejected as a release blocking bug for F19 final.
18:58:18 <adamw> yeah, there's no -93 update yet at all
18:58:19 <Viking-Ice> so you would do that before upgrade or after installation
18:58:19 <Viking-Ice> ack
18:58:31 <tflink> Viking-Ice: the question was whether there was db corruption on failure or not
18:58:45 <adamw> but we're now figuring that if there was, someone would have said so by now
18:58:47 <adamw> ack
18:58:49 <tflink> adamw: I thought there was a -94, though
18:59:04 <adamw> yum-3.4.3-91.fc19 is the most recent build in bodhi.
18:59:09 <adamw> was that the last blocker?
18:59:22 <tflink> yep
18:59:41 <jreznik> right on time :) at least for blockers
18:59:49 <tflink> #agreed 955236 - RejectedBlocker - This doesn't violate any of the F19 release criteria and is thus rejected as a release blocking bug for F19 final.
19:00:06 <tflink> we didn't touch the accepted blockers, but we can do that on wednesday
19:00:16 <tflink> #topic Open Floor
19:00:17 <adamw> yup
19:00:20 <Viking-Ice> yep
19:00:24 <tflink> Anything else that should be brought up today?
19:00:44 <jreznik> yep, and I'll be checking the status too
19:00:44 <adamw> just please comment on the final blocker revision so we can get it into production
19:00:50 <adamw> i'll work on the stuff that came up during the meeting
19:00:58 * jreznik has to run, will comment on revision
19:01:07 <Viking-Ice> adamw, we really ought not to change it until we release F19 ;)
19:01:53 <adamw> Viking-Ice: eh, maybe, i wanted to get them all done but you're right that it's a bit late now
19:02:05 <jreznik> hmm, my head seems to be better now, but my mouth definitely not - I can't open it and what's worst - I'm hungry but I can't bite :)))
19:02:05 <adamw> i did manage to get alpha and beta into proudction before we really got rolling on validation for those milestones
19:02:11 <adamw> jreznik: diet!
19:02:26 <Viking-Ice> adamw, yeah
19:02:57 <adamw> Viking-Ice: we can always basically use the 'old' ones but keep the 'new' ones in mind too, as we did for the GNOME menu thingh
19:03:32 <adamw> alrighty, apart from that, anything else?
19:03:42 <Viking-Ice> nothing from me
19:04:06 <jreznik> nothing from me, thanks guys
19:04:45 * adamw sets Quantum Fuse for a number of minutes that has been redacted by the NSA
19:04:57 <Viking-Ice> and not whistle blown yet
19:05:01 <adamw> =)
19:06:31 <adamw> alrighty, thanks for coming, folks
19:06:38 <adamw> let's get the testin' rolling
19:06:41 <adamw> #endmeeting