#fedora-blocker-review: f20beta-blocker-review-4

Meeting started by kparal at 16:02:28 UTC (full logs).

Meeting summary

  1. Roll Call (kparal, 16:02:39)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (kparal, 16:06:19)
    2. We'll be following the process outlined at: (kparal, 16:06:19)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (kparal, 16:06:19)
    4. The bugs up for review today are available at: (kparal, 16:06:22)
    5. http://qa.fedoraproject.org/blockerbugs/current (kparal, 16:06:23)

  2. Introduction (kparal, 16:06:34)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (kparal, 16:06:45)
    2. We'll be following the process outlined at: (kparal, 16:06:45)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (kparal, 16:06:45)
    4. The bugs up for review today are available at: (kparal, 16:06:45)
    5. http://qa.fedoraproject.org/blockerbugs/current (kparal, 16:06:46)
    6. The criteria for release blocking bugs can be found at: (kparal, 16:06:53)
    7. https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria (kparal, 16:07:03)
    8. Up for review today, we have: (kparal, 16:07:15)
    9. 4 Proposed Blockers (kparal, 16:07:22)
    10. 8 Accepted Blockers (kparal, 16:07:23)
    11. 5 Proposed Freeze Exceptions (kparal, 16:07:23)
    12. 3 Accepted Freeze Exceptions (kparal, 16:07:23)

  3. (1017435) Anaconda uses LVM when Standard Partition is selected in text mode (kparal, 16:08:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1017435 (kparal, 16:08:10)
    2. Proposed Blocker, anaconda, MODIFIED (kparal, 16:08:10)
    3. AGREED: 1013586 - AcceptedBlocker - Violates the following F20 beta release criterion for text mode and standard partitions: "When using the guided partitioning flow, the installer must be able to: Complete an installation using any combination of disk configuration options it allows the user to select " (kparal, 16:11:13)

  4. (1017977) FormatDestroyError: error wiping old signatures from /dev/vda2: 1 (kparal, 16:11:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1017977 (kparal, 16:11:34)
    2. Proposed Blocker, anaconda, NEW (kparal, 16:11:34)
    3. AGREED: 1017977 - RejectedBlocker - This is rejected as a blocker until someone else can also reproduce the issue or the reporter can provide us with a clear steps that would help us reproduce the issue. (kparal, 16:18:30)

  5. (1019541) unknown install shows up as entire disks instead of mount points of selected disks (kparal, 16:18:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1019541 (kparal, 16:18:42)
    2. Proposed Blocker, anaconda, NEW (kparal, 16:18:42)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1019541#c8 (adamw, 16:25:25)
    4. ACTION: kparal to test or delegate 1019541 with valid partition tables and previous BIOS install and no ESP booted with UEFI (kparal, 16:53:27)

  6. (1019500) device factories need to set a default name if empty name given for defined device (kparal, 16:54:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1019500 (kparal, 16:54:08)
    2. Proposed Blocker, python-blivet, ASSIGNED (kparal, 16:54:08)
    3. AGREED: 1019500 - AcceptedBlocker - Violates the following F20 beta release criterion for RAID installs with unnamed array: "When using the custom partitioning flow, the installer must be able to: Reject or disallow invalid disk and volume configurations without crashing." (kparal, 17:06:12)

  7. (1016801) "Don't install the latest software updates" box is unchecked by default, can't be checked permanently (kparal, 17:07:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1016801 (kparal, 17:07:13)
    2. Proposed Freeze Exceptions, anaconda, ASSIGNED (kparal, 17:07:13)
    3. AGREED: 1016801 - AcceptedFreezeException - Updates download checkbox might be an important feature for some people and doesn't present large risk. It can't be fixed post-release. A fix would be considered as a freeze exception. (kparal, 17:16:38)

  8. (1016566) Installing a package silently fails if the GPG key for the yum repo is not installed (kparal, 17:16:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1016566 (kparal, 17:16:48)
    2. Proposed Freeze Exceptions, gnome-software, ASSIGNED (kparal, 17:16:48)
    3. AGREED: 1016566 - AcceptedFreezeException - Installing software using gnome-software is an important feature and we will consider this fix even after freeze. If anyone finds out that update (not install) is not working with a missing gpg key, please propose this as a blocker bug. (kparal, 17:28:18)

  9. (1011714) btrfs scrub finds csum corruption after btrfs balance (kparal, 17:28:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1011714 (kparal, 17:28:27)
    2. Proposed Freeze Exceptions, kernel, POST (kparal, 17:28:27)
    3. AGREED: 1011714 - AcceptedFreezeException - We would like to avoid data corruption on btrfs. A patch is ready and seems to be safe. We will consider it past freeze. (kparal, 17:36:50)

  10. (1017683) Invalid UID in persistent keyring name (kparal, 17:37:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1017683 (kparal, 17:37:36)
    2. Proposed Freeze Exceptions, kernel, MODIFIED (kparal, 17:37:36)
    3. AGREED: 1017683 - AcceptedFreezeException - This is a serious issue for Kerberos users. A fix would be considered past freeze. (kparal, 17:44:05)

  11. (1012141) [abrt] pulseaudio-4.0-4.gita89ca.fc20: core_free: Process /usr/bin/pulseaudio was killed by signal 6 (SIGABRT) (kparal, 17:45:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1012141 (kparal, 17:45:23)
    2. Proposed Freeze Exceptions, pulseaudio, NEW (kparal, 17:45:23)
    3. AGREED: 1012141 - AcceptedFreezeException - This is a visible and annoying crash. An early and safe fix would be considered past freeze. (kparal, 17:51:27)

  12. (1016959) ValueError: Cannot remove non-leaf device 'btrfs.14' (kparal, 17:53:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1016959 (kparal, 17:53:39)
    2. Accepted Blocker, anaconda, NEW (kparal, 17:53:39)
    3. this is waiting for developers action (kparal, 17:55:12)
    4. We don't know whether this is going to be fixed before go/no-go, dlehman is busy with other bugs (kparal, 18:02:20)

  13. (1010495) Apple Mac EFI: you have not created a bootloader stage1 target device (kparal, 18:02:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1010495 (kparal, 18:02:46)
    2. Accepted Blocker, anaconda, ASSIGNED (kparal, 18:02:46)
    3. the current patch is incomplete and we're waiting for bcl to refine the patch and submit it (kparal, 18:04:20)

  14. (986575) installer fails to apply lower bound to resize requests in custom spoke (kparal, 18:05:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=986575 (kparal, 18:05:17)
    2. Accepted Blocker, anaconda, ASSIGNED (kparal, 18:05:17)
    3. this is a fairly simple fix, but it hasn't be implemented yet. waiting on developers (kparal, 18:07:42)

  15. (1013586) SizeNotPositiveError: spec= param must be >=0 (kparal, 18:08:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1013586 (kparal, 18:08:42)
    2. Accepted Blocker, anaconda, NEW (kparal, 18:08:42)
    3. this is still waiting for developer action. the fix is expected to be invasive and affect many parts of the installer (kparal, 18:12:27)
    4. AGREED: 1013586 - AcceptedBlocker - We move this blocker from Beta to Final, because we have an explicit shrinking criterion there, as it was originally intended: "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation.". If the fix is ready in time, please propose as Beta FE. (kparal, 18:31:06)

  16. (1000891) DVD is oversized (larger than 4.7 GB) (kparal, 18:31:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1000891 (kparal, 18:31:19)
    2. Accepted Blocker, distribution, MODIFIED (kparal, 18:31:19)
    3. this seems to be a pungi bug, waiting for dgilmore (kparal, 18:33:22)

  17. (1015234) F20 Beta TC1 ARM disk images unable to find root filesystem (kparal, 18:35:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1015234 (kparal, 18:35:12)
    2. Accepted Blocker, dracut, ASSIGNED (kparal, 18:35:12)
    3. discussion is still ongoing as how to fix this properly. it's not clear whether this is fixed with the latest compose. it would be a good idea to ask the reporter to retest (kparal, 18:38:59)
    4. ACTION: adamw to ask Harald and Dennis about bug 1015234 (kparal, 18:39:25)

  18. (1013767) rootfs on thinp not found, startup failure (kparal, 18:39:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1013767 (kparal, 18:39:55)
    2. Accepted Blocker, dracut, NEW (kparal, 18:39:55)
    3. the developers are working on this, nothing to do from QA perspective (kparal, 18:42:08)

  19. (1013800) devicetree.py:1293:handleVgLvs:DeviceTreeError: failed to look up thin pool (kparal, 18:42:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1013800 (kparal, 18:42:42)
    2. Accepted Blocker, python-blivet, ASSIGNED (kparal, 18:42:42)
    3. patch is ready for this one. dlehman needs to submit it (kparal, 18:44:57)

  20. Open Discussion <your bugs here> (kparal, 18:46:38)


Meeting ended at 18:48:41 UTC (full logs).

Action items

  1. kparal to test or delegate 1019541 with valid partition tables and previous BIOS install and no ESP booted with UEFI
  2. adamw to ask Harald and Dennis about bug 1015234


Action items, by person

  1. adamw
    1. adamw to ask Harald and Dennis about bug 1015234
  2. kparal
    1. kparal to test or delegate 1019541 with valid partition tables and previous BIOS install and no ESP booted with UEFI


People present (lines said)

  1. kparal (290)
  2. adamw (205)
  3. tflink (121)
  4. dlehman (49)
  5. roshi (28)
  6. jwb (24)
  7. jreznik (24)
  8. pwhalen (10)
  9. Viking-Ice (10)
  10. mkrizek (7)
  11. zodbot (6)
  12. satellit (3)
  13. satellit_RPi (3)
  14. leigh123linux (2)
  15. narekb (2)


Generated by MeetBot 0.1.4.