16:05:49 <adamw> #startmeeting F23-blocker-review
16:05:49 <zodbot> Meeting started Thu Aug 20 16:05:49 2015 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:05:49 <adamw> #meetingname F23-blocker-review
16:05:49 <adamw> #topic Roll Call
16:05:49 <zodbot> The meeting name has been set to 'f23-blocker-review'
16:05:57 <adamw> sorry, can we state our names again for bot purposes? :P
16:06:09 <adamw> #chair pwhalen sgallagh
16:06:09 <zodbot> Current chairs: adamw pwhalen sgallagh
16:06:23 <sgallagh> our names again
16:06:30 * tflink dislikes having his IRC habits run by a bot, refuses to comply
16:07:44 * pschindl is here
16:08:09 <adamw> tflink: you seem like a candidate for the skynet resistance
16:08:30 <tflink> adamw: shush! the bot will hear you
16:08:38 <adamw> #topic Introduction
16:08:38 <adamw> Why are we here?
16:08:38 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:08:38 <adamw> #info We'll be following the process outlined at:
16:08:40 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:08:40 <adamw> #info The bugs up for review today are available at:
16:08:44 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:08:44 <adamw> #info The criteria for release blocking bugs can be found at:
16:08:46 <adamw> #link https://fedoraproject.org/wiki/Fedora_23_Alpha_Release_Criteria
16:08:48 <adamw> #link https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria
16:08:50 <adamw> #link https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria
16:08:52 <adamw> tflink: no problem, i'll drown it in boilerplate
16:09:19 * tflink hears a clunk at his front door and a robotic voice demanding that I open it
16:09:29 <tflink> adamw: see what you've done?!
16:09:46 <adamw> tflink: that's just Columbia House.
16:10:01 <tflink> is that even still a thing?
16:10:11 <adamw> just shut down recently i think
16:10:14 <adamw> For Beta, we have:
16:10:15 <adamw> #info 6 Proposed Blockers
16:10:15 <adamw> #info 6 Accepted Blockers
16:10:15 <adamw> #info 4 Proposed Freeze Exceptions
16:10:17 <adamw> #info 0 Accepted Freeze Exceptions
16:10:34 <adamw> we also have 10 Proposed Blockers for Final, which we might get to later.
16:10:54 <adamw> anyone willing to secretarialize?
16:12:09 <adamw> bueller?
16:12:20 <adamw> well, if no-one will i guess i'll do it after the meeting
16:12:37 <adamw> here we go with Beta proposed blockers
16:12:38 <adamw> #topic (1245423) TypeError: nothing connected to functools.partial(<pyanaconda.ui.gui.utils.timed_action.<locals>.TimedAction object
16:12:39 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1245423
16:12:39 <adamw> #info Proposed Blocker, anaconda, MODIFIED
16:13:01 <sgallagh> This looks like a pretty clear blocker. +1
16:13:13 <adamw> this is the crasher where you try to delete a single partition in Reclaim Space, and yeah, looks fairly clear.
16:13:20 <adamw> the fix does work.
16:14:01 <pschindl> +1
16:15:04 <pwhalen> +1
16:16:37 <danofsatx> +1
16:17:06 <adamw> sorry, lemme find the agreed format we're using lately...
16:18:09 <adamw> proposed #agreed 1245423 - AcceptedBlocker Beta - clear violation of "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction"
16:18:29 <sgallagh> ack
16:18:38 <tflink> ack
16:18:46 <pwhalen> ack
16:18:52 <pschindl> ack
16:19:42 <adamw> #agreed 1245423 - AcceptedBlocker Beta - clear violation of "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction"
16:19:50 <adamw> #topic (1225957) Regression: GFileMonitor doesn't react to "mv some-file watched-file"
16:19:50 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1225957
16:19:50 <adamw> #info Proposed Blocker, glib2, NEW
16:19:55 <adamw> hum, this is a new one
16:20:55 <sgallagh> I voted in the ticket, but it's a serious regression affecting a lot of Glib-based software, including Cockpit.
16:21:12 <sgallagh> mclasen reported yesterday (or maybe this morning) that he has a fix ready upstream for it.
16:21:32 <adamw> yeah, since it affects cockpit looks like a +1 blocker to me.
16:21:54 <sgallagh> It probably affects a lot of other stuff, but we have a handy blocker criterion for Cockpit.
16:22:11 <pwhalen> yea, +1 as well
16:22:19 <sgallagh> +1 as in the ticket
16:22:31 <pschindl> +1
16:24:00 <adamw> proposed #agreed 1225957 - AcceptedBlocker Beta - clear violation of "after system installation the Cockpit web management interface must be running and accessible on its default port (9090)"
16:24:18 <sgallagh> ack
16:24:32 <pwhalen> ack
16:24:32 <pschindl> ack
16:24:54 <adamw> #agreed 1225957 - AcceptedBlocker Beta - clear violation of "after system installation the Cockpit web management interface must be running and accessible on its default port (9090)"
16:25:08 <adamw> #topic (1249304) UnboundLocalError: local variable 'e' referenced before assignment
16:25:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1249304
16:25:08 <adamw> #info Proposed Blocker, python-blivet, ON_QA
16:25:21 <sgallagh> So, there's no explanation for why this is happening in the bZ
16:25:47 <sgallagh> That said, it was reported fairly often from people installing Alpha from Live media. So it's probably hardware-specific.
16:25:57 <adamw> i'm assuming it's some kind of exception handling corner case
16:25:57 <sgallagh> (Since we didn't spot this during validation)
16:26:29 <sgallagh> A fix is in updates-testing and people are already reporting that it worked
16:26:40 <sgallagh> Without a clear idea of what triggers it, I'm not prepared to call it a blocker.
16:26:50 <sgallagh> (And it may just sort itself out before Beta Freeze anyway)
16:27:52 <sgallagh> Proposal: Defer a decision until someone identifies the specific reproduction steps or we enter Beta Freeze.
16:28:29 <danofsatx> +1 defer
16:28:36 * adamw looks at the code a bit
16:29:44 <adamw> meh, can't tell how serious it is easily
16:30:01 <adamw> so, +1 defer, sure. fix should get in there.
16:30:13 <adamw> pwhalen: pschindl ?
16:30:44 <pwhalen> sure, +1 defer for now
16:30:47 <pschindl> +1 defer
16:32:25 <adamw> proposed #agreed 1249304 - defer decision - it's unclear how serious or how commonly encountered this bug is, and a fix is already pending, so we'll hope to see it gone by next meeting
16:32:53 <pschindl> ack
16:33:21 <pwhalen> ack
16:33:33 <sgallagh> ack
16:34:14 <adamw> #agreed 1249304 - defer decision - it's unclear how serious or how commonly encountered this bug is, and a fix is already pending, so we'll hope to see it gone by next meeting
16:34:21 <adamw> #topic (1252052) blivet.errors.DeviceError: ('cannot replace active format', 'fedora_dhcp45-root')
16:34:21 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1252052
16:34:21 <adamw> #info Proposed Blocker, python-blivet, MODIFIED
16:35:02 <adamw> +1, seems to affect installs with pre-existing LVM layouts
16:35:12 <adamw> (i hit this trying to reinstall my fedlet for e.g.)
16:35:19 <pschindl> +1
16:35:53 <garretraziel> looks +1 to me
16:36:10 <sgallagh> +1
16:36:11 <pwhalen> +1
16:36:51 <danofsatx> +1
16:37:58 <adamw> proposed #agreed 1252052 - AcceptedBlocker Beta - clear violation of "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction"
16:38:37 <sgallagh> ack
16:38:43 <garretraziel> ack
16:39:09 <pwhalen> ack
16:39:22 <adamw> #agreed 1252052 - AcceptedBlocker Beta - clear violation of "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction"
16:39:31 <adamw> #topic (1253787) AttributeError: 'int' object has no attribute 'convertTo'
16:39:31 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1253787
16:39:31 <adamw> #info Proposed Blocker, python-blivet, MODIFIED
16:41:17 <sgallagh> +1 from the criterion cited in the BZ
16:42:05 <pschindl> +1
16:42:16 <garretraziel> +1 although it looks like it will be fixed probably in next compose
16:43:01 <adamw> we hope!
16:43:09 <sgallagh> garretraziel: The purpose of voting a blocker is so that if it turns out it's not fixed, we know that we can't ship until it is.
16:43:24 <adamw> well, no, that's just for rawhide; we need to get updates pushed for anaconda
16:43:31 <adamw> (there's a new anaconda/blivet update today, we should test it)
16:43:34 <sgallagh> We didn't vote on the earlier one only because we had no idea what was causing it and how prevalent it was.
16:43:58 <pwhalen> +1
16:43:59 <adamw> proposed #agreed 1253787 - AcceptedBlocker Beta - clear violation of "When using the custom partitioning flow, the installer must be able to: ... Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions."
16:44:16 <pwhalen> ack
16:44:23 <adamw> (iirc there's a footer in there or something which includes thinp)'
16:44:25 <danofsatx> +1ack
16:44:43 * danofsatx thought he pushed enter after the +1
16:44:56 <sgallagh> ack
16:44:57 <adamw> #agreed 1253787 - AcceptedBlocker Beta - clear violation of "When using the custom partitioning flow, the installer must be able to: ... Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions."
16:45:04 <adamw> #topic (1250942) clicking on buttons on error pop-up doesn't work
16:45:05 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1250942
16:45:05 <adamw> #info Proposed Blocker, python-meh, NEW
16:45:18 <danofsatx> meh...
16:45:43 <adamw> so, i've seen cases like this in previous releases, but it sounds like it may be worse here
16:45:47 <adamw> it is a bit of a judgment call, though
16:45:55 <sgallagh> /me smacks danofsatx
16:46:27 <sgallagh> We should just fix all the bugs so we don't have to report them
16:46:42 <danofsatx> or just not create any in the first place.
16:47:03 <adamw> YAK FARM
16:47:26 * adamw sees if anaconda folks have an opinion
16:51:08 <adamw> i guess i'm kinda on the fence on thios
16:51:22 <adamw> it *is* pretty bad if people can't report crashes...but not sure it'd make it past a go/no-go meeting
16:51:37 <adamw> bugs where the mechanism is completely broken are more clear cut
16:51:54 <sgallagh> Yeah, this would be one of those "would we block on it if it was the only one left" sort of bugs
16:52:21 * roshi steps in late
16:52:29 <danofsatx> -1
16:53:10 <sgallagh> I'm a tentative -1/+1 on this
16:53:19 <sgallagh> err -1 blocker/+1 FE
16:53:34 <adamw> is anyone -1 beta / +1 final?
16:53:45 <sgallagh> If it turns out to be happening very frequently during TC testing, I might revise it
16:53:53 * adamw provides swatches for the bikeshed
16:54:02 <sgallagh> adamw: No, I don't think it makes sense at Final at all
16:54:21 <sgallagh> Reporting bugs in anaconda is really only useful at Alpha or Beta, otherwise they won't be fixable for that release
16:54:40 <sgallagh> (Yes, they'll be fixable in the next release, but that's not terribly helpful)
16:54:57 <adamw> well, it helps *us*...and it does look bad if you can see a nice 'report a bug!' button but not click it.
16:55:11 <sgallagh> true
16:55:23 <adamw> (for values of 'help' that mean 'provide more work', i guess...)
16:55:29 <garretraziel> you can still report it from console, can't you?
16:55:44 <sgallagh> I'm -1 Beta Blocker, +1 FE and I could be convinced to discuss blocking Final after Beta
16:55:45 <pschindl> but you can still get logs. I'm more for FE.
16:56:08 <pschindl> I don't think it will touch lot of bugs
16:56:24 <adamw> garretraziel: i never remember if report-cli is in the images or not. worst case you have to scp it out and run report-cli from somewhere else.
16:56:41 <adamw> sounds like a -1/+1 consensus
16:56:42 <sgallagh> (Where by "after beta" I mean "if we discover that it happens frequently")
16:57:10 <pschindl> That makes sense.
16:57:29 <garretraziel> I'm for -1/+1 FE, because it will only affect bugs where modal dialog is shown and you can still get logs/report it from console
16:57:36 <adamw> proposed #agreed 1250942 RejectedBlocker AcceptedFreezeException Beta - as things stand our call is that this is probably not quite common enough to block (it's a conditional criterion violation, so it's a judgment call). We may revise this later if it turns out to be more common than we thought
16:57:56 <sgallagh> ack
16:58:09 <pschindl> ack
16:58:10 <garretraziel> ack
16:59:08 <danofsatx> ack
16:59:44 <adamw> #agreed 1250942 RejectedBlocker AcceptedFreezeException Beta - as things stand our call is that this is probably not quite common enough to block (it's a conditional criterion violation, so it's a judgment call). We may revise this later if it turns out to be more common than we thought
16:59:59 <adamw> OK, that's all the proposed beta blockers
17:00:08 <roshi> making good time I see :)
17:00:19 <adamw> beta freeze is 09-08
17:00:26 <adamw> with that in mind, do we want to do final blockers or beta FE next?
17:00:33 <adamw> or, you know, drink ourselves senseless?
17:00:39 <roshi> ^^ that
17:01:06 <roshi> we've got a bunch for Final, should probably look at them
17:01:10 <garretraziel> -1 work/+1 senseless drinking
17:01:10 <roshi> before the keep piling up
17:01:28 <sgallagh> We're not in Freeze yet, so I'd focus on blockers
17:01:30 <roshi> garretraziel: drink until senseless, then work
17:02:16 <adamw> roshi: the breakfast of champions
17:02:28 <adamw> drink until you don't feel the perl any more
17:02:44 <adamw> alrighty, final blockers it is then
17:03:03 <adamw> roshi: do you want to take over driving, or secretarializing? i've been doing both so far
17:03:18 <roshi> which ever you prefer
17:03:58 * roshi can drive
17:04:03 <adamw> alrighty, take the wheel
17:04:10 <adamw> #chair roshi
17:04:10 <zodbot> Current chairs: adamw pwhalen roshi sgallagh
17:04:22 <sgallagh> /me hangs on for dear life
17:04:24 <roshi> looks like we've got 10 to go through
17:04:46 * roshi still wants to figure out why sgallagh can't "/me" properly
17:04:50 <roshi> #topic (1252756) repository definition nor product branding works with nfsiso
17:04:53 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1252756
17:04:55 <roshi> #info Proposed Blocker, anaconda, NEW
17:04:59 <adamw> sgallagh: 'mind if I drive, Sam?' 'Not if you don't mind me clawing at the dash and screaming like a cheerleader, Max.'
17:05:31 <sgallagh> adamw: One of my favorite games of all-time
17:05:37 <adamw> yup
17:05:48 <adamw> "there's nothing but strangers out there."
17:06:54 <adamw> +1 on this, though it looks like one that's subject to go/no-go squeezing
17:07:03 <adamw> "oh who uses nfsiso anyway"
17:07:08 <roshi> +1
17:07:13 <garretraziel> +1
17:07:25 <roshi> I sense the squeezing coming for this as well
17:07:26 <pschindl> blocker_count++
17:07:37 <roshi> pschindl: it's BlockerCount
17:07:53 <roshi> indented with 1 tab and 3 spaces
17:07:54 <pschindl> roshi: I'm sorry, I forgot :)
17:08:00 <roshi> :p
17:08:27 <roshi> after the 3 spaces is a unicode zero-width character
17:08:30 <roshi> in case you were wondering
17:08:44 <sgallagh> Yeah... I'd really be asking whether nfsiso is something people are really using
17:08:59 <sgallagh> And whether it should be part of the criteria at all
17:09:15 <roshi> proposed #agreed - 1252756 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources."
17:09:23 <pschindl> sgallagh: of course I use it. Because test case makes me :(
17:09:24 <sgallagh> (And I'd prefer to have that conversation ahead of time, rather than Go/No-Go)
17:09:29 <sgallagh> roshi: I'm not convinced I'm +1...
17:09:38 <adamw> sgallagh: i'm pretty sure it really is something real people use
17:09:39 <roshi> #unchair sgallagh
17:09:39 <zodbot> Current chairs: adamw pwhalen roshi
17:09:43 <roshi> :p
17:09:49 <roshi> #chair sgallagh
17:09:49 <zodbot> Current chairs: adamw pwhalen roshi sgallagh
17:09:50 <sgallagh> /me glares
17:09:51 <adamw> ooooh, someone's playing hardball
17:10:06 <pschindl> ack
17:10:10 <roshi> this is a bandwagon that you're on now whether you like it or not :p
17:10:21 <roshi> votes are currently 4/1
17:10:40 <roshi> sgallagh: want to send a missive to the list for discussion, and we can remove status if the criteria gets edited?
17:10:56 <roshi> tbh, I wasn't sure if #unchair would do anything...
17:10:57 <roshi> lol
17:11:18 <sgallagh> Just a minute; I'm ruminating on this
17:11:45 * adamw wasn't aware you had that many stomachs
17:11:53 <danofsatx> are we +1ing or acking?
17:11:58 <kparal> +1
17:12:12 <sgallagh> Alright, I think I'm with you on +1
17:12:12 * danofsatx is lost
17:12:27 <roshi> chewing your cud in public is bad form
17:12:32 <sgallagh> Even to the point of Go/No-Go discussion
17:13:05 <roshi> to be fair adamw it could just be that his stomach has compartments - not distinct stomachs
17:13:16 <roshi> #agreed - 1252756 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources."
17:13:33 <roshi> #topic (1252902) inst.repo=hd: is not working
17:13:34 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1252902
17:13:34 <roshi> #info Proposed Blocker, anaconda, POST
17:14:02 <sgallagh> roshi: My stomach at this point is growing *a*partements... I need to lose weight.
17:14:15 <kparal> this is similar to the previous one, just hd instead of nfs
17:14:27 <danofsatx> ok then, +1
17:14:54 <roshi> same +1
17:15:06 <garretraziel> +1
17:15:12 <pschindl> +1
17:15:15 <adamw> +1
17:15:15 <sgallagh> +1
17:15:28 <roshi> proposed #agreed - 1252902 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources."
17:15:41 <pschindl> ack
17:15:48 <sgallagh> ack
17:15:54 <garretraziel> ack
17:15:56 <danofsatx> ack
17:15:58 <roshi> proposed #agreed - 1252902 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources."
17:16:03 <roshi> #agreed - 1252902 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "The installer must be able to use all supported local and remote package and installer sources."
17:16:07 <roshi> #topic (1254687) DNF does not display any translations
17:16:07 <roshi> #info Proposed Blocker, dnf, POST
17:16:10 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1254687
17:16:32 <adamw> so i did the l10n test day and found a bunch of bugs, who'd'athinkit
17:16:50 <sgallagh> +1, seems obvious
17:16:54 <roshi> +1
17:16:58 <roshi> and it has a PR
17:16:58 <sgallagh> (bonus: it's fixed)
17:17:01 <roshi> which makes me happy
17:17:38 <adamw> obviously +1 for me
17:18:23 <roshi> proposed #agreed - 1254687 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use."
17:18:35 <sgallagh> ack
17:18:38 <pschindl> ack
17:19:11 <adamw> ack
17:19:14 <roshi> #agreed - 1254687 - AcceptedBlocker Final - This bug is a clear violation of the following Final criteria: "All critical path actions on release-blocking desktops must correctly display all sufficiently complete translations available for use."
17:19:18 <roshi> #topic (1250414) media check fails on DVD/netinst - "configured resource limit was exceeded"
17:19:21 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1250414
17:19:23 <roshi> #info Proposed Blocker, dracut, ON_QA
17:20:27 <roshi> +1 and it's got a fix
17:20:40 <pschindl> +1 per cited criterion
17:21:22 <kparal> +1
17:21:33 <adamw> +1
17:21:34 <danofsatx> +10
17:21:39 <danofsatx> erm, -9
17:21:42 <roshi> proposed #agreed - 1250414 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "Validation of install media must work correctly for all release-blocking images."
17:21:50 <pschindl> ack
17:21:58 <danofsatx> ack
17:21:59 <roshi> well, now we know someone uses their 10key
17:22:42 <adamw> ack
17:22:53 <danofsatx> well, it was better than +any
17:22:57 <roshi> #agreed - 1250414 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "Validation of install media must work correctly for all release-blocking images."
17:23:10 <roshi> #topic (1236034) many fonts missing in fontconfig cache after installation, forced refresh needed
17:23:13 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1236034
17:23:15 <roshi> #info Proposed Blocker, fontconfig, VERIFIED
17:23:24 <kparal> you can skip verified
17:24:04 <roshi> that never happens so I didn't notice
17:24:06 <roshi> #topic (1249336) [abrt] setroubleshoot-server: util.py:291:<module>:ImportError: No module named sepolicy
17:24:10 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1249336
17:24:12 <roshi> #info Proposed Blocker, setroubleshoot, MODIFIED
17:24:27 <adamw> well, it's not entirely safe because the update might not get karma. but this far out it should be OK
17:24:41 <adamw> we usually skip VERIFIED during review of *existing* blockers, not *new proposed* ones.
17:24:51 <kparal> adamw: you're right, as always. spoke too soon
17:25:02 <kparal> maybe because I'm not officially here
17:25:10 * kparal is a ghost, wheeee
17:25:28 <adamw> roshi: can we go back to the fontconfig one just in case?
17:25:33 <sgallagh> /me gets out the proton pack
17:25:36 <roshi> sure
17:25:40 * roshi does the same
17:25:46 <roshi> sgallagh: on three!
17:25:59 <roshi> #topic (1236034) many fonts missing in fontconfig cache after installation, forced refresh needed
17:26:02 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1236034
17:26:04 <roshi> #info Proposed Blocker, fontconfig, VERIFIED
17:26:11 <kparal> in that case +1
17:26:11 <adamw> +1
17:26:21 <danofsatx> +1
17:26:31 <garretraziel> +1
17:26:32 <pschindl> +1
17:26:51 <sgallagh> +1
17:28:02 <roshi> proposed #agreed - 1236034 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."
17:28:14 <danofsatx> ack
17:28:26 <garretraziel> ack
17:28:58 <pschindl> ack
17:29:00 <kparal> ack
17:29:01 <sgallagh> ack
17:29:02 <roshi> #agreed - 1236034 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."
17:29:09 <roshi> #topic (1249336) [abrt] setroubleshoot-server: util.py:291:<module>:ImportError: No module named sepolicy
17:29:12 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1249336
17:29:15 <roshi> #info Proposed Blocker, setroubleshoot, MODIFIED
17:29:15 <danofsatx> +1
17:29:27 <pschindl> +1 too
17:30:11 <adamw> in case it's not obvious, this is the 'selinux troubleshooting' gui for selinux alerts
17:30:20 <adamw> on a clean default workstation live install it doesn't run
17:30:34 <sgallagh> +1
17:30:36 <roshi> fun
17:30:38 <roshi> +1
17:31:05 <sgallagh> This feels like it should have a dedicated criterion as well
17:31:05 <roshi> proposed #agreed - 1249336 - AcceptedBlocker Final - This bug is a clear violation of the following Final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."
17:31:19 <sgallagh> Does the non-graphical reporter work?
17:31:44 <adamw> dunno, but the criterion is more of a 'you shouldn't get any crashes launching apps through the menus' one
17:31:51 <adamw> it's not primarily about whether reporting selinux avc's works
17:32:11 <sgallagh> I know, but I feel like that should *also* be a criterion
17:32:20 <adamw> it may be
17:32:24 <adamw> i just didn't think of that angle
17:32:36 <adamw> dunno if the cli reporter is present/working out of the box, sorry.
17:33:02 <adamw> still, fixing this one is easy enough.
17:33:13 <adamw> (the py3 port isn't, but if that doesn't shake out, we can just add the dep.)
17:33:13 <roshi> ack/nack/patch?
17:33:18 <adamw> ack
17:33:26 <danofsatx> ack
17:33:41 <garretraziel> ack
17:33:42 <roshi> #agreed - 1249336 - AcceptedBlocker Final - This bug is a clear violation of the following Final criterion: "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."
17:33:52 <roshi> #topic (1240802) Can't unlock an encrypted root partition using caps lock key
17:33:55 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1240802
17:33:57 <roshi> #info Proposed Blocker, systemd, NEW
17:34:24 <adamw> this one still
17:34:27 <roshi> this one is fun
17:34:29 <adamw> i keep meaning to look at it and never get to it
17:34:36 <sgallagh> Can we file this under "Why would you do that??"
17:36:22 * adamw doesn't understand how the behaviour from #c7 is 'strange'
17:36:28 <adamw> isn't that exactly how caps lock is supposed to work?
17:37:00 <roshi> adamw: I think it's the brokenness of libvirt
17:37:07 <adamw> #c8 sounds bad, but yeah, i'm inclined to file under 'weird shit, do it differently'
17:37:14 <roshi> later he said that caps lock on produced a mix in tty3
17:37:40 <sgallagh> adamw: It looks like this is all in libvirt.
17:37:42 <adamw> so i'm basically -1 on this, if you have weirdness with caps lock, turn it off.
17:37:45 <adamw> sgallagh: #c8
17:37:49 <adamw> is bare metal.
17:37:50 <sgallagh> I've seen this too, not just at password prompts
17:38:03 <sgallagh> where libvirt will sometimes toggle the caps-lock at random
17:38:14 <adamw> virt-manager / libvirt do have weirdness though, yeah. i often wind up with alt stuck down.
17:38:17 <sgallagh> it's most painful at password
17:38:29 <roshi> theory: it's not random, the ghost in the machine is trying to communicate and we're just not listening
17:38:41 <roshi> it's typing out one character at a time with capslocks...
17:38:51 <sgallagh> I suspect #c8 is a different bug from the rest of this
17:39:15 <sgallagh> roshi: I highly doubt Kusanagi would be that obtuse
17:39:26 <roshi> I lean more -1 on a practical level of what would happen if this is the last blocker at go/no-go
17:39:46 <sgallagh> I'm with roshi here. -1
17:39:55 <garretraziel> -1
17:40:01 <roshi> sgallagh: the kernel is a harnessing mechanism - it controls the magic smoke inside the chips - it can only communicate at LUKS password prompts
17:40:23 <sgallagh> That's just like... your opinion, man
17:40:58 <roshi> proposed #agreed - 1240802 - RejectedBlocker Final - While this bug is very odd and annoying, the workaround is easy and doesn't seem to happen enough to warrant blocking the release for it.
17:41:02 <roshi> sgallagh: heh
17:41:11 <adamw> ack
17:41:16 <sgallagh> ack
17:41:42 <garretraziel> ack
17:41:45 <roshi> #agreed - 1240802 - RejectedBlocker Final - While this bug is very odd and annoying, the workaround is easy and doesn't seem to happen enough to warrant blocking the release for it.
17:41:57 <roshi> #topic (1250737) systemd-tmpfiles-setup.service fails on 23 Alpha RC1 Server
17:42:00 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1250737
17:42:03 <roshi> #info Proposed Blocker, systemd, POST
17:42:41 <roshi> +1, pretty clear
17:43:57 <sgallagh> +1 to the blocker, but I'm not certain that the solution as presented is necessarily correct.
17:44:05 <pschindl> +1
17:44:24 <sgallagh> "A bunch of stuff we want tmpfiles to do didn't happen. We'll call it a warning instead of a failure"
17:44:33 <roshi> yeah
17:44:52 * pschindl has to leave. ack to whatever roshi writes to propose :)
17:45:41 <adamw> i wasn't entirely clear on whether he meant 'we just let it fail and call it a warning' or 'by downgrading some error we allow the rest of the tmpfiles stuff to complete'
17:45:43 <roshi> :)
17:45:49 <adamw> i can ask him to clarify in the comment
17:45:55 <roshi> that'd be good
17:46:06 <roshi> still accept as a blocker though, or punt?
17:46:12 <adamw> it's a blocker either way.
17:46:15 <roshi> we all seem to agree on blockeriness
17:46:17 <adamw> the only question is whether the fix is appropriate.
17:46:32 <sgallagh> adamw: I'm reading through the systemd upstream bug
17:46:39 <sgallagh> It's... ugly
17:47:01 * adamw tries to avoid systemd upstream bugs because he likes to cherish his illusions
17:47:20 <adamw> they still haven't fixed the 'oh hey, we'll just kill -9 everything on shutdown, that's fine right?'
17:47:22 <adamw> bug.
17:47:28 <roshi> proposed #agreed - 1250737 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present." We would prefer a actual fix to merely relabeling this error as a warning.
17:47:44 <roshi> s/a/an/ in final sentence
17:48:27 <adamw> ack
17:48:35 <sgallagh> ack
17:48:51 <garretraziel> ack
17:48:52 <roshi> #agreed - 1250737 - AcceptedBlocker Final - This is a clear violation of the following Final criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present." We would prefer an actual fix to merely relabeling this error as a warning.
17:49:05 <roshi> #topic (1254658) systemctl seems not to be translated at all
17:49:05 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1254658
17:49:05 <roshi> #info Proposed Blocker, systemd, NEW
17:49:18 <sgallagh> The short version of the upstream bug is that Lennart considers XFS to be an "exotic" filesystem and should follow ext[234]'s lead in how to handle that ioctl
17:49:41 <roshi> that's who I read it too sgallagh
17:49:42 <sgallagh> How *the default FS in Fedora Server and RHEL* is considered "exotic" is outside my ability to process.
17:50:30 <roshi> is this something we've released with in the past?
17:51:12 <roshi> I can see an argument that it's already been shipped like this, sans translations - but I think it's a clear blocker
17:52:02 <adamw> i *think* i ran the 'service' checks for 22 final.
17:52:16 <sgallagh> -1 blocker
17:52:33 <sgallagh> The blocker criterion requires us to ship translations if they exist, but none do
17:52:53 <roshi> oh, good point
17:52:56 <adamw> yeah, fair enough.
17:52:57 <roshi> -1
17:53:02 * adamw should read his own criteria sometimes.
17:53:43 <roshi> proposed #agred - 1254658 - RejectedBlocker Final - While it would be great to have translations for this, none currently exist upstream so this doesn't actually violate the criterion.
17:53:49 <sgallagh> ack
17:54:12 <adamw> patch: agreed, not agred.
17:54:59 <roshi> I guess I'll accept your revision :p
17:55:05 * roshi can typ
17:56:00 <sgallagh> I think somthing is wrong with a crtain ky, but I can't b sur.
17:56:03 <adamw> i always remember the guy from my university irc channel who came in extremely drunk one day
17:56:12 <roshi> proposed #agreed - 1254658 - RejectedBlocker Final - While it would be great to have translations for this, none currently exist upstream so this doesn't actually violate the criterion.
17:56:15 <adamw> i think it went something like 'i aturrrrgling tp typr'
17:56:31 <adamw> ack
17:56:33 <sgallagh> ack
17:56:35 <roshi> hh awsom
17:56:44 <roshi> #agreed - 1254658 - RejectedBlocker Final - While it would be great to have translations for this, none currently exist upstream so this doesn't actually violate the criterion.
17:56:56 <roshi> #topic (1199252) default html mime configuration
17:56:56 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1199252
17:56:56 <roshi> #info Proposed Blocker, xfce4-session, ASSIGNED
17:59:09 <sgallagh> I don't see any criterion this violates
17:59:23 <roshi> basic usage
17:59:30 <sgallagh> Not a blocking desktop
18:00:36 <roshi> yeah, I was looking through to see about other DE's
18:00:39 <roshi> but doesn't look like it
18:00:42 <roshi> -1
18:02:13 <sgallagh> -1
18:02:29 <adamw> -1 then
18:03:00 <adamw> +1 FE, but we're a long way from that.
18:03:05 <roshi> proposed #agreed - 1199252 - RejectedBlocker Final - This bug doesn't seem to affect any release blocking desktops and so is not considered a blocker for Final.
18:03:32 <adamw> ack
18:03:37 <adamw> oh wait!
18:03:38 <roshi> proposed #agreed - 1199252 - RejectedBlocker Final - This bug doesn't seem to affect any release blocking desktops and so is not considered a blocker for Final. Please propose as an FE if needed during freeze.
18:03:40 <adamw> that's wrong, isn't it?
18:03:42 <adamw> nack
18:03:44 <adamw> Xfce is blocking now
18:03:46 * nirik doesn't know why he proposed it even but whatever.
18:03:53 <adamw> which seemed like a great idea at Alpha
18:03:57 <adamw> so, +1.
18:03:58 <sgallagh> oof
18:04:00 <roshi> blocker for arm, at least, that's right
18:04:02 <nirik> for arm? right
18:04:04 <sgallagh> You're right
18:04:12 <sgallagh> /me shakes fist at his past self
18:04:14 <roshi> not for workstation though?
18:04:22 <adamw> roshi: ?
18:04:34 <nirik> it's all kinda moot, I am going to push the fix out to f23 today.
18:04:37 <adamw> roshi: we don't have per-arch blockers at present. it's a blocker or it ain't.
18:04:44 <roshi> if it worked on arm and didn't work on workstation - we'd ship
18:04:46 <roshi> right?
18:05:05 <adamw> roshi: wait, how are you comparing arm and workstation?
18:05:18 <adamw> one of them is an arch. one of them is a flavor.
18:05:20 * adamw raises a TypeError
18:05:21 <sgallagh> Using the Chewbacca defense?
18:05:46 <adamw> roshi: if this bug is present on the ARM Xfce image, which by all indications it would be, it's a blocker.
18:05:56 <roshi> right
18:06:01 <roshi> but if it wasn't on the arm image
18:06:04 <roshi> would we block?
18:06:18 <adamw> no. if you're asking would we block for an Xfce bug which didn't affect ARM, we would not.
18:06:30 <roshi> if the arm images worked flawlessly, and everything else catches fire and kills puppies, do we still ship?
18:06:30 <nirik> whats the criteria? advanced menus?
18:06:52 <roshi> ok, so we really need to see if this is on arm before we can say if it's a blocker then
18:07:01 <adamw> it's basically a noarch bug, isn't it?
18:07:11 <adamw> i'm willing to go ahead and assume it affects arm, personally.
18:07:21 <adamw> (especially since nirik says he's fixing it today so let's move on already.)
18:07:39 <roshi> I am too, just wanted to suss out that eventuality in case we come across it in the future
18:07:49 <roshi> +1 then
18:08:01 <roshi> do we need to update criteria or test matrices with the new arm DE?
18:08:06 <adamw> i already did it.
18:08:07 * roshi didn't see if we did that already
18:08:11 <roshi> sweet
18:09:15 <roshi> proposed #agreed - 1199252 - AcceptedBlocker Final - As Xfce is the desktop environment for arm this violates the following Final criterion: "Each application in the default system menu layout should launch without crashing and withstand basic usage. Bugs should be filed in any case where this does not happen"
18:09:23 <adamw> ack
18:09:37 <garretraziel> ack
18:09:38 <sgallagh> ack
18:09:47 <roshi> #agreed - 1199252 - AcceptedBlocker Final - As Xfce is the desktop environment for arm this violates the following Final criterion: "Each application in the default system menu layout should launch without crashing and withstand basic usage. Bugs should be filed in any case where this does not happen"
18:09:57 <roshi> that's it for blockers
18:10:04 <roshi> call it for now or go through FE's?
18:10:07 <sgallagh> Assuming no more came in while we were processing.
18:10:19 <sgallagh> We're not in Freeze yet; any good reason to bother?
18:10:21 <roshi> since this is an out of band review, I'm for calling it now and doing them on monday
18:11:07 <sgallagh> WFM
18:11:13 <roshi> #topic Open Floor
18:11:14 <adamw> me too
18:11:17 <roshi> anybody have anything?
18:11:17 <adamw> nice work folks, that was quick
18:11:21 * roshi sets the fuse
18:11:28 <adamw> it'd be good if people could test+karma latest anaconda/blivet
18:11:33 <roshi> thanks for handling the beginning and secretarializing adamw
18:11:39 <adamw> the one we have in f23 stable atm is a bit crusty
18:11:49 <adamw> i'm gonna try it with a live image and also spin up a boot.iso and throw it at colada
18:12:28 <roshi> sounds good
18:13:34 <roshi> thanks for coming!
18:13:38 <roshi> 3...
18:13:40 <roshi> 2...
18:13:42 <roshi> 1...
18:13:47 <roshi> #endmeeting