#fedora-blocker-review: F24-blocker-review

Meeting started by adamw at 16:07:09 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:07:09)
  2. Introduction (adamw, 16:10:16)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:10:16)
    2. We'll be following the process outlined at: (adamw, 16:10:17)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:10:18)
    4. The bugs up for review today are available at: (adamw, 16:10:20)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:10:22)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:10:24)
    7. https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria (adamw, 16:10:26)
    8. https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria (adamw, 16:10:28)
    9. https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria (adamw, 16:10:30)
    10. kparal will secretarialize (adamw, 16:11:51)

  3. (1321393) blivet.errors.DeviceTreeError: no slaves found for device md127 (adamw, 16:12:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1321393 (adamw, 16:12:29)
    2. Proposed Blocker, python-blivet, ASSIGNED (adamw, 16:12:29)
    3. AGREED: 1321393 - punt (delay decision) - we still didn't get categorical information here, but we suspect it was caused by multiple installer launches, which is an unfortunate UI issue but wouldn't be a blocker. if we don't get new information by next week this will be rejected (adamw, 16:24:16)
    4. ACTION: adamw to ping hughsie about his 1321393 experience (adamw, 16:24:24)
    5. moving on to proposed Final blockers (adamw, 16:26:02)

  4. (1325471) resolving Supplements: dependencies pull in multilib packages (adamw, 16:26:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1325471 (adamw, 16:26:07)
    2. Proposed Blocker, dnf, NEW (adamw, 16:26:07)
    3. AGREED: 1325471 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - details are not nailed down yet, but installing a ton of multilib packages on system update is considered a conditional violation of "The installed system must be able to download and install updates with the default console package manager." and accepted as a Final blocker and Beta freeze exception for now. decision may be changed based on later info (adamw, 16:41:03)

  5. (1320273) Grub2 out of memory error (adamw, 16:41:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1320273 (adamw, 16:41:26)
    2. Proposed Blocker, grub2, NEW (adamw, 16:41:26)
    3. AGREED: 1320273 - AcceptedBlocker (Final) - this seems like a clear violation of "The installer must be able to install into free space alongside an existing clean Windows installation and install a bootloader which can boot into both Windows and Fedora." in the case of a UEFI windows install (adamw, 16:47:30)

  6. (1317927) selinux prevents systemd-coredump from working (adamw, 16:47:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1317927 (adamw, 16:47:43)
    2. Proposed Blocker, selinux-policy, NEW (adamw, 16:47:43)
    3. AGREED: 1317927 - RejectedBlocker (Final) - firefox being unusable would constitute a blocker issue, however no-one present in the blocker meeting has hit this issue in F24 testing and the bug seems unclear on exactly what configuration is required to trigger it. can be re-proposed with a clearer reproducer and blocker justification (adamw, 16:53:22)
    4. circling back to the newly proposed beta blocker (adamw, 16:53:59)

  7. (1326047) Network Manager IPv4 and IPv6 dialogs incorrectly displayed, unusable with mouse (adamw, 16:54:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1326047 (adamw, 16:54:30)
    2. Proposed Blocker, NetworkManager, NEW (adamw, 16:54:31)
    3. AGREED: 1326047 - AcceptedBlocker (Final) - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test." The 'advanced network config' experience for Beta is unfortunate, but we don't consider it a sufficiently serious case to take as a conditional violation of e.g. updates criterion (adamw, 17:08:22)
    4. AGREED: we do think 1326047 sucks and would like it fixed ASAP, and will likely vote +1 FE for Beta if it comes to that. (adamw, 17:08:51)

  8. (1326055) Applications using Qt 5 are not displaying spinner and checked menu items properly. (adamw, 17:09:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1326055 (adamw, 17:09:26)
    2. Proposed Blocker, adwaita-qt, NEW (adamw, 17:09:27)
    3. AGREED: 1326055 - RejectedBlocker (Beta) - this clearly does not violate any of the Beta criteria, nothing in those depends on Qt apps running on Workstation (adamw, 17:18:43)

  9. Beta accepted blocker round up (adamw, 17:19:19)
    1. info is still requested on https://bugzilla.redhat.com/show_bug.cgi?id=1262556 (adamw, 17:19:30)
    2. we more or less know what's going on with https://bugzilla.redhat.com/show_bug.cgi?id=1306808 (btrfs volume reuse bug) and anaconda team expects it to be dealt with some time this week (adamw, 17:20:21)
    3. Beta freeze is 2016-04-19 , so we'll be reviewing FEs next week (adamw, 17:22:24)

  10. Open floor (adamw, 17:23:24)


Meeting ended at 17:28:11 UTC (full logs).

Action items

  1. adamw to ping hughsie about his 1321393 experience


Action items, by person

  1. adamw
    1. adamw to ping hughsie about his 1321393 experience


People present (lines said)

  1. adamw (210)
  2. sgallagh (83)
  3. cmurf (81)
  4. kparal (42)
  5. danofsatx (16)
  6. pwhalen (11)
  7. pschindl (11)
  8. garretraziel (9)
  9. jpigface (8)
  10. zodbot (5)


Generated by MeetBot 0.1.4.