#fedora-blocker-review: F24-blocker-review

Meeting started by adamw at 16:02:11 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:11)
  2. Introduction (adamw, 16:12:00)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:12:00)
    2. We'll be following the process outlined at: (adamw, 16:12:00)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:12:01)
    4. The bugs up for review today are available at: (adamw, 16:12:02)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:12:04)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:12:06)
    7. https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria (adamw, 16:12:10)
    8. https://fedoraproject.org/wiki/Fedora_24_Beta_Release_Criteria (adamw, 16:12:12)
    9. https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria (adamw, 16:12:14)
    10. pschindl will secretarialize (adamw, 16:13:55)
    11. 8 Proposed Blockers (adamw, 16:14:29)
    12. 2 Accepted Blockers (adamw, 16:14:30)
    13. 3 Proposed Freeze Exceptions (adamw, 16:14:30)
    14. 4 Accepted Freeze Exceptions (adamw, 16:14:30)
    15. we also have 4 Proposed Blockers for Final (adamw, 16:14:47)

  3. (1322909) docker-1.10.3-3.gitd93ee51.fc24 fails to run anything (adamw, 16:15:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1322909 (adamw, 16:15:17)
    2. Proposed Blocker, docker, NEW (adamw, 16:15:17)
    3. ACTION: adamw to propose docker criteria (adamw, 16:20:27)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1322909#c21 (adamw, 16:23:11)
    5. AGREED: 1322909 - RejectedBlocker - this is rejected for now as sgallagh's testing indicates the current stable package is not affected and there are no docker criteria in any case, but it may be re-evaluated if the bug affects -4 and we add docker criteria as proposed (adamw, 16:31:44)

  4. (1314494) knode has unmet dependencies during dnf system-upgrade to f24 (adamw, 16:32:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1314494 (adamw, 16:32:32)
    2. Proposed Blocker, kdepim, ON_QA (adamw, 16:32:32)
    3. AGREED: 1314494 - AcceptedBlocker (Beta) - this is a violation of "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed." for the KDE package set (adamw, 16:41:28)

  5. (1328369) Luc doesn't reuse already downloaded image and stuck (adamw, 16:41:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1328369 (adamw, 16:41:56)
    2. Proposed Blocker, liveusb-creator, VERIFIED (adamw, 16:41:56)
    3. AGREED: 1328369 - AcceptedFreezeException (Beta) - this is clearly bad enough to merit a freeze exception. We are undecided on blocker status for now, will re-evaluate at Go/No-Go if it is not pushed stable for all releases by then (adamw, 16:48:46)

  6. (1328484) liveusb-creator on Windows 10 opens diskpart.exe but does nothing (adamw, 16:49:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1328484 (adamw, 16:49:12)
    2. Proposed Blocker, liveusb-creator, VERIFIED (adamw, 16:49:12)
    3. no evaluation needed for #1328484 as bug is considered resolved (adamw, 16:52:09)

  7. (1328498) partitions are not unmounted before writing image to a device, can lead to corrupted data written (adamw, 16:52:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1328498 (adamw, 16:52:18)
    2. Proposed Blocker, liveusb-creator, VERIFIED (adamw, 16:52:18)
    3. AGREED: 1328498 - AcceptedPreviousRelease (22 and 23), AcceptedFreezeException (Beta) - this violates "All release-blocking images must boot in their supported configurations." (with the footnote about USB media) for F22 and F23. we may also consider it serious enough to be an F24 Beta blocker if not pushed stable by go/no-go, but it is at least freeze exception-worthy for now (adamw, 17:01:01)

  8. (1329532) liveusb-creator on Windows 10 doesn't write image (adamw, 17:01:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1329532 (adamw, 17:01:20)
    2. Proposed Blocker, liveusb-creator, VERIFIED (adamw, 17:01:21)
    3. as with 1328484, this is believed resolved in current version of Windows build, no evaluation required (adamw, 17:03:36)

  9. (1329608) missing deps on F22 (adamw, 17:03:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1329608 (adamw, 17:03:47)
    2. Proposed Blocker, liveusb-creator, ASSIGNED (adamw, 17:03:47)
    3. AGREED: 1329608 - RejectedBlocker (Beta) - the affected luc never reached stable for F22, so this bug does not violate the criteria (adamw, 17:19:08)

  10. (1329611) no image written on F22 (adamw, 17:19:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1329611 (adamw, 17:19:17)
    2. Proposed Blocker, liveusb-creator, ASSIGNED (adamw, 17:19:17)
    3. AGREED: 1329611 - RejectedBlocker (Beta) - the affected luc never reached stable for F22, so this bug does not violate the criteria (adamw, 17:20:44)

  11. (1327615) Incorrect subnet mask shown in network spoke (adamw, 17:22:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1327615 (adamw, 17:22:03)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 17:22:03)
    3. AGREED: 1327615 - RejectedFreezeException (Beta) - at this point in the Beta process it's a bit late to poke the network screen for a purely cosmetic fix (adamw, 17:29:57)

  12. (1329715) [abrt] sddm: drainMarkStack(): sddm-greeter killed by SIGSEGV (adamw, 17:30:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1329715 (adamw, 17:30:49)
    2. Proposed Freeze Exceptions, sddm, NEW (adamw, 17:30:50)
    3. https://openqa.fedoraproject.org/tests/14439 (adamw, 17:32:18)
    4. AGREED: 1329715 - AcceptedFreezeException (Beta) - if a targeted and tested fix for this is available soon we will consider including it (as this would be an upgrade criterion violation if i686 still blocked releases), but will be careful not to break x86_64 (adamw, 17:36:01)
    5. accepted blocker update (adamw, 17:36:32)
    6. 1321330 - dennis and peter are actively working on it (adamw, 17:36:45)
    7. 1259865 - hughsie and mclasen reported earlier that this is also being worked on (adamw, 17:37:02)
    8. we will do final blocker review next week, for now we'll prioritize beta testing (adamw, 17:42:21)

  13. Open floor (adamw, 17:42:27)


Meeting ended at 18:54:20 UTC (full logs).

Action items

  1. adamw to propose docker criteria


Action items, by person

  1. adamw
    1. adamw to propose docker criteria


People present (lines said)

  1. adamw (267)
  2. kparal (95)
  3. cmurf (74)
  4. RaphGro (19)
  5. jkurik (19)
  6. pschindl (13)
  7. pwhalen (10)
  8. zodbot (8)
  9. garretraziel (4)
  10. nb (3)
  11. Amita (2)
  12. tflink (1)


Generated by MeetBot 0.1.4.