16:01:16 <adamw> #startmeeting F25-blocker-review
16:01:16 <zodbot> Meeting started Mon Aug  8 16:01:16 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:16 <zodbot> The meeting name has been set to 'f25-blocker-review'
16:01:16 <adamw> #meetingname F25-blocker-review
16:01:16 <zodbot> The meeting name has been set to 'f25-blocker-review'
16:01:16 <adamw> #topic Roll Call
16:01:24 <adamw> ahoyhoy folks, who's around to review some blockers?
16:01:27 <adamw> it's the most amazing fun!
16:01:33 <adamw> no, wait, no. it isn't. but we have to do it anyway!
16:02:14 <adamw> gonna leave the roll call open for a few mins so people can get a break after the qa meeting, please do say hi when you're around :)
16:02:24 * coremodule standing by.
16:02:29 <Southern_Gentlem> .hello jbwillia
16:02:30 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@yahoo.com>
16:02:35 * satellit listening
16:02:38 * h4xr is here
16:04:23 * potty is here
16:04:38 <adamw> #chair coremodule southern_gentlem
16:04:38 <zodbot> Current chairs: adamw coremodule southern_gentlem
16:05:04 * kparal is here
16:05:09 <coremodule> Happy to act as secretary if needed.
16:05:35 * brunowolff is here
16:06:01 * cmurf is here
16:06:08 <adamw> thanks coremodule!
16:06:15 <coremodule> No problem!
16:06:16 <adamw> #info coremodule will secretarialize
16:06:27 <adamw> #topic Introduction
16:06:27 <adamw> Why are we here?
16:06:27 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:06:27 <adamw> #info We'll be following the process outlined at:
16:06:29 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:06:30 <adamw> #info The bugs up for review today are available at:
16:06:32 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:06:34 <adamw> #info The criteria for release blocking bugs can be found at:
16:06:36 <adamw> #link https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria
16:06:38 <adamw> #link https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria
16:06:40 <adamw> #link https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria
16:07:00 <adamw> #info 1 Proposed Blocker (Alpha), 2 Proposed Blockers (Beta)
16:07:06 <adamw> #info 3 Accepted Blockers
16:07:22 <adamw> so we don't have too much today, hope it'll be a short meeting :)
16:07:34 <adamw> starting with the Alpha proposed blocker:
16:07:34 <adamw> #topic (1361338) Connecting to /dev/log gets Connection Refused
16:07:34 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1361338
16:07:34 <adamw> #info Proposed Blocker, systemd, NEW
16:08:28 <adamw> this sounds bad, but i haven't seen it - at least in the shape of anaconda not running on lives...has anyone else?
16:09:24 <satellit> liveinst has problems in some lives
16:09:32 <cmurf> Doesn't sound familiar, but FWIW /dev/log is a symlink to /run/systemd/journal/dev-log
16:09:36 <cmurf> Or at least it's supposed to be.
16:09:38 <brunowolff> The bug seems low level. It would be better if it actually was about an anaconda failure and not something that is only suspected to cause the problem
16:09:39 * satellit no blocking
16:10:00 <coremodule> Haven't seen this...
16:10:09 * satellit non blocking DE's*
16:10:43 * kmurarka is here
16:11:00 <Southern_Gentlem> needs to be tested more imho
16:11:03 <cmurf> punt, not enough info
16:11:14 <Southern_Gentlem> +1 punt
16:11:48 <adamw> i'm -1 on this, actually
16:11:59 <adamw> since we can pretty easily confirm it does not stop the installer running on a current live image...
16:12:18 <adamw> i just tested with the 20160805 Workstation live in a VM and anaconda runs fine and the given python lines run fine.
16:12:35 <satellit> wks and kde work fine
16:12:36 <adamw> but i can go with a punt too
16:13:36 * satellit punt
16:14:19 <Southern_Gentlem> link to the f25 lives please
16:14:25 <coremodule> Punt, just in case we're missing something here.
16:14:35 <adamw> proposed #agreed 1361338 - punt (delay decision) - the bug sounds bad, but its existence has not been confirmed by anyone else and some in-meeting testing did not encounter it, so we at least need more information here
16:14:55 <coremodule> Southern_Gentlem, https://kojipkgs.fedoraproject.org/compose/branched/
16:15:03 <coremodule> ack
16:15:16 <kparal> ack
16:15:21 <Southern_Gentlem> ack
16:15:25 <adamw> #agreed 1361338 - punt (delay decision) - the bug sounds bad, but its existence has not been confirmed by anyone else and some in-meeting testing did not encounter it, so we at least need more information here
16:15:41 <adamw> #info moving on to Beta proposed blockers
16:15:47 <adamw> #topic (1347436) fedora-import-state sets incorrect mode for /dev/shm when dracut places it in /run/initramfs/state (causes various things to break, inc. webkit and Boxes)
16:15:47 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1347436
16:15:47 <adamw> #info Proposed Blocker, initscripts, ASSIGNED
16:15:53 <adamw> this is the semi-infamous UEFI /dev/shm bug
16:16:03 <adamw> which i'm having lots of 'fun' trying to get anyone to goddamn fix
16:16:18 * satellit see it all the time
16:17:54 <adamw> so i'm +1 obviously, any other votes?
16:17:56 <cmurf> There's also an selinux related bug with /dev/shm/lldpad.state
16:17:59 <cmurf> +1 blocker
16:19:19 <potty> blocker
16:19:19 <adamw> i think that one's filed separately.
16:19:34 <Southern_Gentlem> +1
16:19:38 <kparal> +1
16:19:39 <cmurf> it is separately filed
16:21:03 <adamw> oh, can we also take this as an alpha FE?
16:21:14 <adamw> since i at least got someone to work on it now, and freeze is soon
16:21:23 * adamw +1 Alpha FE, other votes?
16:21:28 <Southern_Gentlem> +1
16:21:31 <satellit> +1
16:21:41 <Southern_Gentlem> sooner its fixed the better
16:21:42 <cmurf> IF it's blocking does it need FE?
16:22:20 <adamw> cmurf: it's a beta blocker, not alpha.
16:22:31 <cmurf> oic
16:22:40 <cmurf> seems serious enough to be an alpha blocker...
16:23:24 <cmurf> but yeah sure +1 alpha FE
16:24:27 <adamw> hmm, now i look, i think this is only clearly a final blocker
16:24:43 <adamw> it obviously violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." which is a Final criterion
16:24:48 <adamw> but i don't immediately see a Beta violation
16:24:54 <adamw> does anyone want to argue for Beta, or should we make it Final?
16:25:00 <adamw> Alpha FE will still stand
16:25:11 <Southern_Gentlem> we know its borked lets not wait till holding up release on it
16:25:26 <Southern_Gentlem> so leave it as beta
16:25:32 <adamw> Southern_Gentlem: that's not a valid reason
16:25:39 <adamw> it can only be a beta blocker if it violates the beta criteria
16:25:57 <adamw> if anyone can see a beta criterion it violates, speak up :)
16:27:05 <Southern_Gentlem> The release must be able host virtual guest instances of the same release.
16:27:52 <adamw> mm, doesn't really break that, though, virt-manager works
16:28:06 <Southern_Gentlem> is boxes not an approved tool for this
16:29:00 <Southern_Gentlem> boxes is in a required DE and that is borked
16:29:11 <adamw> "This criterion applies only to the recommended Fedora virtualization tools - the qemu/kvm - libvirt - virt-manager stack."
16:29:24 <adamw> that was written before boxes existed, but we've never changed it...
16:29:46 <cmurf> I think it's a final blocker, even though it smells much more ripe than that.
16:29:51 <Southern_Gentlem> there must be some beta that gnome tools have to work
16:30:35 <adamw> not really
16:30:55 <Southern_Gentlem> i am afraid if its only a final blocker we will be waiting on it till then
16:30:56 <adamw> well, maybe let's not waste too much time for now
16:31:12 <adamw> Southern_Gentlem: i don't think so, i have someone from the relevant team working on it now
16:31:26 <Southern_Gentlem> **crossing fingers**
16:31:38 <adamw> let's take it as a final blocker / alpha fe and if we want to re-consider for beta blocker later with a valid justification we can...
16:32:04 <adamw> proposed #agreed 1347436 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.", consequences are quite visible and serious on UEFI live installs so also taken as an Alpha FE
16:32:25 <Southern_Gentlem> +1
16:33:59 <kparal> ack
16:34:02 <adamw> ack/nack/patch?
16:34:48 <Southern_Gentlem> ack
16:34:51 <coremodule> ack
16:34:57 <adamw> #agreed 1347436 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.", consequences are quite visible and serious on UEFI live installs so also taken as an Alpha FE
16:35:03 <adamw> #topic (1362165) doesn't connect to wifi after resume
16:35:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1362165
16:35:03 <adamw> #info Proposed Blocker, NetworkManager, NEW
16:35:41 <adamw> this doesn't really hit any criteria for m,e
16:35:51 <adamw> it's a bug to be fixed for sure, but i can't see it as a beta blocker...
16:36:44 <kparal> isn't basic desktop panel functionality broken this way?
16:37:01 <kparal> the wifi list is available from the user menu in gnome
16:37:02 <brunowolff> I didn't see any resume or network criteria that seemed to fit for either alpha or veta.
16:37:29 <adamw> or final
16:38:01 <adamw> kparal: well, i'd read that criterion as being 'right after boot', not after booting and suspending and resuming
16:38:02 <cmurf> It does seem like it ought to be a blocker...
16:38:10 <Southern_Gentlem> i dont see this as a blocker way too many things that could cause this
16:38:10 <cmurf> BUT you can work around it by restarting NM
16:38:34 <adamw> i dunno, just on a 'feels' basis i'd maaaaaybe think about final blocker but it doesn't really feel much like a beta blocker
16:38:54 <adamw> i.e. i'm comfortable with not amending the beta criteria for it
16:38:59 <kparal> adamw: it says "in typical use"
16:39:08 <brunowolff> Only if we made a requirement that resume works, which I don't think has reached the point where we wanted to make it a requirement.
16:39:10 <kparal> suspend and resume is pretty typical on laptops
16:39:11 <cmurf> Well feelings being subject and all... my bias is for a beta that people can use and not get frustrated by.
16:39:23 <cmurf> Question is how frustrating + obscure this bug is, and its work around.
16:39:33 <adamw> kparal: we've always held the criteria don't cover suspend/resume, though.
16:39:43 <adamw> still, that keeps coming up.
16:40:03 <kparal> yeah, we did
16:40:05 <cmurf> Sure and I'm trying to push that this needs to stop, but part of that means more resources for power management related things.
16:40:24 <Southern_Gentlem> easy fix is thart on resume it auto restarts nm
16:40:43 <adamw> kparal: 'in typical use' means typical use *of the panel*, taking this as a violation of that criterion does feel like quite a big stretch to me, but i'm not entirely against...
16:41:00 <adamw> Southern_Gentlem: ew, god, no, we're not going down that kind of hacky line :P there's already a fix proposed in the bug
16:41:53 <adamw> so, any votes?
16:42:02 <Southern_Gentlem> i am for fixing this, he see people all the time complaining about nm not coming back up on resume in fedora
16:42:05 * adamw is -1 beta, about -0.5 final
16:42:15 <adamw> Southern_Gentlem: again, the blocker meetings are not votes on whether to fix bugs or not
16:42:17 <Southern_Gentlem> +1 final and +1 beta
16:42:22 <adamw> we're deciding whether they're release blockers
16:42:36 <adamw> 'i really think this should be fixed!' is not a valid basis for deciding whether it's a blocker, that's what the criteria are for
16:43:48 <kparal> it's true we don't cover system resume, but if the system resumed correctly (kernel, X, etc) and it's just a service bug, I'd say we don't need to exclude it from criteria
16:43:51 <adamw> if you think the criteria ought to say 'network connections must always be brought back up on system resume' or something then it's ok to propose a criteria change, but there really does have to be some kind of criteria justification for our decisions
16:45:07 <cmurf> I agree with adamw
16:45:31 <cmurf> But I think we should have a criteria
16:45:32 <brunowolff> Given the current criteria I am -1 blocker.
16:45:49 <adamw> brunowolff: for which milestone?
16:45:59 <cmurf> And it should cover resume from suspend to RAM.
16:46:32 <kparal> if this affects all hardware, I'm -1 Beta +1 Final. if this is affects just some specific hardware, it depends on how many users this affects
16:46:34 <cmurf> +1 Alpha FE, because there are patches now to fix this
16:46:38 <cmurf> So just fix it that way.
16:46:54 <kparal> but honestly, if this affected everyone, I can't imagine releasing F25 with this kind of a bug
16:46:57 <brunowolff> alpha and beta, and probably final as well but I haven't double checked the final criteria.
16:47:02 <adamw> oh, yeah, we should also consider alpha FE status, i'm +1 Alpha FE
16:47:18 <adamw> brunowolff: the final criterion that's been cited is "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."
16:47:34 <cmurf> I can't imagine we'd release either, but chances are we don't even get close.
16:47:39 <adamw> note there is a footnote on that:
16:47:40 <cmurf> (to releasing with it)
16:47:41 <adamw> "
16:47:41 <adamw> Especially with GNOME 3 and KDE 4, 'panel (or equivalent)' covers quite a wide range of features, including some pretty advanced stuff - you could argue that all elements of GNOME network configuration are covered because there's a network icon on the top panel, for instance. The intent of the criterion is more that very prominent features of the desktop don't break easily, so there's a subjective cut-off in there which is decided in the blocker
16:47:41 <adamw> review process. The key question is "would this bug cause significant inconvenience or just a really bad first impression to a typical user or reviewer of the release?"
16:47:42 <adamw> "
16:48:03 <cmurf> all three
16:48:06 <cmurf> bad, bad, bad
16:48:22 <brunowolff> I don't think that criteria covers this case. I believe that currently suspend/resume is not considered normal use.
16:48:47 <cmurf> Which in 2016 is absurd...
16:48:49 <adamw> my objection is still that the criterion is about the *panel* itself and using that as a proxy for things the panel just exposes access to is a bit of a worrying precedent. but i can see the argument for +1 final on that basis.
16:48:50 <kparal> it is normal use, but we don't usually block on that because of too many hardware and kernel issues
16:48:58 <kparal> but this is not a hw/kernel issue
16:49:00 <Southern_Gentlem> brunowolff, i would since the majority of our users use laptops
16:49:28 <kparal> adamw: point taken, I agree we should not use the panel criterion for everything
16:49:51 <adamw> it's definitely reasonable to re-consider the 'we don't cover resume' position at this point, sure.
16:49:52 <brunowolff> Well if we make suspend / resume working a release criteria, are we going to be able to make releases?
16:50:02 <adamw> brunowolff: i think it'd depend a lot on the details.
16:50:14 <adamw> so since this seems controversial...
16:50:26 <cmurf> Realize that this particular bug is going to get fixed in about 2 seconds...
16:50:30 <adamw> how about we accept it as an alpha FE and punt the blocker decision for now so people have time to propose criteria revisions or whatever?
16:50:46 <cmurf> Sure
16:50:47 <kparal> or not :)
16:50:48 <kparal> sure
16:50:51 <Southern_Gentlem> +1 AFE +1 punt
16:51:11 <brunowolff> I am +1 FE for alpha.
16:51:52 <coremodule> +1 FE, +1 punt blocker classification
16:51:55 <adamw> proposed #agreed 1362165 - AcceptedFreezeException (Alpha), punt (delay decision) on blocker status - there is considerable disagreement about whether this currently qualifies as a beta or final blocker under the criteria (and if not, whether it *should* do), so for now we accept it as an Alpha FE and delay the blocker decision for further discussion and criteria proposals
16:52:02 <cmurf> ack
16:52:11 <brunowolff> ack
16:52:15 <Southern_Gentlem> ack
16:52:23 <adamw> \#agreed 1362165 - AcceptedFreezeException (Alpha), punt (delay decision) on blocker status - there is considerable disagreement about whether this currently qualifies as a beta or final blocker under the criteria (and if not, whether it *should* do), so for now we accept it as an Alpha FE and delay the blocker decision for further discussion and criteria proposals
16:52:25 <adamw> grr
16:52:26 <adamw> #agreed 1362165 - AcceptedFreezeException (Alpha), punt (delay decision) on blocker status - there is considerable disagreement about whether this currently qualifies as a beta or final blocker under the criteria (and if not, whether it *should* do), so for now we accept it as an Alpha FE and delay the blocker decision for further discussion and criteria proposals
16:52:36 <adamw> OK, that's all the proposed blockers
16:52:54 <adamw> we can have a quick look through the accepted Alpha blockers and check current status, there aren't many
16:53:01 <adamw> #info moving on to accepted Alpha blockers
16:53:11 <adamw> #topic (1358416) "Error setting up software source" when attempting a Network installation
16:53:11 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1358416
16:53:11 <adamw> #info Accepted Blocker, dracut, ON_QA
16:53:22 <adamw> ah, i think we can close this, pretty sure the fix worked.
16:54:14 <adamw> #info the fix for this looks good, we can just double-check it's fixed and close it
16:54:27 <adamw> #topic (1352680) efibootmgr calls in anaconda crashing since efivar-0.24-1.fc25 landed
16:54:27 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1352680
16:54:27 <adamw> #info Accepted Blocker, efibootmgr, NEW
16:54:32 <adamw> we're still waiting on pjones here :/
16:54:42 <adamw> i did check in with him last week and he said he'd fix it soon
16:55:22 <cmurf> For lives it's possible to downgrade efivars to work around it.
16:55:28 <adamw> not sure there's much else to say/do...
16:56:04 <cmurf> I guess it's efivar not efivars
16:56:22 <adamw> #info still waiting on pjones to fix this, not much else anyone else can do
16:56:27 <adamw> #topic (1353054) FreeIPA server deployment fails due to pki-core dangling symlinks (one from non-installed 'scannotation' package, one formerly in resteasy-jaxrs-api but now lost)
16:56:28 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1353054
16:56:28 <adamw> #info Accepted Blocker, pki-core, NEW
16:56:33 <adamw> so there seems to be movement on this, but no package builds
16:56:43 <adamw> i guess i can poke them and let them know the urgency here
16:56:55 <cmurf> adamw: well if push came to shove couldn't we just take a previous version?
16:57:14 <adamw> cmurf: presumably, i guess.
16:57:32 <cmurf> OK well we'll cross that bridge if there isn't a fix in a week or two...
16:58:18 <adamw> yeah
16:59:03 <adamw> #action adamw to poke freeipa team and emphasize the urgency here (and give them the deadlines)
16:59:39 <adamw> we've got one more proposed alpha FE, courtesy of satellit
16:59:45 <adamw> #info moving to a newly proposed Alpha FE
17:00:22 <adamw> #topic (1363915) soas f25 liveuser no longer logs in in live
17:00:27 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1363915
17:00:43 <adamw> #info Proposed Freeze Exception, sugar, NEW
17:00:57 <adamw> i'm +1 FE on this, if a fix doesn't look to affect anything outside sugar
17:01:09 <adamw> it's not world-ending, but always nice to fix
17:01:10 <cmurf> +1 alpha FE
17:01:20 <satellit> +1 alpha FE
17:02:02 <kparal> +1 FE
17:02:06 <coremodule> +1FE
17:02:59 <adamw> proposed #agreed 1363915 - AcceptedFreezeException (Alpha) - this isn't critical but it's part of the first-time experience for SoaS, worth fixing and cannot be fixed with an update
17:04:29 <adamw> ack/nack/patch?
17:04:36 <Southern_Gentlem> ack
17:04:41 <satellit> ack
17:04:43 <cmurf> ack
17:05:06 <adamw> #agreed 1363915 - AcceptedFreezeException (Alpha) - this isn't critical but it's part of the first-time experience for SoaS, worth fixing and cannot be fixed with an update
17:05:08 <adamw> alrighty
17:05:14 <adamw> i think that's everything!
17:05:16 <adamw> #topic Open floor
17:05:22 <adamw> any other blocker-related topics, missed bugs etc?
17:06:45 <potty> no
17:07:50 <adamw> so if anyone wants to propose criteria revisions, please do, it's always ok to re-examine and update them
17:08:25 <adamw> all you really need to do is send a mail to test@ which accurately describes your proposed changes, however you want to do that - i generally copy the criteria page to my personal space then edit the copy and make my changes, then you can post a link to the diff, but there's various ways
17:09:21 <adamw> thanks for coming, everyone!
17:10:44 <coremodule> Thanks for hosting adamw
17:10:46 <satellit> thanks
17:11:43 <kparal> thanks, see you
17:12:56 <adamw> #endmeeting