#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 16:00:15 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:15)
  2. Introduction (adamw, 16:05:12)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:05:12)
    2. We'll be following the process outlined at: (adamw, 16:05:12)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:05:15)
    4. The bugs up for review today are available at: (adamw, 16:05:16)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:05:18)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:05:20)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 16:05:22)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 16:05:24)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 16:05:26)
    10. 1 Proposed Blockers (adamw, 16:05:30)
    11. 4 Accepted Blockers (adamw, 16:05:32)
    12. 3 Proposed Freeze Exceptions (adamw, 16:05:34)
    13. 3 Accepted Freeze Exceptions (adamw, 16:05:36)
    14. we also have 2 Proposed (Beta) and 1 Proposed (Final) (adamw, 16:05:52)
    15. coremodule to secretarialize (adamw, 16:08:28)
    16. starting with the Alpha proposed blocker (adamw, 16:12:55)

  3. (1366403) [abrt] sssd-common: ipa_dyndns_update_send(): sssd_be killed by SIGSEGV (adamw, 16:12:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366403 (adamw, 16:12:58)
    2. Proposed Blocker, sssd, NEW (adamw, 16:12:59)
    3. AGREED: 1366403 - AcceptedBlocker (Alpha) - this appears to violate "It must be possible to join the system to a FreeIPA or Active Directory domain at install time and post-install, and the system must respect the identity, authentication and access control configuration provided by the domain." adamw will test this in a bit more detail after the meeting to see if it's only a transient failure (adamw, 16:23:25)
    4. moving onto proposed Beta blockers (adamw, 16:23:45)

  4. (1366793) Nothing obsoletes retired dnf-langpacks packages, breaks upgrade from Fedora 23 to 25+ (adamw, 16:23:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366793 (adamw, 16:23:53)
    2. Proposed Blocker, dnf, ASSIGNED (adamw, 16:23:53)
    3. AGREED: 1366793 - punt (delay decision) - we are not sure whether 'workarounding' this with allowerasing (or equivalent) is acceptable, and can't really decide in the absence of any packaging policy covering what to do with retired packages if Obsoletes + Provides is not appropriate. will refer to FPC for consideration (adamw, 16:42:57)

  5. (1362165) doesn't connect to wifi after resume (adamw, 16:43:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1362165 (adamw, 16:43:06)
    2. Proposed Blocker, NetworkManager, ON_QA (adamw, 16:43:06)
    3. this is in 'punt' status expecting some criteria revision proposals, but we haven't had any yet, so nothing much to discuss (adamw, 16:46:19)
    4. moving to final blocker (adamw, 16:46:38)

  6. (1363914) [abrt] qupzilla: base::debug::BreakDebugger(): qupzilla killed by SIGABRT (adamw, 16:46:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1363914 (adamw, 16:46:39)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 16:46:39)
    3. AGREED: 1363914 - AcceptedBlocker (Final) - violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." (adamw, 16:53:35)
    4. moving to Alpha proposed freeze exceptions (adamw, 16:54:41)

  7. (1365686) kernel BUG at mm/rmap.c:1288! (adamw, 16:54:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1365686 (adamw, 16:54:47)
    2. Proposed Freeze Exceptions, kernel, ON_QA (adamw, 16:54:47)
    3. AGREED: 1365686 - AcceptedFreezeException (Alpha) - seems significant enough to ensure it's fixed on the live images, kernel team requested. (adamw, 16:59:33)

  8. (1366554) template fixes for alternative arches (adamw, 16:59:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366554 (adamw, 16:59:42)
    2. Proposed Freeze Exceptions, lorax, MODIFIED (adamw, 16:59:42)
    3. AGREED: 1366554 - AcceptedFreezeException (Alpha) - this is needed to fix compose of secondary arch (ppc64le), by convention we accept these as FEs so the freeze doesn't prevent work on secondary arches (adamw, 17:02:27)

  9. (1364781) QtWebEngine 5.7.0 breaks when built against glibc 2.24 (2.23.90) which defines MADV_FREE (adamw, 17:02:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1364781 (adamw, 17:02:37)
    2. Proposed Freeze Exceptions, qt5-qtwebengine, MODIFIED (adamw, 17:02:37)
    3. AGREED: 1364781 - AcceptedFreezeException (Alpha) - bug affects a prominent app on the KDE live image, so cannot be fully fixed with an update, fix does not touch glibc so possible negative impact should be restricted (adamw, 17:09:12)

  10. (1363914) [abrt] qupzilla: base::debug::BreakDebugger(): qupzilla killed by SIGABRT (adamw, 17:09:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1363914 (adamw, 17:09:55)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 17:09:55)
    3. re-visiting this bug to consider Alpha FE (adamw, 17:10:00)
    4. AGREED: 1363914 - AcceptedFreezeException (Alpha) - bug affects a prominent app on the KDE live image, so cannot be fully fixed with an update, fix does not touch glibc so possible negative impact should be restricted (adamw, 17:11:21)

  11. (1366023) digikam has broken dependencies (adamw, 17:11:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1366023 (adamw, 17:11:55)
    2. Proposed Freeze Exceptions, digikam, MODIFIED (adamw, 17:11:55)
    3. this was accidentally proposed as a Beta FE but was meant to be proposed for Alpha, will fix (adamw, 17:12:08)
    4. AGREED: 1366023 - AcceptedFreezeException (Alpha) - we confirmed this does not actually affect the KDE live image, but we're still OK granting a freeze exception to fix the broken dependencies in the 'stable' repository (adamw, 17:22:39)

  12. (1365661) Cloud images fail to compose from 20160809.n.0 (adamw, 17:23:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1365661 (adamw, 17:23:12)
    2. Accepted Blocker, distribution, NEW (adamw, 17:23:12)
    3. the whole Rawhide and F25 compose process has been failing for the last few days, so we have little concrete info here; first we will try to get an F25 compose completed at all, then move on from there (adamw, 17:30:23)

  13. (1352680) efibootmgr calls in anaconda crashing since efivar-0.24-1.fc25 landed (adamw, 17:30:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1352680 (adamw, 17:30:47)
    2. Accepted Blocker, efibootmgr, NEW (adamw, 17:30:47)
    3. pjones is in the middle of working on this, update should be coming soon (adamw, 17:34:39)

  14. (1324623) glibc: split libcrypt into separate package and package libcrypt-nss with NSS-based implementation (adamw, 17:35:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1324623 (adamw, 17:35:16)
    2. Accepted Blocker, glibc, ASSIGNED (adamw, 17:35:16)
    3. https://kojipkgs.fedoraproject.org//work/tasks/6208/15226208/root.log is the one I was looking at. (nirik, 17:54:37)
    4. we are still investigating this and deciding on the best fix. there are open questions about yum's behaviour and what dependency is triggering this. various folks are looking into it (adamw, 17:57:41)

  15. (1353054) FreeIPA server deployment fails due to pki-core dangling symlinks (one from non-installed 'scannotation' package, one formerly in resteasy-jaxrs-api but now lost) (adamw, 17:57:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1353054 (adamw, 17:57:54)
    2. Accepted Blocker, pki-core, ON_QA (adamw, 17:57:54)
    3. this is fixed and fix has been tested by adamw, will be pushed stable soon (adamw, 17:59:18)

  16. Open floor (adamw, 17:59:21)


Meeting ended at 18:02:07 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (199)
  2. dgilmore (38)
  3. kparal (36)
  4. jkurik (25)
  5. nirik (19)
  6. cmurf (19)
  7. pwhalen (16)
  8. lupinix (15)
  9. jsmith (12)
  10. coremodule (11)
  11. pschindl (8)
  12. rdieter_work (7)
  13. zodbot (7)
  14. sgallagh (5)
  15. brunowolff (4)


Generated by MeetBot 0.1.4.