#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 16:00:34 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:34)
    1. pschindl will secretarialize (adamw, 16:06:43)
    2. coremodule will refill adamw's drink (adamw, 16:08:18)

  2. Introduction (adamw, 16:08:39)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:08:40)
    2. We'll be following the process outlined at: (adamw, 16:08:40)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:08:40)
    4. The bugs up for review today are available at: (adamw, 16:08:41)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:43)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:45)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 16:08:47)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 16:08:51)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 16:08:53)
    10. 3 Proposed Blockers (adamw, 16:09:07)
    11. 3 Accepted Blockers (adamw, 16:09:08)
    12. 6 Proposed Blockers (adamw, 16:09:26)

  3. (1379865) Current Fedora 25 and Rawhide cannot detect Intel firmware RAID set (adamw, 16:12:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1379865 (adamw, 16:12:31)
    2. Proposed Blocker, libblockdev, POST (adamw, 16:12:31)
    3. AGREED: 1379865 - AcceptedBlocker - violates Beta criterion "The installer must be able to detect and install to hardware or firmware RAID storage devices." (adamw, 16:16:39)

  4. (1377113) [selinux-policy] media inserted into by optical drive do not get auto-mounted (adamw, 16:16:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1377113 (adamw, 16:16:48)
    2. Proposed Blocker, selinux-policy, POST (adamw, 16:16:48)
    3. AGREED: 1377113 - AcceptedBlocker (Beta) - violates Beta criterion "Automatic mounting of removable media on insertion must work in release-blocking desktops." (adamw, 16:21:37)

  5. (1381045) xorg-x11-drv-qxl update lets sddm coredump (adamw, 16:21:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1381045 (adamw, 16:21:47)
    2. Proposed Blocker, xorg-x11-drv-qxl, NEW (adamw, 16:21:48)
    3. AGREED: 1381045 - Accepted0Day (Beta) - the affected package is in updates-testing, so the Beta compose is not affected, but Beta installs will break on first update. So we accept this as a 0-day blocker, meaning (for Beta) a fixed package must be added to the update or the update must be unpushed, by go/no-go day (adamw, 16:36:10)
    4. Moving to Beta accepted blockers: not reviewing blocker status but checking that fix is in progress (adamw, 16:36:46)

  6. (1369786) Autopart fails on installation from live usb created by l-i-t-d (adamw, 16:36:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1369786 (adamw, 16:36:53)
    2. Accepted Blocker, anaconda, POST (adamw, 16:36:53)

  7. (1374864) initial-setup is not completable when there's no network link (adamw, 16:53:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1374864 (adamw, 16:53:48)
    2. Accepted Blocker, anaconda, POST (adamw, 16:53:49)
    3. a proposed fix for this is under review, we have asked dgilmore to check status with current nightlies and test proposed fix if possible (adamw, 16:56:21)

  8. (1225184) Live installer does not detect RAID devices (adamw, 16:56:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1225184 (adamw, 16:56:27)
    2. Accepted Blocker, python-blivet, VERIFIED (adamw, 16:56:28)
    3. the fix for this has been tested, only needs a new anaconda build (adamw, 16:59:38)
    4. moving to proposed Final blockers (adamw, 17:01:21)

  9. (1378156) TypeError: Must be number, not str (adamw, 17:01:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1378156 (adamw, 17:01:35)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:01:35)
    3. https://openqa.fedoraproject.org/tests/38358/file/disk_custom_iscsi-anaconda.log (adamw, 17:02:50)
    4. AGREED: 1378156 - AcceptedBlocker (Final) - violates "The installer must be able to detect (if possible) and install to supported network-attached storage devices." (adamw, 17:05:41)

  10. (1379459) Fedora 25 official backgrounds not yet present in images / installed systems (adamw, 17:05:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1379459 (adamw, 17:05:48)
    2. Proposed Blocker, desktop-backgrounds, ON_QA (adamw, 17:05:49)
    3. AGREED: 1379459 - AcceptedBlocker (Final) - violates "The proposed final Fedora artwork must be included and used as the background on release-blocking desktops. All Fedora artwork visible in critical path actions on release-blocking desktops must be consistent with the proposed final theme." (adamw, 17:09:58)

  11. (1381039) USB devices aren't found or enumerated, results in boot failure from USB stick installation media (adamw, 17:10:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1381039 (adamw, 17:10:08)
    2. Proposed Blocker, kernel, NEW (adamw, 17:10:08)
    3. AGREED: 1381039 - RejectedBlocker - so far we only know of a single affected system, and it's not a regression; this isn't a broad enough impact for a hardware-specific bug to be counted as a violation of the criteria. this decision can be revisited if more systems are found to be affected (adamw, 17:20:33)

  12. (1380859) Should obsolete liveusb-creator (adamw, 17:20:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1380859 (adamw, 17:20:44)
    2. Proposed Blocker, mediawriter, NEW (adamw, 17:20:44)
    3. AGREED: 1380859 - RejectedBlocker (Final) - we don't think adding this Obsoletes: specifically would really resolve anything that could be described as a 'criteria violation'. however, we discussed some other cases which may be more suitable and will propose new blockers (adamw, 17:37:37)

  13. (1379800) systemd does not create new machine-id file if none is present (adamw, 17:37:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1379800 (adamw, 17:37:57)
    2. Proposed Blocker, systemd, NEW (adamw, 17:37:57)
    3. AGREED: 1379800 - RejectedBlocker (Final) - this would be a blocker, but it has been worked around in fedora-kickstarts by ensuring the images contain an empty file, so we do not actually need to block on it so long as that works (adamw, 17:53:39)

  14. (1381327) LUC is presented as FMW in gnome-software (adamw, 17:54:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1381327 (adamw, 17:54:45)
    2. Proposed Blocker, liveusb-creator, NEW (adamw, 17:54:54)
    3. AGREED: 1381327 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods", as we think we can live with the confusion for Beta but it's not acceptable for Final (adamw, 17:59:03)

  15. (1379311) 15Gigs root partition maxSize not customisable in anaconda kickstart script (adamw, 18:01:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1379311 (adamw, 18:01:12)
    2. Proposed Blocker (Beta), anaconda, NEW (adamw, 18:01:35)
    3. AGREED: 1379311 - RejectedBlocker (Beta) - so far as we can determine there is not even a bug here, let alone a blocker. It is just the intended behaviour: if you specify autopart in your kickstart, the exact result will differ between Fedora flavors. (adamw, 18:08:57)

  16. Open floor (adamw, 18:10:07)


Meeting ended at 18:21:01 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (247)
  2. cmurf (73)
  3. kparal (72)
  4. sgallagh (35)
  5. jkurik (32)
  6. coremodule (25)
  7. dgilmore (20)
  8. pwhalen (17)
  9. pschindl (15)
  10. zodbot (9)
  11. RaphGro (6)
  12. jforbes (5)
  13. nb (3)
  14. garretraziel (2)
  15. kushal (1)
  16. pwhalen_ (1)


Generated by MeetBot 0.1.4.