#fedora-blocker-review: F25-blocker-review

Meeting started by adamw at 17:01:59 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:02:00)
  2. Introduction (adamw, 17:08:14)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:08:14)
    2. We'll be following the process outlined at: (adamw, 17:08:14)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:08:16)
    4. The bugs up for review today are available at: (adamw, 17:08:16)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:08:18)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:08:20)
    7. https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria (adamw, 17:08:21)
    8. https://fedoraproject.org/wiki/Fedora_25_Beta_Release_Criteria (adamw, 17:08:23)
    9. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria (adamw, 17:08:27)
    10. 7 Proposed Blockers (adamw, 17:08:31)
    11. 3 Accepted Blockers (adamw, 17:08:33)
    12. 10 Proposed Freeze Exceptions (adamw, 17:08:35)
    13. 8 Accepted Freeze Exceptions (adamw, 17:08:37)
    14. coremodule will be the great and powerful secretary (adamw, 17:09:45)

  3. (1370073) [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by SIGTRAP (adamw, 17:10:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370073 (adamw, 17:10:06)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 17:10:06)
    3. this is a tricky one and people are going to go run some bare metal installs and see if they hit it, we'll circle back (adamw, 17:19:07)

  4. (1390610) LibreOffice Impress crashes when you move slide pane into a separate window on Wayland (adamw, 17:21:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1390610 (adamw, 17:21:10)
    2. Proposed Blocker, libreoffice, VERIFIED (adamw, 17:21:10)
    3. AGREED: 1390610 - delay blocker decision, AcceptedFreezeException - there's some disagreement about whether this is serious enough to merit blocker status, but as there's already a tested fix, we'll simply grant it FE status and move on (adamw, 17:32:37)

  5. (1390607) LibreOffice Impress (and stripped down native gtk demo) doesn't run presentation correctly on Wayland (adamw, 17:32:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1390607 (adamw, 17:32:47)
    2. Proposed Blocker, mutter, NEW (adamw, 17:32:47)
    3. AGREED: 1390607 - AcceptedBlocker (Final) - this use of Impress is so common that we consider it to be part of 'basic functionality', it's pretty much how everyone gives presentations, so this violates "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." (adamw, 17:45:08)

  6. (1389130) Existing RAID or LVM metadata can cause various types of install failures. (adamw, 17:45:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1389130 (adamw, 17:45:17)
    2. Proposed Blocker, python-blivet, POST (adamw, 17:45:17)
    3. AGREED: 1389130 - AcceptedBlocker (Final) - this is a violation of Beta criterion "When using the custom partitioning flow, the installer must be able to: Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions" (adamw, 18:00:55)

  7. (1390027) Anaconda should tell the user it is running fsck, possibly allow to skip (adamw, 18:01:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1390027 (adamw, 18:01:53)
    2. Proposed Blocker, python-blivet, NEW (adamw, 18:01:53)
    3. AGREED: 1390027 - RejectedBlocker (Final), RejectedFreezeException (Final) - this has in fact been broken since Fedora 21, and was rejected as a blocker for Fedora 22. Though we note it causes e2fsck to perform 'safe' fixes on non-selected filesystems, as well as taking a long time if large ext2/3/4 filesystems are present, we don't see sufficient reason to change that decision or change this as an FE at this time (adamw, 18:50:21)

  8. (1350054) Refuses to let systemd fix label of /dev/shm/lldpad.state on boot (adamw, 18:50:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1350054 (adamw, 18:50:48)
    2. Proposed Blocker, selinux-policy, ON_QA (adamw, 18:50:48)
    3. AGREED: 1350054 - AcceptedFreezeException (Final), delay blocker decision - there's some disagreement about whether this is consistently-encountered enough to qualify as a blocker; as there's a fix we accept it as a freeze exception and delay the blocker decision in the expectation it will be fixed and we won't have to make a decision (adamw, 19:13:10)

  9. (1391522) unknown input device type 'virtio1.0-input' (adamw, 19:13:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1391522 (adamw, 19:13:25)
    2. Proposed Blocker, virt-manager, VERIFIED (adamw, 19:13:25)
    3. AGREED: 1391522 - AcceptedBlocker (Final) - this is a violation of "The release must be able host virtual guest instances of the same release" in the case of using virt-manager, which is one of the two prime front ends for the 'Fedora virt stack' (adamw, 19:19:12)

  10. (1370073) [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by SIGTRAP (adamw, 19:20:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1370073 (adamw, 19:20:35)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 19:20:35)
    3. moving to proposed freeze exceptions (adamw, 19:40:04)

  11. (1335046) TypeError: Argument 0 does not allow None as a value (adamw, 19:40:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1335046 (adamw, 19:40:05)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 19:40:05)
    3. AGREED: 1335046 - AcceptedFreezeException (Final) - this fixes a significant issue for s390x users and the fix is limited to s390-specific code so cannot affect primary arches (adamw, 19:43:36)

  12. (1390617) Pandaboard (omap4) fails to boot from mmc. (adamw, 19:43:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1390617 (adamw, 19:43:44)
    2. Proposed Freeze Exceptions, kernel, ON_QA (adamw, 19:43:44)
    3. https://fedoraproject.org/wiki/Fedora_25_Final_Release_Criteria#Security_bugs (cmurf, 19:51:17)
    4. AGREED: 1390617 - AcceptedFreezeException (Final) - this is a significant issue on a supported ARM platform that cannot be fixed with an update, clearly worth a freeze exception (adamw, 19:57:47)

  13. (1390937) mem region issue with aarch64 NUMA host (and potentially other devices) (adamw, 19:57:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1390937 (adamw, 19:57:58)
    2. Proposed Freeze Exceptions, kernel, ON_QA (adamw, 19:57:59)
    3. AGREED: 1390937 - AcceptedFreezeException (Final) - installer crashing on non-primary arch is a clear justification for a freeze exception (adamw, 20:04:24)

  14. (1385836) [abrt] LabPlot: QApplication::notify(): labplot2 killed by SIGSEGV (adamw, 20:04:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1385836 (adamw, 20:04:28)
    2. Proposed Freeze Exceptions, LabPlot, ON_QA (adamw, 20:04:28)
    3. https://kojipkgs.fedoraproject.org/compose/branched/Fedora-25-20161107.n.0/compose/Labs/x86_64/iso/ (adamw, 20:08:55)
    4. AGREED: 1385836 - AcceptedFreezeException (Final) - this is a crasher bug in a default application on non-blocking media (Astronomy and Electronics Lab), so that qualifies it as a freeze exception issue (adamw, 20:11:26)

  15. (1392203) mariadb permissions don't allow access to /var/lib/mysql (adamw, 20:11:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1392203 (adamw, 20:11:31)
    2. Proposed Freeze Exceptions, mariadb, NEW (adamw, 20:11:31)
    3. AGREED: 1392203 - AcceptedFreezeException (Final) - mariadb is obviously a major component for many Fedora installs and should definitely work out of the box (adamw, 20:14:02)

  16. (1391183) [abrt] mediawriter: pushbuf_kref(): mediawriter killed by SIGSEGV (adamw, 20:14:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1391183 (adamw, 20:14:12)
    2. Proposed Freeze Exceptions, mediawriter, POST (adamw, 20:14:12)
    3. AGREED: 1391183 - AcceptedFreezeException (Final) - mediawriter is the primary USB writing tool for F25, so obviously we should avoid known crasher bugs in it (adamw, 20:16:33)

  17. (1391212) Service fails if no switchable graphics present (adamw, 20:16:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1391212 (adamw, 20:16:43)
    2. Proposed Freeze Exceptions, switcheroo-control, ON_QA (adamw, 20:16:43)
    3. AGREED: 1391212 - AcceptedFreezeException (Final) - avoiding failed services on every live boot and initial install is clearly worth doing (adamw, 20:18:12)

  18. (1391932) [skopeo][ FTBFS due golang deficiency on ppc64 (adamw, 20:18:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1391932 (adamw, 20:18:25)
    2. Proposed Freeze Exceptions, skopeo, ON_QA (adamw, 20:18:26)
    3. AGREED: 13191932 - punt (delay decision) - this seems potentially worth fixing, but the current builds look a bit off, so we are going to ask for some details in the bug before deciding on this (adamw, 20:24:40)

  19. Open floor (adamw, 20:24:48)


Meeting ended at 20:30:06 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (324)
  2. cmurf (155)
  3. sgallagh (116)
  4. kparal (90)
  5. jkurik (21)
  6. garretraziel (20)
  7. pschindl (16)
  8. zodbot (13)
  9. jforbes (11)
  10. dgilmore (9)
  11. coremodule (7)
  12. mclasen_ (3)
  13. mboddu (2)
  14. Southern_Gentlem (2)
  15. satellit (2)
  16. RaphGro (2)
  17. rtcm (1)
  18. dowdle (1)
  19. Kevin_Kofler (1)


Generated by MeetBot 0.1.4.