17:02:37 <adamw> #startmeeting F26-blocker-review
17:02:37 <zodbot> Meeting started Mon Mar  6 17:02:37 2017 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:37 <zodbot> The meeting name has been set to 'f26-blocker-review'
17:02:39 <adamw> #meetingname F26-blocker-review
17:02:39 <zodbot> The meeting name has been set to 'f26-blocker-review'
17:02:41 <adamw> #topic Roll Call
17:02:47 * roshi is here
17:02:51 * garretraziel is here
17:02:53 * coremodule is here.
17:02:57 <adamw> who's around for blocker review fun?
17:03:29 * satellit listening
17:03:31 * pwhalen is here
17:03:43 * kparal is here
17:03:57 <sgallagh> .hello sgallagh
17:03:58 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:04:52 <adamw> morning folks
17:05:10 <adamw> #chair sgallagh coremodule
17:05:10 <zodbot> Current chairs: adamw coremodule sgallagh
17:05:15 <adamw> #topic Introduction
17:05:15 <adamw> Why are we here?
17:05:15 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:05:15 <adamw> #info We'll be following the process outlined at:
17:05:15 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:05:17 <adamw> #info The bugs up for review today are available at:
17:05:21 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
17:05:23 <adamw> #info The criteria for release blocking bugs can be found at:
17:05:25 <adamw> #link https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria
17:05:27 <adamw> #link https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria
17:05:29 <adamw> #link https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria
17:05:31 <adamw> we have:
17:05:33 <adamw> #info 2 Proposed Blockers (Alpha)
17:05:38 <adamw> #info 2 Proposed Freeze Exceptions (Alpha)
17:05:50 <adamw> #info 3 Proposed Blockers (Final)
17:05:56 <adamw> who wants to secretarialize?
17:06:16 * coremodule will do it!
17:06:32 <adamw> #info coremodule will secretarialize
17:06:37 <sgallagh> #info Fedora 26 will enter Alpha Freeze at midnight UTC
17:06:41 <adamw> thanks sgallagh
17:06:47 <adamw> so, starting in with Alpha proposed blockers...\
17:06:54 <adamw> #topic (1429132) blivet.safe_dbus.DBusCallError: Failed to call Introspect method on /org/freedesktop/UDisks2/Manager with None arguments: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UDisks2 was not provided by any .service files
17:06:54 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1429132
17:06:54 <adamw> #info Proposed Blocker, anaconda, NEW
17:08:45 <garretraziel> hm, is it confirmed that this is happening with other spins than LXQt?
17:08:55 <sgallagh> That looks like someone probably forgot to include storaged in the manifest for the LXQt spin
17:08:56 <roshi> that's my question
17:09:05 <adamw> yeah
17:09:05 <roshi> -1 if it's not hitting a blocking DE
17:09:10 <adamw> since we're not actually seeing this on other spins
17:09:22 <adamw> KDE live install passes in openQA for e.g.
17:10:17 <sgallagh> -1 Blocker, +1 FE
17:10:23 <Kohane> Hello
17:10:31 <Kohane> .fas lailah
17:10:34 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
17:10:40 <sgallagh> If I'm right about the cause, accepting it through freeze should be harmless
17:10:43 <adamw> hi kohane, morning
17:10:45 <adamw> sgallagh: yeah, i think so
17:10:46 <roshi> -1 blocker +1 FE
17:10:59 <kparal> -1/+1
17:11:10 <Kohane> hi adamw  afternoon :-P
17:11:30 <pwhalen> -1/+1
17:11:33 <garretraziel> -1/+1
17:11:43 <adamw> proposed #agreed 1429132 - RejectedBlocker AcceptedFreezeException (Alpha) - we suspect this is a missing package on the lxqt spin, which is non-blocking, so not a blocker - but if that's the cause, we approve a freeze exception to add the missing package to the spin
17:11:48 <pwhalen> ack
17:11:50 <roshi> ack
17:11:52 <Kohane> ack
17:12:01 <sgallagh> ack
17:12:05 <kparal> ack
17:12:48 <adamw> #agreed 1429132 - RejectedBlocker AcceptedFreezeException (Alpha) - we suspect this is a missing package on the lxqt spin, which is non-blocking, so not a blocker - but if that's the cause, we approve a freeze exception to add the missing package to the spin
17:13:10 <adamw> #topic (1426850) Re-enable ARMv7 builds on all releases
17:13:10 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1426850
17:13:10 <adamw> #info Proposed Blocker, firefox, ASSIGNED
17:14:26 <roshi> looks like this is fixed?
17:14:35 <adamw> yeah
17:14:36 <kparal> what's armv7? is that different from armhfp?
17:14:39 <adamw> since bodhi isn't enabled yet
17:14:40 <adamw> kparal: same
17:14:48 <kparal> ok, so primary arch
17:15:05 <adamw> yeah
17:15:19 <adamw> so i'd be +1, but i think in fact we can just close
17:15:32 <adamw> pwhalen: is there anything left on this one?
17:15:57 <pwhalen> nope, its fixed, I'll close it now.
17:16:22 <adamw> rgrt
17:16:33 <adamw> #info this bug has now been fixed, pwhalen will close it
17:16:45 <adamw> alrighty, let's do Alpha freeze exceptions next
17:16:50 <adamw> #info moving onto Alpha freeze exceptions
17:16:57 <adamw> #topic (1426796) Regression: kernel doesn't boot on qemu on either ppc64 or ppc64le
17:16:57 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1426796
17:16:57 <adamw> #info Proposed Freeze Exceptions, kernel, NEW
17:17:16 <adamw> this one was proposed as a blocker, but it clearly can't be a blocker, so i moved it.
17:17:22 <sgallagh_> Sorry folks. Laptop crashed and isn't coming back...
17:17:40 * sgallagh_ tries to follow along from mobile
17:17:49 <Kohane> Yeah, I don't see it as blocker really.
17:17:53 <adamw> sounds like an FE, though.
17:18:03 <roshi> +1 FE
17:18:13 <kparal> +1
17:18:20 <garretraziel> +1 fe
17:18:27 <Kohane> +1 FE
17:18:50 <pwhalen> +1 FE
17:19:19 <adamw> proposed #agreed 1426796 - AcceptedFreezeException (Alpha) - this is clearly a severe issue and would be a blocker for a blocking arch, so accepted as an FE for non-blocking ppc64(le) arches
17:19:26 <kparal> ack
17:19:28 <roshi> ack
17:19:33 <Kohane> ack
17:19:46 <sgallagh_> ack
17:20:06 <pwhalen> ack
17:20:29 <adamw> #agreed 1426796 - AcceptedFreezeException (Alpha) - this is clearly a severe issue and would be a blocker for a blocking arch, so accepted as an FE for non-blocking ppc64(le) arches
17:20:35 <adamw> #topic (1419980) SELinux is preventing abrt-dump-journ from 'execute' accesses on the file /usr/bin/lz4.
17:20:36 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1419980
17:20:36 <adamw> #info Proposed Freeze Exceptions, selinux-policy, ON_QA
17:21:35 <adamw> i'd be +1 on this, sounds like it may already be fixed but we should get confirmation
17:21:53 <adamw> neither stickster nor mcatanzaro is here
17:22:01 <adamw> mclasen: any idea if this is working yet?
17:22:51 <roshi> +1 if it's not fixed already
17:23:02 <Kohane> Yes, me too
17:23:12 <pwhalen> selinux-policy builds have been failing
17:23:47 <garretraziel> +1
17:23:58 <Kohane> +1
17:24:15 <adamw> the build that was linked to went through and was tagged, though
17:24:34 <adamw> let's just accept it for now, coremodule, can you then add a comment asking mcatanzaro if it's working now and needinfo him?
17:24:35 <pwhalen> ah, k
17:24:44 <pwhalen> +1
17:24:51 <Kohane> Yes, but it doesn't seem to have a fix at sight....
17:25:06 <adamw> proposed #agreed 1419980 - AcceptedFreezeException (Alpha) - this prevents a significant accepted Change from working in the Workstation live environment
17:25:21 <mclasen> adamw: stickster is sitting next to me in this meeting, but I don't think either of us knows the asnwer
17:25:22 <adamw> Kohane: #c6 claims it is already fixed.
17:25:35 <adamw> mclasen: ah, ok :) no problem, we can accept it for now and check later
17:25:41 <roshi> ack
17:25:52 <garretraziel> ack
17:25:53 <pwhalen> ack
17:25:59 <Kohane> ack
17:26:04 <adamw> #agreed 1419980 - AcceptedFreezeException (Alpha) - this prevents a significant accepted Change from working in the Workstation live environment
17:26:22 <adamw> #info moving on to proposed Final blockers
17:26:34 <adamw> #topic (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after
17:26:34 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1405539
17:26:34 <adamw> #info Proposed Blocker, plymouth, NEW
17:26:36 <adamw> ...aaaaand we're back here
17:26:38 <sgallagh> /me has recovered his laptop and is back
17:26:41 <pwhalen> :)
17:26:44 <sgallagh> ...
17:26:47 <adamw> kohane didn't have a chance to ask the g11n folks for input yet, i think
17:26:54 <roshi> yeah
17:26:54 <adamw> but she's going to do it soon
17:26:56 <sgallagh> Hasn't this been an issue since... grub2?
17:26:57 <roshi> that's what the email said
17:27:02 <Kohane> No, I did. I'm waiting for a reply.
17:27:40 <Kohane> adamw: I already sent an email to g11n I'm waiting for a reply.
17:27:58 <kparal> sgallagh: well, that depends. it has been really easy to hit since gnome ui changed two releases back or so
17:28:04 <adamw> ah, great
17:28:16 <adamw> #info we have asked g11n teams for their thoughts on this and are waiting for feedback
17:28:17 <kparal> but I assume it was a problem even before that. just not that likely to hit
17:31:29 <adamw> so i'm feeling punty on this one again, since we're waiting on feedback
17:31:36 <adamw> at some point we'll have to decide something though..
17:32:07 <Kohane> Well...  let's wait one last week. If nothing comes up we decide on our own.
17:32:31 <adamw> fair enough
17:32:33 <adamw> anyone else?
17:32:48 <garretraziel> +1 for punt
17:32:50 <roshi> punt
17:32:53 <pwhalen> punt!
17:33:06 <sgallagh> I'm okay to punt
17:33:07 <Kohane> +1 for punt
17:33:11 <kparal> špunt
17:33:34 <garretraziel> puňť
17:33:48 <kparal> (don't mind us)
17:34:32 <garretraziel> we got a bigger alphabet!
17:34:36 <Kohane> kparal garretraziel  those are really cool punts  ^_^
17:34:48 <Kohane> Oh, yeah!
17:34:59 <adamw> proposed #agreed 1405539 - ƥüňť - we still don't have any additional info here, we'll wait one more week for thoughts from g11n folks before making up our minds
17:35:19 <kparal> garretraziel: just wait until we have a chinese person on the meeting
17:35:24 <garretraziel> áčk
17:35:35 <sgallagh> ack
17:35:44 <Kohane> ack
17:35:55 <kparal> äck
17:36:12 <adamw> kparal: それと日本人?
17:36:34 <garretraziel> (we don't actually have umlauts in our alphabet)
17:36:51 <kparal> adamw: does it mean "I have no idea what I'm doing"?
17:36:55 <adamw> garretraziel: the p comes from an african language, apparently :P
17:36:58 <adamw> #agreed 1405539 - ƥüňť - we still don't have any additional info here, we'll wait one more week for thoughts from g11n folks before making up our minds
17:37:07 <adamw> kparal: it means "or a Japanese person?"
17:37:19 <adamw> (more or less)
17:37:42 <adamw> (you can ask google if i screwed up :P or tflink)
17:37:55 <Kohane> I still can't read the Japanese ideograms...  :-/
17:38:18 <adamw> anyhow, enough of this tomfoolery!
17:38:18 <adamw> #topic (1411360) SELinux is preventing (ostnamed) from 'mounton' accesses on the file /proc/mtrr.
17:38:18 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1411360
17:38:19 <adamw> #info Proposed Blocker, selinux-policy, ASSIGNED
17:38:31 <adamw> this is the AVC everyone's running into all the time
17:39:08 <kparal> let's outlaw it
17:39:41 <adamw> ah, so sgallagh doesn't think this is what was hanging his gnome session
17:40:01 <adamw> so, i'm +1 final blocker, +1 alpha FE, I think
17:40:13 <kparal> sounds good
17:40:43 <Kohane> Yes, that's fine
17:40:43 <roshi> +1/+1 Alpha FE for me as well
17:40:48 <sgallagh> right, it was just one of several that were showing up that I gave the same description
17:40:55 <sgallagh> Some of the others were fixed.
17:42:43 <sgallagh> +1 final blocker, +1 alpha FE
17:42:46 <adamw> proposed #agreed 1411360 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - this clearly violates "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop", and is sufficiently annoying and widespread to also be an Alpha freeze exception
17:42:56 <kparal> ack
17:42:58 <roshi> ack
17:42:59 <Kohane> ack
17:43:54 <garretraziel> ack
17:43:55 <pschindl_wfh> ack
17:44:03 <adamw> #agreed 1411360 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - this clearly violates "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop", and is sufficiently annoying and widespread to also be an Alpha freeze exception
17:44:08 <adamw> #topic (1427392) SELinux is preventing (-localed) from mounton access on the file /proc/mtrr.
17:44:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1427392
17:44:09 <adamw> #info Proposed Blocker, selinux-policy, NEW
17:44:19 <adamw> this one looks pretty similar, but it's a different thing requesting the permission...
17:44:27 <Kohane> Yet another with Selinux?
17:45:05 <adamw> it's pretty normal
17:45:05 <roshi> +1
17:45:22 <adamw> with every release, selinux policy is tightened some, and we have to find the places where it gets over-tightened
17:45:28 <adamw> also, other things change their behaviour
17:45:41 <Kohane> yes, I see
17:45:41 <kparal> +1
17:45:45 <Kohane> +1
17:45:53 <adamw> it's not really practical to have everyone figure out ahead of time exactly what selinux policy is going to be needed for every facet of every process, it's easier just to put it out there and figure it out in the wild :P
17:46:12 <pwhalen> +1
17:46:14 <adamw> this could wind up being a dupe, but no harm keeping it separate for now, and if it does happen on each install, +1 .
17:46:16 <pschindl_wfh> +1
17:46:20 <Kohane> adamw: LOL
17:47:01 <adamw> do we want to make it FE for Alpha too?
17:47:04 <adamw> i'm ok with that
17:47:09 <roshi> I am as well
17:47:26 <pwhalen> +1 for alpha
17:47:38 <Kohane> Yeah, +1 for alpha too
17:48:31 <adamw> proposed #agreed 1427392 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - as per #1411360 this is a clear violation of the 'no AVCs during install / first boot' criterion, and is worth fixing in Alpha too due to visibility
17:48:37 <roshi> ack
17:48:43 <Kohane> ack
17:48:46 <garretraziel> ack
17:49:33 <pwhalen> ack
17:49:46 <kparal> ack
17:50:16 <adamw> #agreed 1427392 - AcceptedBlocker (Final) AcceptedFreezeException (Alpha) - as per #1411360 this is a clear violation of the 'no AVCs during install / first boot' criterion, and is worth fixing in Alpha too due to visibility
17:50:39 <adamw> OK, we still have lots of time and we're getting closer to Alpha release, so let's check in on the accepted blockers
17:51:00 <Kohane> okay
17:51:06 <adamw> as a quick reminder, in this part of the meeting we are no longer voting +1/-1 - these bugs are already accepted - but checking that it looks like things are progressing smoothly to a fix
17:51:13 <adamw> #info moving on to a review of accepted Alpha blockers
17:51:16 <adamw> #topic (1420520) All ARM disk image composes fail in Rawhide
17:51:16 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1420520
17:51:16 <adamw> #info Accepted Blocker, distribution, NEW
17:51:35 <adamw> so i closed this last week as ARM disk images had started showing up again since it was filed, but pwhalen has since reopened it as apparently they stopped again
17:51:36 <pwhalen> sadly, this seems to be back
17:51:41 <adamw> nirik: any idea what's going on here?
17:52:09 <nirik> might be pungi version differences.
17:52:31 <nirik> IMHO there was a new upstream pungi release today and I think we should update both rawhide/branched composes to use that one
17:52:53 <adamw> #info this seemed to be resolved for a few weeks, but disk images have once again stopped appearing for F26 since branching
17:53:06 <adamw> #info nirik believes a new pungi version may help
17:53:07 <pwhalen> rawhide images worked, the f26 task werent even attempted
17:53:10 <nirik> well, hum, nothing would have changed on the composer tho
17:53:12 <pwhalen> (in koji)
17:53:19 <nirik> were there ever f26 ones?
17:53:35 <pwhalen> 0228 was the last
17:53:35 <nirik> (after branch )
17:53:40 <pwhalen> no, branch then nothing
17:53:51 <nirik> ok, then yeah, my pungi version theory seems possible
17:54:25 <nirik> they claim the same version tho. ;(
17:54:35 <adamw> nirik: can we say you're gonna look into this one?
17:55:00 <nirik> sure, in my copious spare time. ;)
17:55:11 <adamw> well, 'you' as in releng
17:55:16 <nirik> sure.
17:55:55 <adamw> #info releng is looking into this one, we'll check back next week
17:56:03 <adamw> #topic (1410523) gi.overrides.BlockDev.LVMError: Failed to call the 'LvCreate' method on the '/com/redhat/lvmdbus1/Vg/1' object: GDBus.Error:org.freedesktop.DBus.Python.dbus.exceptions.DBusException: ('com.redhat.lvmdbus1.Vg', "Exit code 3, stderr =   --size may not ...
17:56:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1410523
17:56:03 <adamw> #info Accepted Blocker, python-blivet, NEW
17:58:12 <adamw> so sbueno changed assignee on this recently
17:59:14 <adamw> that's about all that's happened, though
17:59:19 <adamw> i can take an action to check in with anaconda team
17:59:25 <adamw> #action adamw to check with anaconda folks that this is in hand
18:00:31 <adamw> and finally...
18:00:32 <adamw> #topic (1422634) selinux prevents kernel modules from loading
18:00:32 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1422634
18:00:33 <adamw> #info Accepted Blocker, selinux-policy, ON_QA
18:00:58 <pwhalen> waiting for a successful build
18:01:16 <adamw> it should be MODIFIED or POST not ON_QA, then...will adjust
18:02:03 <adamw> #info this is expected to be fixed in the next selinux-policy build, but builds have been failing; SELinux team is working on getting a successful build
18:02:12 <adamw> i think that's the lot
18:02:18 <adamw> any other bugs that should be discussed?
18:02:47 * roshi doesn't have anything
18:02:55 * pwhalen has nothing else.
18:03:06 * Kohane has nothing
18:03:07 <adamw> #topic Open floor
18:03:12 <adamw> any other f26-ish business?
18:03:41 <Kohane> Not that I can remember but I'm maybe wrong....
18:04:15 <kparal> nothing from me
18:04:43 <adamw> alrighty
18:04:46 <adamw> thanks a lot for coming, folks
18:05:33 <Kohane> you're welcome, see you next week
18:05:34 * adamw sets the fuse
18:05:55 <pwhalen> thanks adamw!
18:06:44 <adamw> #endmeeting