16:07:09 <roshi> #startmeeting F26-blocker-review
16:07:09 <zodbot> Meeting started Mon Mar 13 16:07:09 2017 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:07:09 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:07:09 <roshi> #meetingname F26-blocker-review
16:07:09 <roshi> #topic Roll Call
16:07:09 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:07:10 * pschindl_wfh is here
16:07:16 * roshi had to get a sammich
16:07:18 <adamw> here!
16:07:22 <roshi> or something like a sammich
16:07:25 * kparal is here
16:07:26 <dustymabe> estoy aqui
16:07:40 <dustymabe> roshi: nice
16:07:44 <roshi> who's around for blocker funtimes :)
16:07:55 <Southern_Gentlem> .hello jbwilla
16:07:56 <zodbot> Southern_Gentlem: Sorry, but you don't exist
16:08:02 * pwhalen is here
16:08:05 <adamw> FUN TIMES!
16:08:10 <Southern_Gentlem> .hello jbwillia
16:08:11 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@yahoo.com>
16:08:42 <roshi> #chair adamw Southern_Gentlem pwhalen pschindl_wfh kparal
16:08:42 <zodbot> Current chairs: Southern_Gentlem adamw kparal pschindl_wfh pwhalen roshi
16:08:49 <dustymabe> .hello dustymabe
16:08:50 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
16:08:50 <roshi> #topic Introduction
16:08:51 <roshi> Why are we here?
16:08:51 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:08:54 <roshi> #info We'll be following the process outlined at:
16:08:57 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:08:59 <roshi> #info The bugs up for review today are available at:
16:09:02 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:09:04 <roshi> #info The criteria for release blocking bugs can be found at:
16:09:07 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria
16:09:10 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria
16:09:13 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria
16:09:19 <roshi> so for Alpha, this is what we're looking at:
16:09:21 <roshi> #info 3 Proposed Blockers
16:09:21 <roshi> #info 1 Accepted Blockers
16:09:21 <roshi> #info 0 Accepted 0-day Blockers
16:09:23 <roshi> #info 0 Accepted Previous Release Blockers
16:09:25 <roshi> #info 6 Proposed Freeze Exceptions
16:09:28 <roshi> #info 5 Accepted Freeze Exceptions
16:09:38 <roshi> first up, proposed blockers
16:09:39 <roshi> #topic (1430250) bind-pkcs11 keeps failing to connect to LDAP server during FreeIPA server deployment on current Rawhide
16:09:43 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1430250
16:09:45 <roshi> #info Proposed Blocker, 389-ds, NEW
16:10:54 <adamw> so this clearly prevents deployment of a working FreeIPA server
16:11:41 <adamw> i'd argue that's a violation of "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried", the "brought to a working configuration" part
16:12:10 <adamw> it's worth reading the two relevant criteria at https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria#Role_definition_requirements in full, though...
16:12:17 <adamw> sgallagh: around? got an opinion on this one?
16:12:27 <roshi> +1, from my reading of it
16:12:35 <adamw> the other relevant criterion is "The core functional requirements for all Featured Server Roles must be met, but it is acceptable if moderate workarounds are necessary to achieve this.", and you could argue there's possibly a workaround for this bug (I haven't tested it yet)
16:12:37 <sgallagh> in another concurrent meeting, sorry
16:13:06 <sgallagh> Can we loop back to it? I'll be done in about 10 mins
16:13:18 * roshi is fine with that
16:13:24 <roshi> adamw: ?
16:13:25 <pwhalen> +1
16:13:35 <Southern_Gentlem> +1 delay
16:13:37 <adamw> sure, i guess
16:13:47 <pwhalen> sorry, I was +1 blocker
16:14:28 <roshi> #info will come back around to this later in the meeting
16:14:29 <roshi> #topic (1430043) VMs with virtio-scsi devices often crash during boot with traceback running through scsi code since kernel-4.11.0-0.rc1.git0.1.fc27
16:14:32 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1430043
16:14:34 <roshi> #info Proposed Blocker, kernel, NEW
16:15:47 <adamw> so after digging into this a bit further it's probably not a blocker
16:15:58 <adamw> unless anyone's seen something similar on real hardware or a default vm?
16:17:26 <roshi> seems like -1 to me
16:17:26 <dustymabe> i'm not running f26 as VMs, not as VM hosts, so I haven't seen this
16:17:28 <kparal> looks like not a blocker
16:17:39 * pwhalen hasnt seen it
16:17:43 <dustymabe> grr. i'm only running it as VMs
16:17:52 <dustymabe> so I don't think I would have seen it
16:18:59 <dustymabe> or does this actually affect a VM that is running f26 kernel?
16:19:09 <dustymabe> with a virt-io scsi device from the host?
16:19:16 <roshi> so this is crashes when loaded in virt with a scsi virtio device, right?
16:19:27 <roshi> which isn't the default for virt-manager
16:19:48 <adamw> dustymabe: my best guess so far is it affects F26 running on a VM with a virtio-scsi device
16:19:55 <adamw> roshi: yeah.
16:20:24 <roshi> I haven't seen this with any of the F26 vms I've launched
16:20:30 <roshi> but then again, I don't use scsi
16:20:32 <dustymabe> adamw: ok, i'll spin one up and see if I see an issue
16:20:42 <roshi> -1 blocker, +1 FE
16:21:09 <adamw> -1 / +1
16:21:25 <pwhalen> -1 blocker, +1 FE
16:21:38 <dustymabe> so does that mean, we won't block release on it, but if a fix comes available we'll allow it as an exception?
16:21:42 <roshi> yep
16:21:45 <dustymabe> kk
16:21:45 <roshi> a tested fix
16:22:07 <Southern_Gentlem> -! +1fe
16:22:25 <pschindl_wfh> -1
16:22:29 <pschindl_wfh> +1 fe
16:22:40 <Southern_Gentlem> -1 +1fe
16:23:16 <adamw> as long as it's not too disruptive
16:24:25 <roshi> proposed #agreed - RejectedBlocker AcceptedFreezeException - RHBZ#1430043 - This isn't conisdered serious enough to block release because it only seems to affect VMs booted with a SCSI virtio device and other methods work. We would consider a patch to fix this before release provided it's tested and focused on just this issue.
16:24:57 <pwhalen> ack
16:24:59 <kparal> ack
16:25:02 * roshi needs more coffee, typing too slow
16:25:31 <pschindl_wfh> ack
16:25:33 <roshi> #agreed - RejectedBlocker AcceptedFreezeException - RHBZ#1430043 - This isn't conisdered serious enough to block release because it only seems to affect VMs booted with a SCSI virtio device and other methods work. We would consider a patch to fix this before release provided it's tested and focused on just this issue.
16:25:47 <roshi> #topic (1430406) opendnssec: broken ldns dependency prevents from installing freeipa-server-dns
16:25:50 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1430406
16:25:52 <roshi> #info Proposed Blocker, opendnssec, NEW
16:26:02 <adamw> this one's pretty slam dunk-y
16:26:16 <roshi> yeah
16:26:17 <adamw> +1
16:26:18 <pwhalen> right, +1
16:26:19 <roshi> +1
16:26:23 <Southern_Gentlem> +1
16:27:19 <Southern_Gentlem> +1 +1FE
16:27:30 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1430406 - This is a clear violation of the following Alpha critrion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried."
16:27:55 <adamw> ack
16:28:11 <kparal> ack
16:28:18 <Southern_Gentlem> ack
16:28:18 <roshi> #agreed - AcceptedBlocker - RHBZ#1430406 - This is a clear violation of the following Alpha critrion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried."
16:28:25 <roshi> cmurf: you back for that bug yet?
16:28:44 <Southern_Gentlem> roshi,  i thought it was sgallagh
16:29:03 <cmurf> oops
16:29:10 <cmurf> which bug
16:29:19 <Southern_Gentlem> does block auto grant +FE
16:29:21 <adamw> yeah, it was sgallagh
16:29:24 <roshi> damn autocomplete
16:29:25 <sgallagh> I am back now
16:29:30 <adamw> Southern_Gentlem: being a blocker is 'superior' to being an fe.
16:29:32 <roshi> :P
16:29:50 <Southern_Gentlem> adamw,  so that would be a yes
16:29:53 <adamw> yeah.
16:30:31 <roshi> #topic (1430250) bind-pkcs11 keeps failing to connect to LDAP server during FreeIPA server deployment on current Rawhide
16:30:34 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1430250
16:30:36 <roshi> #info Proposed Blocker, 389-ds, NEW
16:31:41 <adamw> sgallagh: so yeah, just wondered if you had an opinion on whether we should consider this a blocker. i'm probably +1, but open to argument we should be ok with a workaround...
16:32:07 <sgallagh> adamw: Looking at it, I don't think it's a realistic workaround.
16:32:59 <sgallagh> Switching the backend to use simple authentication is more complicated than it's worth, very manual, requires a manual switch *back* and is potentially insecure if they don't do it right.
16:33:09 <sgallagh> So I'll argue for blocker status here
16:33:14 <adamw> ok
16:33:16 <adamw> so we're both +1.
16:33:24 <sgallagh> yes, +1 blocker
16:33:26 <pschindl_wfh> +1
16:34:28 <pwhalen> +1
16:34:45 * roshi looks for cited criteria
16:36:35 <adamw> roshi: https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria#Role_definition_requirements
16:37:18 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1430250 - This bug is accepted as an Alpha blocker due to the severity of the breakage and lack of an adequate workaround. The Alpha criteria state that "The core functional requirements for all Featured Server Roles must be met, but it is acceptable if moderate workarounds are necessary to achieve this."
16:37:23 * roshi was typing
16:37:57 <adamw> nack
16:38:00 <adamw> i'd go with the other criterion
16:38:09 <adamw> "Role definition requirements"
16:38:45 <roshi> kk
16:38:58 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1430250 - This bug is accepted as an Alpha blocker due to the severity of the breakage and lack of an adequate workaround. The Alpha criteria state that "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed,
16:39:04 <roshi> started, stopped, brought to a working configuration, and queried."
16:40:29 <adamw> bit too long :)
16:40:38 <adamw> forget about the workaround bit
16:40:43 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1430250 - This bug is accepted as an Alpha blocker due to the severity of the breakage and lack of an adequate workaround - voilating the following Alpha criterion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully
16:40:49 <roshi> deployed..."
16:40:50 <roshi> grr
16:40:52 <roshi> haha
16:41:16 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1430250 - This bug is accepted as an Alpha blocker due to the severity of the breakage and lack of an workaround - voilating the following Alpha criterion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed..."
16:42:00 <adamw> ack
16:42:02 <pschindl_wfh> ack
16:42:32 <pwhalen> ack
16:43:00 <roshi> #agreed - AcceptedBlocker - RHBZ#1430250 - This bug is accepted as an Alpha blocker due to the severity of the breakage and lack of an workaround - voilating the following Alpha criterion: "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed..."
16:43:20 <roshi> go on to beta blockers, or do alpha FEs since we're so close to the window?
16:43:24 * roshi is thinking FEs
16:44:09 <sgallagh> BTW, in case it was missed, FESCo invoked its authority and declared the python UTF8 locale change officially an approved FE.
16:44:51 <roshi> good ot know
16:45:02 <adamw> is there a bug for that? has it had the correct tags done?
16:45:56 * roshi doesn't know
16:46:22 <adamw> asking sgallagh :)
16:46:29 <roshi> looks like it's under proposed but not changed to accepted yet
16:46:42 <roshi> 1404918 is the bug methinks
16:46:48 <sgallagh> Yes, it's on the list.
16:46:52 <sgallagh> Sorry, jumped ahead.
16:47:10 <roshi> so, let's go through the alpha FE proposals
16:47:16 <sgallagh> I'm in three different meetings right now, so I'm trying to make sure I don't forget things :)
16:47:28 <roshi> no worries sgallagh :)
16:47:30 <roshi> #topic (1429988) ValueError: New size must be between minimal (4 MiB) and maximum (0 B) size.
16:47:33 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1429988
16:47:35 <roshi> #info Proposed Freeze Exceptions, blivet-gui, MODIFIED
16:48:42 <adamw> is blivet-gui on any of the media?
16:49:53 <adamw> if not, not sure what good an FE does
16:49:58 <mkolman_> adamw: that's in Anaconda
16:50:15 <mkolman_> adamw: https://fedoraproject.org/wiki/Changes/AnacondaBlivetGUI
16:50:44 * pwhalen hasnt tested it much
16:50:52 <adamw> ah, right. i keep forgetting to test that button
16:50:55 <adamw> so, +1 FE then!
16:50:59 <roshi> sgtm
16:51:02 <roshi> +1 FE
16:51:03 <adamw> and we probably need to look at the release criteria again, sigh
16:51:20 <adamw> brb
16:51:46 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1429988 - We'd consider letting a fix for this in during freeze.
16:51:48 <pwhalen> +1 FE
16:53:15 <mkolman_> an updated blivet-gui package should be enough to fix the issue
16:53:41 <mkolman_> I am correctly assuming the latest version of packages are always used when creating the media, right ?
16:54:06 <roshi> not during freeze, then only packages with accepted patches are
16:54:17 <mkolman_> yeah
16:54:19 <roshi> then after release, of say Alpha, they start doing that for Beta
16:54:25 <mkolman_> but if it gets FE & is bodihied in
16:54:29 <roshi> right
16:54:34 <mkolman_> OK
16:54:43 <roshi> but even then, we really only want packages that have the fix
16:54:51 <roshi> not a bunch of new features
16:54:52 <mkolman_> so no need to raise required version in Anaconda spec
16:54:54 <roshi> if that makes sense
16:55:29 <adamw> mkolman: yes. as long as it's pushed stable through bodhi or listed in the compose request for an RC, it'll be pulled in.
16:55:46 * mkolman_ actually kinda looks forward to not having an alpha ;-)
16:56:42 <roshi> lol
16:56:56 <roshi> acks?
16:56:59 <pwhalen> ack
16:57:05 <adamw> ack
16:57:09 <roshi> #agreed - AcceptedFreezeException - RHBZ#1429988 - We'd consider letting a fix for this in during freeze.
16:57:21 <roshi> #topic (1430247) FreeIPA server deployment runs ipa-custodia on Python 3, should use Python 2
16:57:24 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1430247
16:57:27 <roshi> #info Proposed Freeze Exceptions, freeipa, NEW
16:58:20 <adamw> this might actually be a blocker, given latest feedback
16:58:26 <Southern_Gentlem> ?? i htought everything is suppose to port to py3 whenever possible
16:58:36 <roshi> so it seems
16:58:38 <adamw> read the bug.
16:58:55 <adamw> sgallagh: do you happen to know off the top of your head what ipa-custodia is *for*? I didn't get a chance to figure it out yet.
16:58:59 <sgallagh> Right, someone changed the dep without it working.
16:59:10 <sgallagh> adamw: custodia is, IIRC, essentially a database of secrets
16:59:39 <adamw> sgallagh: i know that much, what i don't know is what FreeIPA is doing with it
16:59:41 <sgallagh> I'm not entirely sure how deeply it's hooked into FreeIPA at this point
16:59:43 <adamw> and how critical it is to basic freeipa operation
17:00:05 <sgallagh> adamw: I think it's used in replication between masters.
17:00:15 <sgallagh> So pretty important if you have more than one running
17:00:41 <adamw> not technically for our alpha criteria, though...
17:00:46 <sgallagh> Yeah, quick digging suggests it's necessary for creating replicas.
17:00:50 <adamw> so, i'm gonna vote +1 FE for now...
17:01:15 * roshi isn't that familiar with FreeIPA
17:01:24 <sgallagh> I'm +1 FE
17:01:28 <pschindl_wfh> kparal just told me to let you know that his net just died.
17:01:33 <pschindl_wfh> +1 FE
17:01:36 <sgallagh> Let me see if I can find someone to confirm whether it should be a blocker though
17:02:43 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1430247 - It'd be really good to get a fix in for this before Alpha release. Please update the bug if this issue is more severe than we currently suspect.
17:02:51 <roshi> or we can wait for that too
17:03:16 <sgallagh> Let's move ahead. I'll ask around in parallel
17:03:26 <sgallagh> If it's more serious, I'll propose it for blocker and we can circle baclk
17:03:39 <pwhalen> +1 FE
17:03:44 <roshi> works for me
17:03:45 <adamw> ack
17:03:54 <pwhalen> ack
17:04:07 <roshi> #agreed - AcceptedFreezeException - RHBZ#1430247 - It'd be really good to get a fix in for this before Alpha release. Please update the bug if this issue is more severe than we currently suspect.
17:04:26 <roshi> #topic (1423793) js: FTBFS in rawhide
17:04:27 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1423793
17:04:27 <roshi> #info Proposed Freeze Exceptions, js, ON_QA
17:05:35 <sgallagh> This breaks a LOT of stuff on aarch64
17:05:49 <adamw> then +1 FE
17:05:51 <pwhalen> +1 FE, woudl be great to pull this in
17:05:57 <pschindl_wfh> +1 FE
17:06:00 <roshi> +1 FE
17:06:10 <sgallagh> +1 FE
17:06:40 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1423793 - It would be great to get support for aarch64.
17:06:46 <pwhalen> ack
17:07:34 <adamw> ack
17:07:39 <roshi> #agreed - AcceptedFreezeException - RHBZ#1423793 - It would be great to get support for aarch64.
17:07:51 <roshi> #topic (1428559) Rawhide Workstation live installer is suddenly orange
17:07:54 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1428559
17:07:57 <roshi> #info Proposed Freeze Exceptions, mutter, ON_QA
17:08:44 <adamw> this one screws up openQA, and looks a bit jarring if you run into it manually...
17:08:47 <roshi> +1 FE and +1 for favorite bug so far
17:08:58 <sgallagh> +1 FE
17:09:19 <sgallagh> /me wondered briefly if he'd accidentally downloaded Ubuntu media
17:09:28 <pwhalen> +1 FE
17:09:28 <pschindl_wfh> +1 FE
17:09:40 <mkolman_> looks pretty nice IMHO :)
17:09:48 <adamw> =)
17:09:54 <adamw> i always think anaconda looks best in japanese
17:09:59 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1428559 - We really should ensure that the colorscheme of the installer matches the Fedora brand.
17:10:19 <adamw> ...and that our automated tests work without me making a bunch of screenshots of the wrong color. :P
17:10:20 <adamw> ack
17:10:48 <pwhalen> ack
17:10:50 <sgallagh> ack
17:10:51 <roshi> #agreed - AcceptedFreezeException - RHBZ#1428559 - We really should ensure that the colorscheme of the installer matches the Fedora brand.
17:11:00 <roshi> #topic (1404918) Proposal: force C.UTF-8 when Python 3 is run under the C locale
17:11:03 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1404918
17:11:06 <roshi> #info Proposed Freeze Exceptions, python3, ASSIGNED
17:11:12 <sgallagh> This is the one that FESCo declared an approved FE by fiat
17:11:40 <roshi> #info FESCo has declared this an FE, so we'll update the bug to reflect that
17:11:46 <roshi> that enough?
17:12:05 <adamw> sure
17:12:08 <roshi> #topic (1431400) ostrees are not building in f26
17:12:08 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1431400
17:12:08 <roshi> #info Proposed Freeze Exceptions, rpm-ostree, MODIFIED
17:12:16 <roshi> dustymabe: ^^ this is you
17:12:24 <dustymabe> roshi: :)
17:12:30 <sgallagh> Oh, I was going to link the FESCo decision on the last topic.
17:12:51 <roshi> sgallagh: can just put it in the bug, right?
17:12:55 <sgallagh> sure
17:13:01 <roshi> sorry, kinda just powered through
17:13:35 * roshi forgot to ask: who wants to secretarialize?
17:14:03 <dustymabe> are you guys expecting me to talk about this bug?
17:14:11 <dustymabe> or does the BZ do enough talking?
17:15:27 * roshi just didn't know if there was anything else you wanted to bring up
17:15:29 <adamw> we got distracted
17:15:32 <Southern_Gentlem> +1 FE
17:15:43 * roshi is +1 FE
17:16:02 <adamw> +1 FE, prevents creation of images currently marked non-blocking.
17:16:36 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1431400 - We should pull in a fix so that Atomic ostree's get build properly for Fedora Atomic.
17:16:39 <dustymabe> right, so what happens in the future if we identify bugs and our images are non-blocking?
17:16:56 <roshi> propose an FE, just like you did
17:17:01 <dustymabe> ok
17:17:11 <roshi> since it's ostree, there likely won't be any issues
17:17:18 <roshi> doesn't touch anything else
17:17:21 <dustymabe> cool
17:17:36 <roshi> if you wanted to do something for say, anaconda, we'd have to take a closer look at that since it touches everything
17:17:50 <dustymabe> yeah
17:17:52 <dustymabe> understood
17:18:04 <roshi> ack, nack, patch?
17:18:14 <adamw> ack
17:18:16 <Southern_Gentlem> ack
17:18:25 <roshi> #agreed - AcceptedFreezeException - RHBZ#1431400 - We should pull in a fix so that Atomic ostree's get build properly for Fedora Atomic.
17:19:11 <roshi> normally I'd move onto beta, but I think we should frontload going through the accepteds with Go/No-go in 3 days
17:19:18 <roshi> any objections?
17:19:54 <adamw> there's only one accepted, isn't there?
17:20:08 <roshi> and 5 accepted FEs
17:20:49 <roshi> #topic Review of accepted blockers and FE's for Alpha
17:20:58 <roshi> #topic (1422634) selinux prevents kernel modules from loading
17:20:58 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1422634
17:20:58 <roshi> #info Accepted Blocker, selinux-policy, ON_QA
17:21:37 <adamw> we don't really have to review accepted FEs, usually.
17:21:42 <adamw> as they're not blocking anything.
17:21:54 <roshi> that's fair
17:21:55 <sfix> /3/33
17:21:57 <adamw> so we have a build for this now? yay. did you get to try it yet pwhalen?
17:22:03 <sfix> oops, sorry
17:22:16 <roshi> just figured we'd go through the list to see if anything could use poking before the meeting thursday
17:22:34 <roshi> I can do that after the meeting, if anything stands out
17:22:38 <pwhalen> adamw, looks ok so far
17:22:42 <roshi> sweet
17:23:02 * dustymabe is going to run to lunch
17:23:06 <dustymabe> bbl
17:23:09 <roshi> onto the Beta Proposals, or break here to go test/work on Alpha?
17:23:12 <roshi> l8r dustymabe
17:23:17 <roshi> thanks for coming
17:24:51 <adamw> #info  this one first
17:25:49 <roshi> #info looks like we have a fix for this and should be ready for Go/No-Go decision on Thursday (20170316)
17:26:02 <roshi> we only have 1 beta proposal and 1 for final
17:26:13 <roshi> we can finish those out and break early
17:26:22 <adamw> sure
17:26:28 <roshi> #topic (1430920) gnome-software graphical updates fail, pk-offline-update: no trigger, exiting
17:26:31 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1430920
17:26:33 <roshi> #info Proposed Blocker, PackageKit, NEW
17:28:08 <adamw> blocker if true
17:28:08 <adamw> :P
17:28:42 <adamw> +1
17:28:44 <roshi> seems pretty clear
17:28:45 <roshi> _+1
17:28:55 <sgallagh> I've seen this on my system as well
17:28:57 <sgallagh> +1
17:29:06 <Southern_Gentlem> +1
17:29:34 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1430920 - This is a clear violation of the following criterion: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops."
17:31:27 <Southern_Gentlem> ack
17:31:35 <adamw> ack
17:31:48 <roshi> #agreed - AcceptedBlocker - RHBZ#1430920 - This is a clear violation of the following criterion: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops."
17:32:00 <roshi> and onto the last proposal, which is for Final
17:32:19 <roshi> our old friend
17:32:20 <roshi> #topic (1405539) changing the default keyboard layout changes also disk decryption in plymouth, but only after kernel update, long after
17:32:23 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1405539
17:32:25 <roshi> #info Proposed Blocker, plymouth, NEW
17:32:59 <adamw> everyone take a drink!
17:33:10 <adamw> we seem to have got a bit more discussion and opinion on this one
17:33:11 <roshi> whee!
17:33:26 <adamw> what'd we say about this last week? that was like ten bottles of gin ago
17:34:48 <roshi> punt for more information methinks
17:35:00 <adamw> right , but did we say we were gonna make a decision for sure this week or whjat
17:36:04 <roshi> I don't know that we *ever* claim to do something "next meeting"
17:36:18 <roshi> if it happens it happens, but we don't make plans like that :p
17:36:44 <adamw> hah.
17:36:51 <adamw> well, i dunno, i'm sick of this but still dunno what to do.
17:36:57 <roshi> me either
17:37:22 <roshi> I mean, it's bad and I want a fix, but it also requires changes to the foundation of the universe to do...so...
17:38:26 <roshi> +1 punt?
17:38:33 * pwhalen recalls a commitment to make a decision :)
17:38:41 <roshi> sshh
17:38:48 <roshi> no one listen to him
17:38:49 <pwhalen> heh, that said, wfm
17:38:51 <roshi> he's a madman
17:38:57 <roshi> :P
17:39:23 <adamw> i dunno that punting is going to get us much more at this point...
17:39:33 <roshi> I guess I lean -0.5 since it's been there for ages
17:39:41 <adamw> i think i'm gonna vote -1 on this, broadly on the basis of https://bugzilla.redhat.com/show_bug.cgi?id=1405539#c29
17:39:53 <adamw> it's hard to identify a viable change we can block the f26 release on here
17:40:06 <roshi> yeah
17:40:11 <roshi> other votes?
17:40:26 <sgallagh> -1
17:40:42 * roshi really dislikes the "this isn't a blocker because of the feasibility of a fix" thing, but I don't have a better solution to offer
17:41:01 <pwhalen> -1
17:41:58 <roshi> proposed #agreed - RejectedBlocker - RHBZ#1405539 - While this is a severe bug we'd love to have a fix for, the problem has existed for multiple releases and is exceptionally non-trivial to fix.
17:42:12 <adamw> ack
17:42:16 <roshi> we can't even reall FE it, because the changes wouldbe too large :(
17:42:23 <roshi> s/reall/really
17:42:27 <adamw> yeah
17:42:41 <adamw> i mean, we could consider some specific change for FE status if it comes up
17:42:55 <adamw> but i don't wanna FE the bug in general at this ponit since there's still not really any agreement on what a 'fix' would be
17:42:59 <roshi> no real point in doing that right now though
17:43:03 <roshi> yeah
17:43:09 <roshi> any other acks?
17:43:50 <Southern_Gentlem> ack
17:43:56 <pwhalen> ack
17:44:11 <roshi> #agreed - RejectedBlocker - RHBZ#1405539 - While this is a severe bug we'd love to have a fix for, the problem has existed for multiple releases and is exceptionally non-trivial to fix.
17:44:17 <roshi> #topic Open Floor
17:44:27 <roshi> that's all the proposed blockers and all the Alpha FEs
17:44:36 <roshi> anyone have anythign else they want to bring up?
17:45:11 <Southern_Gentlem> link to alphas?
17:45:25 <adamw> ?
17:45:26 <roshi> what do you mean?
17:47:56 <roshi> Southern_Gentlem: ^^
17:48:47 <Southern_Gentlem> i am sure stuff needs tested
17:48:54 <adamw> but what do you *mean* by 'link to alphas'?
17:49:10 <Southern_Gentlem> link to isos ?
17:49:18 <adamw> there are no "alphas"
17:49:22 <adamw> there will be one Alpha, like always.
17:49:26 <adamw> it doesn't exist yet.
17:49:35 <adamw> we haven't made any Alpha RCs yet. current validation testing is on nightlies
17:50:11 <Southern_Gentlem> and we are suppose to have a go\nogo on thursday?
17:50:17 <adamw> you can always go to https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test , https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test etc. to find the latest compose for testing
17:50:19 <adamw> yes.
17:50:23 <roshi> yep
17:50:28 <adamw> we can't do RCs until all blockers are addressed.
17:50:35 <Southern_Gentlem> ok
17:50:55 * roshi sets the fuse...
17:51:00 <roshi> thanks for coming folks!
17:51:03 <roshi> 3...
17:51:32 <adamw> thanks for hosting, roshi!
17:51:38 <adamw> did anyone volunteer to secretaralize?
17:52:05 <roshi> 2...
17:52:09 <roshi> I don't think so
17:52:21 * roshi just figured he'd go through after the meeting and do it then
17:52:33 <adamw> ok, if you don't mind :) thanks!
17:52:39 <roshi> np
17:52:40 <roshi> 1...
17:52:46 <roshi> #endmeeting