16:01:01 <roshi> #startmeeting F26-blocker-review
16:01:01 <roshi> #meetingname F26-blocker-review
16:01:01 <zodbot> Meeting started Mon Mar 27 16:01:01 2017 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:01 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:01:01 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:01:02 <roshi> #topic Roll Call
16:01:11 * coremodule is here.
16:01:12 <roshi> who's around for some blockery fun times!?
16:01:26 <coremodule> And ready for secretary duty.
16:01:47 * garretraziel is he as you are he as you are me and we are all together
16:02:09 <adamw> aloha
16:02:25 * guest823 is here
16:02:25 <jkurik> .hello jkurik
16:02:27 <roshi> awesome, thanks coremodule
16:02:28 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
16:02:48 <coremodule> roshi, No problem!
16:02:54 * pschindl_ is also here
16:03:02 <roshi> #chair adamw coremodule garretraziel jkurik pschindl_
16:03:02 <zodbot> Current chairs: adamw coremodule garretraziel jkurik pschindl_ roshi
16:03:07 <roshi> #topic Introduction
16:03:08 <roshi> Why are we here?
16:03:08 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:03:11 <roshi> #info We'll be following the process outlined at:
16:03:14 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:03:16 <roshi> #info The bugs up for review today are available at:
16:03:19 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:03:21 <roshi> #info The criteria for release blocking bugs can be found at:
16:03:24 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria
16:03:27 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria
16:03:30 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria
16:04:56 <sgallagh> Sorry I'm late
16:04:57 <sgallagh> .hello sgallagh
16:05:01 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:05:03 <roshi> no worries sgallagh
16:05:06 <roshi> #chair sgallagh
16:05:06 <zodbot> Current chairs: adamw coremodule garretraziel jkurik pschindl_ roshi sgallagh
16:05:15 <roshi> onto the Alpha proposal
16:05:28 <roshi> #topic (1436032) dma driver causes boot issues in a number of circumstances
16:05:30 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1436032
16:05:33 <roshi> #info Proposed Blocker, bcm283x-firmware, POST
16:06:01 <sgallagh> So, we got this in as a Freeze Exception for RC3 just before they kicked it off.
16:06:09 <sgallagh> So hopefully this decision will be academic.
16:06:50 <sgallagh> That said, I think that if this had come up a Go/No-Go, we would likely come down to "This is really bad for the RPi2/3 systems, but it doesn't affect other ARMv7 boards" and opt for not blocking.
16:06:53 <sgallagh> So I'm -1 blocker
16:07:36 <pschindl_> is RPi officially supported?
16:07:46 <roshi> it is a pretty clear violation of the criteria though, and an RPi is pretty big for users
16:07:57 <roshi> since they moved to ARMv7, I thought it was
16:08:03 <adamw> yeah, the rule is pretty clear
16:08:09 <adamw> i don't think you get to just make it up on the fly, sgallagh
16:08:15 <pschindl_> then I am +1
16:08:25 <adamw> "All release-blocking images must boot in their supported configurations."
16:08:30 <adamw> "Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms."
16:08:34 * roshi is +1
16:08:40 <jkurik> I am +1 to block, even I do not want to slip again :(
16:08:43 * pwhalen is also +1
16:08:46 <adamw> and that page lists "Raspberry Pi 2/3" for F26.
16:09:00 <sgallagh> adamw: We've made rulings based on frequency of affected hardware before, though
16:09:06 <adamw> not for ARM.
16:09:19 <adamw> we don't have a similar rule for x86 because we couldn't possibly make a reasonable 'list of supported platforms' for x86.
16:09:30 <adamw> but for ARM, we have one, and it's 11 systems long.
16:10:01 <roshi> and an rpi would arguably be the biggest player for new to fedora users, from a hardware availability standpoint
16:10:02 <sgallagh> Well, as I said: I hope that this is academic, because I wrangled the fix into the RC3 candidate already
16:10:03 <adamw> if it was, like, 50, it'd probably be unsustainable to require them all to work every time, but 11 seems fine.
16:10:16 <pschindl_> and RPi is quite widespread
16:10:56 <jkurik> sgallagh: than we can block for it now and have it solved before go/no-go
16:11:04 <roshi> that's the hope :)
16:11:19 <sgallagh> adamw: I'm not denying that we want this fixed by any stretch; I'm merely attempting to represent that if this was the last thing blocking the Go/No-Go, I suspect that there would be strong resistance to slipping just for this.
16:11:48 <adamw> i'd still be +1.
16:12:04 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1436032 - This bug is a clear violation of the following criterion: "Release-blocking ARM disk images must boot to the initial-setup utility."
16:12:07 <sgallagh> And that's fair. I've said my piece and been outvoted.
16:12:07 <adamw> ack
16:12:09 <garretraziel> ack
16:12:13 <pwhalen> ack
16:12:18 <jkurik> ack
16:12:23 <coremodule> ack
16:12:24 <sgallagh> meh, I'd still say "conditional"
16:12:26 <pschindl_> ack
16:12:29 <adamw> well, i'd say the criterion I listed, but whichever.
16:13:00 <roshi> bah, thought I copied that
16:13:04 * roshi edits
16:13:22 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1436032 - This bug is a clear violation of the following criterion: "All release-blocking images must boot in their supported configurations."
16:13:41 <adamw> ack
16:13:43 <roshi> #agreed - AcceptedBlocker - RHBZ#1436032 - This bug is a clear violation of the following criterion: "All release-blocking images must boot in their supported configurations."
16:14:04 <roshi> and now a break from our regular programming, and we'll take a look at Alpha FEs?
16:14:45 <jkurik> roshi: go on
16:14:45 <adamw> sure
16:15:22 <roshi> #topic (1428638) Cannot install on i686 or ppc64 since criu dep added
16:15:25 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1428638
16:15:27 <roshi> #info Proposed Freeze Exceptions, docker, ASSIGNED
16:16:39 <adamw> +1
16:16:51 <adamw> since the maintainer isn't responding i guess dgilmore or i could just do this ourselves
16:16:53 * adamw does
16:16:56 <sgallagh> +1, though I dearly hope we don't respin again
16:17:08 <pwhalen> +1
16:17:08 <adamw> can maybe stuff this in rc3 if i do it quick
16:17:14 <roshi> +1
16:17:18 <sgallagh> adamw: I thought RC3 had started
16:17:22 <jkurik> +1 FE
16:17:34 <adamw> oh, bah
16:17:56 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1428638 - It would be great to get this pulled in for Alpha.
16:18:00 <sgallagh> (hence why I ran around in a hurry to get the previous one landed)
16:18:29 * pwhalen doesnt see it, perhaps we still have time?
16:18:58 <sgallagh> Also, Docker is only on the Server media as a non-default install option, so is this urgent for FE?
16:19:34 <pwhalen> .."prevents us making all 32 bit x86 and ppc64 deliverables"
16:20:02 <roshi> yeah, it's for building 32bit
16:20:03 <sgallagh> Yes, but do we have any of those? :)
16:20:05 <roshi> and ppc
16:20:17 <roshi> we generally do, they're just not blocking
16:20:24 <roshi> acks?
16:20:26 <sgallagh> Oh, it's a compose-time issue
16:20:48 <sgallagh> Will the composes fail or just fail to have certain package groups included?
16:20:51 <adamw> it fails.
16:20:54 * adamw brb, call of nature
16:21:58 <jkurik> roshi: ack
16:22:05 <pwhalen> ack
16:22:28 <roshi> #agreed - AcceptedFreezeException - RHBZ#1428638 - It would be great to get this pulled in for Alpha.
16:22:33 <roshi> #topic (1429050) Gnome core dumps on startup with llvmpipe crash due to llvm failing to clear high 16bits of correct register.
16:22:36 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1429050
16:22:39 <roshi> #info Proposed Freeze Exceptions, llvm, MODIFIED
16:24:12 <coremodule> I'm +1FE
16:24:35 <jkurik> yeah, +1 FE
16:25:09 <jkurik> it is in MODIFIED status, so may we have it in the Alpha compose if it does not start building yet ?
16:25:39 <sgallagh> +1 FE
16:26:05 <roshi> +1 FE as well
16:26:25 <roshi> proposed #agreed - AcceptedFreezeException - RHBZ#1429050 - It would be great to get this pulled in for Alpha.
16:26:35 <jkurik> ack
16:26:50 <coremodule> ack
16:26:53 <sgallagh> ack
16:26:58 <adamw> jkurik: as it's about secondary arches, it doesn't matter if it goes in RC3
16:27:02 <roshi> #agreed - AcceptedFreezeException - RHBZ#1429050 - It would be great to get this pulled in for Alpha.
16:27:10 <adamw> the point of the FE is just to allow those secondary arches to get fixed (their own composes, and nightlies)
16:27:21 <roshi> do we want to go through all the accepted?
16:27:22 <pwhalen> +1FE
16:27:27 <pwhalen> ack
16:27:32 * roshi thinks we can move on to the beta/final proposals
16:27:41 <roshi> since now we're really just waiting on the compose...
16:27:51 <adamw> yeah, i'm tracking the accepted.
16:27:52 <jkurik> adamw: I know, but as we were blocking for raspberry, it will be affectes as well
16:28:06 <adamw> jkurik: i don't think so? the llvmpipe issue was ppc64, wasn't it?
16:28:16 <adamw> not arm
16:28:37 <jkurik> aarch64
16:29:35 <jkurik> the bug report starts with "Starting gnome on an ARM64 machine without hardware GL support"
16:29:53 <jkurik> it is also RaspberryPI, is in it ?
16:30:17 <jkurik> is'n it ?
16:30:26 <pwhalen> jkurik, we support rpi3 on armhfp (aarch64 support is pending)
16:30:28 <adamw> oh, yes.
16:30:36 <adamw> but aarch64 still isn't a primary arch.
16:30:41 <adamw> so, same point. anyhoo
16:30:42 <jkurik> oh, ok, thanks for the explanation :)
16:31:43 <roshi> onto the beta proposals? or break for other work?
16:32:04 <roshi> we don't have a large backlog, so figured I'd throw it out there as an option
16:32:29 <roshi> 1/2 proposed blockers for beta/final
16:32:45 <adamw> sure, let's do it
16:33:07 <roshi> beta/final let's do it, or cull the meeting?
16:33:39 <adamw> beta/final do it
16:33:46 <roshi> #topic (1435583) Can't install any applications
16:33:46 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1435583
16:33:46 <roshi> #info Proposed Blocker, gnome-software, NEW
16:34:54 <roshi> +1
16:34:57 <jkurik> +1 Beta blocker
16:34:59 <roshi> under: The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops.
16:35:07 <coremodule> Yeah, +1.
16:35:15 <pwhalen> +1
16:35:42 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1435583 - This is a clear violation of the following Beta criterion: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops."
16:35:54 <jkurik> ack
16:35:54 <nb> +1
16:35:55 <pwhalen> ack
16:35:57 <nb> ack
16:36:02 <guest823> ack
16:36:11 <roshi> #agreed - AcceptedBlocker - RHBZ#1435583 - This is a clear violation of the following Beta criterion: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops."
16:36:40 <roshi> onto the 2 proposed for Final
16:36:41 <roshi> #topic (1435310) avc denial during F26AH boot - 'error_name=org.freedesktop.systemd1.NoSuchDynamicUser'
16:36:43 <jkurik> .hello nb
16:36:44 <zodbot> jkurik: nb 'Nick Bebout' <nb@nb.zone>
16:36:45 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1435310
16:36:47 <roshi> #info Proposed Blocker, selinux-policy, POST
16:37:17 <roshi> -1 since it's atomic
16:37:24 <roshi> but +1 FE if it ends up being needed
16:37:35 <roshi> though, I think these will go away before then
16:38:48 <jkurik> -1 Blocker, +1 FE
16:38:52 <adamw> "Since it affects the Base image, I've reapplied the blocker nomination."
16:38:56 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1435310#c9
16:39:03 <nb> -1 blocker, +1 FE
16:39:07 <guest823> -1 blocker, +1 FE
16:39:09 <adamw> so, +1 blocker.
16:40:01 <roshi> ah, right
16:40:11 <roshi> and it's already approved FE
16:40:14 <roshi> +1
16:40:43 <adamw> it's approved Alpha FE
16:41:22 * roshi even was the one that filed it's blocker status - how'd I forget that? lol
16:41:34 <garretraziel> +1 blocker
16:41:44 <roshi> anyone want to change their votes since it affects the cloud base image?
16:41:58 <pwhalen> +1 blocker
16:42:07 <jkurik> then we should block on it, so I am changing to +1 block
16:42:11 <guest823> +1 blocker
16:42:16 <nb> +1 blocker
16:42:47 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1435310 - This is a violoation of the following Final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop"
16:42:49 <jkurik> it is treacherous ...
16:42:59 <jkurik> ack
16:43:03 <pwhalen> ack
16:44:02 <coremodule> ack
16:44:05 <roshi> #agreed - AcceptedBlocker - RHBZ#1435310 - This is a violoation of the following Final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop"
16:44:12 <roshi> #topic (1434619) systemd-vconsole-setup.service fails to start on F26 Alpha base cloud image
16:44:15 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1434619
16:44:18 <roshi> #info Proposed Blocker, systemd, NEW
16:44:44 <adamw> violoation?
16:44:51 <roshi> All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present.
16:44:55 <adamw> i wonder if that's like a violaation
16:44:59 <roshi> ah
16:45:01 <roshi> spelling
16:45:03 <roshi> who needs it
16:45:06 <adamw> =)
16:45:08 <roshi> #undo
16:45:08 <zodbot> Removing item from minutes: INFO by roshi at 16:44:18 : Proposed Blocker, systemd, NEW
16:45:11 <roshi> #undo
16:45:11 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2ec2e310>
16:45:14 <roshi> #undo
16:45:14 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x398ccf10>
16:45:15 <roshi> #undo
16:45:15 <zodbot> Removing item from minutes: AGREED by roshi at 16:44:05 : - AcceptedBlocker - RHBZ#1435310 - This is a violoation of the following Final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop"
16:45:29 <roshi> #agreed - AcceptedBlocker - RHBZ#1435310 - This is a violation of the following Final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop"
16:45:35 <roshi> #topic (1434619) systemd-vconsole-setup.service fails to start on F26 Alpha base cloud image
16:45:38 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1434619
16:45:41 <roshi> #info Proposed Blocker, systemd, NEW
16:45:44 <roshi> there
16:45:49 <roshi> thanks adamw
16:46:22 <adamw> +1 per criteria.
16:46:45 <jkurik> +1
16:46:52 <garretraziel> looks like +1 to me
16:47:16 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1434619 - This is a clear violation of the following Final criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present."
16:47:34 <nb> akc
16:47:49 <jkurik> ack
16:48:21 <pschindl_> ack
16:48:25 <garretraziel> ack
16:48:44 * roshi double checks his spelling...
16:48:59 <adamw> ack
16:49:02 <adamw> violination?
16:49:07 <roshi> #agreed - AcceptedBlocker - RHBZ#1434619 - This is a clear violation of the following Final criterion: "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present."
16:49:14 <roshi> adamw: that's a different thing
16:49:22 <roshi> here we call it the Fiddle
16:49:25 <adamw> heh
16:49:28 <roshi> :p
16:49:35 <roshi> #topic Open Floor
16:49:45 <roshi> that's all of the proposals
16:50:16 <roshi> anyone have anything for Open Floor?
16:51:00 <jkurik> I just want to thank you guys for the excellent job on testing
16:51:12 <roshi> :D
16:52:04 <adamw> nothing from me, i don't think
16:53:11 * roshi sets the fuse...
16:53:12 <roshi> 3...
16:53:32 <roshi> 2...
16:54:56 <roshi> 1...
16:55:02 <roshi> thanks for coming folks!
16:55:05 <roshi> #endmeeting