16:00:02 <roshi> #startmeeting F26-blocker-review
16:00:02 <zodbot> Meeting started Mon Apr 24 16:00:02 2017 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:02 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:00:02 <roshi> #meetingname F26-blocker-review
16:00:02 <zodbot> The meeting name has been set to 'f26-blocker-review'
16:00:02 <roshi> #topic Roll Call
16:00:09 <roshi> who's around for blocker funtimes!
16:00:25 <roshi> it's the best time you'll have this side of the Mississippi*
16:00:49 <roshi> * All claims not actual, YMMV
16:01:34 * kparal is here, despite his previous email
16:02:09 * garretraziel is lurking around
16:02:45 <roshi> #chair kparal adamw garretraziel
16:02:45 <zodbot> Current chairs: adamw garretraziel kparal roshi
16:03:37 * roshi waits a couple minutes for people to refill their coffee and get back to their seats
16:04:12 <adamw> i'm here
16:04:28 <dustymabe> .hello dustymabe
16:04:29 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
16:04:58 <roshi> #chair dustymabe
16:04:58 <zodbot> Current chairs: adamw dustymabe garretraziel kparal roshi
16:05:10 <roshi> #topic Introduction
16:05:10 <roshi> Why are we here?
16:05:10 <roshi> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:05:14 <roshi> #info We'll be following the process outlined at:
16:05:16 <roshi> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:05:19 <roshi> #info The bugs up for review today are available at:
16:05:21 <roshi> #link http://qa.fedoraproject.org/blockerbugs/current
16:05:24 <roshi> #info The criteria for release blocking bugs can be found at:
16:05:26 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria
16:05:29 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Beta_Release_Criteria
16:05:32 <roshi> #link https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria
16:05:41 <roshi> so we've got 3 proposed for Beta
16:05:52 <roshi> let's get started
16:06:01 <roshi> #topic (1444651) Unable to print on HP Printers after upgrade from Fedora 25 to Fedora 26 Alpha
16:06:04 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1444651
16:06:06 <roshi> #info Proposed Blocker, cups, NEW
16:07:26 <dustymabe> was this one officially proposed as blocker using the tool?
16:07:34 <dustymabe> doesn't it usually add a comment to the bug?
16:07:47 <roshi> nope
16:07:49 <adamw> probably just needs the plugin reinstalled, that's normal on upgrade
16:07:55 <adamw> and yeah, there's no blocker justification
16:08:00 <adamw> we don't really cover...anything  about printing at all
16:08:03 <roshi> you can propose it just by adding the right block
16:08:08 <roshi> yeah
16:08:09 <adamw> as things stand this seems pretty -1 to me
16:08:19 <roshi> -1 from me as well
16:08:53 <garretraziel> -1 since it looks like it doesn't break any criteria
16:08:54 <kparal> I would consider it if it involves all or most printers
16:09:02 <Kohane> Hi! Sorry for my lateness.
16:09:08 <Kohane> .fas lailah
16:09:08 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:09:12 <kparal> in the current state, -1
16:09:29 <dustymabe> would this be eligible for FE?
16:10:02 <roshi> I would consider it for FE, but not blocker - since there's no criteria
16:10:13 <adamw> i'd want at least a little more indication it's a real bug before giving it FE.
16:10:30 <roshi> and adding a "must print" criteria just feels like a huge PITA to have a list of "supported printers" and then we have a real cost to testing
16:10:33 <dustymabe> adamw: yeah, assuming it was a real bug
16:10:40 <roshi> home printing is expensive, lol
16:10:42 <dustymabe> -1
16:10:49 <Kohane> I think it's annoying but not to the point of considering a blocker.
16:10:52 <adamw> home printing is killing...signs?
16:11:51 <roshi> proposed #agreed - RejectedBlocker - RHBZ#1444651 - This bug doesn't violate any release criteria and isn't considered a blocker. If this can be reproduced on a variety of print setups, we will consider it as an FE.
16:12:12 <adamw> ack
16:13:04 <roshi> more acks?
16:13:07 <roshi> nacks?
16:13:16 <dustymabe> ack
16:13:17 <kparal> ack
16:13:19 <roshi> #agreed - RejectedBlocker - RHBZ#1444651 - This bug doesn't violate any release criteria and isn't considered a blocker. If this can be reproduced on a variety of print setups, we will consider it as an FE.
16:13:26 <roshi> #topic (1443206) gnome-shell consistently crashes in the middle of first-login gnome-initial-setup
16:13:29 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1443206
16:13:31 <roshi> #info Proposed Blocker, gnome-shell, NEW
16:14:01 <adamw> so for me this is 100% reproducible in KVMs (std and qxl graphics) and on my test laptop (which is a third-gen xps 13)
16:14:12 <adamw> it causes quite a lot of the openqa tests to fail every day
16:14:51 <Kohane> Well, I see this one as a blocker indeed.
16:14:54 <roshi> +1
16:15:11 <garretraziel> +1 blocker
16:15:12 <Kohane> +1
16:15:21 <kparal> +1
16:15:32 <adamw> be good to know if others can reproduce on other hardware too, for info
16:15:49 <dustymabe> +1
16:16:36 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1443206 - This bug is a clear violation of the following criterion: "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."
16:17:30 <kparal> +1
16:17:32 <kparal> ack
16:17:34 <dustymabe> ack
16:17:38 <Kohane> ack
16:17:48 <roshi> #agreed - AcceptedBlocker - RHBZ#1443206 - This bug is a clear violation of the following criterion: "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility."
16:17:54 <roshi> #topic (1227736) Minimal grub after a kernel update with gnome-software
16:17:57 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1227736
16:18:00 <roshi> #info Proposed Blocker, plymouth, NEW
16:18:24 <adamw> we discussed this two weeks ago
16:18:36 <Kohane> ?
16:18:44 <kparal> I think we forgot to appoint a secretary. but I'm not volunteering :)
16:19:10 <roshi> coremodule said before the meeting that he would do it after the meeting
16:19:17 <adamw> we seem to have been waiting for: "<cmurf> I suggest punting until we hear from plymouth folks."
16:19:25 <adamw> which...i think we still didn't
16:19:47 <roshi> sounds right
16:20:02 <Kohane> Yeah, sounds fine to me too.
16:20:11 <Kohane> But I still have a small question.
16:20:19 <roshi> punt again? with an action item to chase down an answer?
16:20:44 <dustymabe> wow, lots of info in this bug
16:20:56 <roshi> it's an old bug
16:21:12 <dustymabe> +1 for delay I guess
16:22:09 <adamw> what's the question, kohane?
16:22:19 <Kohane> Ah!
16:22:50 <Kohane> I never use Gnome Software to update so... what exactly is a minimal grub?
16:22:57 <Kohane> It never happened to me.
16:23:19 <adamw> basically it just means boot fails to work properly and you wind up in grub's interactive environment, which isn't much use to most people :)P
16:23:30 <adamw> that only happens in a specific case, though (no /boot partition, / partition is xfs)
16:23:36 <Kohane> Ah, now I get it
16:24:02 <Kohane> Oh, okay, that explains why I never met this bug
16:24:06 <Kohane> Thanks adamw
16:24:29 <roshi> so punt I guess seems to be the consensus
16:24:35 <adamw> yeah
16:24:44 <Kohane> Yeah, agree.
16:25:06 <roshi> proposed #agreed - Punt - RHBZ#1227736 - We're still waiting on more information regarding this bug. We'll look at it again next blocker review meeting.
16:25:12 <garretraziel> ack
16:25:35 <adamw> ack
16:25:47 <roshi> #agreed - Punt - RHBZ#1227736 - We're still waiting on more information regarding this bug. We'll look at it again next blocker review meeting.
16:26:06 <roshi> #topic Onto the Final proposals
16:26:10 <roshi> we have 4 of them to go through
16:26:14 <roshi> first up:
16:26:19 <roshi> #topic (1439282) [e10s] Tabs crash on loading large sites.
16:26:19 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1439282
16:26:19 <roshi> #info Proposed Blocker, firefox, NEW
16:27:30 <adamw> i still haven't seen this. anyone else?
16:27:37 <Kohane> Nope.
16:27:52 <roshi> nope
16:28:20 <dustymabe> Not yet - i'm on F25
16:28:29 <dustymabe> I think people reported seeing the problem there
16:29:16 <adamw> yeah, seems that way
16:29:32 <kparal> we seem to have sufficient coverage to begin worrying about this
16:29:37 <Kohane> Well...  my machine is not the most powerful thing but didn't have any crashes in firefox up to now.
16:29:43 <adamw> so the bug has...four people claiming to be affected
16:29:49 <roshi> looks like more people are seeing it
16:29:56 <adamw> perhaps this would be a good one to send out mails about
16:30:00 <adamw> i could do that
16:30:06 <adamw> (requesting more feedback)
16:30:18 <kparal> ack
16:30:21 <roshi> sounds good
16:30:41 <roshi> #action adamw to send out an email looking for more info on RHBZ#1439282
16:31:22 <roshi> proposed #agreed - Punt - RHBZ#1439282 - We're going to ask for more feedback from the mailing lists, and if more people see this bug we'll accept it as a blocker.
16:31:45 <adamw> ack
16:31:47 <Kohane> ack
16:32:03 <roshi> #agreed - Punt - RHBZ#1439282 - We're going to ask for more feedback from the mailing lists, and if more people see this bug we'll accept it as a blocker.
16:32:10 <roshi> #topic (1404285) [abrt] gjs: sqlite3DbMallocRawNN(): gjs-console killed by SIGSEGV: TAINTED
16:32:13 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1404285
16:32:16 <roshi> #info Proposed Blocker, gjs, NEW
16:33:10 <adamw> yeah, i've seen this one too
16:33:18 <adamw> +1 on the 'no avcs in a normal boot/install/boot cycle' criterion
16:33:38 <Kohane> This looks cryptic to me. Sorry. I only understand the general description. :-/
16:33:50 <roshi> seems +1 to me
16:34:32 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1404285 - This bug is a clear violation of the following criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
16:34:46 <kparal> ack
16:34:47 <Kohane> ack
16:35:04 <adamw> Kohane: you don't need to understand the details of the denial to vote on it :)
16:35:05 <adamw> ack
16:35:11 <garretraziel> ack
16:35:11 <roshi> #agreed - AcceptedBlocker - RHBZ#1404285 - This bug is a clear violation of the following criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."
16:35:14 <dustymabe> ack
16:35:22 <roshi> #topic (1442631) crash on login following software update; (gnome-shell) of user 1000 dumped core
16:35:25 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1442631
16:35:28 <roshi> #info Proposed Blocker, gnome-shell, NEW
16:35:54 <Kohane> Uhm.... I saw this one.
16:36:30 <adamw> this one could well be the same as the g-i-s bug, the tracebacks look very similar
16:36:36 <adamw> but we're not totally sure yet
16:36:59 <roshi> yeah
16:37:30 <roshi> this one is losing data though, sounds like
16:37:33 <dustymabe> hey guys, got to run grab some food before next meeting
16:37:42 <roshi> gl hf dustymabe - thanks for coming
16:37:43 <dustymabe> see you next week :)
16:37:58 <dustymabe> ping me if anything atomic/cloud specific comes up
16:37:59 <Kohane> see you !
16:39:01 <adamw> cya dusty
16:39:06 <roshi> +1 from me, under either of the criterion really
16:39:08 <adamw> hi amita
16:39:22 <Amita> hey hi adamw
16:39:35 <roshi> welcome Amita :)
16:39:42 <Kohane> Hi Amita
16:39:52 <Amita> hello roshi hey Kohane
16:39:54 <adamw> it'd be nice to have confirmation from anyone else, but it's definitely bad that just one person is hitting this, since it's a complete crash-to-gdm
16:40:59 <roshi> yeah
16:41:05 <roshi> votes?
16:41:17 <roshi> and I guess votes for criterion as well, since there's two that seem to fit
16:41:22 <adamw> i'm either +1 or punt and try to get more info (reproduce)
16:41:23 <Kohane> +1
16:41:33 <adamw> people could try to reproduce this in a VM, it shouldn't be terribly hard...
16:41:38 <roshi> I'm +1 and get more info
16:41:47 <kparal> it's another crash in libweather, no?
16:41:53 <kparal> wasn't the first crash also about this?
16:42:36 * kparal talking about 1443206
16:42:56 <adamw> i did say that
16:43:02 <adamw> but we're not sure yet if they're really the same
16:43:06 <Kohane> I'm getting lost...
16:43:08 <kparal> ah, sorry, was on the call
16:43:31 <kparal> ok, now I see it in the scrollback :)
16:43:35 <Kohane> what bug are we discussing now
16:43:38 <Kohane> ?
16:43:45 <kparal> the one in title
16:43:53 <Kohane> ah
16:44:25 <kparal> sorry for confusion, seems close enough, +1 from me if cmurf can reproduce on will
16:48:24 <roshi> seems we're mostly +1 on this
16:48:43 <roshi> how strongly do people feel about punting for more info?
16:48:53 <adamw> i don't mind if we +1 it, we can always change our minds
16:49:51 <kparal> people, welcome your qa overlords!
16:49:56 * kparal rubs his hands
16:50:05 <roshi> lol
16:50:12 <Kohane> To me is a +1
16:50:21 <Kohane> LOL
16:50:29 <adamw> i like to keep people on their toes
16:51:16 <roshi> proposed #agreed - AcceptedBlocker - RHBZ#1442631 - This bug is a clear violation of the following criterion: "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional." However, we may reconsider this if it turns out to not impact as many people as we fear.
16:52:22 <Kohane> ack
16:52:38 <adamw> ack
16:52:51 <kparal> ack
16:52:51 <roshi> #agreed - AcceptedBlocker - RHBZ#1442631 - This bug is a clear violation of the following criterion: "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional." However, we may reconsider this if it turns out to not impact as many people as we fear.
16:52:56 <roshi> #topic (1429711) [abrt] setroubleshoot-server: sighandler(): service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set
16:53:00 <roshi> #link https://bugzilla.redhat.com/show_bug.cgi?id=1429711
16:53:03 <roshi> #info Proposed Blocker, setroubleshoot, NEW
16:53:04 <roshi> last one :)
16:53:54 <Kohane> Uhm! I don't know this one.
16:54:16 <roshi> +1
16:54:57 <Kohane> +1
16:55:38 <adamw> well, it's a crash in setroubleshoot
16:55:49 <adamw> but
16:56:05 <adamw> if this was happening every time, openqa ought to be seeing it..
16:56:14 <kparal> we have 77 total crash count on F26
16:56:20 <adamw> sgallagh: are you seeing this consistently?
16:56:23 <kparal> https://retrace.fedoraproject.org/faf/reports/1518755/
16:56:35 <kparal> 56 unique, not sure if it means unique users
16:57:15 <sgallagh> adamw: I haven't been keeping track
16:58:40 <adamw> when i saw it, it was an i686 install
16:58:44 <adamw> i686 isn't release blocking...
16:59:11 <roshi> ah, I missed that it was 32bit
16:59:24 <Kohane> I didn't see it at all, for what is worth.
17:00:55 <adamw> well, the bug has the arch set to x86_64
17:00:56 <kparal> it's interesting that FAF only contains x86_64 reports
17:00:58 <adamw> which i think is done automatically
17:01:04 <sgallagh> I saw it on x86_64
17:01:20 <kparal> so the one from Adam wasn't counted by FAF
17:02:14 <kparal> so wait until we see it more often?
17:02:36 <adamw> maybe just ask people (that is, *you* people) to run some installs and see if it happens
17:02:45 <adamw> 77 hits is...quite a lot, though...
17:04:09 <Kohane> So...? What are we going to do?
17:05:26 <adamw> panic?
17:05:43 <roshi> I say +1 with an admonition to get more reproducers
17:05:44 <adamw> i think i'd be happiest if we try and look into this ourselves a bit, but i can go with a +1.
17:05:56 * roshi is fine with a punt as well
17:06:05 <roshi> +1 punt, and dig into it a big more
17:06:13 <roshi> s/big/bit/g
17:06:27 <Kohane> +1 to punt.
17:07:52 <roshi> proposed #agreed - Punt - RHBZ#1429711 - We'd like to have some more people reproduce this before we accept it as a blocker.
17:08:06 <kparal> ack
17:08:57 <adamw> ack
17:09:11 <roshi> #agreed - Punt - RHBZ#1429711 - We'd like to have some more people reproduce this before we accept it as a blocker.
17:10:32 <roshi> #topic Open Floor
17:10:38 <roshi> that's all we have for today
17:11:03 <roshi> anyone have an accepted blocker they want to look at before we adjorn, or do we just want to get back to our regularly scheduled programming?
17:11:11 <adamw> i think i'm good
17:12:04 * roshi sets the fuse...
17:12:07 <roshi> thanks for coming folks!
17:12:10 <roshi> 3...
17:12:15 <kparal> thanks everyone
17:12:30 <Kohane> Welcome! See you!
17:12:34 <adamw> thanks roshi!
17:12:41 <roshi> np :)
17:12:42 <roshi> 2...
17:12:54 <roshi> I'm just typing the words, I have the easy job :D
17:13:04 <roshi> 1...
17:13:26 <roshi> #endmeeting