17:01:09 <adamw> #startmeeting F28-blocker-review
17:01:09 <zodbot> Meeting started Mon Jan  8 17:01:09 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:09 <zodbot> The meeting name has been set to 'f28-blocker-review'
17:01:09 <adamw> #meetingname F28-blocker-review
17:01:10 <adamw> #topic Roll Call
17:01:10 <zodbot> The meeting name has been set to 'f28-blocker-review'
17:01:19 <adamw> morning folks! who's around for blocker review fun times?
17:04:34 * pwhalen is here
17:04:36 * adamw kicks feet, watches dust balls roll by
17:04:38 <adamw> hi pwhalen!
17:06:26 <adamw> hi tenk, kohane
17:06:39 <Kohane> Hi adamw tenk
17:06:43 <tenk> hi adamw
17:06:45 * Kohane waves
17:07:08 <tenk> i am in France, so in a good timezone for the meeting :)
17:07:24 <tenk> comeback to japan tomorrow
17:07:50 * pschindl_wfh is here
17:08:08 <adamw> hi pschindl
17:08:19 <adamw> sgallagh: tflink: pingles?
17:08:24 <adamw> mboddu: pingity?
17:08:26 <pschindl_wfh> Hi Adam. Hi all.
17:08:48 <adamw> nirik: kparal: pingaroonie?
17:08:52 <Kohane> tenk: how do you find France?
17:09:06 <adamw> Kohane: i find it's easiest to find Germany and then head west
17:09:11 <adamw> ba-dum *tish*
17:09:22 <tenk> Kohane: it's my home country so good :)
17:10:15 <adamw> you know, cos, france is west of germany...and find can mean...you know what, never mind
17:10:18 <adamw> *pouts*
17:10:36 <Kohane> adamw: LOL  for me that's sure, I'm in Stuttgart
17:10:47 <adamw> aha, suse-land
17:10:52 * adamw checks if kohane is a spy
17:10:57 <adamw> :P
17:10:59 <Kohane> LOL
17:11:11 <adamw> #chair pwhalen kohane
17:11:11 <zodbot> Current chairs: adamw kohane pwhalen
17:11:23 <Kohane> Funnily enough, I found more Fedora than Suse users.
17:11:28 <adamw> huh, interesting
17:11:42 <adamw> ok so, we're a bit low on numbers, but let's get started and see how we do...
17:11:43 <adamw> #topic Introduction
17:11:44 <adamw> Why are we here?
17:11:44 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:11:44 <adamw> #info We'll be following the process outlined at:
17:11:45 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:11:47 <adamw> #info The bugs up for review today are available at:
17:11:48 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
17:11:50 <adamw> #info The criteria for release blocking bugs can be found at:
17:11:54 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
17:11:56 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria
17:11:58 <adamw> #link https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria
17:14:01 <adamw> we have:
17:14:11 <adamw> #info 6 Proposed Blockers (Beta)
17:14:25 <Kohane> I was looking at them, yeah...
17:14:35 <adamw> does anyone want to volunteer as secretary?
17:14:55 <pschindl_wfh> I'll do it
17:16:15 <adamw> thanks pschindl
17:16:21 <adamw> #info pschindl_wfh will secretarialize
17:16:35 <adamw> alrighty, let's get to the proposed Beta blockers, then
17:16:41 <adamw> #topic (1323012) AttributeError: '_ped.Partition' object has no attribute 'setName'
17:16:42 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1323012
17:16:42 <adamw> #info Proposed Blocker, anaconda, POST
17:16:55 <adamw> this one may be fixed already, let me check
17:17:30 <Kohane> Give me second to read, please, because I don't get it by the description
17:18:15 <adamw> yeah, this is fixed.
17:18:24 <adamw> Kohane: it was a crasher during all UEFI installs.
17:18:41 <Kohane> Ah.
17:18:45 <Kohane> Okay.
17:18:49 <adamw> #info this is fixed in current Rawhide, bug can be closed.
17:19:01 <adamw> so, we don't need to do anything for that one. moving on
17:19:46 <adamw> #topic (1526861) unable to do an installation when a boot option is added
17:19:47 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1526861
17:19:47 <adamw> #info Proposed Blocker, anaconda, MODIFIED
17:20:17 <adamw> erf, this one. so, this one is 'fixed', but i think the fix was wrong.
17:20:26 <Kohane> How so?
17:20:28 <adamw> so far as this bug is concerned at least, though, it's gone.
17:20:36 <adamw> Kohane: bit of a long story - see https://github.com/rhinstaller/anaconda/commit/ab29bdff2e041ec4f354c3334d8aa15ea8366a17#commitcomment-26397639
17:20:47 <Kohane> Oh. Okay. Thanks.
17:22:07 <Kohane> So. Is this fixed...?
17:22:29 <adamw> yeah...
17:22:48 <adamw> probably the best thing is to close this, and i'll try to figure out precisely what's broken by the removal of the escape code and file a new bug for that
17:23:00 <pwhalen> sounds good
17:23:17 <adamw> #info this bug is fixed in current Rawhide: adamw has some issues with other consequences of the chosen fix, but the actual bug reported here is definitely gone, so this can also be closed
17:23:17 <Kohane> Yeah, sounds good.
17:23:29 <adamw> #topic (1530428) AttributeError: 'FC3_Cdrom' object has no attribute 'url'
17:23:29 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1530428
17:23:29 <adamw> #info Proposed Blocker, anaconda, NEW
17:24:33 <Kohane> This is one that I don't understand.
17:25:19 <adamw> i think lnie is saying that there's a crash when selecting an http install source with the Server DVD iso, but not with the Server netinst iso
17:25:42 <Kohane> Ah.
17:26:06 <adamw> however, the same test in openQA passed: https://openqa.fedoraproject.org/tests/184723#
17:26:24 <adamw> so...we need to look into this one a bit further, i guess
17:26:55 <pwhalen> I havent tested the isos yet, will do so shortly. +1 as its written or punt til we reproduce?
17:27:22 <Kohane> punt
17:27:30 <Kohane> My humble opinion
17:27:43 <pwhalen> wfm
17:27:46 <adamw> i'd say punt till we're sure about the reproducer, yah
17:28:02 <pwhalen> will leave a note if I reproduce today
17:28:47 <tenk> +1 punt
17:29:29 <pschindl_wfh> +1 punt
17:29:53 <Kohane> +1 punt
17:30:18 <adamw> proposed #agreed 1530428 - punt (delay decision) - this sounds bad, but openQA has a test covering similar ground that is passing. we need clearer details on the scenario and an independent reproduction before accepting this as a blocker
17:30:36 <pschindl_wfh> ack
17:30:41 <Kohane> ack
17:31:05 <pwhalen> ack
17:31:15 <adamw> #agreed 1530428 - punt (delay decision) - this sounds bad, but openQA has a test covering similar ground that is passing. we need clearer details on the scenario and an independent reproduction before accepting this as a blocker
17:31:16 <tenk> ack
17:31:31 <Kohane> ack
17:32:19 <adamw> you don't have to ack the actual agreed, that's okay :P
17:32:31 <adamw> #topic (1528103) Crash when creating a container (VG, RAID set etc.): TypeError: suggest_container_name() got an unexpected keyword argument 'hostname'
17:32:31 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1528103
17:32:31 <adamw> #info Proposed Blocker, blivet-gui, MODIFIED
17:32:36 <adamw> this is another one that might be fixed, let me see
17:32:52 <adamw> sorry, i should've gone through and closed the fixed ones before the meeting, but i'm trying not to work on weekends lately
17:33:17 <Kohane> Okay, no worries.
17:33:58 <adamw> yup, install_blivet_btrfs is passing on openqa, so this is fixed.
17:34:08 <adamw> #info this is another one that is fixed with latest Rawhide packages, can be closed, no vote needed.
17:34:16 <adamw> #topic (1531398) F28 keys missing from F26
17:34:17 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1531398
17:34:17 <adamw> #info Proposed Blocker, fedora-repos, ON_QA
17:34:38 <Kohane> Good. Another fixed bug.
17:35:56 <adamw> so, this one affects upgrades from F26 to Rawhide (and will affect upgrades to F28 when it branches, if not fixed by then)
17:36:08 <Kohane> Yes.
17:36:19 <adamw> obviously to check the package signatures when upgrading from release X to release Y, release X needs to have the public key for release Y
17:36:28 <adamw> but F26 did not have the F28 public key.
17:36:35 <Kohane> Why?
17:36:38 <adamw> just an oversight
17:36:52 <Kohane> I mean, why is missing in 26 but not in 27?
17:36:56 <adamw> oh, just timing
17:37:15 <adamw> the F28 key was created after F26 was already released
17:37:22 <adamw> so we have to do a post-release update to add it to F26
17:37:28 <Kohane> Ah. Okay.
17:37:36 <Kohane> So it's easy to fix?
17:38:11 <adamw> oh yeah. it's ON_QA already, which means the fix has been sent to testing
17:38:24 <adamw> i'll have to check it out later
17:38:27 <adamw> but for now...
17:38:30 <pwhalen> same
17:38:35 <pwhalen> +1
17:38:43 <Kohane> Oh, nice.
17:39:10 <adamw> proposed #agreed 1531398 - AcceptedPreviousRelease - this is accepted as a 'previous release' blocker, meaning it needs fixing in F26 before F28 can go out, as a violation of Beta criterion "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed"
17:39:17 <tenk> ack
17:39:37 <Kohane> ack
17:39:38 <pwhalen> ack
17:39:39 <pschindl_wfh> ack
17:39:41 <sumantro> ack
17:39:46 <adamw> #agreed 1531398 - AcceptedPreviousRelease - this is accepted as a 'previous release' blocker, meaning it needs fixing in F26 before F28 can go out, as a violation of Beta criterion "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed"
17:39:49 <adamw> hi again sumantro
17:40:12 <adamw> #topic (1527684) Flood of 'read' denials for systemd-journald with selinux-policy-3.13.1-306.fc28
17:40:12 <sumantro> hi adamw , bit under the weather :P took med and came back
17:40:12 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1527684
17:40:12 <adamw> #info Proposed Blocker, selinux-policy-targeted, ASSIGNED
17:40:21 <adamw> sumantro: oof :( go get some rest when we're done here!
17:40:23 <adamw> this is the last one
17:40:41 <adamw> sumantro: it's always better to rest up when you're sick than push yourself to work
17:40:52 <pwhalen> +1
17:41:09 <sumantro> thats okay , 1 is still left :P will pull through :D
17:41:23 <adamw> so, lukas thought he'd fixed this, but i'm pretty sure it's still happening
17:41:38 <adamw> openQA is set to check for AVCs after most installs, and it still sees these denials on just about all installs
17:41:48 <pwhalen> adamw, testing yesterdays compose it's still there
17:41:54 <adamw> pwhalen: cool, glad to have confirmation
17:42:02 <adamw> pwhalen: can you add a note to the bug so lukas knows it's not just me and my bots? :)
17:42:08 <pwhalen> sure
17:42:10 <adamw> thanks
17:43:27 <adamw> so, on the basis that this messes with logging, i'm +1 as a violation of ""A system logging infrastructure must be available, enabled by default, and working"
17:43:46 <Kohane> Yes, me too.
17:43:47 <sumantro> +1
17:43:47 <Kohane> +1
17:44:17 <adamw> (it's not actually a violation of the criterion about 'no SELinux alerts', because GNOME doesn't actually notify about this, i guess because it isn't part of the user session)
17:44:24 <pschindl_wfh> +1
17:44:33 <pwhalen> adamw, xfce does
17:44:40 <adamw> pwhalen: aha, so it violates that too, for arm
17:44:48 <pwhalen> yea
17:45:02 <tenk> +&
17:45:04 <tenk> +1
17:45:06 <Kohane> adamw: What do you mean? I always get SELinux alerts when I install first time.
17:45:24 <adamw> Kohane: huh, you do? the openQA test doesn't get any. interesting
17:45:31 <adamw> Kohane: is it these denials that you are notified about?
17:46:02 <sfix> elinks http://google.com/
17:46:19 * mboddu just came back from lunch
17:46:21 <adamw> sfix: wrong window, but i can send you some javascript that'll spy on you if you like :P
17:46:45 <sumantro> adamw, lol :P
17:46:45 <pwhalen> heh
17:47:05 <mboddu> haha :D
17:47:06 <Kohane> Sometimes. I always get SELinux notifications when I make a fresh install. And the last time I kept getting them for over a month.
17:47:17 <Kohane> Which is both annoying and surprising, heh
17:47:28 <adamw> proposed #agreed 1527684 - AcceptedBlocker (Beta) - this is accepted as a violation of Basic criterion "A system logging infrastructure must be available, enabled by default, and working" - also violates Final criterion "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop" for Xfce/ARM
17:47:29 <adamw> and possibly GNOME/x86_64
17:47:33 <adamw> grr, i'll trim that a bit.
17:48:05 <pwhalen> ack
17:48:06 <adamw> proposed #agreed 1527684 - AcceptedBlocker (Beta) - this is accepted as a violation of Basic criterion "A system logging infrastructure must be available, enabled by default, and working" - also Final criterion "There must be no SELinux denial notifications...on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop" for Xfce, possibly GNOME
17:48:11 <sumantro> ack
17:48:13 <pwhalen> ack
17:48:14 <tenk> ack
17:48:16 <Kohane> ack
17:48:19 <pschindl_wfh> ack
17:48:21 <adamw> #agreed 1527684 - AcceptedBlocker (Beta) - this is accepted as a violation of Basic criterion "A system logging infrastructure must be available, enabled by default, and working" - also Final criterion "There must be no SELinux denial notifications...on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop" for Xfce, possibly GNOME
17:48:37 <adamw> alrighty, that's all the proposed blockers
17:48:43 <Kohane> Good.
17:48:49 <adamw> i don't think there's any value to going through accepted blockers this early
17:48:53 <adamw> so...
17:48:54 <adamw> #topic Open floor
17:48:57 <adamw> any other business, folks?
17:49:07 <Kohane> I can't remember any.
17:49:27 <sumantro> nothing from my end
17:49:30 <pwhalen> adamw, heads up we have the firefox FTBFS issue again on armv7. I've not yet nominated it, but xfce currently has no browser
17:49:56 <adamw> pwhalen: zoiks, thanks for the heads-up - that'll definitely need fixing
17:49:59 <pwhalen> https://bugzilla.redhat.com/show_bug.cgi?id=1523912
17:50:12 <adamw> #info Firefox is FTBFS on ARM again, pwhalen is on it: https://bugzilla.redhat.com/show_bug.cgi?id=1523912
17:50:14 <pwhalen> I moved it to rust last week, hopefully get some additional eyes
17:50:42 <sumantro> pwhalen thanks for bringing this up!
17:51:13 * adamw cc's self
17:51:58 <adamw> thanks for coming and voting, everyone!
17:52:03 <adamw> i guess we're done here
17:52:12 <pwhalen> thanks folks!
17:52:17 <tenk> thx all
17:52:29 <Kohane> Thanks adamw !
17:52:34 <adamw> #endmeeting