#fedora-blocker-review: F28-blocker-review

Meeting started by adamw at 16:02:30 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:30)
  2. Introduction (adamw, 16:09:56)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:09:56)
    2. We'll be following the process outlined at: (adamw, 16:09:56)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:09:56)
    4. The bugs up for review today are available at: (adamw, 16:09:58)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:10:00)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:10:04)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:10:06)
    8. https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria (adamw, 16:10:08)
    9. https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria (adamw, 16:10:10)
    10. 7 Proposed Blockers (adamw, 16:11:24)
    11. 4 Accepted Blockers (adamw, 16:11:24)
    12. 0 Accepted 0-day Blockers (adamw, 16:11:24)
    13. 1 Accepted Previous Release Blockers (adamw, 16:11:25)
    14. 3 Proposed Freeze Exceptions (adamw, 16:11:25)
    15. 6 Accepted Freeze Exceptions (adamw, 16:11:28)
    16. for Final, we have: (adamw, 16:11:38)
    17. 5 Proposed Blockers (adamw, 16:11:39)
    18. 2 Accepted Blockers (adamw, 16:11:39)
    19. 1 Proposed Freeze Exceptions (adamw, 16:11:43)
    20. coremodule will secretarialize (adamw, 16:13:11)
    21. we'll start with proposed Beta blockers (adamw, 16:13:36)

  3. (1557472) Anaconda installing in text mode fails to report errors to Bugzilla. (adamw, 16:13:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557472 (adamw, 16:13:37)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:13:37)
    3. AGREED: 1557472 - AcceptedBlocker (Beta) - this is accepted as a conditional violation of Basic criterion "The installer must be able to report failures to Bugzilla, with appropriate information included", we consider 'that always crashes in text mode' to be a sufficient violation to constitute a blocker (adamw, 16:20:16)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1557463 (lruzicka, 16:20:52)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=1557471 (lruzicka, 16:21:02)
    6. AGREED: 1557472 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - on second thought, we make this an FE for Beta and blocker for Final, as anaconda did manage to file the bug, it just crashed afterwards. we think this is OK for Beta (though fixing it would be nice), but should block Final. (adamw, 16:26:51)

  4. (1557529) Setting root password on live images fails since anaconda-28.22.2-3.fc28 (adamw, 16:27:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557529 (adamw, 16:27:01)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:27:01)
    3. AGREED: 1557529 - AcceptedBlocker (Beta) - this is accepted as a blocker as a violation of "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system", read as applying to the root account (adamw, 16:32:24)

  5. (1558022) upgrading from fedora 27 server to fedora 28 server fails rpm transaction for docker (adamw, 16:33:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1558022 (adamw, 16:33:39)
    2. Proposed Blocker, docker, NEW (adamw, 16:33:39)
    3. https://openqa.fedoraproject.org/tests/207089 doesn't show it... (adamw, 16:34:26)
    4. http://dl.fedoraproject.org/pub/fedora/linux/development/28/Server/x86_64/os/Packages/d/ (kparal, 16:37:17)
    5. AGREED: 1558022 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - it's not clear if this is ARM-only, 32-bit-only, or affects all arches. however, we are fairly sure Docker is not in any default release-blocking package sets, so it cannot be a blocker. we accept it as a freeze exception, though, as it's obviously a significant package and fixing upgrade issues is desirable. (adamw, 16:53:00)

  6. (1557609) Login to FreeIPA web UI as regular user fails (adamw, 16:54:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557609 (adamw, 16:54:53)
    2. Proposed Blocker, freeipa, NEW (adamw, 16:54:53)
    3. AGREED: 1557609 - AcceptedBlocker (Beta) - this is accepted as a Beta blocker as a violation of "The core functional requirements for all Featured Server Roles must be met, without any workarounds being necessary", core requirement "The FreeIPA configuration web UI must be available and allow at least basic configuration of user accounts and permissions" (adamw, 17:01:42)

  7. (1558064) Gnome-software does not allow to work with packages at all. (adamw, 17:01:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1558064 (adamw, 17:01:52)
    2. Proposed Blocker, gnome-software, NEW (adamw, 17:01:52)
    3. AGREED: 1558064 - close as duplicate of 1544193 - investigation during the meeting confirmed that lruzicka's failure was in fact caused by the existing accepted blocker #1544193 (adamw, 17:18:30)

  8. (1557659) aacraid: Host adapter abort request (adamw, 17:18:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557659 (adamw, 17:18:42)
    2. Proposed Blocker, kernel, NEW (adamw, 17:18:42)
    3. AGREED: 1557659 - punt (delay decision) - so long as this involves a combination (RAID device accessed over FCoE) we think that's too esoteric to be considered as violating the criteria. if testing indicates that aacraid is entirely broken for a *local* adapter, we will consider whether that is blocker-worthy. (adamw, 17:43:56)

  9. (1557957) TypeError: __init__() got an unexpected keyword argument 'wwn' (adamw, 17:44:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557957 (adamw, 17:44:11)
    2. Proposed Blocker, python-blivet, NEW (adamw, 17:44:11)
    3. AGREED: 1557957 - AcceptedBlocker (Beta) - this is accepted as a blocker as a violation of "The installer must be able to detect and install to hardware or firmware RAID storage devices", it looks like a showstopper for all Intel firmware RAID cases, which is one of the most common firmware RAID cases. (adamw, 17:49:10)
    4. next, proposed Beta FEs (adamw, 17:49:34)

  10. (1554966) Include GNOME 3.28.0 in Fedora 28 Beta (adamw, 17:49:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1554966 (adamw, 17:49:40)
    2. Proposed Freeze Exceptions, distribution, ON_QA (adamw, 17:49:40)
    3. AGREED: 1554966 - AcceptedFreezeException (Beta) - in general we like to get the latest GNOME in Beta we plausibly can, so tests are run with up-to-date code, and this fixes several other known bugs. It's been quite extensively tested, with positive results. (adamw, 17:58:16)

  11. (1554279) pconfigintrin.h missing on x86_64 (adamw, 17:59:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1554279 (adamw, 17:59:35)
    2. Proposed Freeze Exceptions, gcc, ASSIGNED (adamw, 17:59:36)
    3. as the proposer, adamw is unproposing this, per gcc maintainer stating the problem is not in f28 (adamw, 18:01:46)

  12. (1554986) [abrt] gnome-software: gs_plugin_loader_app_create(): gnome-software killed by SIGTRAP (adamw, 18:02:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1554986 (adamw, 18:02:31)
    2. Proposed Freeze Exceptions, gnome-software, ON_QA (adamw, 18:02:31)
    3. AGREED: 1554986 - AcceptedFreezeException (Beta) - this should be covered by the 3.28.0 exception, but in case that has to be backed out, we accept this as an FE on its own merits and would accept a separate fix (adamw, 18:08:16)
    4. checking in on accepted Beta blockers (adamw, 18:08:49)

  13. (1520580) Unable to log in on arm disk images (adamw, 18:09:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1520580 (adamw, 18:09:06)
    2. Accepted Blocker, selinux-policy, NEW (adamw, 18:09:06)
    3. there is some progress being made on this now, it seems to be the most concerning of current accepted blockers in terms of getting fixed on time, however. we will continue to monitor it (adamw, 18:14:18)
    4. proposed Final blockers (adamw, 18:14:33)

  14. (1558027) The network.service failed LSB in Fedora Cloud. (adamw, 18:16:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1558027 (adamw, 18:16:34)
    2. Proposed Blocker, initscripts, NEW (adamw, 18:16:34)
    3. AGREED: 1558027 - punt (delay decision) - we certainly think there could be a blocker issue here, but we'd like more clarity on what's going on. we'd particularly like to know if the service fails in our supported cloud environments. (adamw, 18:35:50)

  15. (1555292) Fedora Workstation Live can't resume after suspend when booted from DVD connected via an external drive (adamw, 18:36:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1555292 (adamw, 18:36:02)
    2. Proposed Blocker, kernel, NEW (adamw, 18:36:02)
    3. AGREED: 1555292 - punt (delay decision) - we'd like to do two things before making a decision here: call for wider testing of suspending of live images to see just how commonly it fails, and re-start the desktop@ discussion about whether it would make sense to disable auto-suspend of the live image just on general principles (adamw, 18:56:17)

  16. (1544507) [abrt] pulseaudio: pa_sink_assert_ref(): pulseaudio killed by SIGABRT (adamw, 18:56:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1544507 (adamw, 18:56:21)
    2. Proposed Blocker, pulseaudio, ON_QA (adamw, 18:56:21)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1555115 (roca, 19:03:14)
    4. AGREED: 1544507 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - we accept this as a Beta freeze exception as it appears to affect a lot of commonly-used hardware and will affect live sessions. we accept it as a Final blocker as a conditional violation of "The installed system must be able to play back sound with gstreamer-based applications" (adamw, 19:05:15)

  17. Open floor (adamw, 19:05:31)
    1. per the meeting policy we're over the time limit, so we leave the remaining proposed Final blocker for next meeting (adamw, 19:05:45)


Meeting ended at 19:07:13 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (312)
  2. kparal (108)
  3. lruzicka (72)
  4. kalev (44)
  5. pwhalen (30)
  6. roca (30)
  7. Southern_Gentlem (17)
  8. sumantro (17)
  9. frantisekz (15)
  10. coremodule (12)
  11. zodbot (11)
  12. lbrabec (10)
  13. satellit (6)
  14. mkolman (6)
  15. jforbes (6)
  16. mclasen (3)
  17. nb (1)


Generated by MeetBot 0.1.4.