#fedora-blocker-review: F28-blocker-review

Meeting started by adamw at 16:00:47 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:51)
  2. Introduction (adamw, 16:09:13)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:09:13)
    2. We'll be following the process outlined at: (adamw, 16:09:13)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:09:15)
    4. The bugs up for review today are available at: (adamw, 16:09:15)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:09:17)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:09:19)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:09:21)
    8. https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria (adamw, 16:09:25)
    9. https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria (adamw, 16:09:27)
    10. frantisekz will secretarialize (adamw, 16:12:38)
    11. 7 Proposed Blockers (adamw, 16:14:27)
    12. 5 Accepted Blockers (adamw, 16:14:27)
    13. 8 Proposed Freeze Exceptions (adamw, 16:14:32)

  3. (1566621) initial-setup fails on aarch64 disk images (adamw, 16:14:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566621 (adamw, 16:14:46)
    2. Proposed Blocker, anaconda, ASSIGNED (adamw, 16:14:46)
    3. AGREED: 1566621 - AcceptedBlocker (Final) - accepted as a violation of "Release-blocking ARM disk images must boot to the initial-setup utility" (note that at least one blocking aarch64 platform can only deploy from disk images, and the aarch64 Server disk image is marked as release blocking) (adamw, 16:21:33)

  4. (1566344) Traceback from DNF (adamw, 16:21:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566344 (adamw, 16:21:43)
    2. Proposed Blocker, dnf, POST (adamw, 16:21:43)
    3. AGREED: 1566344 - AcceptedBlocker (Final) - accepted as a clear violation of the requirements for Modularity specified in https://bugzilla.redhat.com/show_bug.cgi?id=1537253#c6 , as FESCo has declared modularity blocking F28 (adamw, 16:34:01)

  5. (1566464) crypt in fedora28 does crash in code which works fine under fedora27 (adamw, 16:34:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566464 (adamw, 16:34:18)
    2. Proposed Blocker, glibc, NEW (adamw, 16:34:19)
    3. AGREED: 1566464 - RejectedBlocker (Final) - this is an interesting issue and may well need to be prominently communicated, but nothing cited so far comes close to breaking any of the release criteria. no functional impact on any part of Fedora itself has yet been noted at all. (adamw, 16:46:31)

  6. (1566566) The Fedora 28 KDE Live background wallpaper image is old (from Fedora 27) (adamw, 16:46:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566566 (adamw, 16:46:47)
    2. Proposed Blocker, kde-settings, VERIFIED (adamw, 16:46:47)
    3. AGREED: 1566566 - AcceptedBlocker (Final) - clear violation of "The default desktop background must be different from that of the last two stable releases" (adamw, 16:52:26)

  7. (1567921) libmodulemd emits modulemd-defaults with incorrect keys (adamw, 16:52:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1567921 (adamw, 16:52:37)
    2. Proposed Blocker, libmodulemd, MODIFIED (adamw, 16:52:37)
    3. AGREED: 1567921 - AcceptedBlocker (Final) - accepted as a clear violation of the requirements for Modularity specified in https://bugzilla.redhat.com/show_bug.cgi?id=1537253#c6 , as FESCo has declared modularity blocking F28 (adamw, 16:58:45)

  8. (1567897) Fedora Media Writer shows Fedora 26 instead of Fedora 27 (adamw, 16:58:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1567897 (adamw, 16:58:51)
    2. Proposed Blocker, mediawriter, NEW (adamw, 16:58:51)
    3. AGREED: 1567897 - Accepted0DayBlocker (Final) - accepted as a violation of "Any component which prominently identifies a Fedora release version number, code name, milestone (Beta, Final), or Edition (Workstation, Server, Atomic) must do so correctly", with a liberal interpretation of 'component' - as there is apparently no good process to ensure this is updated at each milestone, we will use the blocker process to do it (adamw, 17:13:18)

  9. (1539327) SELinux is preventing logrotate from using the 'dac_override' capabilities. (adamw, 17:14:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1539327 (adamw, 17:14:26)
    2. Proposed Blocker, selinux-policy, MODIFIED (adamw, 17:14:26)
    3. AGREED: 1539327 - RejectedBlocker (Final) AcceptedFreezeException (Final) - we don't believe this actually happens consistently to all installs right after install, which is the scenario the criterion is intended to prevent, so we don't think it quite qualifies as a release blocker. However, it is a polish issue and should be fixed, so we grant it a freeze exception, and expect it will be fixed soon (adamw, 17:23:20)
    4. moving onto proposed freeze exceptions (adamw, 17:23:41)

  10. (1565369) dvd-ostree installs require network, even though they shouldn't (adamw, 17:23:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1565369 (adamw, 17:23:47)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 17:23:47)
    3. sgallagh reserves the right to say he told us so (adamw, 17:34:42)
    4. AGREED: 1565369 - AcceptedFreezeException (Final) - this isn't a super important fix, but it is to the installer (so cannot be done post-install) and is pretty isolated and safe, so accepted as an FE issue so long as it lands soon (adamw, 17:35:01)

  11. (1567875) Update appstream-data after final freeze (adamw, 17:35:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1567875 (adamw, 17:35:12)
    2. Proposed Freeze Exceptions, appstream-data, NEW (adamw, 17:35:12)
    3. AGREED: 1567875 - AcceptedFreezeException (Final) - there's clearly a benefit to having the appstream data as up to date as possible with the packages included in Final, so updating it after freeze is a good idea (adamw, 17:43:51)

  12. (1558425) [f28] kubelet.service fails to start: Failed to create "/kubepods" cgroup (adamw, 17:43:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1558425 (adamw, 17:43:59)
    2. Proposed Freeze Exceptions, docker, ON_QA (adamw, 17:43:59)
    3. Kohane == Lailah (adamw, 17:48:17)
    4. https://www.youtube.com/watch?v=dwkwjOd7MCU (Southern_Gentlem, 18:04:29)
    5. https://c1.staticflickr.com/4/3110/2790566367_a25b088baf_b.jpg (mclasen, 18:17:49)
    6. AGREED: 1558425 - punt (delay decision) - we don't want to delay *too* long on this, but it's a fairly complex area and it doesn't feel like folks have all the consequences of this entirely worked out yet, so we would like to wait a few days to see if a clearer pictures emerges and then perhaps vote async (in bugzilla comments) on this one (adamw, 18:18:53)

  13. (1567727) f28-backgrounds-extras filename mismatches (adamw, 18:19:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1567727 (adamw, 18:19:43)
    2. Proposed Freeze Exceptions, f28-backgrounds, NEW (adamw, 18:19:43)
    3. AGREED: 1567727 - AcceptedFreezeException (Final) - this affects use of the affected backgrounds on at least the MATE and probably the Cinnamon live images, so it's worth fixing in the frozen package set (adamw, 18:28:09)

  14. (1565757) Update Fedora Server logo for anaconda installer (adamw, 18:28:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1565757 (adamw, 18:28:16)
    2. Proposed Freeze Exceptions, fedora-logos, ON_QA (adamw, 18:28:16)
    3. AGREED: 1565757 - AcceptedFreezeException (Final) - obviously this change can't be done with an update, and it's an important change to Server branding, so we should get it in (adamw, 18:37:41)

  15. (1566464) crypt in fedora28 does crash in code which works fine under fedora27 (adamw, 18:40:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566464 (adamw, 18:40:08)
    2. Proposed Freeze Exceptions, glibc, NEW (adamw, 18:40:08)
    3. AGREED: 1566464 - RejectedFreezeException (Final) - this is rejected at least for now as there's no concrete proposal to actually change a package here, so no way to judge whether such a change would be appropriate. It can be re-proposed with a more specific suggestion if we get to one (adamw, 18:49:28)

  16. (1567229) [f28] kubelet.service fails to start: Failed to create "/kubepods" cgroup (adamw, 18:49:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1567229 (adamw, 18:49:51)
    2. Proposed Freeze Exceptions, runc, ON_QA (adamw, 18:49:51)
    3. this is a clone of the earlier-discussed #1558425 against runc (adamw, 18:50:09)
    4. AGREED: 1567229 - punt (delay decision) - following 1558425, we don't want to delay *too* long on this, but it's a fairly complex area and it doesn't feel like folks have all the consequences of this entirely worked out yet, so we would like to wait a few days to see if a clearer pictures emerges and then perhaps vote async (in bugzilla comments) on this one (adamw, 18:51:55)

  17. (1566140) pyanaconda.bootloader.BootLoaderError: could not find IPL device (adamw, 18:52:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566140 (adamw, 18:52:04)
    2. Proposed Freeze Exceptions, s390utils, ON_QA (adamw, 18:52:04)
    3. AGREED: 1566140 - AcceptedFreezeException (Final) - this is an install time issue (so can't be fully fixed with updates) and is quite serious, would be a blocker on release-blocking arches, so is obviously accepted as an FE (adamw, 18:56:56)

  18. Open floor (adamw, 18:57:08)


Meeting ended at 19:00:28 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (274)
  2. sgallagh (129)
  3. kparal (54)
  4. Lailah (50)
  5. lroca (41)
  6. pwhalen (23)
  7. frantisekz (23)
  8. Kohane (19)
  9. Southern_Gentlem (14)
  10. lbrabec (14)
  11. sumantrom (13)
  12. zodbot (13)
  13. jsmith (6)
  14. mclasen (5)
  15. mkolman (1)


Generated by MeetBot 0.1.4.