#fedora-blocker-review: F28-blocker-review

Meeting started by adamw at 16:00:58 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:58)
  2. Introduction (adamw, 16:05:58)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:05:59)
    2. We'll be following the process outlined at: (adamw, 16:05:59)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:06:00)
    4. The bugs up for review today are available at: (adamw, 16:06:01)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:06:03)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:06:05)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:06:07)
    8. https://fedoraproject.org/wiki/Fedora_28_Beta_Release_Criteria (adamw, 16:06:09)
    9. https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria (adamw, 16:06:11)
    10. frantisekz will secretarialize (adamw, 16:08:13)
    11. 3 Proposed Blockers (adamw, 16:08:33)
    12. 4 Accepted Blockers (adamw, 16:08:33)
    13. 10 Proposed Freeze Exceptions (adamw, 16:08:39)
    14. 4 Accepted Freeze Exceptions (adamw, 16:08:39)
    15. starting with proposed blockers (adamw, 16:12:19)

  3. (1569321) cloud-init-17.1-4.fc28 sets BOOTPROTO=none when using EC2 private network only (adamw, 16:12:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1569321 (adamw, 16:12:25)
    2. Proposed Blocker, cloud-init, MODIFIED (adamw, 16:12:25)
    3. AGREED: 1569231 - AcceptedFreezeException (Final), punt (delay decision) on blocker - this is a judgment call as it depends how common ec2 instances with only private IPs are. We agree this is at least serious enough to be an FE; we don't yet have enough data to be totally sure if it's serious enough to be a blocker. If the fix presents problems, we will revisit whether to make this a blocker. (adamw, 16:26:12)

  4. (1557655) Install to system with HPSA storage fails to boot, stops at "Failed to start udev Wait for Complete Device Initialization" (adamw, 16:26:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557655 (adamw, 16:26:25)
    2. Proposed Blocker, kernel, NEW (adamw, 16:26:25)
    3. https://www.idc.com/getdoc.jsp?containerId=prUS43274017 suggests that HP has the largest chunk of the storage market. Not sure how much of that is HPSA though (sgallagh, 16:31:27)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1557655#c10 (adamw, 16:36:02)
    5. AGREED: 1557655 - RejectedBlocker (Final) - we consider this bug as falling under the "System-specific bugs" footnote to the RAID criterion, and our feeling is that this family of storage controllers is not sufficiently commonly used with Fedora to make this bug constitute a release blocker. (adamw, 16:36:29)

  5. (1570552) Email composing loses Text when clearing selection by clicking (adamw, 16:36:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1570552 (adamw, 16:36:41)
    2. Proposed Blocker, webkit2gtk3, NEW (adamw, 16:36:41)
    3. https://bugzilla.gnome.org/show_bug.cgi?id=794630 has another report of it (adamw, 16:45:17)
    4. AGREED: 1570552 - AcceptedBlocker (Final) - accepted as a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must...withstand a basic functionality test", on the basis that being able to type, select and unselect text is pretty 'basic functionality' for Evolution, dissenting votes from sgallagh and lailah (adamw, 17:01:46)

  6. (1570879) [abrt] gnome-calendar: gcal_date_chooser_day_set_date(): gnome-calendar killed by SIGSEGV (adamw, 17:05:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1570879 (adamw, 17:06:03)
    2. Proposed Blocker, gnome-calendar, NEW (adamw, 17:06:12)
    3. AGREED: 1570879 - RejectedBlocker (Final) - this is close, but we agreed it doesn't quite meet the definition of "basic functionality" - people testing in meeting were able to make gnome-calendar crash by poking at it a bit, but no-one else could exactly reproduce lroca's crash, and just the basics of creating and editing events don't reliably crash the app. We will consider an FE if crasher fix(es) appear (adamw, 17:36:46)
    4. moving onto proposed freeze exception (adamw, 17:37:12)

  7. (1570363) Update to 0.6.46 (adamw, 17:37:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1570363 (adamw, 17:37:28)
    2. Proposed Freeze Exceptions, accountsservice, MODIFIED (adamw, 17:37:28)
    3. AGREED: 1570363 - RejectedFreezeException (Final) - while the improvements to resource use are attractive, the risks of a major update to something as significant as accountsservice this late in the release process substantially outweigh the benefits (adamw, 17:47:40)

  8. (1507940) Root password listed as 'set' on AArch64 disk images (adamw, 17:47:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1507940 (adamw, 17:47:51)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 17:47:51)
    3. AGREED: 1507940 - AcceptedFreezeException (Final) - this can result in the user being locked out of the install, and cannot be fully fixed with a post-release update (adamw, 17:50:01)

  9. (1569045) kickstart file trigger critical exception in anaconda (adamw, 17:50:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1569045 (adamw, 17:50:13)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 17:50:13)
    3. AGREED: 1569045 - AcceptedFreezeException (Final) - this can cause kickstart / console installs to crash on certain systems, and cannot be fixed with a post-release update (adamw, 17:52:37)

  10. (1567622) bluetoothd (bluez 5.49) crashes on start: core-dump (adamw, 17:52:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1567622 (adamw, 17:52:45)
    2. Proposed Freeze Exceptions, bluez, ON_QA (adamw, 17:52:45)
    3. AGREED: 1567622 - AcceptedBlocker (Final) - we are accepting this as a blocker (not just FE) for Final as a violation of criterion "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use", this is a major function which can be reached (and users with bluetooth devices will commonly interact with) via the panel (adamw, 18:00:02)

  11. (1568670) gnome-shell should obsolete caribou in F28+ (adamw, 18:00:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1568670 (adamw, 18:00:38)
    2. Proposed Freeze Exceptions, gnome-shell, NEW (adamw, 18:00:38)
    3. AGREED: 1568670 - RejectedFreezeException (Final) - there's no reason we can think of that this actually needs an FE, it can be done fine as an update (adamw, 18:06:23)

  12. (1566988) repomd.xml GPG signature verification error: gpgme_op_verify() (adamw, 18:06:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1566988 (adamw, 18:06:30)
    2. Proposed Freeze Exceptions, gpgme, NEW (adamw, 18:06:30)
    3. https://bodhi.fedoraproject.org/updates/gpgme-1.10.0-4.fc28 (kalev, 18:14:27)
    4. AGREED: 1566988 - AcceptedFreezeException (Final) - this can affect trying to enable repos from live environments or between install and first update, and could affect installing updates in that case, so fixing it in the release seems worthwhile (adamw, 18:14:46)

  13. (1531140) no console output with acpi on mustang (Warning: unable to open an initial console.) (adamw, 18:15:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1531140 (adamw, 18:15:19)
    2. Proposed Freeze Exceptions, kernel, POST (adamw, 18:15:20)
    3. AGREED: 1531140 - AcceptedFreezeException (Final) - this is a significant issue on affected hardware which can't be fully fixed with an update. however, we note there are several other unrelated changes in current f28 kernel git branch, and would strongly prefer an update to fix this pull in as few other non-blocker/non-FE changes as possible (adamw, 18:22:50)

  14. (1569242) Weak dependencies (Recommends, Supplements) not included in install trees, hence DVD media, ostrees (adamw, 18:23:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1569242 (adamw, 18:23:15)
    2. Proposed Freeze Exceptions, pungi, ASSIGNED (adamw, 18:23:15)
    3. AGREED: 1569242 - punt (delay decision) - we would like to gather more data on this, particularly get a list of all Recommends: and Supplements: in F28 stable at present, and think through the potential consequences of changing or not changing this before making a decision (adamw, 18:37:34)

  15. (1360289) CVE-2016-7103 python-XStatic-jquery-ui: jquery-ui: cross-site scripting in dialog closeText [fedora-all] (adamw, 18:37:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1360289 (adamw, 18:37:44)
    2. Proposed Freeze Exceptions, python-XStatic-jquery-ui, ASSIGNED (adamw, 18:37:44)
    3. AGREED: 1360289 - punt (delay decision) - there's no update here, so we can't really judge how significant the change would be and thus whether it's worth pulling in for a LOW severity CVE (adamw, 18:43:33)
    4. quick accepted blocker check-in (adamw, 18:45:02)

  16. (1560481) Some core applications in Gnome 3.28 are unresponsive and not working on AMD graphics cards (adamw, 18:45:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1560481 (adamw, 18:45:23)
    2. Accepted Blocker, gnome-shell, NEW (adamw, 18:45:23)
    3. there is some progress being made on this, but kalev will talk to jonas and explain the need to do some kind of fix/bodge for this urgently given the release schedule (adamw, 18:56:26)

  17. (1569411) When installing Fedora to dual boot with Windows, Anaconda does not add GRUB entry for Windows. (adamw, 18:56:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1569411 (adamw, 18:56:37)
    2. Accepted Blocker, grub2, NEW (adamw, 18:56:37)
    3. our choices here are: 1) get pjones to actually do it, 2) get someone else with the necessary superpowers to do it (nirik? puiterwijk? who else can do it?), 3) add the dep to anaconda instead as a hack (adamw, 18:58:08)
    4. ACTION: adamw to follow up with pjones again and also try to find someone else who can do a grub2 build with the dep re-added if pjones can't (adamw, 19:00:38)

  18. Open floor (adamw, 19:00:50)


Meeting ended at 19:02:21 UTC (full logs).

Action items

  1. adamw to follow up with pjones again and also try to find someone else who can do a grub2 build with the dep re-added if pjones can't


Action items, by person

  1. adamw
    1. adamw to follow up with pjones again and also try to find someone else who can do a grub2 build with the dep re-added if pjones can't


People present (lines said)

  1. adamw (398)
  2. sgallagh (142)
  3. kalev (82)
  4. lruzicka (70)
  5. lroca (69)
  6. kparal (61)
  7. Lailah (32)
  8. pwhalen (22)
  9. Southern_Gentlem (20)
  10. dustymabe (18)
  11. zodbot (16)
  12. frantisekz (15)
  13. mclasen (9)
  14. jsmith (9)
  15. sumantro (9)
  16. jforbes (9)
  17. lbrabec (7)
  18. pschindl_wfh (5)
  19. Kohane (4)
  20. mkolman (2)
  21. halfline (1)
  22. satellit (1)
  23. nirik (1)


Generated by MeetBot 0.1.4.