#fedora-blocker-review: F29-blocker-review

Meeting started by adamw at 16:01:30 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:30)
  2. Introduction (adamw, 16:07:18)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:18)
    2. We'll be following the process outlined at: (adamw, 16:07:18)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:20)
    4. The bugs up for review today are available at: (adamw, 16:07:21)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:23)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:24)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:26)
    8. https://fedoraproject.org/wiki/Fedora_29_Beta_Release_Criteria (adamw, 16:07:28)
    9. https://fedoraproject.org/wiki/Fedora_29_Final_Release_Criteria (adamw, 16:07:30)
    10. 4 Proposed Blockers (Beta) (adamw, 16:07:34)
    11. 24 Proposed Freeze Exceptions (Beta) (adamw, 16:07:39)
    12. 5 Proposed Blockers (Final) (adamw, 16:07:47)
    13. coremodule will secretarialize (adamw, 16:08:42)
    14. starting with proposed Beta blockers (adamw, 16:09:26)

  3. (1626844) grub2-2.02-54.fc29 fails to boot, drops to grub shell (adamw, 16:09:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1626844 (adamw, 16:09:27)
    2. Proposed Blocker, grub2, NEW (adamw, 16:09:27)
    3. AGREED: 1626844 - punt (delay decision) - this one looks worrying, but so far only one laptop model definitely seems to be affected and we're not sure what the problem is. we'll try and figure out what's going on here today so we can make a decision on it soon (adamw, 16:22:32)

  4. (1624972) No GUI desktop (adamw, 16:23:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1624972 (adamw, 16:23:45)
    2. Proposed Blocker, lightdm, MODIFIED (adamw, 16:23:45)
    3. AGREED: 1624972 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - per pwhalen's testing this seems hardware-specific (he has not seen it, on multiple devices), so we decided it's not bad enough to constitute a blocker. however, we're accepting it as a freeze exception issue as obviously the impact on hardware that *is* affected is significant (adamw, 16:29:20)

  5. (1626413) Add dependency on librepo (adamw, 16:29:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1626413 (adamw, 16:29:26)
    2. Proposed Blocker, lorax, NEW (adamw, 16:29:26)
    3. AGREED: 1626413 - RejectedBlocker (Beta) - this may be a blocker if we pulled in a dnf update that drops the librepo dependency without adding the dependency to lorax. but for now, it is not. we will ensure that any dnf update we pull in comes with any necessary changes to lorax so this does not become a blocker. (adamw, 16:39:25)

  6. (1616269) [abrt] xorg-x11-server-Xwayland: OsLookupColor(): Display server crashed (adamw, 16:39:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1616269 (adamw, 16:39:32)
    2. Proposed Blocker, xorg-x11-server, MODIFIED (adamw, 16:39:32)
    3. AGREED: 1616269 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - we haven't received any indication that lots of people will run into these crashes often, so it doesn't seem the impact is serious enough for blocker status, but there are definitely real crasher bugs here it would be good to have fixed on the media, so it is accepted as an FE issue (adamw, 16:43:06)
    4. that's all the proposed blockers (adamw, 16:43:46)
    5. moving onto proposed FEs (adamw, 16:43:50)

  7. (1627459) Include GNOME 3.30.0 in Fedora 29 Beta (adamw, 16:43:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1627459 (adamw, 16:43:55)
    2. Proposed Freeze Exceptions, distribution, NEW (adamw, 16:43:55)
    3. AGREED: 1627459 - AcceptedFreezeException (Beta) - it's obviously suboptimal to take such a major change so late, but the other choices are to ship Beta with a messy mixed-up GNOME but Final with 3.30+, or to kick 3.30 out of Final. neither of those choices makes much sense, so pulling 3.30 into Beta (even late) seems the least worst option (adamw, 16:50:20)

  8. (1626076) Raspberry Pi fixes and improvements for IoT (lruzicka, 16:55:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1626076 (lruzicka, 16:55:13)
    2. Proposed Freeze Exceptions, bcm283x-firmware, ON_QA (lruzicka, 16:55:13)
    3. AGREED: 1626076 - AcceptedFreezeException (Beta) - We agree that it is important to pull in these fixes for the RasPi as they improve the overall user experience. (coremodule, 17:00:40)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1603511 (coremodule, 17:01:08)

  9. (1600444) Wrong conflicts between dnf and yum prevents upgrade (lruzicka, 17:03:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1600444 (lruzicka, 17:03:12)
    2. Proposed Freeze Exceptions, dnf, NEW (lruzicka, 17:03:12)
    3. AGREED: 1600444- AcceptedFreezeException (Beta) - --allowerasing is not a safe recommendation, pulling this in is the correct way to fix this (coremodule, 17:08:02)

  10. (1624474) Missing icons in leave dialog and leave menu of panel (lruzicka, 17:08:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1624474 (lruzicka, 17:08:19)
    2. Proposed Freeze Exceptions, fedora-icon-theme, NEW (lruzicka, 17:08:19)
    3. AGREED: 1624474 - AcceptedFreezeException (Beta) - Having these icons in the lxqt menu affects the overall user experience and we don't imagine pulling this fix in will cause any problems, so we are voting to accept this bug as an AcceptedFreezeException. (coremodule, 17:10:43)

  11. (1624292) Icons in Xfce menu are absurdly big (lruzicka, 17:11:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1624292 (lruzicka, 17:11:03)
    2. Proposed Freeze Exceptions, garcon, ON_QA (lruzicka, 17:11:03)
    3. AGREED: 1624292 - AcceptedFreezeException (Beta) - Having these icons in xfce the correct size affects the overall user experience and we don't imagine pulling this fix in will cause any problems, so we are voting to accept this bug as an AcceptedFreezeException. (coremodule, 17:13:00)

  12. (1624743) Adding input method dialog broken in gnome-control-center (lruzicka, 17:13:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1624743 (lruzicka, 17:13:32)
    2. Proposed Freeze Exceptions, gnome-desktop3, NEW (lruzicka, 17:13:32)
    3. AGREED: 1624743 - RejectedFreezeException (Beta) - We can't seem to find an easy to understand reason as to why this was suggested as an FE. We will reconsider this bug if the submitting user can validate why he proposed this bug as an FE. (coremodule, 17:18:08)

  13. (1625572) Gnome initial setup runs twice when installing from a Live ISO (lruzicka, 17:18:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1625572 (lruzicka, 17:18:43)
    2. Proposed Freeze Exceptions, gnome-initial-setup, MODIFIED (lruzicka, 17:18:43)
    3. AGREED: 1625572 - RejectedFreezeException (Beta) - The behavior exhibited by gdm in this case is annoying and unnecessary, however a fix has been pushed through so we vote this bug as a RejectedFreezeException. (coremodule, 17:26:47)

  14. (1625142) In Gnome Wayland, forward-key-event does not work well, breaks space key completely (lruzicka, 17:27:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1625142 (lruzicka, 17:27:24)
    2. Proposed Freeze Exceptions, gnome-shell, NEW (lruzicka, 17:27:24)
    3. AGREED: 1625142 - RejectedFreezeException (Beta) – As this fix is still being reviewed upstream and there is potential that it might break something else input-module related, we vote against this as a FreezeException. (coremodule, 17:35:07)

  15. (1622312) golang 1.11 breaks snapd compilation on s390x (lruzicka, 17:35:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1622312 (lruzicka, 17:35:20)
    2. Proposed Freeze Exceptions, golang, MODIFIED (lruzicka, 17:35:20)
    3. AGREED: 1622312 - AcceptedFreezeException (Beta) – This fix will help users build packages on the s390x arch, so we vote AcceptedFreezeException. (coremodule, 17:38:31)

  16. (1622353) kf5-libkdcraw Fails to upgrade from F28 to F29 (lruzicka, 17:39:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1622353 (lruzicka, 17:39:03)
    2. Proposed Freeze Exceptions, kf5-libkdcraw, ON_QA (lruzicka, 17:39:03)
    3. AGREED: 1622353 - AcceptedFreezeException (Beta) – As there is a fix in place that is known to be working, we vote AcceptedFreezeException on this bug. (coremodule, 17:40:34)

  17. (1626002) f29: MATE-Compiz beta spin needs f29-background (lruzicka, 17:40:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1626002 (lruzicka, 17:40:50)
    2. Proposed Freeze Exceptions, mate-desktop, ON_QA (lruzicka, 17:40:50)
    3. AGREED: 1626002 - AcceptedFreezeException (Beta) – This fix will add the F29 backgrounds to the Fedora MATE spin, so we vote AcceptedFreezeException. (coremodule, 17:41:53)

  18. (1625218) Fedora Workstation 29 takes a long time to boot in enforcing mode. (lruzicka, 17:42:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1625218 (lruzicka, 17:42:15)
    2. Proposed Freeze Exceptions, selinux-policy, MODIFIED (lruzicka, 17:42:15)
    3. AGREED: 1625218 - AcceptedFreezeException (Beta) – The times required to boot without a fix for this bug severely inhibit the use of F29 in this case. As such we vote that this bug warrants an AcceptedFreezeException status. (coremodule, 17:44:53)

  19. (1626839) No default editor in Fedora 29 LXQt LiveCD (lruzicka, 17:45:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1626839 (lruzicka, 17:45:11)
    2. Proposed Freeze Exceptions, spin-kickstarts, NEW (lruzicka, 17:45:11)
    3. AGREED: 1626839 - AcceptedFreezeException (Beta) – Having a default editor in the LXQt spin is essential for a good user experience and as such we vote AcceptedFreezeException. (coremodule, 17:48:17)
    4. We have now covered all proposed freeze exceptions except those marked as FTBFS. (lruzicka, 17:48:20)
    5. AGREED: “all FTBFS F29 Beta bugs” - AcceptedFreezeException (Beta) – As these bugs are all FTBFS bugs, we batch accept them all in favor of shipping the Beta on time. We also delegate proper authority to adamw to modify the status of any of these bugs as he sees fit. (coremodule, 18:00:26)

  20. Accepted Blockers review (lruzicka, 18:00:47)
  21. Open discussion (lruzicka, 18:02:08)
  22. (1596540) RuntimeError: C++ std::exception: Exec failed: no such table: main.trans_cmdline (lruzicka, 18:05:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1596540 (lruzicka, 18:05:20)
    2. Accepted Blocker, dnf, ASSIGNED (lruzicka, 18:05:20)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1596540#c30 (adamw, 18:08:11)
    4. there is a clear reproducer for this and dnf team committed to fixing it 'asap' two weeks ago, but there is no update on a fix since then (adamw, 18:08:58)
    5. ACTION: adamw to check with dnf team on status of this and dnf in general (adamw, 18:11:17)

  23. (1616167) dnf doesn't record modular metadata in a local database (lruzicka, 18:16:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1616167 (lruzicka, 18:16:55)
    2. Accepted Blocker, dnf, NEW (lruzicka, 18:16:55)
    3. AGREED: 1616167 - RejectedBlocker (Beta) - per FESCo's decision in https://pagure.io/fesco/issue/1974 , this bug should no longer block Beta. it should be made a proposed blocker for Final for now. (lruzicka, 18:20:11)

  24. (1615969) AArch64 - Error when booting "error: out of memory." (adamw, 18:20:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1615969 (adamw, 18:20:26)
    2. Accepted Blocker, grub2, VERIFIED (adamw, 18:20:26)
    3. this bug was fixed in grub2 -52, but we still have continuing fallout from the changes made in that build and its successors on x86_64 (especially #1626844). we are continuing to try and figure out a grub build that resolves this blocker while not regressing anything on x86_64 UEFI (adamw, 18:25:47)

  25. Open floor (adamw, 18:29:38)


Meeting ended at 18:32:13 UTC (full logs).

Action items

  1. adamw to check with dnf team on status of this and dnf in general


Action items, by person

  1. adamw
    1. adamw to check with dnf team on status of this and dnf in general


People present (lines said)

  1. adamw (218)
  2. cmurf (192)
  3. lruzicka (170)
  4. coremodule (71)
  5. pwhalen (50)
  6. Southern_Gentlem (49)
  7. kalev (31)
  8. sgallagh (26)
  9. zodbot (21)
  10. frantisekz (17)
  11. mboddu (2)
  12. lbrabec (2)
  13. maxamillion (2)
  14. bcotton (1)
  15. halfline (1)
  16. zbyszek (1)
  17. Pharaoh_Atem (1)


Generated by MeetBot 0.1.4.