#fedora-blocker-review: F29-blocker-review

Meeting started by adamw at 16:02:44 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:44)
  2. Introduction (adamw, 16:06:28)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:06:28)
    2. We'll be following the process outlined at: (adamw, 16:06:31)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:06:31)
    4. The bugs up for review today are available at: (adamw, 16:06:32)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:06:33)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:06:35)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:06:37)
    8. https://fedoraproject.org/wiki/Fedora_29_Beta_Release_Criteria (adamw, 16:06:39)
    9. https://fedoraproject.org/wiki/Fedora_29_Final_Release_Criteria (adamw, 16:06:41)
    10. 4 Proposed Blockers (adamw, 16:06:45)
    11. 1 Accepted Blockers (adamw, 16:06:47)
    12. 3 Proposed Freeze Exceptions (adamw, 16:06:49)
    13. 14 Accepted Freeze Exceptions (adamw, 16:06:51)
    14. 8 Proposed Final Blockers (adamw, 16:07:29)
    15. coremodule will secretarialize (adamw, 16:09:36)
    16. starting with proposed Beta blockers... (adamw, 16:09:43)

  3. (1629378) Trying to start dnfdragora causes an error in dnfdaemon and the program cannot continue (adamw, 16:09:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1629378 (adamw, 16:09:51)
    2. Proposed Blocker, dnfdaemon, NEW (adamw, 16:09:51)
    3. AGREED: 1629378 - AcceptedBlocker (Beta) - this clearly violates Beta criterion "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)" for Xfce, which is a release-blocking desktop for 32-bit ARM (adamw, 16:20:53)

  4. (1629628) Default F29 Wallpaper is Solid Black on XFCE/ARM (adamw, 16:21:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1629628 (adamw, 16:21:01)
    2. Proposed Blocker, f29-backgrounds, NEW (adamw, 16:21:01)
    3. AGREED: 1629628 - RejectedBlocker (Beta), AcceptedFreezeException (Beta) - we agree this does not violate the criteria as a black background is "different" from previous stable. We accept it as a freeze exception issue assuming pwhalen and frantisekz can figure out exactly what's going on (adamw, 16:29:50)

  5. (1629340) PackageKit update crashes at end of transaction with "TransactionItem state is not set: grub2-tools-1:2.02-57.fc29.x86_64" (adamw, 16:30:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1629340 (adamw, 16:30:05)
    2. Proposed Blocker, PackageKit, NEW (adamw, 16:30:05)
    3. AGREED: 1629340 - AcceptedBlocker (Beta) - this seems a clear violation of Beta criterion "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)" for Workstation, with current repo state (adamw, 16:40:39)

  6. (1628495) In UEFI mode, Fedora 29 cannot be installed in Safe Graphics Mode (adamw, 16:40:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628495 (adamw, 16:40:48)
    2. Proposed Blocker, xorg-x11-server, NEW (adamw, 16:40:48)
    3. AGREED: 1628495 - punt (delay decision) - ajax has suggested this may only affect hardware that works fine with a native driver, which would make it likely not a blocker, but he is not here and we're not 100% sure on that, so we will delay the decision (adamw, 16:49:52)

  7. (1629935) freeipa-server cannot be installed on aarch64 (adamw, 16:49:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1629935 (adamw, 16:49:55)
    2. Proposed Blocker, pki-core, MODIFIED (adamw, 16:49:55)
    3. AGREED: 1629935 - AcceptedBlocker (Beta) - this clearly violates all the FreeIPA-related criteria for aarch64, which is a release-blocking arch for Server (adamw, 16:54:26)
    4. onto proposed FEs (adamw, 16:54:53)

  8. (1622312) golang 1.11 breaks snapd compilation on s390x (adamw, 16:55:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1622312 (adamw, 16:55:32)
    2. Proposed Freeze Exceptions, golang, MODIFIED (adamw, 16:55:32)
    3. AGREED: 1622312 - AcceptedFreezeException (Beta) - accepted as a freeze exception to resolve snapd upgrade path issues (adamw, 17:04:23)

  9. (1628462) input method cannot commit any strings in gnome-terminal with multiple Tabs (adamw, 17:04:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628462 (adamw, 17:04:30)
    2. Proposed Freeze Exceptions, gtk3, NEW (adamw, 17:04:30)
    3. AGREED: 1628462 - AcceptedFreezeException (Beta) - this is inconvenient for users of input methods in the Workstation live and would benefit from a fix in the compose (adamw, 17:11:24)

  10. (1628263) wifi doesnt connect from the drop down in live WS F29 Beta 1.1 (adamw, 17:11:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628263 (adamw, 17:11:31)
    2. Proposed Freeze Exceptions, NetworkManager, NEW (adamw, 17:11:31)
    3. AGREED: 1628263 - AcceptedFreezeException (Beta) - this is a prominent bug in the Workstation live, it's the natural way for people to try and use wifi, so fixing it would be desirable (adamw, 17:16:30)
    4. that's all proposed FEs, a quick look at the accepted blocker: (adamw, 17:17:07)

  11. (1628355) F29 Beta RC1 does not boot on Raspberry Pi (adamw, 17:17:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628355 (adamw, 17:17:09)
    2. Accepted Blocker, spin-kickstarts, VERIFIED (adamw, 17:17:09)
    3. this seems resolved in RC3, we will close it (adamw, 17:18:36)
    4. moving onto proposed Final blockers (adamw, 17:19:10)

  12. (1585036) there isn't 'switch user' option in the list (adamw, 17:19:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1585036 (adamw, 17:19:23)
    2. Proposed Blocker, accountsservice, NEW (adamw, 17:19:23)
    3. AGREED: 1585036 - RejectedBlocker (Final) - the criteria intentionally do not cover user switching, so this is not violating any of them (adamw, 17:24:13)

  13. (1627757) The installer failed to use an iscsi target create by targetcli (adamw, 17:24:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1627757 (adamw, 17:24:19)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:24:19)
    3. AGREED: 1627757 - AcceptedBlocker (Final) - this seems to violate Final criterion "The installer must be able to detect (if possible) and install to supported network-attached storage devices", iSCSI is a 'supported' network-attached protocol. we will look further into when this does and does not happen (adamw, 17:29:33)

  14. (1625645) selinux prevents loading of anything inside /etc/cron.d (adamw, 17:30:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1625645 (adamw, 17:30:27)
    2. Proposed Blocker, cronie, ASSIGNED (adamw, 17:30:27)
    3. AGREED: 1625645 - punt (delay decision) - this doesn't seem to be violating any existing criteria, but the group was fairly worried about it on merit. we will delay the decision to investigate further and to provide an opportunity for someone to propose a new criterion if they want to (adamw, 17:41:14)

  15. (1596827) DNF 3 crashes with "UNIQUE constraint failed" for comps_environment_group.groupid or trans_with.trans_id (adamw, 17:41:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1596827 (adamw, 17:41:44)
    2. Proposed Blocker, dnf, NEW (adamw, 17:41:44)
    3. AGREED: 1596827 - AcceptedBlocker (Final) - on the face of it, a reproducible crash in normal dnf operation seems a sufficient violation of Basic criterion "The installed system must be able appropriately to install, remove, and update software with the default console tool for the relevant software type" to block Final. we will ask dnf team for more investigation of this (adamw, 17:52:44)

  16. (1628255) glibc: Sticky EOF for fgetc/fread breaks stream concatenation via dup2 (adamw, 17:52:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628255 (adamw, 17:52:53)
    2. Proposed Blocker, glibc, NEW (adamw, 17:52:53)
    3. AGREED: 1628255 - RejectedBlocker (Final) - this is obviously an annoying bug for some, but release criteria don't cover printing in any way, never mind network printing (adamw, 17:57:45)

  17. (1628244) gnome-documents will not start (adamw, 17:57:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628244 (adamw, 17:57:54)
    2. Proposed Blocker, gnome-documents, ON_QA (adamw, 17:57:54)
    3. AGREED: 1628244 - AcceptedBlocker (Final) - clear violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test" (adamw, 18:00:40)

  18. (1626862) Broken Fedora/Windows dualboot (adamw, 18:00:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1626862 (adamw, 18:00:45)
    2. Proposed Blocker, grub2, NEW (adamw, 18:00:45)
    3. AGREED: 1626862 - punt (delay decision) - this is a potential violation of the dual-boot criterion, but it seems a little unclear what's going on and if it's somehow system-specific. we will delay the decision to try and gather more info (adamw, 18:04:09)

  19. (1628263) wifi doesnt connect from the drop down in live WS F29 Beta 1.1 (adamw, 18:04:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628263 (adamw, 18:04:16)
    2. Proposed Blocker, NetworkManager, NEW (adamw, 18:04:16)
    3. AGREED: 1628263 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" (adamw, 18:08:07)

  20. Open floor (adamw, 18:10:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628859 came out (sumantro, 18:10:51)


Meeting ended at 18:19:04 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (231)
  2. cmurf (48)
  3. frantisekz (45)
  4. pwhalen (42)
  5. lruzicka2 (34)
  6. sumantro (27)
  7. Son_Goku (27)
  8. lbrabec (17)
  9. zodbot (16)
  10. contyk (12)
  11. sgallagh (5)
  12. coremodule (5)
  13. nirik (2)
  14. bcotton (2)
  15. mclasen (2)
  16. nb (1)
  17. i_dont_lock_pc (1)


Generated by MeetBot 0.1.4.