#fedora-blocker-review: F29-blocker-review

Meeting started by adamw at 16:00:11 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:12)
  2. Introduction (adamw, 16:10:45)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:10:45)
    2. We'll be following the process outlined at: (adamw, 16:10:45)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:10:47)
    4. The bugs up for review today are available at: (adamw, 16:10:47)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:10:50)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:10:51)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:10:53)
    8. https://fedoraproject.org/wiki/Fedora_29_Beta_Release_Criteria (adamw, 16:10:57)
    9. https://fedoraproject.org/wiki/Fedora_29_Final_Release_Criteria (adamw, 16:10:59)
    10. 7 Proposed Blockers (adamw, 16:11:03)
    11. 5 Accepted Blockers (adamw, 16:11:05)
    12. 4 Proposed Freeze Exceptions (adamw, 16:11:07)
    13. 7 Accepted Freeze Exceptions (adamw, 16:11:09)
    14. coremodule will secretarializie (adamw, 16:11:13)
    15. starting with proposed blockers (adamw, 16:12:34)

  3. (1637927) iSCSI Reverse CHAP authentication not working (adamw, 16:12:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637927 (adamw, 16:12:41)
    2. Proposed Blocker, iscsi-initiator-utils, NEW (adamw, 16:12:41)
    3. AGREED: 1637927 - RejectedBlocker AcceptedFreezeException (Final) - we believe enough iSCSI configs now work that this remaining problematic one should not be considered a blocker, but it would be great to fix it for the release if we can (adamw, 16:23:14)

  4. (1636743) dnf update --refresh fails for repo_gpgcheck=1 (adamw, 16:23:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1636743 (adamw, 16:23:22)
    2. Proposed Blocker, dnf, MODIFIED (adamw, 16:23:22)
    3. AGREED: 1636743 - RejectedBlocker AcceptedFreezeException (Final) - this is not believed to affect any official / out-of-the-box repositories and thus does not break any release criteria. As the fix is said to be simple and could benefit some folks on first boot, it is accepted as a freeze exception (adamw, 16:33:01)

  5. (1637148) dnf doesn't resolve variables in mirrorlists (adamw, 16:33:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637148 (adamw, 16:33:14)
    2. Proposed Blocker, dnf, ASSIGNED (adamw, 16:33:14)
    3. AGREED: 1637148 - RejectedBlocker AcceptedFreezeException (Final) - this is not believed to affect any official / out-of-the-box repositories and thus does not break any release criteria. As this could benefit some folks on first boot, it is accepted as a freeze exception if the fix is simple and testable (adamw, 16:37:48)

  6. (1637418) Switching keyboard layouts is not working without relogin/reboot (adamw, 16:37:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637418 (adamw, 16:37:55)
    2. Proposed Blocker, gnome-control-center, NEW (adamw, 16:37:55)
    3. AGREED: 1637418 - RejectedBlocker AcceptedFreezeException (Final) - on a split vote, under the 'conditional violation' policy where we have to decide how significant the impact of the bug is, this was decided to be not quite significant enough to block the release. it is bad, though, and we definitely would like a fix if at all possible (adamw, 16:57:11)
    4. ACTION: kparal to try and get some response to 1637418 from gnome folks (adamw, 16:59:29)

  7. (1637751) Display gets messed up when routing panel is active (adamw, 16:59:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637751 (adamw, 16:59:35)
    2. Proposed Blocker, gnome-maps, NEW (adamw, 16:59:35)
    3. AGREED: 1637751 - AcceptedBlocker (Final) - the issues mentioned in the bug are widely reproducible and agreed to violate "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test". We note that dropping the app from Workstation is acceptable if a fix is not available (adamw, 17:08:14)

  8. (1637957) Closing GNOME Software outside of the main page causes it to glitch (adamw, 17:08:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637957 (adamw, 17:08:20)
    2. Proposed Blocker, gnome-software, NEW (adamw, 17:08:20)
    3. AGREED: 1637957 - AcceptedBlocker (Final) - this is agreed to be a violation of "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." (adamw, 17:13:34)

  9. (1632981) Cannot commit Japanese candidates or Korean Hangul in gnome-terminal and libreoffice (adamw, 17:13:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1632981 (adamw, 17:13:45)
    2. Proposed Blocker, gtk3, NEW (adamw, 17:13:45)
    3. AGREED: 1632981 - AcceptedBlocker (Final) - this is accepted as a conditional violation of the "basic functionality test" criterion when affected input methods are used, certainly including Japanese and Korean and likely also affecting some Chinese IMs (adamw, 17:22:26)
    4. that's all the proposed blockers (adamw, 17:22:40)

  10. End of proposed blockers (adamw, 17:23:28)
    1. moving on to proposed FEs (adamw, 17:27:06)

  11. (1639233) Update nvdimm support with fixes from rhel (adamw, 17:27:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1639233 (adamw, 17:27:37)
    2. Proposed Freeze Exceptions, anaconda, POST (adamw, 17:27:37)
    3. AGREED: 1639233 - AcceptedFreezeException (Final) - hardware enablement in the installer is always desirable, and cannot be fixed with an update. As this is said to be fairly isolated from other storage code, the risk should be low (adamw, 17:30:51)

  12. (1638444) One of the external displays is sometimes turned off (adamw, 17:30:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1638444 (adamw, 17:30:58)
    2. Proposed Freeze Exceptions, mutter, ON_QA (adamw, 17:30:58)
    3. AGREED: 1638444 - AcceptedFreezeException (Final) - this affects some hardware configs on first boot so cannot be fixed with an update, may cause inconvenience if the affected display is the main one (adamw, 17:35:00)

  13. (1632518) PackageKit installs packages from default module streams, but does not enable the module stream (adamw, 17:35:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1632518 (adamw, 17:35:10)
    2. Proposed Freeze Exceptions, PackageKit, NEW (adamw, 17:35:10)
    3. https://fedoraproject.org/wiki/Changes/StratisStorage-1.0 (adamw, 17:45:12)
    4. AGREED: 1632518 - AcceptedBlocker (Final) - default module streams appearing in F29 was not expected by all parties involved. We agree at least that this bug must be fixed *OR* default module streams must be delayed to Fedora 30. We will also file a FESCo ticket to ensure FESCo is aware of this situation (adamw, 18:09:36)

  14. (1638847) Privileged containers running as container_t instead of spc_t (adamw, 18:09:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1638847 (adamw, 18:09:53)
    2. Proposed Freeze Exceptions, podman, ON_QA (adamw, 18:09:53)
    3. AGREED: 1638847 - AcceptedFreezeException (Final) - this is accepted to make sure ostree-based installs work correctly from day 1 (adamw, 18:13:05)

  15. End of proposed FEs (adamw, 18:13:12)
  16. (1616167) dnf doesn't record modular metadata in a local database (adamw, 18:13:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1616167 (adamw, 18:13:42)
    2. Accepted Blocker, dnf, NEW (adamw, 18:13:42)
    3. per https://pagure.io/fesco/issue/1974#comment-536385 , fesco has voted to drop their requirements around this issue for Final, so this should be changed to rejectedblocker at this point (adamw, 18:15:40)

  17. (1632177) dnf segfault in libdnf::TransactionItem::saveReplacedBy() (adamw, 18:17:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1632177 (adamw, 18:17:02)
    2. Accepted Blocker, dnf, NEW (adamw, 18:17:02)
    3. we are still waiting on a fix from the developers here (adamw, 18:18:24)

  18. (1630899) unmounting ISO in Nautilus crashes gnome-shell and kills a wayland session (adamw, 18:22:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1630899 (adamw, 18:22:17)
    2. Accepted Blocker, gnome-shell, NEW (adamw, 18:22:17)
    3. AGREED: 1630899 - RejectedBlocker (Final) - this no longer seems to be reliably reproducible. we are not sure that it is fixed, but it at least no longer seems to have sufficient impact to be a blocker bug (adamw, 18:28:44)

  19. (1633786) SELinux is preventing (boltd) from 'create' accesses on the directory boltd. (adamw, 18:29:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1633786 (adamw, 18:29:37)
    2. Accepted Blocker, selinux-policy, MODIFIED (adamw, 18:29:37)
    3. https://koji.fedoraproject.org/koji/buildinfo?buildID=1153617 (adamw, 18:31:27)
    4. some related fixes are in selinux-policy -38 and -39, but no update has yet been submitted. cmurf and kparal will see if any AVCs persist in -39. adamwill will ask lukas to submit an update (adamw, 18:40:37)
    5. end of accepted blockers (adamw, 18:41:41)

  20. Open floor (adamw, 18:41:49)
  21. Open floor: DNF rebase to 4.0 (adamw, 18:42:03)
    1. as a fix for various blocker and FE issues, DNF team has submitted an update containing major new releases of DNF and libdnf: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2789f6b6e7 (adamw, 18:42:49)
    2. this goes fairly strongly against the policy that, during freezes, only changes to fix FE and blocker issues should be made (adamw, 18:43:51)
    3. adamw will file a FESCo ticket asking them to consider if we should take dnf 4.0 / libdnf 0.22 for f29, or ask for 3.6 / 0.20 branches with more targeted blocker/fe fixes (adamw, 18:55:18)

  22. Open floor (adamw, 18:55:30)


Meeting ended at 19:01:14 UTC (full logs).

Action items

  1. kparal to try and get some response to 1637418 from gnome folks


Action items, by person

  1. kparal
    1. kparal to try and get some response to 1637418 from gnome folks


People present (lines said)

  1. adamw (395)
  2. kparal (114)
  3. sgallagh (107)
  4. contyk (76)
  5. cmurf (71)
  6. lruzicka (64)
  7. frantisekz (54)
  8. jlanda (43)
  9. bcotton (39)
  10. Southern_Gentlem (36)
  11. zodbot (22)
  12. pwhalen (19)
  13. coremodule (16)
  14. mboddu (15)
  15. zbyszek (7)
  16. vtrefny (4)
  17. mclasen (1)


Generated by MeetBot 0.1.4.