#fedora-blocker-review: F29-blocker-review

Meeting started by coremodule at 16:00:09 UTC (full logs).

Meeting summary

  1. Roll Call (coremodule, 16:00:09)
  2. Introduction (coremodule, 16:03:49)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (coremodule, 16:03:49)
    2. We'll be following the process outlined at: (coremodule, 16:03:49)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (coremodule, 16:03:50)
    4. The bugs up for review today are available at: (coremodule, 16:03:51)
    5. http://qa.fedoraproject.org/blockerbugs/current (coremodule, 16:03:53)
    6. The criteria for release blocking bugs can be found at: (coremodule, 16:03:57)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (coremodule, 16:03:59)
    8. https://fedoraproject.org/wiki/Fedora_29_Beta_Release_Criteria (coremodule, 16:04:01)
    9. https://fedoraproject.org/wiki/Fedora_29_Final_Release_Criteria (coremodule, 16:04:03)
    10. Proposed Blockers (coremodule, 16:04:15)

  3. (1636739) kickstart doesn't find standard repos Fedora 29 beta Everything netinst (metalink False) (coremodule, 16:04:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1636739 (coremodule, 16:04:30)
    2. Proposed Blocker, anaconda, MODIFIED (coremodule, 16:04:30)
    3. AGREED: 1636739 - AcceptedBlocker - WE find this bug is a violation of the following criteria: "The installer must be able to use all supported local and remote package and installer sources." We note that the anaconda team says a fix has been submitted and merged and will be available ASAP. (coremodule, 16:08:20)

  4. (1637418) Switching keyboard layouts is not working without relogin/reboot (coremodule, 16:08:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637418 (coremodule, 16:08:32)
    2. Proposed Blocker, gnome-shell, NEW (coremodule, 16:08:32)
    3. Workstation WG voted +1 blocker (coremodule, 16:10:18)
    4. AGREED: 1637418 - AcceptedBlocker - We find this bug to be a violation of the following blocker criteria: "Default panel functionality - All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use." We note that the Workstation WG has voted +1 blocker on this bug. (coremodule, 16:12:04)

  5. (1636271) LSI mpt3sas driver not in kernel (coremodule, 16:12:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1636271 (coremodule, 16:12:18)
    2. Proposed Blocker, kernel, MODIFIED (coremodule, 16:12:18)
    3. https://access.redhat.com/errata/RHEA-2016:1930 (coremodule, 16:14:30)
    4. https://fedoraproject.org/wiki/Basic_Release_Criteria#storage-interfaces (kparal, 16:15:55)
    5. https://access.redhat.com/errata/RHEA-2016:1930 (coremodule, 16:22:02)
    6. AGREED: 1636271 - AcceptedFreezeException - We find this bug worthy of AcceptedFreezeException status as the fix is already available and we can't find specifics regarding if the mpt3sas driver has been included in Fedora before or if it is a new addition. (coremodule, 16:26:44)
    7. AGREED: 1636271 - AcceptedFreezeException - We find this bug worthy of RejectedBlocker AcceptedFreezeException status as the fix is already available and we can't find specifics regarding if the mpt3sas driver has been included in Fedora before or if it is a new addition. (coremodule, 16:28:12)
    8. AGREED: 1636271 - RejectedBlocker AcceptedFreezeException - We find this bug worthy of AcceptedFreezeException status as the fix is already available and we can't find specifics regarding if the mpt3sas driver has been included in Fedora before or if it is a new addition. (coremodule, 16:28:36)
    9. moving on to Proposed Freeze Exceptions (coremodule, 16:29:31)

  6. (1640409) Atomic Host Installclass detection not working (coremodule, 16:29:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1640409 (coremodule, 16:29:44)
    2. Proposed Freeze Exceptions, anaconda, ON_QA (coremodule, 16:29:44)
    3. skipping all anaconda/dnf fe's as the updates surrounding those are already stable (coremodule, 16:32:38)

  7. (1641268) dracut-network: iscsi module causes device timeout on boots with resume= cmdline arg (coremodule, 16:32:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1641268 (coremodule, 16:32:47)
    2. Proposed Freeze Exceptions, dracut, NEW (coremodule, 16:32:47)
    3. A fix has been made, we're just waiting for it to get pulled in (coremodule, 16:41:32)
    4. the fix seems isolated to iscsid (coremodule, 16:44:10)
    5. AGREED: 1641268 - AcceptedFreezeException - This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException. (coremodule, 16:44:23)

  8. (1628209) kernel 4.18.5-200.fc28.armv7hl has non-functional ethernet on wandboard quad (coremodule, 16:44:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1628209 (coremodule, 16:44:33)
    2. Proposed Freeze Exceptions, kernel, MODIFIED (coremodule, 16:44:33)
    3. AGREED: 1628209 - AcceptedFreezeException - This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException. (coremodule, 16:46:26)

  9. (1639765) Rock960 hangs after boot (coremodule, 16:46:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1639765 (coremodule, 16:46:37)
    2. Proposed Freeze Exceptions, kernel, MODIFIED (coremodule, 16:46:37)
    3. AGREED: 1639765 – AcceptedFreezeException - This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException. (coremodule, 16:48:48)

  10. (1641254) Backport a couple of mutter memory leaks (coremodule, 16:48:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1641254 (coremodule, 16:48:57)
    2. Proposed Freeze Exceptions, mutter, MODIFIED (coremodule, 16:48:57)
    3. this bug needs more karma to go stable (coremodule, 16:50:16)
    4. AGREED: 1641254 – AcceptedFreezeException - This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException. We additionally note that this bug needs more positive karma to be pushed stable. (coremodule, 16:52:56)

  11. (1640488) evince has moved from evince.desktop to org.gnome.Evince.desktop (coremodule, 16:53:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1640488 (coremodule, 16:53:10)
    2. Proposed Freeze Exceptions, shared-mime-info, VERIFIED (coremodule, 16:53:10)
    3. the fix has been tested and found to work (coremodule, 16:54:24)
    4. AGREED: 1640488 – AcceptedFreezeException - This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException. (coremodule, 16:54:51)

  12. (1640352) Final (hopefully) version of spin-kickstarts for f29 (coremodule, 16:55:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1640352 (coremodule, 16:55:01)
    2. Proposed Freeze Exceptions, spin-kickstarts, VERIFIED (coremodule, 16:55:01)
    3. AGREED: 1640352 – AcceptedFreezeException - This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException. It is also noted that the original blocker classification of this bug was based on old criteria, and as such no longer qualifies as a blocker. (coremodule, 16:57:17)
    4. moving on to review the accepted blockers (coremodule, 16:58:06)

  13. (1632177) dnf segfault in libdnf::TransactionItem::saveReplacedBy() (coremodule, 16:58:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1632177 (coremodule, 16:58:16)
    2. Accepted Blocker, dnf, VERIFIED (coremodule, 16:58:16)

  14. (1636743) dnf update --refresh fails for repo_gpgcheck=1 (coremodule, 17:00:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1636743 (coremodule, 17:00:44)
    2. Accepted Blocker, dnf, VERIFIED (coremodule, 17:00:44)

  15. (1633133) [abrt] gjs: gtk_box_pack(): gjs-console killed by SIGSEGV (coremodule, 17:01:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1633133 (coremodule, 17:01:25)
    2. Accepted Blocker, gnome-maps, POST (coremodule, 17:01:25)
    3. we need karma on the fix for this (coremodule, 17:03:05)
    4. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6dc96f6d57 (coremodule, 17:03:16)

  16. (1637751) Display gets messed up when routing panel is active (coremodule, 17:03:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1637751 (coremodule, 17:03:44)
    2. Accepted Blocker, gnome-maps, NEW (coremodule, 17:03:44)
    3. Workstation WG was grateful to be consulted here, and doesn't believe this belongs on the blocker list (stickster, 17:04:17)
    4. AGREED: 1637751 – RejectedBlocker AcceptedFreezeException – After much deliberation and hearing from stickster as representative from the Workstation WG, we have unanimously decided to not block the release on this bug, based on the fact that 1) the bug is not universal, 2) the fix may destabilize other things, and 3) it seems overly-zealous to block the release on this bug. We accept it as a Freeze Exception in case a (coremodule, 17:19:08)

  17. (1640701) GNOME Software "update and restart" button appears to do nothing (coremodule, 17:19:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1640701 (coremodule, 17:19:26)
    2. Accepted Blocker, gnome-software, NEW (coremodule, 17:19:26)
    3. lruzicka to test this right now (coremodule, 17:22:31)
    4. stickster to also attempt to reproduce the bug (coremodule, 17:23:19)
    5. stickster to get with kalev on the status of a fix for this bug and report any findings in-bug (coremodule, 17:31:24)
    6. coremodule to run some gnome-software tests today (coremodule, 17:32:13)

  18. (1632981) Cannot commit Japanese candidates or Korean Hangul in gnome-terminal and libreoffice (coremodule, 17:32:18)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1632981 (coremodule, 17:32:18)
    2. Accepted Blocker, gtk3, NEW (coremodule, 17:32:18)
    3. there are several fixes available that should be in GNOME 3.30.2, we are just waiting for them to land here in Fedora-land (coremodule, 17:37:50)

  19. (1632518) PackageKit installs packages from default module streams, but does not enable the module stream (coremodule, 17:39:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1632518 (coremodule, 17:39:10)
    2. Accepted Blocker, libdnf, POST (coremodule, 17:39:10)
    3. a fix is in the works for this bug (coremodule, 17:46:08)
    4. coremodule and frantisekz to look into the freeze exceptions and post in-bug there on any additional data found (coremodule, 17:50:11)

  20. Open Discussion (coremodule, 17:52:31)


Meeting ended at 17:53:51 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. coremodule (204)
  2. lruzicka (78)
  3. kparal (75)
  4. stickster (62)
  5. frantisekz (50)
  6. bcotton (24)
  7. pwhalen (17)
  8. zodbot (17)
  9. roshi (8)
  10. nirik (5)
  11. satellit (4)
  12. nb (3)
  13. Southern_Gentlem (2)
  14. mboddu (1)


Generated by MeetBot 0.1.4.