#fedora-blocker-review: F30-blocker-review

Meeting started by adamw at 16:03:34 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:03:34)
  2. Introduction (adamw, 16:06:06)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:06:06)
    2. We'll be following the process outlined at: (adamw, 16:06:08)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:06:08)
    4. The bugs up for review today are available at: (adamw, 16:06:10)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:06:11)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:06:13)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:06:15)
    8. https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria (adamw, 16:06:17)
    9. https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria (adamw, 16:06:19)
    10. for Beta, we have: (adamw, 16:06:37)
    11. 2 Proposed Blockers (adamw, 16:06:38)
    12. 3 Accepted Blockers (adamw, 16:06:43)
    13. 3 Proposed Freeze Exceptions (adamw, 16:06:48)
    14. 6 Accepted Freeze Exceptions (adamw, 16:06:48)
    15. there are no Final proposals (adamw, 16:06:57)
    16. coremodule will secretarialize (adamw, 16:07:05)
    17. we'll start with the proposed Beta blockers (adamw, 16:07:23)

  3. (1648907) grub2-common kernel.d plugin removes $ESP/<machine-id>/ directory rendering machine unbootable (adamw, 16:07:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1648907 (adamw, 16:07:31)
    2. Proposed Blocker, grub2, POST (adamw, 16:07:31)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1648907#c6 (adamw, 16:09:07)
    4. AGREED: 1648907 - RejectedBlocker (Beta) RejectedFreezeException (Beta) - as this does not involve a default or supported bootloader, and the change required looks like it could break stuff badly if it goes wrong, we agreed this is not a blocker for Beta and the risk of taking the change as an FE is too high (adamw, 16:22:26)

  4. (1688462) System upgrades involving modular content require explicit --setopt=module_platform_id to work correctly (adamw, 16:22:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1688462 (adamw, 16:22:38)
    2. Proposed Blocker, libdnf, NEW (adamw, 16:22:38)
    3. AGREED: 1688462 - RejectedBlocker (Beta) RejectedFreezeException (Beta) AcceptedBlocker (Final) - we agreed that the workaround here (using --setopt) is OK for Beta, but not acceptable for Final, so this is accepted as a Final blocker. We do not grant a Beta FE as we don't think fixing this late for Beta is worth the risk of taking more DNF change. (adamw, 16:32:27)

  5. Accepted Beta blockers (adamw, 16:33:44)
    1. that's all the proposed Beta blockers, moving onto existing accepted ones (adamw, 16:33:57)

  6. (1688925) Need kde-settings-30 with appropriate settings for F30, including desktop background (adamw, 16:34:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1688925 (adamw, 16:34:13)
    2. Accepted Blocker, kde-settings, ON_QA (adamw, 16:34:13)
    3. the update is submitted, we just need to test it so it can be pushed stable (adamw, 16:35:41)

  7. (1656509) F29 to F30+ upgrades fail unless --allowerasing is used due to issue with module_platform_id, even explicit --setopt=module_platform_id does not work (adamw, 16:37:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1656509 (adamw, 16:37:09)
    2. Accepted Blocker, libdnf, ON_QA (adamw, 16:37:09)
    3. this was never formally reviewed as an F30 Beta blocker due to various shenanigans with it being closed and opened and bumped, but we agreed at this meeting that it ought to be one (adamw, 16:46:14)
    4. so far as a fix goes, one exists and updates are submitted for f29 and f30, they just need to be tested and we need to clarify which one(s) need to be pushed for the issue to be resolved (adamw, 16:51:35)

  8. (1683197) gdm Fails to load with "nomodeset" (adamw, 16:52:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1683197 (adamw, 16:52:07)
    2. Accepted Blocker, systemd, ASSIGNED (adamw, 16:52:07)
    3. https://www.reddit.com/r/Fedora/comments/9twenw/fedora_29_install_boot_hangs/ (adamw, 16:55:24)
    4. https://ask.fedoraproject.org/en/question/130444/unable-to-boot-on-live-usb-with-nomodeset/ (adamw, 16:56:19)
    5. the proposed fix for this turns out not to be a complete fix, so this is putting the release at risk at this point (adamw, 17:02:59)
    6. ACTION: adamw to follow up with graphics and systemd folks to see if a fix is still plausible (adamw, 17:03:16)

  9. Open floor (adamw, 17:11:50)
  10. Proposed Beta freeze exceptions (adamw, 17:12:46)
    1. sorry, went to open floor too soon (adamw, 17:12:52)

  11. (1686851) nm-connection-editor should be moved to the X-GNOME-Utilities folder (adamw, 17:13:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1686851 (adamw, 17:13:01)
    2. Proposed Freeze Exceptions, gnome-menus, ON_QA (adamw, 17:13:01)
    3. AGREED: 1686851 - AcceptedFreezeException (Beta) - this bug is quite visible in the Workstation live image (so cannot be fixed with an update) and the fix is very safe (adamw, 17:18:38)

  12. (1684424) [Wayland][ja_JP] [Firefox][wayland] Not able to commit Japanese input from the candidate list, on address bar or search field. (adamw, 17:18:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1684424 (adamw, 17:18:40)
    2. Proposed Freeze Exceptions, mutter, NEW (adamw, 17:18:40)
    3. AGREED: 1684424 - AcceptedFreezeException (Beta) - as described this is a significant problem for CJK-type input that will be present in the Workstation live and so cannot be fixed fully with an update (adamw, 17:28:14)

  13. (1687896) python-aniso8601 cannot be installed on Fedora 30 (adamw, 17:28:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1687896 (adamw, 17:28:20)
    2. Proposed Freeze Exceptions, python-aniso8601, NEW (adamw, 17:28:20)
    3. AGREED: 1687896 - AcceptedFreezeException (Beta) - this package is a build dependency for others, so it not being installable is causing problems for other package builds. We grant it an FE to solve that issue. It should not affect the actual Beta composes at all. (adamw, 17:32:36)

  14. Open floor (adamw, 17:32:43)
    1. the go/no-go meeting is at 1700 UTC Thursday in #fedora-meeting (bcotton, 17:34:07)
    2. the release readiness meeting is at 1900 UTC Thursday in #fedora-meeting, even if we are no-go (bcotton, 17:34:31)


Meeting ended at 17:43:31 UTC (full logs).

Action items

  1. adamw to follow up with graphics and systemd folks to see if a fix is still plausible


Action items, by person

  1. adamw
    1. adamw to follow up with graphics and systemd folks to see if a fix is still plausible


People present (lines said)

  1. adamw (198)
  2. cmurf (96)
  3. sgallagh (40)
  4. bcotton (34)
  5. frantisekz (27)
  6. jlanda (21)
  7. zodbot (9)
  8. sumantro (2)
  9. coremodule (2)
  10. satellit_ (1)


Generated by MeetBot 0.1.4.