#fedora-blocker-review: F30-blocker-review

Meeting started by adamw at 16:00:29 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:29)
  2. Introduction (adamw, 16:04:30)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:04:31)
    2. We'll be following the process outlined at: (adamw, 16:04:31)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:04:31)
    4. The bugs up for review today are available at: (adamw, 16:04:32)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:04:34)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:04:36)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:04:38)
    8. https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria (adamw, 16:04:40)
    9. https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria (adamw, 16:04:42)
    10. we have, all for Final: (adamw, 16:04:44)
    11. 2 Proposed Blockers (adamw, 16:04:54)
    12. 2 Accepted Blockers (adamw, 16:04:54)
    13. 4 Proposed Freeze Exceptions (adamw, 16:04:57)
    14. 6 Accepted Freeze Exceptions (adamw, 16:04:58)
    15. let's start with proposed blockers (adamw, 16:05:10)

  3. (1700856) data abort in U-Boot when attempting to boot Allwinner A20 SBC's from SATA (adamw, 16:05:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1700856 (adamw, 16:05:21)
    2. Proposed Blocker, uboot-tools, ON_QA (adamw, 16:05:21)
    3. AGREED: 1700856 - AcceptedBlocker (Final) - accepted as a violation of "All release-blocking images must boot in their supported configurations. ... Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms." (adamw, 16:07:38)

  4. (1697591) modesetting driver on some Intel hardware fails to start after kernel 4.20.13 update (adamw, 16:08:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1697591 (adamw, 16:08:21)
    2. Proposed Blocker, xorg-x11-server, ASSIGNED (adamw, 16:08:21)
    3. https://pagure.io/fedora-workstation/issue/89 (cmurf, 16:09:18)
    4. we will circle back to this later, in case we can track down relevant folks for input during the meeting (adamw, 16:16:32)

  5. Proposed freeze exceptions (adamw, 16:16:54)
  6. #topic (1689409) Let desktop-backgrounds-compat provide a symlink to the 16:9 image in ../f30/default/tv-wide/f30.png (adamw, 16:17:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1689409 (adamw, 16:17:05)
    2. Proposed Freeze Exceptions, desktop-backgrounds, ON_QA (adamw, 16:17:05)
    3. AGREED: 1689409 - AcceptedFreezeException (Final) - this affects live environments and so cannot be fully fixed with an update, and is a very safe change (adamw, 16:18:53)

  7. (1701012) Many packages require rebuild for Meson 0.50.0 execstack bug (adamw, 16:19:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1701012 (adamw, 16:19:05)
    2. Proposed Freeze Exceptions, distribution, MODIFIED (adamw, 16:19:05)
    3. AGREED: 1701012 - AcceptedFreezeException (Final) - it is desirable from a security standpoint to avoid having packages built with 0.50.0 in the frozen release repos, so this is accepted as an FE. Only cases where the current stable package was built with 0.50.0 will be pushed (adamw, 16:25:58)

  8. (1699432) appliance-creator crash in setting up grub-legacy (adamw, 16:26:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1699432 (adamw, 16:26:06)
    2. Proposed Freeze Exceptions, livecd-tools, MODIFIED (adamw, 16:26:07)
    3. https://github.com/livecd-tools/livecd-tools/commit/1764b8034c816672d142e17b2f18904bf649f9a0 (Son_Goku, 16:42:03)
    4. https://koji.fedoraproject.org/koji/packageinfo?packageID=2463 (adamw, 16:44:37)
    5. https://koji.fedoraproject.org/koji/buildinfo?buildID=1249323 (adamw, 16:44:45)
    6. https://koji.fedoraproject.org/koji/buildinfo?buildID=1252678 (adamw, 16:45:14)
    7. https://koji.fedoraproject.org/koji/buildinfo?buildID=1243478 (adamw, 16:45:46)
    8. AGREED: 1699432 - RejectedFreezeException (Final) - at this point we don't want to touch the compose creation tools unless absolutely necessary. What is in F30 currently is working for producing F30, we don't want to change it. This can be shipped fine as an update (adamw, 16:46:58)

  9. (1700737) CVE-2018-16877 CVE-2018-16878 CVE-2019-3885 pacemaker: various flaws [fedora-all] (adamw, 16:47:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1700737 (adamw, 16:47:08)
    2. Proposed Freeze Exceptions, pacemaker, ON_QA (adamw, 16:47:08)
    3. https://access.redhat.com/security/cve/cve-2018-16877 (adamw, 16:50:45)
    4. AGREED: 1700737 - AcceptedBlocker (Final) - accepted as a blocker (despite proposal as an FE) as a violation of Final criterion "The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update (e.g. issues during installation)." - CVE-2018-16877 is rated 'important' (adamw, 16:54:48)

  10. Proposed blockers redux (adamw, 16:55:02)
  11. (1697591) modesetting driver on some Intel hardware fails to start after kernel 4.20.13 update (adamw, 16:55:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1697591 (adamw, 16:55:13)
    2. Proposed Blocker, xorg-x11-server, ASSIGNED (adamw, 16:55:13)
    3. AGREED: 1697591 - AcceptedFreezeException (Final), punt (blocker status) - we still cannot make a solid blocker decision here as we are still missing input from the graphics team. However, we think this is at minimum serious enough to rate a freeze exception. We will try to get info from graphics team ASAP and make a blocker decision (adamw, 17:06:37)

  12. Open floor (adamw, 17:06:45)
  13. Accepted blockers (adamw, 17:07:02)
    1. 1693409 - we are waiting on the graphics team for this one (adamw, 17:07:12)
    2. 1688462 - we are waiting for clarification from the dnf team on what exactly needs to be pushed where to get this fully 'fixed' (adamw, 17:07:28)

  14. Open floor (adamw, 17:17:13)


Meeting ended at 17:19:40 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (200)
  2. cmurf (55)
  3. frantisekz (43)
  4. Son_Goku (31)
  5. Lailah (27)
  6. sgallagh (26)
  7. mboddu (23)
  8. coremodule (22)
  9. bcotton (19)
  10. zodbot (15)
  11. nirik (12)
  12. Southern_Gentlem (12)
  13. tflink (10)
  14. satellit_ (1)


Generated by MeetBot 0.1.4.