16:00:53 <adamw> #startmeeting F31-blocker-review
16:00:53 <zodbot> Meeting started Mon Sep 9 16:00:53 2019 UTC.
16:00:53 <zodbot> This meeting is logged and archived in a public location.
16:00:53 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:53 <zodbot> The meeting name has been set to 'f31-blocker-review'
16:00:54 <adamw> #meetingname F31-blocker-review
16:00:54 <adamw> #topic Roll Call
16:00:54 <zodbot> The meeting name has been set to 'f31-blocker-review'
16:01:00 <adamw> morning folks, who's around for blocker review fun?
16:01:05 <bcotton> .hello2
16:01:06 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:07 <frantisekz_> .hello2
16:01:09 * bcotton wins again!
16:01:09 <zodbot> frantisekz_: Sorry, but you don't exist
16:01:12 <frantisekz_> damn
16:01:19 <frantisekz> .hello2
16:01:20 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
16:01:55 <coremodule> .hello2
16:01:56 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:02:03 <tablepc> .hello2
16:02:04 <zodbot> tablepc: tablepc 'Pat Kelly' <pmkellly@frontier.com>
16:02:05 <pwhalen> .hello2
16:02:06 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
16:02:07 * coremodule willing to secretarialize.
16:02:30 <cmurf> .hello chrismurphy
16:02:31 <zodbot> cmurf: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
16:03:09 * satellit_ listening
16:03:10 * kparal is here
16:06:58 <adamw> morning everyone!
16:07:36 <adamw> #chair kparal bcotton
16:07:36 <zodbot> Current chairs: adamw bcotton kparal
16:07:48 <adamw> warning: impending boilerplate
16:07:49 <adamw> #topic Introduction
16:07:49 <adamw> Why are we here?
16:07:49 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:07:49 <adamw> #info We'll be following the process outlined at:
16:07:51 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:07:52 <adamw> #info The bugs up for review today are available at:
16:07:54 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:07:56 <adamw> #info The criteria for release blocking bugs can be found at:
16:07:58 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:08:00 <adamw> #link https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria
16:08:02 <adamw> #link https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria
16:08:08 <adamw> #for F31 Beta, we have:
16:08:09 <adamw> #info 6 Proposed Blockers
16:08:09 <adamw> #info 4 Accepted Blockers
16:08:12 <adamw> #info 4 Proposed Freeze Exceptions
16:08:13 <adamw> #info 5 Accepted Freeze Exceptions
16:08:16 <adamw> #info for F31 Final, we have:
16:08:24 <adamw> #info 4 Proposed Blockers
16:08:46 <adamw> so, let's dive right into the proposed Beta blockers...
16:08:59 <adamw> #info starting with proposed Beta blockers
16:09:01 <adamw> #topic (1749107) firefox does run with old profile after upgrade to F31
16:09:02 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1749107
16:09:02 <adamw> #info Proposed Blocker, firefox, MODIFIED
16:09:28 <kparal> +1 blocker
16:09:31 <bcotton> +1 blocker
16:09:40 <frantisekz_> +1 blocker
16:10:19 <pwhalen> +1 blocker
16:10:38 <Lailah> Hello
16:10:44 <Lailah> .fas lailah
16:10:45 <zodbot> Lailah: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:11:04 <Lailah> Sorry for being so late!
16:11:48 <adamw> proposed #agreed 1749107 - AcceptedBlocker (Beta) - this is accepted as a violation of the "upgraded systems must meet release criteria" criterion combined with the "desktop browser must work" criterion
16:11:58 <frantisekz> ack
16:12:04 <Lailah> ack
16:12:10 <bcotton> ack
16:12:35 <adamw> #agreed 1749107 - AcceptedBlocker (Beta) - this is accepted as a violation of the "upgraded systems must meet release criteria" criterion combined with the "desktop browser must work" criterion
16:12:47 <adamw> #topic (1750394) Gnome Control Center crashes upon a typo in Printers settings
16:12:47 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1750394
16:12:47 <adamw> #info Proposed Blocker, gnome-control-center, NEW
16:13:01 <adamw> okay NICE TRY lukas
16:13:10 <adamw> but i'm definitely -1 beta for this :P
16:13:23 <adamw> i might go +1 FE if the fix is clean, but...
16:13:31 <frantisekz> it's pretty usual to write > instead of : , epsecially when jumping between czech and english keyboard layouts :)
16:13:56 <frantisekz> -1 beta blocker, +1 beta FE (I'd expect the fix to be clean :) )
16:14:14 <bcotton> 0 beta blocker, +1 beta FE, +1 final blocker
16:14:19 <cmurf> +1 beta FE, +1 final blocker
16:14:23 <frantisekz> yeah, final blocker for sure
16:15:20 <Lailah> -1 beta blocker +1 beta FE +1 final blocker
16:15:45 <pwhalen> +1 beta FE, +1 final blocker
16:16:06 <kparal> -1 beta, +1 final
16:17:32 <adamw> proposed #agreed 1750394 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - this is rejected as a Beta blocker as it doesn't really violate the Beta criteria, but is accepted as a Final blocker as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" and as a Beta FE so long as the fix is clean
16:17:42 <bcotton> ack
16:17:47 <Lailah> ack
16:17:48 <pwhalen> ack
16:18:17 <adamw> #agreed 1750394 - AcceptedFreezeException (Beta), AcceptedBlocker (Final) - this is rejected as a Beta blocker as it doesn't really violate the Beta criteria, but is accepted as a Final blocker as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" and as a Beta FE so long as the fix is clean
16:18:30 <adamw> #topic (1749086) Needs updating for Fedora 31 background etc.
16:18:30 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1749086
16:18:30 <adamw> #info Proposed Blocker, kde-settings, NEW
16:18:48 <adamw> this is a dependency of an existing accepted blocker so is technically a blocker already, but it's a bit easier for the apps and stuff if we accept it in its own right
16:18:55 <adamw> (we should really make blockerbugs handle dependencies...)
16:18:57 <bcotton> +1 blocker
16:19:10 <frantisekz> (adamw, adding that to my todo list :) )
16:19:16 <bcotton> (i'm not sure i love this criterion but whatever)
16:19:20 <Lailah> +1 blocker
16:19:20 <kparal> +1
16:19:24 <frantisekz> +1 blocker
16:19:40 <adamw> bcotton: what would be really good is if someone would take charge of rearranging the backgrounds packages
16:19:49 <bcotton> not it!
16:19:55 <adamw> such that we have a Rawhide background which is just a big red banner that says DEVELOPMENT VERSION or something
16:20:01 <adamw> if we had *that*, this would never be an issue at beta
16:20:04 <pwhalen> +1
16:20:43 <tablepc> Great Idea!
16:20:54 <adamw> proposed #agreed 1749086 - AcceptedBlocker (Beta) - accepted as a violation of Basic criterion "The default desktop background must be different from that of the last two stable releases" (for the release-blocking KDE desktop)
16:21:11 <adamw> tablepc: the criteria were specifically written to allow that, but...nobody actually *did the work* :/
16:21:31 <adamw> so instead every beta we get a rush to fix the backgrounds and everyone complains.
16:22:13 <frantisekz> ack
16:22:20 <bcotton> ack
16:22:23 <pwhalen> ack
16:22:24 <Lailah> ack
16:22:40 <cmurf> automate it!
16:23:18 <cmurf> maybe at branch just pick the next image from a pool of preselected backgrounds
16:23:37 <adamw> #agreed 1749086 - AcceptedBlocker (Beta) - accepted as a violation of Basic criterion "The default desktop background must be different from that of the last two stable releases" (for the release-blocking KDE desktop)
16:24:01 <adamw> #topic (1743585) NetworkManager-wifi should prefer wpa_supplicant over iwd (currently iwd is chosen by dnf to resolve ambiguous dependency)
16:24:01 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1743585
16:24:01 <adamw> #info Proposed Blocker, NetworkManager, MODIFIED
16:24:10 <adamw> this basically parses to 'wifi doesn't work ootb'
16:24:16 <bcotton> +1 blocker
16:24:17 <frantisekz> +1 Blocker
16:24:18 <adamw> to which i'm +1
16:24:21 <Lailah> +1 blocker
16:24:31 <Lailah> Yeah, that's an obvious one.
16:24:46 <frantisekz> didn't happen on upgrades though (just for notice)
16:25:00 <frantisekz> (which makes sense looking at the spec)
16:25:05 <adamw> proposed #agreed 1743585 - AcceptedBlocker (Beta) - this is accepted as a violation of all criteria that rely on a remote network connection (e.g. package updates) for a system dependent on a wifi connection
16:25:13 <frantisekz> ack
16:25:13 <adamw> frantisekz: yeah, that's what i'd expect
16:25:19 <pwhalen> +1/ack
16:25:49 <bcotton> ack
16:26:08 <adamw> #agreed 1743585 - AcceptedBlocker (Beta) - this is accepted as a violation of all criteria that rely on a remote network connection (e.g. package updates) for a system dependent on a wifi connection
16:26:14 <adamw> #topic (1734184) python3-jmespath conflicts with but does not obsolete python2-jmespath
16:26:14 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1734184
16:26:14 <adamw> #info Proposed Blocker, python-jmespath, ON_QA
16:26:20 <tablepc> Is this a candidate to be added the list of Automatic blockers?
16:26:54 <tablepc> The wifi one.
16:27:19 <cmurf> what about the quality of wifi for final?
16:27:24 <adamw> tablepc: mmm...i'd say probably not as it's not always so straightforward
16:27:34 <kparal> -1 blocker +1 FE
16:27:39 <frantisekz> I don't think this is a blocker (is it included in any installation media? I don't think so)
16:27:42 <adamw> it's best to keep the automatic blocker list short and for cases that can *only* really be simple ones
16:27:46 <frantisekz> so +1 FE then
16:28:42 <bcotton> -1 blocker, +1 FE
16:28:56 <adamw> note, this appears to be in ansible's dep chain
16:29:02 <bcotton> ohhhhhhh
16:29:23 <adamw> still, i don't think ansible is installed out of the box in any default install...
16:29:26 <frantisekz> still -1 Blocker/+1 FE
16:29:35 <bcotton> kinda surprised it's not in server, tbh
16:29:43 <Lailah> -1 blocker, +1 FE
16:30:08 <pwhalen> -1 blocker, +1 FE
16:31:06 <adamw> proposed #agreed 1734184 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - we don't believe this is in any release-blocking default install package set, so it is rejected as a blocker. However it's accepted as an FE as it will affect quite a lot of upgrades, since it's in ansible dep chain
16:31:16 <bcotton> ack
16:31:18 <frantisekz> ack
16:31:49 <Lailah> ack
16:32:20 <adamw> #agreed 1734184 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - we don't believe this is in any release-blocking default install package set, so it is rejected as a blocker. However it's accepted as an FE as it will affect quite a lot of upgrades, since it's in ansible dep chain
16:32:28 <adamw> #topic (1728240) Cannot start Fedora-KDE-Live (F31) in basic graphics mode on BIOS machine
16:32:28 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1728240
16:32:28 <adamw> #info Proposed Blocker, sddm, NEW
16:32:50 <frantisekz> so, I don't think this is beta blocker, it's definitely the final one
16:33:19 <Lailah> Actually I do think it's a beta blocker.
16:33:36 <Lailah> But why do you think it's not, frantisekz ?
16:33:54 <frantisekz> Lailah: can you point at the crietrion why it shou,d be Beta blocker?
16:34:02 <adamw> Lailah: because 'basic graphics mode' is in the Final criteria, not beta
16:34:02 <adamw> https://fedoraproject.org/wiki/Fedora_31_Final_Release_Criteria#.27Basic_graphics_mode.27_boot_mode_behavior
16:34:17 <adamw> -1 Beta blocker, +1 Beta FE, +1 Final blocker for me
16:34:26 <bcotton> -1 Beta blocker, +1 Beta FE, +1 Final blocker
16:34:33 <pwhalen> -1 Beta blocker, +1 Beta FE, +1 Final blocker
16:34:38 <frantisekz> -1 Beta blocker, +1 Beta FE, +1 Final blocker
16:34:41 <kparal> -1 beta +1 final
16:35:13 <Lailah> -1 beta blocker, +1 beta FE, +1 final blocker
16:35:37 <Lailah> adamw: thanks for the link
16:36:57 <adamw> proposed #agreed 1728240 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this is rejected as a blocker for Beta but accepted for Final under criterion "The generic video driver option ('basic graphics mode' - as described in the Basic criteria) on all release-blocking installer and live images must function as intended...". Also accepted as Beta FE as a significant issue that can't be fixed with an upgrade
16:37:05 <bcotton> ack
16:37:09 <Lailah> ack
16:37:10 <pwhalen> ack
16:37:12 <frantisekz> ack
16:38:12 <adamw> #agreed 1728240 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this is rejected as a blocker for Beta but accepted for Final under criterion "The generic video driver option ('basic graphics mode' - as described in the Basic criteria) on all release-blocking installer and live images must function as intended...". Also accepted as Beta FE as a significant issue that can't be fixed with an upgrade
16:38:26 <adamw> #topic Proposed Beta freeze exceptions
16:38:31 <adamw> #info as we're in Beta freeze, let's do the Beta FEs next
16:38:38 <adamw> #topic (1750414) inaccessible workstation repos make gnome-software and dnf unusable
16:38:39 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1750414
16:38:39 <adamw> #info Proposed Freeze Exceptions, fedora-workstation-repositories, MODIFIED
16:39:41 <frantisekz> +1 Beta FE
16:40:22 <adamw> note, this is also proposed as a Final blocker, so i guess we can vote on both at once
16:40:27 <adamw> definitely +1 Beta FE
16:40:30 <adamw> i'm a *bit* torn on Final blocker
16:40:41 <frantisekz> I am not sure about final blocker, do we have criterion for that?
16:40:42 <kparal> I'm not. +1 Beta FE +1 Final
16:40:51 <bcotton> +1 beta FE, -1 final blocker
16:41:11 <Lailah> +1 Beta FE, +1 Final Blocker
16:41:16 <kparal> if this is contentious, we can just wait a week and it will resolve itself
16:41:43 <kparal> frantisekz: https://bugzilla.redhat.com/show_bug.cgi?id=1750414#c3
16:41:52 <cmurf> +1 Beta FE, 0 on blocker
16:41:55 <pwhalen> +1 Beta FE
16:42:13 <cmurf> I think the working group needs to discuss it and come to a decision
16:42:28 <frantisekz> kparal: I am not sure we can block on third party repos
16:42:30 <adamw> let's just wait a week for it to go away :P
16:42:32 <cmurf> the issue kparal opened is tagged for the next meeting
16:42:36 <frantisekz> this way, we would block on broken nvidia driver for example
16:42:39 <kparal> cmurf: the blocker is not about the approach to take. the blocker is about this being broken at the moment, killing gnome-software
16:42:54 <kparal> always, because the repos don't exist
16:42:57 <cmurf> yeah I'm inclined to think that's a blocker
16:43:10 <cmurf> we can't ship something that blows up like that
16:43:19 <adamw> well, it's not quite 'always', right? it's 'always if you enabled a non-default repo which was very prominently advertised to you'
16:43:26 <adamw> hence why i'm slightly torn
16:43:29 <kparal> adamw: correct
16:43:32 <adamw> but i'm all for 'let's just let it get fixed!'
16:43:40 <cmurf> right and then does that prevent updates from working?
16:43:47 <kparal> cmurf: yes
16:43:54 <cmurf> ok so then they're stuck
16:44:03 <adamw> unless they go and disable it with dnf or something, yeah
16:44:12 <kparal> they can disable it even with gnome-software
16:44:21 <kparal> they just need to know about it
16:44:23 <adamw> oh, it has a ui for that now? i thought it didn't
16:44:33 <kparal> adamw: it's terrible but it's there
16:44:35 <adamw> actually i think i'm a weak +1 final blocker now
16:44:36 <cmurf> but it requires user intervention to get updates after having opted into non-default repos
16:44:39 <adamw> thinking about it a bit
16:45:02 <adamw> counting it as a conditional violation of the criterion, if you take a popular choice that is prominently offered to you
16:45:44 <adamw> still, that gives us only...+2 final so far
16:45:49 <frantisekz> heh, tried to look at "Software reposiotries" in GNOME SW, it doesn't even load ...
16:45:58 <frantisekz> I am +0 for Final
16:45:59 <kparal> to be absolutely clear, if you click the banner in gnome-software, it will install the repos but not enable them. You need to enable those manually from gnome-software menu.
16:46:07 <kparal> so you probably know how to disable it as well
16:46:12 <adamw> oh huh. didn't know that
16:46:15 <adamw> don't make me change my vote again!
16:46:19 <kparal> but I'm not sure people will realize the cause
16:46:35 <cmurf> yeah it's all a little tricky
16:46:40 <kparal> the pop up error will list the repo url and say "failed to download"
16:47:03 <cmurf> maybe kparal will be available monday at 1300UTC to explain it to the working group :D
16:47:03 <adamw> ok, let's just go with +1 Beta FE for now
16:47:05 <bcotton> let's punt on the final blocker decision
16:47:06 <adamw> since we all agree on that
16:47:08 <bcotton> what adamw said
16:47:37 <Lailah> kparal: I don't use Gnome Software but if I had to a message like that, it would be utterly confusing to me.
16:47:57 <kparal> another use case it me installing my parents pc. they won't know why updates are empty for them and will not understand the error
16:48:06 <adamw> proposed #agreed 1750414 - AcceptedFreezeException (Beta), punt (delay decision) for Final blocker - this is clearly bad enough (and the fix simple enough) that we should take it for Beta. Whether to accept it as a Final blocker is a slightly tricky call so we're just going to duck it, because fixing it as a Beta FE will mean we don't have to make up our minds!
16:48:21 <cmurf> kparal: all of those are bugs IMO
16:48:22 <kparal> ack
16:48:23 <pwhalen> ack
16:48:26 <Lailah> ack
16:48:27 <bcotton> ack
16:48:29 <cmurf> anytime humans are confused there's a bug somewhere
16:48:32 <adamw> #agreed 1750414 - AcceptedFreezeException (Beta), punt (delay decision) for Final blocker - this is clearly bad enough (and the fix simple enough) that we should take it for Beta. Whether to accept it as a Final blocker is a slightly tricky call so we're just going to duck it, because fixing it as a Beta FE will mean we don't have to make up our minds!
16:48:42 <adamw> #topic (1750237) g-i-s window overlapped with gdm login screen
16:48:42 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1750237
16:48:42 <adamw> #info Proposed Freeze Exceptions, gnome-initial-setup, NEW
16:48:52 <adamw> i saw this somewhere in openqa the other day, i think..
16:49:23 <kparal> I saw this several times today
16:49:31 <kparal> might be a race or something
16:49:59 <adamw> damn, wish i'd made a note of what openqa test i saw it in :/
16:49:59 <Lailah> adamw: what is a g-i-s ?
16:50:00 <kparal> +1 FE for sure
16:50:05 <adamw> gnome-initial-setup
16:50:10 <Lailah> Ah.
16:50:11 <bcotton> Lailah: gnome-initial-setup
16:50:17 <bcotton> curse you, adamw
16:50:20 <kparal> I haven't spotted any downside in GDM functionality, though. It seems to be just cosmetic
16:50:21 <adamw> the wizard that's meant to pop up right after you install, or the first time you log in as a new user
16:50:24 <Lailah> Oh, okay, thanks adamw bcotton
16:50:26 <adamw> and ask you about keyboard layouts and stuff
16:50:31 <frantisekz> +1 FE
16:50:41 <bcotton> +1 FE, i suppose
16:51:06 <Lailah> adamw: yeah, it doesn't exist in KDE
16:51:06 <Lailah> That's why I didn't know
16:51:17 <adamw> kparal: what context did you see it in?
16:51:17 <Lailah> +1 FE
16:51:31 <adamw> Lailah: yeah, for KDE installs there is a separate initial-setup, the one that looks like anaconda
16:51:45 <adamw> you only see it if you didn't create a user or root password during install though.
16:51:46 <Lailah> Is it?
16:51:48 <kparal> adamw: just rebooting an existing machine sometimes booted into this state
16:52:00 <Lailah> ah, right, that makes sense
16:52:02 <adamw> kparal: hmm, so it could potentially happen first boot after install
16:52:12 <adamw> Lailah: and it doesn't run on first login to a new user, unlike the GNOME one
16:52:18 <kparal> adamw: might be, I can't be sure
16:52:22 <adamw> ok
16:52:23 <pwhalen> +1 FE
16:52:39 <Lailah> adamw: when does it run then?
16:52:59 <Lailah> I configured everything during the install.
16:53:08 <adamw> proposed #agreed 1750237 - AcceptedFreezeException (Beta) - the contexts in which this might happen are a bit unclear, but we think it can happen on upgrade and on first boot after install, so on that basis a freeze exception is justified as those cannot be fully addressed with a 0-day update
16:53:33 <adamw> Lailah: yeah, only if you didn't configure user and root during install, it'll pop up on first boot of the installed system, to let you set a root password and/or user account
16:53:51 <frantisekz> ack
16:53:55 <pwhalen> ack
16:53:59 <Lailah> adamw: Okay, now I'm clear. Thanks!
16:54:01 <Lailah> ack
16:54:01 <bcotton> ack
16:54:19 <adamw> Lailah: it looks like https://openqa.fedoraproject.org/tests/445948#step/_graphical_wait_login/1
16:54:24 <adamw> #agreed 1750237 - AcceptedFreezeException (Beta) - the contexts in which this might happen are a bit unclear, but we think it can happen on upgrade and on first boot after install, so on that basis a freeze exception is justified as those cannot be fully addressed with a 0-day update
16:54:46 <adamw> #topic (1749133) Updates to fix robotics spin compose
16:54:46 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1749133
16:54:46 <adamw> #info Proposed Freeze Exceptions, player, NEW
16:55:14 <adamw> sure, changes look pretty focused and fixing a compose is a good FE reason
16:55:15 <adamw> +1
16:55:31 <pwhalen> +1 FE
16:55:42 <Lailah> +1 FE
16:55:42 <frantisekz> +1 FE
16:55:44 <bcotton> +1 FE
16:55:50 <kparal> +1 FE
16:57:01 <adamw> proposed #agreed 1749133 - AcceptedFreezeException (Beta) - fixing a non-blocking image compose is a good reason for a freeze exception, and the required changes here look focused and safe
16:57:18 <frantisekz> ack
16:57:22 <bcotton> ack
16:57:26 <Lailah> ack
16:57:30 <kparal> ack
16:57:34 <pwhalen> ack
16:57:56 <adamw> #agreed 1749133 - AcceptedFreezeException (Beta) - fixing a non-blocking image compose is a good reason for a freeze exception, and the required changes here look focused and safe
16:58:02 <adamw> #topic (1746538) Rootless podman won't start containers
16:58:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1746538
16:58:03 <adamw> #info Proposed Freeze Exceptions, podman, POST
16:58:10 <frantisekz> +1 FE
16:58:17 <Lailah> +1 FE
16:58:27 <pwhalen> +1 FE
17:00:07 <bcotton> it seems harmless enough, but is it something that can't be fixed with an update?
17:01:01 <adamw> that's a reasonable point
17:01:27 <adamw> so the question would be, is it something important enough to accept as an FE so it will work out of the box
17:01:34 <adamw> or will people want to do it from non-updateable environments
17:02:44 <cmurf> yeah there's not much of an explanation why to give it an FE
17:02:54 <cmurf> the errors are non-obvious
17:02:56 <bcotton> for beta, i'm not too concerned about such a scenario
17:03:12 <bcotton> i'm not opposed, but i can't bring myself to go beyond 0
17:03:41 <cmurf> I would needinfo the bug and punt - there's time for an FE still right?
17:03:46 <adamw> otoh, it doesn't seem like fixing it has much chance of breaking anything else worse
17:03:51 <adamw> cmurf: bit tight at this point
17:03:54 <frantisekz> I can bring myself down to 0... but I feel it can be accepted, no hard feelings though
17:03:56 <cmurf> oh it's this thursday nevermind
17:04:15 <cmurf> yeah I'm gonna say -1 FE, just do an update
17:04:28 <bcotton> adamw: yeah, that's why i'm 0 instead of -1. doesn't seem like it would do any harm, just doesn't meet the requirements imo
17:05:20 <cmurf> how are you going to run podman without internet access to aquire a container?
17:05:35 <pwhalen> sure, I can be 0 too
17:05:40 <bcotton> you could have an internal repository
17:05:42 <cmurf> there's no base container included in the installation, right?
17:06:02 <bcotton> but yeah, if you're running beta anything in an environment that can't get updates, that seems like a recipe for disaster
17:06:33 <cmurf> yeah good luck with that
17:06:37 <adamw> proposed #agreed 1746538 - RejectedFreezeException (Beta) - while this is obviously a significant bug worth fixing, we can't see any justification for why it needs to be a freeze exception rather than a normal update
17:06:42 <bcotton> ack
17:06:44 <frantisekz> ack
17:06:47 <cmurf> ack
17:06:54 <pwhalen> ack
17:07:17 <adamw> #agreed 1746538 - RejectedFreezeException (Beta) - while this is obviously a significant bug worth fixing, we can't see any justification for why it needs to be a freeze exception rather than a normal update
17:08:27 <cmurf> also, its only rootless that's busted
17:08:29 <cmurf> not the whole thing
17:09:20 <adamw> #topic proposed Final blockers
17:09:25 <adamw> #info let's move onto proposed Final blockers!
17:09:51 <adamw> note we've already dealt with the first.
17:09:52 <adamw> #topic (1749433) can't turn zoom off once enabled
17:09:52 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1749433
17:09:52 <adamw> #info Proposed Blocker, gnome-control-center, NEW
17:10:14 <Lailah> adamw: What is zoom?
17:10:22 <Lailah> Sorry, I don't use Gnome at all.
17:10:40 <adamw> Lailah: it's an accessibility feature
17:10:42 <frantisekz> look at the bug lailah
17:10:49 <frantisekz> it's described there pretty well
17:10:54 <bcotton> hotel zoomifornia seems not great
17:10:56 <adamw> it's like a sort of looking glass
17:10:56 <Lailah> Yes, I'm reading.
17:10:58 <bcotton> +1 final FE
17:11:07 <adamw> as you move the cursor around, the area of the screen under it is magnified
17:11:15 <adamw> useful for people with impaired vision
17:11:17 <Lailah> Oh, okay, I remember that.
17:11:19 <Lailah> Yes
17:11:29 <frantisekz> I'd say even a blocker, not just FE
17:11:36 <bcotton> errr
17:11:40 <bcotton> yeah, i meant +1 blocker
17:11:50 <bcotton> +1 to whatever it is we're talking about right now ;-)
17:11:55 <frantisekz> :D
17:11:56 <pwhalen> :)
17:11:58 <Lailah> +1 blocker
17:12:00 <adamw> this is slightly borderline for me
17:12:06 <kparal> heh, that's funny, you can't turn it off :)
17:12:17 <adamw> but i wouldn't fight +1
17:12:33 <pwhalen> +1 Blocker
17:12:36 <kparal> I guess it should be +1, even though the number of people using this is probably low
17:12:55 <frantisekz> (#me tomorrow in the office to everybody on F31: hey, did you try the zoom ? it works amazingly well)
17:13:11 <Lailah> frantisekz: LOL
17:13:30 <adamw> proposed #agreed 1749433 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."
17:13:40 <bcotton> ack
17:13:42 <frantisekz> ack
17:13:43 <kparal> the question is whether we're going too far into considering this an element of the default panel
17:13:46 <Lailah> ack
17:14:02 <kparal> because if we considered Settings an app, we wouldn't require everything to work
17:14:02 <pwhalen> ack
17:14:16 <kparal> I won't fight +1, just thinking aloud :)
17:14:50 <bcotton> kparal: i understand that, but i give extra weight to a11y features as a general rule
17:14:55 <adamw> kparal: that was more or less my take, yeah
17:15:02 <kparal> sure, good enough for me
17:15:04 <adamw> but since we got sufficient +1 votes and i'm not really willing to -1...
17:15:29 <adamw> #agreed 1749433 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."
17:15:36 <adamw> #topic (1643446) download progress is often invisible
17:15:37 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1643446
17:15:37 <adamw> #info Proposed Blocker, gnome-software, NEW
17:15:48 <frantisekz> -1 Blocker, +1 FE
17:15:58 <kparal> I use zoom sometimes to play old games with 640x480 windows to fill the whole screen without going full screen and messing up my resolution :)
17:16:18 <frantisekz> (for me, it seems it's not even apparent there is any progress bar)
17:16:36 <kparal> frantisekz: because it broken! :)
17:16:39 <kparal> it's
17:16:40 <bcotton> this one is technically functional, just not useful. but useful is not a requirement :-)
17:16:42 <adamw> yeah, this one *does* seem more FE than blocker
17:17:11 <kparal> last time there were some concerns that we released Fedora too early, before all issues in gnome-software were properly resolved
17:17:16 <kparal> one year back
17:17:21 <Lailah> -1 Blocker, +1 FE
17:17:23 <kparal> so this time, I nominate it
17:17:29 <bcotton> 0 blocker, +1 FE
17:18:10 <pwhalen> -1 Blocker, +1 FE
17:18:28 <kparal> without the progress bar it looks like being stuck. but I won't argue against -1
17:18:47 <kparal> +1 FE for sure
17:18:57 <kparal> personally I'm somewhere around +0
17:19:10 <frantisekz> yeah, the overall UX without progress bar is terrible, totally worthy of fixing, but not bad enough to block on that, imo
17:19:19 <Lailah> kparal: I imagined you walking around a big zero.
17:19:30 <kparal> Lailah: it's a long walk
17:19:39 <Lailah> LOL
17:20:50 <kparal> looks like the vote is clear
17:20:59 <adamw> proposed #agreed 1643446 - RejectedBlocker (Final), AcceptedFreezeException (Final) - there is not enough support to consider this a clear violation of the release criteria, but it's certainly a bad enough experience to want it fixed for first-time F31 updaters
17:21:07 <adamw> oh
17:21:08 <frantisekz> ack
17:21:12 <adamw> are we FEing it for Beta or Final?
17:21:13 <adamw> or both?
17:21:19 <frantisekz> I'd say both
17:21:25 <adamw> i suppose beta makes sense atm
17:21:33 <bcotton> why_dont_we_have_both.png
17:21:43 <frantisekz> :)
17:22:00 <adamw> #itcanbetwothings
17:22:08 <adamw> so, patch
17:22:17 <adamw> proposed #agreed 1643446 - RejectedBlocker (Final), AcceptedFreezeException (Beta) - there is not enough support to consider this a clear violation of the release criteria, but it's certainly a bad enough experience to want it fixed for first-time F31 updaters
17:22:22 <adamw> not much point granting a Final FE *now*
17:22:25 <bcotton> ack
17:22:27 <frantisekz> ack
17:22:30 <pwhalen> ack
17:22:34 <Lailah> ack
17:22:50 <kparal> ack
17:23:36 <adamw> #agreed 1643446 - RejectedBlocker (Final), AcceptedFreezeException (Beta) - there is not enough support to consider this a clear violation of the release criteria, but it's certainly a bad enough experience to want it fixed for first-time F31 updaters
17:23:47 <adamw> #topic (1749868) GNOME Software doesn't prepare offline updates
17:23:47 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1749868
17:23:47 <adamw> #info Proposed Blocker, gnome-software, NEW
17:24:27 <kparal> we've had a pleasant day with gnome-software today
17:24:35 <adamw> isn't this the same as the other bug?
17:24:50 <frantisekz> no :(
17:24:55 <kparal> adamw: which other?
17:24:56 <adamw> oh, it's more like a superset
17:25:01 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1750414
17:25:04 <bcotton> they're bug cousins
17:25:08 <adamw> fixing that is a sort of workaround for this
17:25:13 <kparal> it's related
17:25:24 <kparal> https://bugzilla.redhat.com/show_bug.cgi?id=1749868#c9
17:25:33 <adamw> so
17:25:33 <adamw> i mean
17:25:40 <adamw> what's the expectation here? a better error?
17:25:52 <adamw> after all, if a mandatory repo is down we presumably expect this to fail
17:25:54 <kparal> now that DNF changed the defaults, we will have many many mandatory third-party repos. like dropbox, or atom, or whatever
17:26:13 <kparal> adamw: better error, yes, that would be a good start
17:26:16 <frantisekz> yep
17:26:33 <frantisekz> maybe even some "Continue without broken repos" button
17:26:36 <kparal> something like "this repo prevents you from getting updates"
17:26:46 <Lailah> adamw: But shouldn't just that repo fail and the programme carry on with the rest?
17:27:01 <adamw> well no, that's what 'mandatory repo' *means*
17:27:02 <mclasen> fix is to make repos not mandatory...
17:27:03 <frantisekz> that's skip_if_unavailable
17:27:14 <frantisekz> yeah
17:27:19 <kparal> mclasen: sure, for repos that we control
17:27:21 <adamw> we can't really expect gnome software to do the exact opposite of what the config option is meant to do
17:27:29 <mclasen> don't blame gnome-software for broken repo setup
17:27:37 <adamw> if we want to lobby dnf to flip the default back again, we can do that
17:27:43 <adamw> but we can't leave gnome-software holding the ball
17:27:47 <kparal> adamw: I'm already responding to the fesco ticket
17:28:00 <frantisekz> but, if I remember correctly, they had some strong arguments to make it like it's now
17:28:03 <adamw> i think my vote on this would be punt until we can clarify expectations here
17:28:10 <kparal> mclasen: I'm not blaming GS for broken repos, just for not giving a clear error
17:28:11 <frantisekz> I just don't remember what was it, I can ask them tomorrow
17:28:20 <adamw> improving the error message is desirable regardless, but not sure if it's blocker worthy
17:28:30 <adamw> that's just first thought, though...
17:28:39 <Lailah> adamw: I also prefer punting.
17:28:40 <kparal> however, my behavior was different from Jiri's behavior, so there are some variations that I don't understand
17:29:10 <kparal> adamw: the idea is again that the user is not getting updates and doesn't know why
17:29:23 <adamw> yeah, i get that
17:29:24 <kparal> it's not a strong +1 from me, but I think it's worth discussion
17:29:36 <adamw> i might be +1 in the end
17:29:40 <adamw> it just seems a bit uncertain atm
17:30:04 <frantisekz> let's punt then? ask gnome sw devs, if it's feasible to have something by the final?
17:30:39 <adamw> and see where the fesco ticket goes too
17:30:49 <adamw> if the default got flipped back, for e.g., this bug would look a lot less important i think
17:31:51 <bcotton> +1 punt
17:31:57 <frantisekz> +1 punt
17:32:42 <adamw> proposed #agreed 1749868 - punt (delay decision) - with the DNF default flipped, this looks like a serious issue, but there are a few uncertainties and we're also waiting on the outcome of the FESCo ticket before making a decision here
17:33:37 <pwhalen> ack
17:34:13 <kparal> ack
17:34:21 <frantisekz> ack
17:34:27 <Lailah> ack
17:34:47 <adamw> #agreed 1749868 - punt (delay decision) - with the DNF default flipped, this looks like a serious issue, but there are a few uncertainties and we're also waiting on the outcome of the FESCo ticket before making a decision here
17:34:56 <adamw> alright, that's everything on the lists
17:35:01 <adamw> #topic Open floor
17:35:11 <adamw> any other business, folks? bugs that were missed? other urgent f31 release-related stuff?
17:35:38 <Lailah> Not from my side.
17:35:55 <adamw> #info for the record, coremodule will secretarialize, apologies for not noting earlier
17:36:05 <frantisekz> I guess nothing important, thanks for the meeting adamw!
17:36:11 <bcotton> just a reminder that the Go/No-Go meeting is Thursday
17:36:36 <bcotton> and we now have a policy that lets us ignore bugs we don't like :p
17:37:16 <Lailah> bcotton: *This* Thursday?
17:37:31 <bcotton> Lailah: yes
17:37:35 <Lailah> Okay.
17:37:42 <Lailah> I'll try to be there
17:37:45 <bcotton> #info Beta Go/No-Go meeting is Thursday
17:37:54 <bcotton> #link https://apps.fedoraproject.org/calendar/meeting/9613/
17:37:54 <tablepc> Ignored bugs will bite you
17:38:25 <Lailah> I have anti-bug bite cream tablepc
17:38:37 <adamw> bcotton: i contest this characterization :P
17:40:40 <adamw> alrighty, thanks for coming everyone
17:40:47 <adamw> see you Thursday for the no-go meeting!
17:40:49 <adamw> *ahem*
17:40:57 <frantisekz> :D
17:41:01 <Lailah> See you!
17:41:09 <bcotton> adamw: spoiler alert!
17:41:23 * Lailah waves everyone and quietly fades in thin air
17:41:44 <pwhalen> heh, thanks adamw et al.
17:41:45 <adamw> wow, that's a cool trick
17:41:49 <adamw> i didn't know we had a package for that
17:42:19 <Lailah> :-D
17:43:12 <tablepc> Have a Great Day!
17:43:19 <adamw> you too!
17:43:26 <adamw> #endmeeting