#fedora-blocker-review: F32-blocker-review

Meeting started by adamw at 16:04:12 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:04:12)
  2. Introduction (adamw, 16:15:41)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:15:42)
    2. We'll be following the process outlined at: (adamw, 16:15:43)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:15:43)
    4. The bugs up for review today are available at: (adamw, 16:15:45)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:15:46)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:15:48)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:15:50)
    8. https://fedoraproject.org/wiki/Fedora_32_Beta_Release_Criteria (adamw, 16:15:52)
    9. https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria (adamw, 16:15:56)
    10. for Final, we have: (adamw, 16:16:04)
    11. 5 Proposed Blockers (adamw, 16:16:09)
    12. 2 Accepted Blockers (adamw, 16:16:09)
    13. 7 Proposed Freeze Exceptions (adamw, 16:16:13)
    14. 1 Accepted Freeze Exceptions (adamw, 16:16:13)
    15. coremodule will secretarialize (adamw, 16:16:25)

  3. Proposed Final blockers (adamw, 16:16:30)
    1. let's start with proposed final blockers! (adamw, 16:16:37)

  4. (1821548) schema validation fails (adamw, 16:16:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1821548 (adamw, 16:16:44)
    2. Proposed Blocker, 389-ds-base, NEW (adamw, 16:16:44)
    3. AGREED: 1821548 - RejectedBlocker (Final) - the update that causes this bug never reached stable state and has been unpushed, so the bug is not really affecting F32 at all (lruzicka, 16:24:06)

  5. (1821702) firefox starts in a non-resizeable cropped window instead of a maximized window (on Wayland) (frantisekz, 16:24:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1821702 (frantisekz, 16:24:41)
    2. Proposed Blocker, gtk3, VERIFIED (frantisekz, 16:24:41)
    3. https://bodhi.fedoraproject.org/updates/FEDORA-2020-ac3dfd7904 (frantisekz, 16:31:42)
    4. AGREED: 1821702 - punt (delay decision) on blocker, AcceptedFreezeException (Final) - it's a close call whether this is bad enough to be a blocker and we don't have a clear decision on that, but we definitely accept it as an FE and the update to fix it has strong positive feedback, so we expect to push that and resolve the bug (adamw, 16:45:19)

  6. (1814810) Basic graphics mode is necessary to boot laptop with dual Intel/AMD Oland GPU (adamw, 16:45:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1814810 (adamw, 16:45:44)
    2. Proposed Blocker, kernel, NEW (adamw, 16:45:44)
    3. AGREED: 1814810 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this is rejected as a blocker as we think the range of hardware affected is quite small (dual Intel/AMD Oland GPU systems are not very common), but accepted as an FE as a severe problem not fixable with an update on hardware that *is* affected (adamw, 17:00:06)

  7. (1817708) KDE desktop session will not start when switching between users (adamw, 17:00:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1817708 (adamw, 17:00:58)
    2. Proposed Blocker, plasma-desktop, NEW (adamw, 17:00:59)
    3. https://lists.fedoraproject.org/pipermail/test/2015-January/124875.html (adamw, 17:05:41)
    4. https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-01-26/f22-blocker-review.2015-01-26-17.00.html (adamw, 17:08:44)
    5. AGREED: 1817708 - RejectedBlocker (Final) AcceptedFreezeException (Final) - in 2015 we accepted a GNOME user switch bug as a blocker and proposed a criteria change to explicitly cover it, but rdieter opposed the proposal and it never actually happened; on that basis we can't really accept this as a blocker but do accept it as FE (adamw, 17:35:52)

  8. (1815463) Cannot create another user account through KDE System Settings if 'Real Name' field is not filled in (adamw, 17:36:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1815463 (adamw, 17:36:23)
    2. Proposed Blocker, plasma-user-manager, NEW (adamw, 17:36:23)
    3. https://lists.fedoraproject.org/pipermail/kde/2015-January/014180.html (adamw, 17:45:04)
    4. AGREED: 1815463 - RejectedBlocker (Final) AcceptedFreezeException (Final) - it's a close call, but with the additional info that populating the 'Real Name' field works around the bug, we agreed this isn't quite serious enough to block the release on, if it is not addressed by Final we will document the workaround in commonbugs (adamw, 18:12:27)

  9. Proposed Final freeze exceptions (adamw, 18:12:41)
    1. moving on to proposed FEs (adamw, 18:12:45)

  10. (1823064) podman fails to start, selinux denials (adamw, 18:12:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1823064 (adamw, 18:12:53)
    2. Proposed Freeze Exceptions, container-selinux, ON_QA (adamw, 18:12:53)
    3. AGREED: 1823064 - RejectedFreezeException (Final) - as we couldn't reproduce it, this seems unclear, and since there's only marginal benefit to taking this as an FE versus fixing it with an update we don't think it's worthwhile given the uncertainty (adamw, 18:25:32)

  11. (1823005) earlyoom is not being pulled in when upgrading F30/F31 to F32 (adamw, 18:25:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1823005 (adamw, 18:25:49)
    2. Proposed Freeze Exceptions, earlyoom, VERIFIED (adamw, 18:25:49)
    3. AGREED: 1823005 - AcceptedFreezeException (Final) - pulling this in as an FE is worthwhile to fix upgrades between now and the 0-day stable push (adamw, 18:32:37)

  12. (1819296) [abrt] geoclue2: g_type_check_instance(): geoclue killed by SIGSEGV (adamw, 18:32:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1819296 (adamw, 18:32:54)
    2. Proposed Freeze Exceptions, geoclue2, NEW (adamw, 18:32:54)
    3. AGREED: 1819296 - RejectedFreezeException (Final) - there's too much uncertainty here at present and the problem does not seem severe enough to merit considering a freeze exception, this can be investigated and fixed with a post-release update (adamw, 18:39:59)

  13. (1822336) Default Utilities folder renamed to X-GNOME-Utilities.directory (adamw, 18:40:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1822336 (adamw, 18:40:05)
    2. Proposed Freeze Exceptions, gnome-shell, NEW (adamw, 18:40:05)
    3. AGREED: 1822336 - AcceptedFreezeException (Final) - this is a very prominent error, even though cosmetic, and cannot be fixed for the live environment with a post-release update (adamw, 18:44:29)

  14. (1822992) gnome-weather displays no cloud conditions and unknown temperature for autodetected locations (adamw, 18:44:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1822992 (adamw, 18:44:37)
    2. Proposed Freeze Exceptions, gnome-weather, VERIFIED (adamw, 18:44:37)
    3. AGREED: 1822992 - AcceptedFreezeException (Final) - this is a fairly visible bug in a core GNOME component and cannot be fixed with an update for the live environment (adamw, 18:47:41)

  15. (1808767) X crashes on i915 GPU with SNA 2D acceleration (adamw, 18:47:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1808767 (adamw, 18:47:42)
    2. Proposed Freeze Exceptions, xorg-x11-drv-intel, ON_QA (adamw, 18:47:42)
    3. AGREED: 1808767 - AcceptedFreezeException (Final) - the range of hardware this affects is quite limited, but it is a serious problem on those systems and cannot be fully addressed with an update (adamw, 18:52:17)

  16. (1820614) zezere-ignition copies the ssh keys to '.ssh/authorized_keys.d/ignition' (adamw, 18:52:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1820614 (adamw, 18:52:29)
    2. Proposed Freeze Exceptions, zezere, ON_QA (adamw, 18:52:29)
    3. AGREED: 1820614 - AcceptedFreezeException (Final) - this is a significant issue for initial deployment and provisioning of IoT instances, cannot be addressed with a post-release update (adamw, 18:57:03)

  17. Accepted blocker review (adamw, 18:57:33)
    1. both accepted blockers are VERIFIED (adamw, 18:57:38)

  18. Open floor (adamw, 18:57:42)


Meeting ended at 19:00:35 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (224)
  2. lruzicka (87)
  3. frantisekz (59)
  4. cmurf (57)
  5. bcotton (45)
  6. zodbot (16)
  7. Southern_Gentlem (15)
  8. coremodule (13)
  9. rdieter (7)
  10. sumantro (2)
  11. mboddu (1)


Generated by MeetBot 0.1.4.