#fedora-blocker-review: F33-blocker-review

Meeting started by adamw at 16:18:20 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:18:20)
  2. Introduction (adamw, 16:19:22)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:19:23)
    2. We'll be following the process outlined at: (adamw, 16:19:23)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:19:24)
    4. The bugs up for review today are available at: (adamw, 16:19:24)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:19:26)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:19:28)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:19:30)
    8. https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria (adamw, 16:19:32)
    9. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria (adamw, 16:19:34)
    10. for Beta, we have: (adamw, 16:19:44)
    11. 5 Proposed Blockers (adamw, 16:19:44)
    12. 1 Proposed Freeze Exceptions (adamw, 16:19:49)
    13. for Final, we have: (adamw, 16:19:58)
    14. 2 Proposed Blockers (adamw, 16:20:07)

  3. Proposed Beta blockers (adamw, 16:20:17)
    1. coremodule will secretarialize (adamw, 16:20:54)

  4. (1856496) Anaconda cannot reclaim space from swap partition (adamw, 16:21:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1856496 (adamw, 16:21:05)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:21:05)
    3. AGREED: 1856496 - AcceptedBlocker (Beta) - it would be good to have independent confirmation of this, but as described we accept it as a blocker as a violation of Beta requirement "When using the guided partitioning flow, the installer must be able to: ... Remove existing storage volumes to free up space, at the user's direction" (adamw, 16:26:01)

  5. (1855174) btrfs installation crashes with multiple disks, when one of them is too small for the OS (adamw, 16:26:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1855174 (adamw, 16:26:09)
    2. Proposed Blocker, btrfs-progs, NEW (adamw, 16:26:09)
    3. https://github.com/kdave/btrfs-progs/issues/270 (cmurf, 16:27:47)
    4. AGREED: 1855174 - AcceptedBlocker (Beta) - accepted as a violation of "When using the guided partitioning flow, the installer must be able to: ... Complete an installation using any combination of disk configuration options it allows the user to select" (adamw, 16:32:04)

  6. (1830343) Network manager started stuck when I tries connecting to VPN (openconnect) after upgrade gnome-shell to 3.37.1-1.fc33 version (adamw, 16:32:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1830343 (adamw, 16:32:14)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:32:14)
    3. AGREED: 1830343 - punt (delay decision) - we see this as a bad problem and on its face potentially a blocker, but existing criteria don't really cover it, and we're not sure exactly how broken it is yet. punting for more research on how common the bug is, and also a potential proposal of VPN-specific release criteria (adamw, 16:57:29)

  7. (1856514) In default boot with 2GB of RAM or less, network install images crash with "loading repo 'rawhide' failure: write_ext(0) has failed: -1" since systemd-246~rc1-1.fc33 (adamw, 16:57:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1856514 (adamw, 16:57:37)
    2. Proposed Blocker, systemd, NEW (adamw, 16:57:37)
    3. https://docs.fedoraproject.org/en-US/fedora/rawhide/release-notes/welcome/Hardware_Overview/ (adamw, 16:58:40)
    4. AGREED: 1856514 - AcceptedBlocker (Beta) - this is accepted as a violation of Basic criterion "The installer must run when launched normally from the release-blocking images" when booting release-blocking netinst images with 2GB of RAM or less. We note that 2GB is a fairly common config for VMs, and the official docs state 1GB is the minimum requirement (adamw, 17:07:12)

  8. (1857043) FreeIPA server deployment fails in Fedora-Rawhide-20200714.n.0 due to pki-tomcat failing to run with "java.lang.ClassNotFoundException: org.apache.tomcat.util.modeler.modules.MbeansDescriptorsIntrospectionSource" (adamw, 17:09:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1857043 (adamw, 17:09:48)
    2. Proposed Blocker, tomcat, NEW (adamw, 17:09:48)
    3. AGREED: 1857043 - AcceptedBlocker (Beta) - accepted as a clear violation of Basic criterion "It must be possible to configure a Fedora Server system installed according to the above criteria as a FreeIPA domain controller, using the official deployment tools provided in the distribution FreeIPA packages." (adamw, 17:15:00)
    4. that's all the proposed Beta blockers, and the only proposed Beta FE is the same openconnect bug we punted, so let's move on to... (adamw, 17:15:34)

  9. Proposed Final blockers (adamw, 17:15:37)
  10. (1855292) btrfs is not resizable in anaconda (adamw, 17:15:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1855292 (adamw, 17:15:43)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:15:43)
    3. AGREED: 1855292 - RejectedBlocker (Final) - it would be nice to have this feature, but we agree the criteria are not intended to require it, and we have substantial precedent for not being able to shrink our own default filesystem layouts (adamw, 17:26:57)

  11. (1829079) Second session fails to start correctly when user switching (adamw, 17:27:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1829079 (adamw, 17:27:28)
    2. Proposed Blocker, gnome-shell, POST (adamw, 17:27:28)
    3. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria#User_switching (adamw, 17:28:11)
    4. AGREED: 1829079 - AcceptedBlocker (Final) - accepted as a clear violation of "User switching must work using the mechanisms offered (if any) by all release-blocking desktops in their default configuration." (adamw, 17:31:09)

  12. Open floor (adamw, 17:31:19)


Meeting ended at 17:45:35 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (136)
  2. cmurf (78)
  3. King_InuYasha (59)
  4. lruzicka (22)
  5. bcotton (19)
  6. pwhalen (17)
  7. coremodule (15)
  8. zodbot (10)
  9. sumantro (4)


Generated by MeetBot 0.1.4.