#fedora-blocker-review: F33-blocker-review

Meeting started by adamw at 16:11:46 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:11:46)
  2. Introduction (adamw, 16:15:57)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:15:57)
    2. We'll be following the process outlined at: (adamw, 16:15:57)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:15:58)
    4. The bugs up for review today are available at: (adamw, 16:15:58)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:16:00)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:16:02)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:16:05)
    8. https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria (adamw, 16:16:06)
    9. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria (adamw, 16:16:08)
    10. for Beta, we have: (adamw, 16:16:16)
    11. 5 Proposed Blockers (adamw, 16:16:17)
    12. 5 Accepted Blockers (adamw, 16:16:17)
    13. 1 Proposed Freeze Exceptions (adamw, 16:16:21)
    14. coremodule will secretarializie (adamw, 16:16:33)

  3. Proposed Beta blockers (adamw, 16:17:22)
  4. (1869140) adding a disk after make some partitions makes anaconda crash everytime (adamw, 16:17:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1869140 (adamw, 16:17:30)
    2. Proposed Blocker, anaconda, NEW (adamw, 16:17:30)
    3. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria#Network_attached_storage (adamw, 16:21:39)
    4. AGREED: 1869140 - RejectedBlocker (Beta) - we do not believe this violates the Beta criteria (the cited criterion refers to "guided partitioning" but the bug involves using custom partitioning, and network storage devices are only in the Final criteria). there is some support for making this a Final blocker but not clear enough to accept it yet (adamw, 16:31:31)

  5. (1869102) ipxe-roms-qemu-20190125-7 breaks UEFI-based VMs (won't boot) (adamw, 16:31:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1869102 (adamw, 16:31:50)
    2. Proposed Blocker, edk2, NEW (adamw, 16:31:50)
    3. AGREED: 1869102 - AcceptedBlocker (Beta) - accepted as a conditional violation of "The release must be able host virtual guest instances of the same release" (when the virtual guest instance is using UEFI) (adamw, 16:38:14)

  6. (1869335) error: ../../grub-core/net/net.c:1795:timeout reading initrd.img (adamw, 16:38:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1869335 (adamw, 16:38:24)
    2. Proposed Blocker, grub2, NEW (adamw, 16:38:24)
    3. https://openqa.fedoraproject.org/tests/641434 (adamw, 16:39:40)
    4. AGREED: 1869335 - AcceptedBlocker (Beta) - accepted as a violation of "It must be possible to install by booting the installation kernel directly (including via PXE)..." there's some question about how many scenarios this affects, but it at least affects some significant aarch64 platforms (adamw, 16:45:10)

  7. (1863041) systemd-resolved.service not work with DNS server placed behind VPN (openconnect) (adamw, 16:45:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1863041 (adamw, 16:45:21)
    2. Proposed Blocker, systemd, NEW (adamw, 16:45:21)
    3. AGREED: 1863041 - punt (delay decision) - this bug really points up an inadequacy of the criteria: we don't have explicit network or VPN criteria, and it'd just be too much of a stretch to crowbar this into any existing criterion. so we are punting on the decision to propose and discuss explicit network/VPN criteria (adamw, 16:56:50)

  8. (1861463) zram-setup@zram0.service: Failed to load configuration: No such file or directory (adamw, 16:56:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1861463 (adamw, 16:56:58)
    2. Proposed Blocker, udisks2, NEW (adamw, 16:56:58)
    3. according to pwhalen this bug has mysteriously gone away again, so we'll close the report for now and hope it never comes back (adamw, 17:02:39)

  9. Proposed Beta freeze exception (adamw, 17:03:03)
  10. (1863041) systemd-resolved.service not work with DNS server placed behind VPN (openconnect) (adamw, 17:03:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1863041 (adamw, 17:03:06)
    2. Proposed Freeze Exceptions, systemd, NEW (adamw, 17:03:07)
    3. AGREED: 1863041 - AcceptedFreezeException (Beta) - it seems reasonable to grant this an FE as someone may want to access an affected VPN from a live image and that would be difficult with this bug (adamw, 17:09:05)

  11. Accepted Beta blocker check-in (adamw, 17:09:31)
  12. (1860616) abrt-server errors when processing zstd compressed core dumps produced by systemd-246~rc1-1.fc33 (adamw, 17:09:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1860616 (adamw, 17:09:46)
    2. Accepted Blocker, libreport, POST (adamw, 17:09:46)
    3. a new libreport release was attempted last week, but had all kinds of problems and was untagged; a new one was done today but the problems aren't fixed so it may need untagging again (adamw, 17:14:38)
    4. ACTION: adamw to find some people to yell at to get this mess dealt with properly (adamw, 17:15:02)

  13. (1866570) FreeIPA deployment fails in current Rawhide due to various issues with Java 11 (adamw, 17:17:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1866570 (adamw, 17:17:14)
    2. Accepted Blocker, resteasy, NEW (adamw, 17:17:14)
    3. https://packages.debian.org/sid/pki-base-java built against openjdk 8 in Debian (ab, 17:27:11)
    4. ab/cipherboy suggest that we may need to build dogtag against an older Java at least for Beta, however the details of that are worked out exactly (adamw, 17:29:14)
    5. we've asked the team to start doing whatever they're going to do ASAP so we have as much time as possible to get it working before Beta release (adamw, 17:30:09)

  14. (1861700) login stuck when changing users repeatedly (log out, log in a different one) (adamw, 17:30:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1861700 (adamw, 17:30:47)
    2. Accepted Blocker, sddm, NEW (adamw, 17:30:47)
    3. kamil is working on debugging this, it seems not straightforward to solve (adamw, 17:31:40)
    4. waiting on developer feedback on kparal's latest debugging (adamw, 17:34:25)

  15. (1862686) SELinux is preventing systemd-machine from 'create' accesses on the sock_file io.systemd.Machine. (adamw, 17:34:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1862686 (adamw, 17:34:33)
    2. Accepted Blocker, selinux-policy, POST (adamw, 17:34:33)
    3. this is in POST, so we're just waiting on a new selinux-policy build. we're not sure yet if more fixes will be needed after the initial one (adamw, 17:35:15)

  16. (1857043) FreeIPA server deployment fails in Fedora-Rawhide-20200714.n.0 due to pki-tomcat failing to run with "java.lang.ClassNotFoundException: org.apache.tomcat.util.modeler.modules.MbeansDescriptorsIntrospectionSource" (adamw, 17:35:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1857043 (adamw, 17:35:30)
    2. Accepted Blocker, tomcat, MODIFIED (adamw, 17:35:30)
    3. this one is still kind of "behind" the general FreeIPA vs. Java 11 issue, we'll know if this is resolved once that's resolved (adamw, 17:35:44)

  17. Open floor (adamw, 17:35:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1849431 and https://bugzilla.redhat.com/show_bug.cgi?id=1827915 should be blockers i believe (adamw, 17:42:58)


Meeting ended at 17:47:41 UTC (full logs).

Action items

  1. adamw to find some people to yell at to get this mess dealt with properly


Action items, by person

  1. adamw
    1. adamw to find some people to yell at to get this mess dealt with properly


People present (lines said)

  1. adamw (188)
  2. cmurf (59)
  3. bcotton (28)
  4. lruzicka (21)
  5. pwhalen (18)
  6. zodbot (16)
  7. Eighth_Doctor (15)
  8. kparal (14)
  9. ab (11)
  10. coremodule (9)
  11. cipherboy (8)
  12. frantisekz_ (6)
  13. michel_slm (4)
  14. jlanda (1)
  15. kalev (1)


Generated by MeetBot 0.1.4.