#fedora-blocker-review: F33-blocker-review

Meeting started by adamw at 16:00:21 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:21)
  2. Introduction (adamw, 16:08:09)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:08:10)
    2. We'll be following the process outlined at: (adamw, 16:08:10)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:08:12)
    4. The bugs up for review today are available at: (adamw, 16:08:12)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:15)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:17)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:08:19)
    8. https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria (adamw, 16:08:21)
    9. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria (adamw, 16:08:23)
    10. for Beta, we have: (adamw, 16:08:25)
    11. 1 Proposed Blockers (adamw, 16:08:51)
    12. 10 Accepted Blockers (adamw, 16:08:51)
    13. 13 Accepted Freeze Exceptions (adamw, 16:08:55)
    14. for Final, we have: (adamw, 16:09:03)
    15. 2 Proposed Blockers (adamw, 16:09:13)
    16. 1 Accepted Blockers (adamw, 16:09:13)
    17. coremodule will secretarialize (adamw, 16:11:26)

  3. Proposed Beta blocker (adamw, 16:11:53)
  4. (1828188) dasbus.error.DBusError: cannot initialize a disk that has partitions (adamw, 16:12:00)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1828188 (adamw, 16:12:00)
    2. https://pagure.io/fedora-qa/blocker-review/issue/60 (adamw, 16:12:00)
    3. Proposed Blocker, kernel, NEW (adamw, 16:12:00)
    4. ticket has -2 from cmurf and lruzicka: https://pagure.io/fedora-qa/blocker-review/issue/60 (adamw, 16:12:28)
    5. AGREED: 1828188 - RejectedBlocker (Beta) - there's no indication this bug is still present in current F33 (or Rawhide), reporter tried and cannot reproduce, neither can anyone else. It should probably be closed, but we definitely reject it as a blocker for now (adamw, 16:16:45)

  5. Proposed Final blockers (adamw, 16:17:10)
  6. (1876162) anaconda storage configuration is extremely slow with an existing btrfs filesystem containing hundreds of snapshots (adamw, 16:17:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1876162 (adamw, 16:17:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/64 (adamw, 16:17:20)
    3. Proposed Blocker, anaconda, NEW (adamw, 16:17:20)
    4. AGREED: 1876162 - punt (delay decision) - this seems like a reasonable blocker candidate but we're concerned about the extent to which it can realistically be addressed in a practical timeframe for F33. we will punt for input from installer team on this (adamw, 16:33:16)

  7. (1875140) g-i-s fails to completely launch following clean install, opens in a tiny non-resizeable window instead (adamw, 16:33:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1875140 (adamw, 16:33:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/61 (adamw, 16:33:27)
    3. Proposed Blocker, gnome-initial-setup, NEW (adamw, 16:33:27)
    4. we have +2 ticket votes from kparal and frantisekz (adamw, 16:45:21)
    5. AGREED: 1875140 - AcceptedBlocker (Final) - this is accepted as a violation of "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system", when the bug happens, g-i-s is definitely not "clearly presented" (adamw, 16:48:50)

  8. Accepted Beta blockers (adamw, 16:49:11)
  9. (1872056) Booting Server DVD then selecting a mirrorlist repository does not work (adamw, 16:49:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1872056 (adamw, 16:49:29)
    2. https://pagure.io/fedora-qa/blocker-review/issue/35 (adamw, 16:49:29)
    3. Accepted Blocker, anaconda, ON_QA (adamw, 16:49:29)
    4. same fix should be in next Rawhide compose, we can verify (or not) there (adamw, 16:50:13)

  10. (1849430) Fedora 33: Everything boot x86_64 image exceeds maximum size (adamw, 16:50:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1849430 (adamw, 16:50:16)
    2. https://pagure.io/fedora-qa/blocker-review/issue/21 (adamw, 16:50:16)
    3. Accepted Blocker, distribution, ASSIGNED (adamw, 16:50:16)
    4. https://github.com/weldr/lorax/pull/1070 (adamw, 16:50:39)
    5. adamw has a PR posted that does some initial work here, more planned soon: https://github.com/weldr/lorax/pull/1070 (adamw, 16:52:33)

  11. (1849431) Fedora 33: Server boot x86_64 image exceeds maximum size (adamw, 16:52:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1849431 (adamw, 16:52:54)
    2. https://pagure.io/fedora-qa/blocker-review/issue/20 (adamw, 16:52:54)
    3. Accepted Blocker, distribution, ASSIGNED (adamw, 16:52:54)
    4. exactly same as previous bug (the installer environment is effectively the same in both) (adamw, 16:53:06)

  12. (1869892) Release-blocking Fedora 33 images have Fedora 32 backgrounds (adamw, 16:53:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1869892 (adamw, 16:53:12)
    2. https://pagure.io/fedora-qa/blocker-review/issue/27 (adamw, 16:53:12)
    3. Accepted Blocker, distribution, NEW (adamw, 16:53:12)
    4. the dependent KDE bug https://bugzilla.redhat.com/show_bug.cgi?id=1872054 is now ON_QA (adamw, 16:53:41)
    5. again, easiest way to check this will be in Rawhide, adamw has sent a build of the same kde-settings to Rawhide so we can check the next Rawhide compose's results (adamw, 16:54:13)

  13. (1874117) 5.8.3-300.fc33.aarch64 kernel panic on boot (X-Gene PMU) (adamw, 16:56:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1874117 (adamw, 16:56:34)
    2. https://pagure.io/fedora-qa/blocker-review/issue/59 (adamw, 16:56:34)
    3. Accepted Blocker, kernel, VERIFIED (adamw, 16:56:34)
    4. bug comments indicate that https://bodhi.fedoraproject.org/updates/FEDORA-2020-5081eec059 fixes this, but it is not marked as fixing it (adamw, 16:57:15)
    5. i'll mark the update as fixing the bug, then it should get pushed stable soon and we'll be OK (adamw, 16:57:46)

  14. (1860616) abrt-server errors when processing zstd compressed core dumps produced by systemd-246~rc1-1.fc33 (adamw, 16:58:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1860616 (adamw, 16:58:58)
    2. https://pagure.io/fedora-qa/blocker-review/issue/15 (adamw, 16:58:58)
    3. Accepted Blocker, libreport, ON_QA (adamw, 16:58:59)
    4. we have two bugs - this one and the next, https://bugzilla.redhat.com/show_bug.cgi?id=1873029 - plus https://pagure.io/fedora-workstation/issue/156 which altogether boil down to: the whole abrt/libreport infrastructure is broken and it needs to work (adamw, 17:02:50)
    5. there seem to be a number of specific problems, but our top-line expectation here is that we at least need sufficient functionality to successfully file crash reports. (adamw, 17:03:56)
    6. ACTION: adamw to talk to abrt/libreport team again about expectations and practicalities here (adamw, 17:08:32)

  15. (1873029) bugs can't be reported: "No matching actions found for this event" (adamw, 17:08:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1873029 (adamw, 17:08:49)
    2. https://pagure.io/fedora-qa/blocker-review/issue/45 (adamw, 17:08:49)
    3. Accepted Blocker, libreport, NEW (adamw, 17:08:49)
    4. see discussion on previous bug, all part of the same area (adamw, 17:08:55)

  16. (1863041) systemd-resolved.service not work with DNS server placed behind VPN (openconnect) (adamw, 17:09:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1863041 (adamw, 17:09:03)
    2. https://pagure.io/fedora-qa/blocker-review/issue/24 (adamw, 17:09:03)
    3. Accepted Blocker, NetworkManager, NEW (adamw, 17:09:03)
    4. systemd and nss-mdns updates were just pushed stable, so we can see how this works in the next compose (adamw, 17:13:16)

  17. (1871990) FreeIPA server upgrade from Fedora 32 or Fedora 31 fails with java.lang.UnsupportedClassVersionError (adamw, 17:15:19)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1871990 (adamw, 17:15:19)
    2. https://pagure.io/fedora-qa/blocker-review/issue/34 (adamw, 17:15:19)
    3. Accepted Blocker, pki-core, ASSIGNED (adamw, 17:15:19)
    4. upstream PR appears to have been merged, just pinged the bug to ask if we can get a downstream build (adamw, 17:16:19)

  18. (1861700) login stuck when changing users repeatedly (log out, log in a different one) (adamw, 17:17:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1861700 (adamw, 17:17:46)
    2. https://pagure.io/fedora-qa/blocker-review/issue/16 (adamw, 17:17:46)
    3. Accepted Blocker, sddm, NEW (adamw, 17:17:46)
    4. we're quite worried about this bug as it doesn't look easy to solve and there has not been a lot of action on it. kparal has provided what looks like sufficient info for developers to start looking into it. (adamw, 17:28:56)

  19. Open floor (adamw, 17:29:00)


Meeting ended at 17:53:44 UTC (full logs).

Action items

  1. adamw to talk to abrt/libreport team again about expectations and practicalities here


Action items, by person

  1. adamw
    1. adamw to talk to abrt/libreport team again about expectations and practicalities here


People present (lines said)

  1. adamw (214)
  2. cmurf (97)
  3. regenbogen (61)
  4. kparal (29)
  5. coremodule (23)
  6. zodbot (12)
  7. pwhalen (9)
  8. bcotton (8)
  9. lruzicka (1)


Generated by MeetBot 0.1.4.