16:01:26 <bcotton_> #startmeeting F33-blocker-review
16:01:26 <zodbot> Meeting started Mon Sep 28 16:01:26 2020 UTC.
16:01:26 <zodbot> This meeting is logged and archived in a public location.
16:01:26 <zodbot> The chair is bcotton_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:26 <zodbot> The meeting name has been set to 'f33-blocker-review'
16:01:27 <bcotton_> #meetingname F33-blocker-review
16:01:27 <zodbot> The meeting name has been set to 'f33-blocker-review'
16:01:29 <bcotton_> #topic Roll Call
16:01:34 <bcotton_> anyone here today?
16:01:46 <Southern_Gentlem> nope
16:01:50 <bcotton_> dang!
16:02:02 <coremodule> .hello2 good morning bcotton, if we reach quorum, I'll secretarialize.
16:02:04 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:02:09 <bcotton_> coremodule: ack!
16:02:14 <bcotton_> #chair coremodule
16:02:14 <zodbot> Current chairs: bcotton_ coremodule
16:04:14 <nb> .hello2
16:04:15 <zodbot> nb: nb 'Nick Bebout' <nick@bebout.net>
16:04:37 <bcotton_> welcome nb
16:04:40 <bcotton_> that makes four of us
16:05:18 <bcotton_> technically quorum is 3, so i guess that works
16:05:31 <coremodule> wfm!
16:05:52 <bcotton_> but we'll be free with the punt today i think, in cases where there's not overwhelming agreement
16:06:08 <bcotton_> #topic Introduction
16:06:09 <bcotton_> Why are we here?
16:06:11 <bcotton_> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:06:12 <bcotton_> #info We'll be following the process outlined at:
16:06:14 <bcotton_> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:06:16 <bcotton_> #info The bugs up for review today are available at:
16:06:17 <bcotton_> #link http://qa.fedoraproject.org/blockerbugs/current
16:06:19 <bcotton_> #info The criteria for release blocking bugs can be found at:
16:06:20 <bcotton_> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:06:22 <bcotton_> #link https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria
16:06:23 <bcotton_> #link https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria
16:06:34 <bcotton_> #info 5 Proposed Blockers
16:06:35 <bcotton_> #info 4 Accepted Blockers
16:06:37 <bcotton_> #info 0 Accepted 0-day Blockers
16:06:38 <bcotton_> #info 0 Accepted Previous Release Blockers
16:06:40 <bcotton_> #info 1 Proposed Freeze Exceptions
16:06:41 <bcotton_> #info 0 Accepted Freeze Exceptions
16:06:49 <bcotton_> #topic (1881234) Resizing doesn't work right in anaconda blivet-gui mode: "AttributeError: 'BlivetStorageHandler' object has no attribute '_resizable_filesystems'"
16:06:51 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1881234
16:06:52 <bcotton_> #link https://pagure.io/fedora-qa/blocker-review/issue/122
16:06:54 <bcotton_> #info Proposed Blocker, blivet-gui, POST
16:07:06 <bcotton_> #info In the ticket: FinalBlocker (+2, 0, -0)
16:07:40 <coremodule> ill refrain from voting here since I voted on pagure, unless you want to double up and call it a day bcotton_
16:07:55 <bcotton_> kparal nominated it under the "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation." criterion
16:08:13 <bcotton_> coremodule: just /nick to someone else for another vote :-)
16:08:21 <coremodule> hahahaha
16:08:29 <modulecore> +1
16:08:32 <nb> +1
16:08:44 <bcotton_> coremodule++
16:09:23 <bcotton_> proposed #agreed 1881234 - AcceptedBlocker (Final) - Violates the final criterion "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation."
16:09:32 <coremodule> ack
16:09:35 <nb> ack
16:09:50 <bcotton_> #agreed 1881234 - AcceptedBlocker (Final) - Violates the final criterion "Any installer mechanism for resizing storage volumes must correctly attempt the requested operation."
16:10:07 <bcotton_> #topic (1868141) Select Printer Driver hangs
16:10:08 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1868141
16:10:10 <bcotton_> #link https://pagure.io/fedora-qa/blocker-review/issue/124
16:10:11 <bcotton_> #info Proposed Blocker, gnome-control-center, ON_QA
16:10:25 <bcotton_> #info In the ticket: FinalBlocker (+7, 0, -0)
16:10:30 <bcotton_> that seems pretty strong
16:10:45 <coremodule> agreed
16:11:07 * pwhalen joins
16:11:20 <bcotton_> welcome pwhalen
16:11:36 <coremodule> good morning pwhalen
16:11:55 <nb> +1
16:11:56 <bcotton_> proposed #agreed 1868141 - AcceptedBlocker (Final) - Violates the criterion "Printing must work in release-blocking desktops on at least one printer available to those performing validation testing."
16:11:59 <nb> ack
16:12:01 <coremodule> ack
16:12:04 <pwhalen> +1, ack
16:12:10 <bcotton_> #agreed 1868141 - AcceptedBlocker (Final) - Violates the criterion "Printing must work in release-blocking desktops on at least one printer available to those performing validation testing."
16:12:27 <bcotton_> #topic (1882718) Can't login if the session is locked
16:12:29 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1882718
16:12:30 <bcotton_> #link https://pagure.io/fedora-qa/blocker-review/issue/131
16:12:32 <bcotton_> #info Proposed Blocker, gnome-remote-desktop, NEW
16:12:46 <bcotton_> ooh, no votes in the ticket yet. guess i have to read now
16:13:00 <coremodule> I am +1 final blocker to this, but would be okay with punting for more info/testing
16:13:51 <bcotton_> yeah, i'm not sure if we intend VNC to be included in the "default panel must work" criterion
16:14:20 <cmurf> woops, sorry i'm late
16:14:30 <bcotton_> oh look, workstation wg shows up just on time ;-)
16:14:39 <cmurf> haha
16:14:44 <cmurf> i am not the wg
16:14:53 <bcotton_> you represent the wg, though :-)
16:15:00 <bcotton_> certainly more than the rest of us do
16:15:03 <cmurf> that's a stretch
16:15:09 <cmurf> :)
16:15:17 <cmurf> i have no backscroll btw
16:15:31 <bcotton_> so we're talking about https://bugzilla.redhat.com/show_bug.cgi?id=1882718
16:15:42 <bcotton_> coremodule is +1 FB but okay with punting
16:15:57 <bcotton_> and i'm not entirely sure VNC was intended to be included in the cited criterion
16:16:02 <pwhalen> does this only happen in vnc?
16:16:27 <bcotton_> that's the implication, although it's not said explicitly
16:17:22 <cmurf> yeah i want more information
16:17:35 <cmurf> so there's possibly two passwords (?)
16:18:01 <bcotton_> proposed #agreed 1882718 - Defer decision (punt) - We want confirmation that 1. this bug only occurs with VNC sessions and 2. That VNC is intended to be covered in the "default panel must function correctly" criterion
16:18:05 <cmurf> the user account password, which also removes the screen unlock
16:18:16 <cmurf> and a VNC password which is a different thing...
16:18:20 <bcotton_> cmurf: right
16:18:23 <cmurf> i don't know how they are intended to interact
16:18:55 <cmurf> my gut instinct is, if a user intentionally sets them differently and they lock their screen or the timeout for screen lock happens, then VNC should not work
16:18:59 <cmurf> but then, that's my opinion
16:19:07 <cmurf> i could be 100% wrong
16:19:12 <cmurf> so yeah we need more info
16:19:39 <cmurf> how it's intended to work vs how it does work is more important to figure out
16:20:28 <bcotton_> agreed
16:21:20 <cmurf> yeah from the  upstream bug, something is busted regardless
16:21:31 <bcotton_> any feelings about my proposed #agreed above?
16:21:39 <coremodule> whoops, missed that
16:21:40 <coremodule> ack
16:21:41 <pwhalen> ack
16:21:55 <cmurf> ack
16:22:06 <bcotton_> #agreed 1882718 - Defer decision (punt) - We want confirmation that 1. this bug only occurs with VNC sessions and 2. That VNC is intended to be covered in the "default panel must function correctly" criterion
16:22:23 <bcotton_> #topic (1882863) gnome-software 3.38.0 does not list all software in Add-ons
16:22:24 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1882863
16:22:26 <bcotton_> #link https://pagure.io/fedora-qa/blocker-review/issue/127
16:22:27 <bcotton_> #info Proposed Blocker, gnome-software, NEW
16:22:45 <bcotton_> #info In the ticket: FinalBlocker (+0, 1, -0)
16:23:36 <coremodule> +1 punt for more info, personally
16:23:50 <bcotton_> what info, specifically?
16:24:31 <cmurf> is this basic functionality
16:24:39 <cmurf> i think probably it is, i mean
16:24:47 <coremodule> well, I'm not totally convinced this is a gnome-software bug, but don't have all the info to figure out if I'm correct in my assumption there.
16:24:48 <cmurf> i can't install the nvidia driver?
16:24:54 <cmurf> unless i go to cli?
16:25:08 <coremodule> cmurf, yeah, that's what i was trying to do when i hit this. so... i mean, yeah. I see that.
16:25:53 <bcotton_> it seeeeeeems like a blocker to me
16:26:17 <cmurf> i'm inclined to block
16:26:26 <bcotton_> like if the nvidia driver is broken, sorry about your luck, but we should at least show it if it's available
16:26:29 <cmurf> it seems weird to block on being unable to install proprietary software but that's a detail
16:26:58 <cmurf> it probably happens to other things also
16:27:15 <cmurf> is there an upstream bug for this?
16:27:20 <coremodule> that was my other thought, but if you think it's an appropriate enforcement of the "default functionality" criterion, my vote could be swayed.
16:27:22 <bcotton_> i mean i suppose we could punt until we have a better understanding of the cause. if it's just nvidia for some reason, then it may still be a blocker, but that's different if it's an entire repo
16:27:42 <coremodule> or lack of vote
16:28:12 <cmurf> needinfo
16:28:14 <cmurf> punt
16:28:27 <pwhalen> +1 punt for more info
16:28:30 <cmurf> but we should be aggressive about it, final freeze in 7 days
16:28:51 <coremodule> cmurf, who would you cc on the bug to get some more info on it?
16:29:14 <cmurf> they're already cc'd
16:29:18 <bcotton_> proposed #agreed 1882863 - Defer decision (punt) - It's not clear what the scope of this bug is, so it's hard to make a blocker decision at this time.
16:29:47 <coremodule> cool
16:29:48 <coremodule> ack
16:30:14 <pwhalen> ack
16:31:11 <cmurf> ack
16:31:16 <bcotton_> #agreed 1882863 - Defer decision (punt) - It's not clear what the scope of this bug is, so it's hard to make a blocker decision at this time.
16:31:38 <bcotton_> #topic (1880833) Massive memory leak on AMD cards
16:31:39 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1880833
16:31:41 <bcotton_> #link https://pagure.io/fedora-qa/blocker-review/issue/116
16:31:43 <bcotton_> #info Proposed Blocker, mesa, NEW
16:31:59 <bcotton_> #info In the ticket: FinalBlocker (+1, 0, -0)
16:32:54 <bcotton_> this seems like a continued punt
16:33:27 <cmurf> ew
16:33:29 <coremodule> agreed, according to pagure its a kernel issue, but no "evidence" as mentioned in the bugzilla report
16:33:34 <cmurf> has this been bisected?
16:34:02 <bcotton_> cmurf: if it has, nobody has mentioned it
16:34:07 <cmurf> -1 blocker
16:34:23 <cmurf> kernel bisects are tedious but it's the only way to be sure
16:35:05 <cmurf> this is where i'm headed in comment 4
16:35:17 <cmurf> as soon as it's working in one and not another, kernel bisect is in order
16:36:13 * cmurf has done his fair share of i915 bug bisection
16:36:48 <bcotton_> so punt again until someone can conclusively show where the problem is (and the scope of affected hardware)?
16:36:55 <cmurf> yep
16:37:01 <coremodule> +1 punt for info
16:37:09 <nb> ack
16:37:17 <pwhalen> I was -1. but punt sounds good too
16:37:46 <cmurf> if no one can do a bisect or figure out where the bug is, there's nothing to block on :)
16:37:52 <bcotton_> proposed #agreed 1880833 - Defer decision (punt) - We will defer this again until it's clear how wide a range of hardware may be affected and where the bug lies
16:37:59 <cmurf> ack
16:38:16 <pwhalen> ack
16:38:17 <coremodule> ack
16:38:24 <bcotton_> #agreed 1880833 - Defer decision (punt) - We will defer this again until it's clear how wide a range of hardware may be affected and where the bug lies
16:39:10 <bcotton_> so that's the end of the proposed blockers. i propose we call it a day. we still have one more meeting before the freeze begins and i'm not sure there's much to talk about on the accepted blockers
16:39:51 <coremodule> wow that was fast! Ill take it!
16:40:20 <pwhalen> bcotton_: no complaints here
16:40:21 <cmurf> we should send a get well card to adamw
16:40:31 * nb wonders what is going on with adamw?
16:40:43 <bcotton_> #topic Open floor
16:41:09 <bcotton_> #info We'll skip proposed freeze exceptions since we have one more meeting before freeze begins
16:41:12 <bcotton_> anything for open floor?
16:41:22 <coremodule> nothing here
16:41:40 <pwhalen> cmurf: +1 to that
16:43:18 <bcotton_> okay, thanks everyone!
16:43:21 <bcotton_> #endmeeting