#fedora-blocker-review: F34-blocker-review

Meeting started by adamw at 17:00:59 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:01:09)
  2. Introduction (adamw, 17:06:03)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:06:14)
    2. We'll be following the process outlined at: (adamw, 17:06:19)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:06:25)
    4. The bugs up for review today are available at: (adamw, 17:06:29)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:06:35)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:06:40)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 17:06:45)
    8. https://fedoraproject.org/wiki/Fedora_34_Beta_Release_Criteria (adamw, 17:06:49)
    9. https://fedoraproject.org/wiki/Fedora_34_Final_Release_Criteria (adamw, 17:06:55)
    10. for Beta, we have: (adamw, 17:07:14)
    11. 1 Proposed Blockers (adamw, 17:07:14)
    12. 3 Accepted Blockers (adamw, 17:07:20)
    13. 7 Proposed Freeze Exceptions (adamw, 17:07:24)
    14. 12 Accepted Freeze Exceptions (adamw, 17:07:24)
    15. for Final, we have: (adamw, 17:07:34)
    16. 2 Proposed Blockers (adamw, 17:07:41)
    17. 5 Accepted Blockers (adamw, 17:07:41)
    18. coremodule will secretarialize (adamw, 17:07:46)

  3. Proposed Beta blocker (adamw, 17:07:55)
  4. (1936288) multiple user space crashes are assigned to kernel-core and cannot be reported (adamw, 17:09:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1936288 (adamw, 17:09:44)
    2. https://pagure.io/fedora-qa/blocker-review/issue/286 (adamw, 17:09:49)
    3. Proposed Blocker, gnome-abrt, NEW (adamw, 17:09:52)
    4. AGREED: 1936288 - RejectedBlocker (Beta) - this is definitely a case abrt should handle better, but it's not new and we know the bounds of it quite well (GPFs), it's not broad enough to block a release (adamw, 17:20:46)

  5. Proposed Beta freeze exceptions (adamw, 17:22:51)
  6. (1934149) F34FailsToInstall: 0ad (adamw, 17:23:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1934149 (adamw, 17:23:30)
    2. https://pagure.io/fedora-qa/blocker-review/issue/277 (adamw, 17:23:33)
    3. Proposed Freeze Exceptions, 0ad, VERIFIED (adamw, 17:23:37)
    4. AGREED: we will treat this bug as a proxy for all five proposed 'fails to install' bugs (adamw, 17:24:57)
    5. AGREED: 1934149, 1924284, 1924317, 1924319, 1924321 AcceptedFreezeException (Beta) - we agree that an FE is generally merited if a package fails to install due to the impact on people upgrading from previous stable releases, likely without updates-testing enabled. However, fixes will only be pushed if they involve minimal change and don't seem likely to endanger compose of release-blocking images (adamw, 17:40:44)

  7. (1930567) ESP's "forwarding" grub.cfg doesn't contain $boot FS UUID when it's btrfs (adamw, 17:40:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1930567 (adamw, 17:41:01)
    2. https://pagure.io/fedora-qa/blocker-review/issue/285 (adamw, 17:41:05)
    3. Proposed Freeze Exceptions, anaconda, NEW (adamw, 17:41:09)
    4. AGREED: 1930567 - AcceptedFreezeException (Beta) - this is accepted as it has the same effect as 1928588 , which was already accepted. It's a significant installer issue that can't be resolved with an update (adamw, 17:50:16)

  8. (1930401) No update notifications shown when updates available (F34, Rawhide) (adamw, 17:50:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1930401 (adamw, 17:50:58)
    2. https://pagure.io/fedora-qa/blocker-review/issue/234 (adamw, 17:51:03)
    3. Proposed Freeze Exceptions, gnome-software, POST (adamw, 17:51:09)
    4. AGREED: 1930401 - AcceptedFreezeException (Beta) - failing to notify of available updates is a significant issue, it can be fixed with an update but of course...there's a catch-22 there :D (adamw, 17:59:43)
    5. that's all the proposed FEs, moving on to: (adamw, 17:59:56)

  9. Proposed Final blockerss (adamw, 18:00:45)
  10. (1930567) ESP's "forwarding" grub.cfg doesn't contain $boot FS UUID when it's btrfs (adamw, 18:01:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1930567 (adamw, 18:01:13)
    2. https://pagure.io/fedora-qa/blocker-review/issue/285 (adamw, 18:01:18)
    3. Proposed Blocker, anaconda, NEW (adamw, 18:01:21)
    4. AGREED: 1930567 - AcceptedBlocker (Final) - this seems like a clear violation of "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration" combined with the Basic "installed system must boot" criteria (adamw, 18:08:42)

  11. (1930401) No update notifications shown when updates available (F34, Rawhide) (adamw, 18:09:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1930401 (adamw, 18:09:06)
    2. https://pagure.io/fedora-qa/blocker-review/issue/234 (adamw, 18:09:12)
    3. Proposed Blocker, gnome-software, POST (adamw, 18:09:16)
    4. AGREED: 1930401 - AcceptedBlocker (Final) - since we determined there is a bug here preventing notifications from being shown, this is a clear violation of Final criterion "Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image." (adamw, 18:14:43)

  12. Accepted Beta blockers (adamw, 18:15:01)
  13. (1930977) [abrt] gnome-shell: nouveau_fence_signalled(): gnome-shell killed by SIGSEGV (adamw, 18:16:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1930977 (adamw, 18:16:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/241 (adamw, 18:16:26)
    3. Accepted Blocker, mesa, ASSIGNED (adamw, 18:16:30)
    4. there basically is a fix for this, we just need to sort out the Fedora process side of things (maintainer is not clear on what's needed for the package) (adamw, 18:20:54)
    5. ACTION: adamw to move 1930977 forward with the packager (adamw, 18:21:02)

  14. (1933433) systemd-resolved: stub resolver is not following CNAME for resolution (adamw, 18:22:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1933433 (adamw, 18:22:46)
    2. https://pagure.io/fedora-qa/blocker-review/issue/261 (adamw, 18:22:53)
    3. Accepted Blocker, systemd, MODIFIED (adamw, 18:22:57)
    4. there is an update for this in testing which is generally reported to solve things, a reporter has suggested there's still an issue in the bug, but it doesn't seem to be really the same problem (adamw, 18:23:35)
    5. update is pending stable, only needs pushing, will happen shortly (adamw, 18:27:37)

  15. (1933454) /etc/resolv.conf is not a symlink (adamw, 18:27:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1933454 (adamw, 18:27:52)
    2. https://pagure.io/fedora-qa/blocker-review/issue/265 (adamw, 18:27:58)
    3. Accepted Blocker, systemd, NEW (adamw, 18:28:04)
    4. several possible resolutions have been discussed in the bug, we need to pick one and do it (adamw, 18:29:12)
    5. ACTION: adamw to poke people to pick and implement a fix for 1933454 (adamw, 18:31:55)

  16. Open floor (adamw, 18:33:26)
    1. https://paste.centos.org/view/9552c3d6 (cmurf, 18:50:48)
    2. https://paste.centos.org/view/334618d0 (cmurf, 18:51:53)


Meeting ended at 19:03:31 UTC (full logs).

Action items

  1. adamw to move 1930977 forward with the packager
  2. adamw to poke people to pick and implement a fix for 1933454


Action items, by person

  1. adamw
    1. adamw to move 1930977 forward with the packager
    2. adamw to poke people to pick and implement a fix for 1933454


People present (lines said)

  1. adamw (168)
  2. cmurf (62)
  3. lruzicka[m] (41)
  4. pwhalen (18)
  5. bcotton (13)
  6. coremodule (13)
  7. zodbot (10)
  8. lruzicka (6)
  9. Eighth_Doctor (3)


Generated by MeetBot 0.1.4.