16:00:31 <adamw> #startmeeting F35-blocker-review
16:00:31 <zodbot> Meeting started Mon Sep 20 16:00:31 2021 UTC.
16:00:31 <zodbot> This meeting is logged and archived in a public location.
16:00:31 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:31 <zodbot> The meeting name has been set to 'f35-blocker-review'
16:00:31 <adamw> #meetingname F35-blocker-review
16:00:31 <zodbot> The meeting name has been set to 'f35-blocker-review'
16:00:32 <adamw> #topic Roll Call
16:00:38 <adamw> ahoyhoy folks, who's around for blocker review times?
16:01:03 <bcotton> .hello2
16:01:04 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:14 <coremodule> .hello2
16:01:15 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:01:34 * coremodule is willing to act as secretary!
16:02:17 <adamw> thanks coremodule!
16:03:18 <geraldosimiao> .hello geraldosimiao
16:03:19 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:03:33 <frantisekz> .hello2
16:03:34 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
16:04:57 <adamw> hmm. is there a way i can see someone's IRC nick from matrix, does anyone know?
16:05:01 <adamw> #chair coremodule
16:05:01 <zodbot> Current chairs: adamw coremodule
16:05:06 <adamw> #chair frantisekz
16:05:06 <zodbot> Current chairs: adamw coremodule frantisekz
16:06:06 <bcotton> adamw: do you mean what IRC nick a matrix account is using across the bridge? not AFAIK :-(
16:06:17 <pwhalen> .hello2
16:06:18 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
16:06:23 <adamw> Ben Cotton (he/him/his): yeah, so i could chair you :D
16:06:25 <adamw> hi pwhalen
16:06:59 <bcotton> adamw: well there's your first mistake! but i'm using 'bcotton' on the bridge
16:07:08 <adamw> haha, too late now
16:07:11 <adamw> we have three chairs, it's full
16:07:22 <bcotton> it's okay. i have a standing desk
16:07:23 <adamw> i was just gonna chair bcotton but then i thought, uh, i dunno if that's actually you :D
16:10:04 <adamw> alrighty, let's get rolling
16:10:10 <adamw> impending boilerplate alert
16:10:31 <adamw> #topic Introduction
16:10:34 <adamw> Why are we here?
16:10:49 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:10:50 <adamw> #info We'll be following the process outlined at:
16:10:50 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:10:52 <adamw> #info The bugs up for review today are available at:
16:10:57 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:11:02 <adamw> #info The criteria for release blocking bugs can be found at:
16:11:06 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:11:11 <adamw> #link https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria
16:11:16 <adamw> #link https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria
16:11:24 <adamw> #info for Beta, we have:
16:11:33 <adamw> #info 1 Proposed Blockers
16:11:40 <adamw> #info 3 Accepted Blockers
16:11:45 <adamw> #info 1 Proposed Freeze Exceptions
16:11:46 <adamw> #info 6 Accepted Freeze Exceptions
16:11:58 <adamw> #info for Final, we have:
16:12:01 <adamw> #info 6 Proposed Blockers
16:12:04 <adamw> #info 2 Accepted Blockers
16:12:07 <adamw> #info 1 Accepted Freeze Exceptions
16:12:19 <adamw> #info coremodule will secretarialize
16:13:01 <adamw> let's start with:
16:13:04 <adamw> #topic Proposed Beta blocker
16:13:16 <adamw> #topic (2005625) Very slow to proceed past password page in initial setup
16:13:19 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2005625
16:13:24 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/463
16:13:31 <adamw> #info Proposed Blocker, gnome-initial-setup, NEW
16:13:32 <adamw> #info Ticket vote: BetaBlocker (+0,0,-4) (-kparal, -frantisekz, -bcotton, -geraldosimiao)
16:13:34 <adamw> #info Ticket vote: FinalBlocker (+4,0,-0) (+kparal, +frantisekz, +bcotton, +geraldosimiao)
16:13:38 <adamw> #info Ticket vote: BetaFreezeException (+4,0,-0) (+kparal, +frantisekz, +bcotton, +geraldosimiao)
16:14:04 <adamw> so we have enough votes for a decision in the ticket, but since it seems kinda important i figured we could still check on it in the meeting
16:14:50 <adamw> i think it's also worth noting that https://bugzilla.redhat.com/show_bug.cgi?id=2004565 is likely part of the same problem
16:15:20 <adamw> so we have the user creation being slow, and the keyring of the created user being bugged
16:18:42 <bcotton> i'm fine with calling them both a Final blocker and marking one as duplicate if it turns out the same update fixes both
16:19:45 <geraldosimiao> ack
16:20:36 <adamw> Ben Cotton (he/him/his): still OK releasing beta with it, thoguh?
16:20:42 <adamw> and that's a real possibility given we're at Monday...
16:20:59 <bcotton> adamw: i am. it's not ideal, but it's beta-able
16:20:59 <adamw> i do feel like this is pretty awkward for beta. hard to say that it violates any criteria though, i guess.
16:21:05 <adamw> okay
16:21:13 <adamw> everyone else okay with beta FE, final blocker?
16:21:43 <coremodule> +1
16:22:24 <frantisekz> +1
16:22:27 <geraldosimiao> I'm ok, is beta.
16:24:10 <adamw> proposed #agreed 2005625 - RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this is accepted as a Final blocker as a conditional violation of criterion "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." We don't think it's bad enough to block Beta, but it is bad enough to warrant a freeze exception
16:24:15 <adamw> (did that fit in one line on IRC?)
16:24:22 <pwhalen> yes
16:24:24 <pwhalen> ack
16:24:24 <frantisekz> yes
16:24:25 <frantisekz> ack
16:25:29 <coremodule> ack
16:25:36 <geraldosimiao> ack
16:26:08 <adamw> #agreed 2005625 - RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this is accepted as a Final blocker as a conditional violation of criterion "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." We don't think it's bad enough to block Beta, but it is bad enough to warrant a freeze exception
16:27:02 <adamw> #topic Proposed Final blockers
16:27:16 <adamw> #info 2005625 was the only proposed Beta FE and we covered it, so moving onto Final.
16:27:42 <adamw> #topic (2005625) Very slow to proceed past password page in initial setup
16:28:00 <adamw> dangit
16:28:01 <adamw> same bug
16:28:01 <adamw> #undo
16:28:01 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fb2e0254e80>
16:28:20 <adamw> hmm, did we lose the bot?
16:28:55 <adamw> oh, there we go.
16:29:06 <adamw> #topic (2004565) The default keyring is created with an unknown password, can't be unlocked
16:29:06 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2004565
16:29:09 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/460
16:29:15 <adamw> #info Proposed Blocker, gnome-initial-setup, NEW
16:29:18 <adamw> #info Ticket vote: FinalBlocker (+3,0,-0) (+kparal, +geraldosimiao, +catanzaro)
16:29:40 <adamw> so as noted above, we suspect this has the same cause as the g-i-s slowness. but i'm OK with accepting it separately for now
16:29:45 <adamw> we can always reconcile them later if necessary
16:29:52 <adamw> anyone opposed?
16:29:57 <pwhalen> +1, ack
16:30:02 <frantisekz> ack
16:30:04 <geraldosimiao> ack
16:30:09 <bcotton> +1
16:31:31 <adamw> hey you can't ack anything yet
16:31:38 * adamw hands out premature acking penalties
16:31:45 <bcotton> snack
16:33:16 <adamw> proposed #agreed 2004565 - AcceptedBlocker (Final) - we believe this has the same cause as 2005625, but there's no harm in accepting it separately in case it doesn't. accepted as a violation of "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test."
16:33:24 <coremodule> ack
16:34:01 <bcotton> ack
16:34:10 <geraldosimiao> ack
16:34:28 <pwhalen> ack
16:34:40 <frantisekz> ack
16:34:58 <pwhalen> (...on x86_64 and AArch64..)
16:35:53 <adamw> hum, do we need to edit that criterion?
16:36:11 <adamw> yeah, i guess we do
16:36:17 <adamw> but for now that's what it says, so will quote it that way :D
16:36:18 <pwhalen> I guess if thats how its written, small nit pick
16:36:22 <adamw> #agreed 2004565 - AcceptedBlocker (Final) - we believe this has the same cause as 2005625, but there's no harm in accepting it separately in case it doesn't. accepted as a violation of "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test."
16:36:31 <pwhalen> hhe, fair :)
16:36:47 <adamw> #topic (1950669) [abrt] gnome-settings-daemon: get_current_screen_saver_status(): gsd-usb-protection killed by SIGSEGV
16:36:50 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1950669
16:37:03 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/412
16:37:03 <adamw> #info Proposed Blocker, gnome-settings-daemon, NEW
16:37:18 <adamw> so at this point i'm -1 on this because we seem to have established that the 'real fix' is not to get in the situation where the crash happens
16:37:33 <adamw> and with the latest changes we have achieved that
16:37:44 <adamw> technically the crash is still possible so this bug should stay open, but it should not happen in normal use so we don't need to block or FE it
16:38:38 <pwhalen> -1 based on that, would like to verify on aarch64 as well. I'll do that after the meeting
16:39:52 <adamw> thanks pwhalen
16:39:56 <bcotton> -1 blocker
16:41:23 <frantisekz> -1 B
16:43:06 <geraldosimiao> that bug shows itself in wich arch?
16:43:27 <adamw> i believe we had it on all arches tested
16:43:48 <adamw> pwhalen wants to confirm that on aarch64 we now don't run into it in 'normal' use any more, i think
16:43:56 <adamw> we have already confirmed that on x86_64
16:44:22 <pwhalen> right, I had proposed it at one point as well
16:44:36 <geraldosimiao> ok
16:45:46 <adamw> proposed #agreed 1950669 - RejectedBlocker (Final) - we believe at this point other bugs have been fixed such that this crash will not usually be encountered, and so there is no need for it to be a blocker or FE issue.
16:45:53 <bcotton> ack
16:45:55 <frantisekz> ack
16:46:08 <geraldosimiao> ack
16:46:50 <pwhalen> ack
16:46:53 <adamw> #agreed 1950669 - RejectedBlocker (Final) - we believe at this point other bugs have been fixed such that this crash will not usually be encountered, and so there is no need for it to be a blocker or FE issue.
16:47:02 <adamw> #topic (2004604) a removed package looks still installed in gnome-software, can't be installed again until reboot
16:47:08 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2004604
16:47:13 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/457
16:47:19 <adamw> #info Proposed Blocker, gnome-software, NEW
16:47:27 <adamw> #info Ticket vote: FinalBlocker (+3,1,-0) (+kparal, +catanzaro, +geraldosimiao, sgallagh)
16:48:28 <frantisekz> +1 FB
16:48:33 <pwhalen> +1 FB
16:48:39 <bcotton> is everyone able to reproduce this except me?
16:50:47 <adamw> Ben Cotton (he/him/his): haven't tried yet
16:50:54 <adamw> i feel like this might not pass the last blocker test
16:51:00 <adamw> but apparently it's fixed in 41.0 final so it may be academic
16:51:10 <bcotton> yeah, i think i'm 0 on this
16:51:53 <bcotton> the opportunity to avoid taking a position prevents itself, so i'll just sit on this nice, cozy fence
16:52:16 <geraldosimiao> 😂
16:52:43 * adamw joins ben on the fence
16:53:30 <adamw> proposed #agreed 2004604 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops", in the case of trying to reinstall a previously removed package
16:53:39 <geraldosimiao> ack
16:53:55 <bcotton> ack
16:53:56 <coremodule> ack
16:54:00 <pwhalen> ack
16:54:11 <frantisekz> ack
16:54:49 <adamw> #agreed 2004604 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops", in the case of trying to reinstall a previously removed package
16:55:00 <adamw> #topic (2005343) System repositories can be disabled by clicking on the row
16:55:04 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2005343
16:55:16 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/461
16:55:17 <adamw> #info Proposed Blocker, gnome-software, NEW
16:55:20 <adamw> #info Ticket vote: FinalBlocker (+1,0,-0) (+geraldosimiao)
16:55:23 <adamw> this seems kinda marginal.
16:55:55 <frantisekz> -1 imo
16:57:17 <adamw> -1 for me, this just isn't enough of a breach of the criterion. it's a bug
16:57:19 <bcotton> -1. it's unfortunate, but falls under the "okay, so don't do that" principle :-)
16:57:38 <pwhalen> -1
16:58:03 <bcotton> even if we don't get 41.1 in time for GA, it's easily fixed in an update
16:58:19 <geraldosimiao> but its confusing and missleading, isn't it?
16:59:02 <adamw> sure, but not release-blockingly so
16:59:04 <adamw> perl is confusing and misleading, but we ship that!
16:59:04 <adamw> <ducks>
16:59:17 <frantisekz> also, the patch seems okay for backporting to 41.0
16:59:23 <frantisekz> if we don't get 41.1 for GA
17:00:46 <geraldosimiao> adamw: 🤣
17:00:48 <adamw> proposed #agreed 2005343 - RejectedBlocker (Final) - this seems like an unfortunate behaviour and it'd be good to fix it, but it's not really serious enough to violate the "basic functionality" criterion or any others
17:00:58 <bcotton> ack
17:01:18 <pwhalen> ack
17:01:19 <geraldosimiao> ack
17:01:29 <frantisekz> ack
17:02:41 <adamw> #agreed 2005343 - RejectedBlocker (Final) - this seems like an unfortunate behaviour and it'd be good to fix it, but it's not really serious enough to violate the "basic functionality" criterion or any others
17:02:47 <adamw> #topic (1995439) cannot run F34 or F33 toolboxes in F35 or C9S: Error: invalid entry point PID of container
17:02:59 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1995439
17:02:59 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/447
17:03:05 <adamw> #info Proposed Blocker, toolbox, NEW
17:03:16 <adamw> #info Ticket vote: FinalBlocker (+0,0,-2) (-kparal, -geraldosimiao)
17:03:19 <frantisekz> -1 Blocker
17:03:34 <frantisekz> Toolbox isn't blocking afaik?
17:06:24 <adamw> yeah, nothing about this looks blocking
17:06:38 <bcotton> yeah, i don't see any criterion we could reasonably apply
17:06:48 <adamw> the justification is "That breaks lives of users of Atomic Host who put their real work in Toolbox containers.", but nothing ostree-ish is release blocking atm.
17:06:48 <bcotton> at least not until silverblue becomes a blocking deliverable :-)
17:06:56 <adamw> -1
17:06:57 <bcotton> -1
17:06:58 <adamw> note it's accepted as Beta FE alrady
17:07:32 <adamw> proposed #agreed 1995439 - RejectedBlocker (Final) - this does not violate any criteria. it's significant primarily for ostree builds, and none of those are release-blocking yet.
17:07:33 * pwhalen notes IoT is ostree :)
17:08:04 <frantisekz> ack
17:08:26 <adamw> patch
17:08:48 <adamw> proposed #agreed 1995439 - RejectedBlocker (Final) - this does not violate any criteria. it's significant primarily for user-facing ostree builds, and none of those are prelease-blocking yet.
17:09:09 <bcotton> patch s/user-facing/desktop-oriented/ ?
17:10:20 <bcotton> i'll stop being a pedant now (temporarily)
17:10:34 <adamw> .fire bcotton
17:10:34 <zodbot> adamw fires bcotton
17:12:03 <adamw> any more acks?
17:12:17 <adamw> i stand by this version of the text :D
17:12:34 <bcotton> i'll allow it :-)
17:12:34 <bcotton> ack
17:12:55 <pwhalen> ack
17:13:15 <geraldosimiao> ack
17:13:25 <frantisekz> ack
17:13:42 <adamw> #agreed 1995439 - RejectedBlocker (Final) - this does not violate any criteria. it's significant primarily for user-facing ostree builds, and none of those are prelease-blocking yet.
17:13:56 <adamw> alright, that's all the proposals
17:14:02 <adamw> let's check in on:
17:14:06 <adamw> #topic Accepted Beta Blockers
17:14:19 <adamw> #info a reminder - we are checking status here, not voting (unless we decide to re-vote one)
17:14:41 <adamw> #topic (1999321) DNS often stops resolving properly after FreeIPA server upgrade to Fedora 35 or 36
17:14:46 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1999321
17:15:04 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/419
17:15:05 <adamw> #info Accepted Blocker, freeipa, NEW
17:15:26 <adamw> so this one is turning out to be awkward to diagnose/fix. we know more or less the outline of what's going on, but not the details. it may also relate somehow to the network environment inside fedora infra, where openQA runs.
17:16:39 <adamw> lruzicka is currently working to see if it's reproducible outside. if not we could potentially revote it
17:17:38 <adamw> #info we are currently working to try and establish the parameters of this issue, and whether it is specific to fedora infra's network environment.
17:18:10 <adamw> anything else on this?
17:19:01 <bcotton> just my usual muttering about freeipa
17:19:11 <adamw> can it, cotton
17:19:16 <adamw> :D
17:19:22 * bcotton prefers bottles
17:19:27 <adamw> #topic (2000756) error: ../../grub-core/loader/arm64/linux.c:326:Invalid PE optional header magic.
17:19:34 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2000756
17:19:38 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/464
17:19:45 <adamw> #info Accepted Blocker, grub2, ON_QA
17:19:52 <adamw> #info fix for this is in the queue, so shouldn't be any problems there
17:20:14 <adamw> pwhalen has confirmed the fix
17:20:26 <adamw> #topic (1989726) [abrt] gnome-shell: cogl_texture_get_gl_texture(): gnome-shell killed by SIGSEGV
17:20:33 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1989726
17:20:38 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/399
17:20:41 <adamw> #info Accepted Blocker, mesa, NEW
17:21:38 <adamw> #info from discussion in the bug, Karol (who's taking care of it) says there's potentially a way to address it but it's not trivial. I gave him the timeframe we're working with in https://bugzilla.redhat.com/show_bug.cgi?id=1989726#c40
17:21:54 <adamw> ben, dunno if you can do any desk sitting here...or offer him any help from anyone else...
17:22:23 <bcotton> i can certainly try
17:22:42 <adamw> thanks
17:23:02 <adamw> alrighty, i think that's everything
17:23:17 <adamw> so we're basically working on those freeipa and mesa issues at this point
17:23:19 <adamw> #topic Open floor
17:24:32 <adamw> as noted in the qa meeting there are a few tests that need running, notably active directory tests and cloud tests on a real cloud
17:24:58 <frantisekz> fingers crossed to get candidate soon... (understand, no later than Wednesday :O )
17:24:59 <adamw> #info please check https://openqa.fedoraproject.org/testcase_stats/35/ for tests at Basic or Beta milestone that have not been run recently and help run them!
17:26:37 <adamw> yup, ideally tomorrow
17:26:44 <adamw> if we can get some kinda fix for the mesa bug i will roll a candidate even if the freeipa bug is still outstanding, since there's a chance we can revote that
17:27:11 <frantisekz> adamw++
17:27:11 <zodbot> frantisekz: Karma for adamwill changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:27:53 <geraldosimiao> adamw: thats fine
17:28:17 <adamw> any other business, folks?
17:28:39 <frantisekz> nope, thanks for the meeting everybody
17:29:01 <geraldosimiao> thank you
17:30:22 <adamw> alright, thanks for coming, everyone
17:30:41 <adamw> i've gotta go head to the polling station and pick tweedledee, tweedledum or tweedledumber...
17:30:48 <adamw> #endmeeting