#fedora-blocker-review: F35-blocker-review

Meeting started by adamw at 16:02:08 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:02:09)
  2. Introduction (adamw, 16:10:05)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:10:05)
    2. We'll be following the process outlined at: (adamw, 16:10:06)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:10:06)
    4. The bugs up for review today are available at: (adamw, 16:10:07)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:10:07)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:10:11)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:10:31)
    8. https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria (adamw, 16:10:32)
    9. https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria (adamw, 16:10:32)
    10. for Final, we have: (adamw, 16:10:37)
    11. 7 Proposed Blockers (adamw, 16:10:43)
    12. 5 Accepted Blockers (adamw, 16:10:50)
    13. 4 Proposed Freeze Exceptions (adamw, 16:10:51)
    14. 2 Accepted Freeze Exceptions (adamw, 16:10:54)
    15. coremodule will secretarialize (adamw, 16:10:59)

  3. Proposed Final blockers (adamw, 16:11:11)
  4. (2010259) [abrt] dnf: _revert_transaction(): history.py:233:_revert_transaction:KeyError: 'Reason Change' (adamw, 16:11:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2010259 (adamw, 16:11:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/493 (adamw, 16:11:27)
    3. Proposed Blocker, dnf, NEW (adamw, 16:11:27)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-bcotton) (adamw, 16:11:31)
    5. Ticket vote: FinalFreezeException (+1,0,-0) (+bcotton) (adamw, 16:11:36)
    6. https://github.com/rpm-software-management/dnf/blob/master/dnf/cli/commands/history.py#L192-L249 (adamw, 16:14:26)
    7. AGREED: 2010259 - RejectedBlocker (Final), RejectedFreezeException (Final) - the crash here appears to be non-destructive and limited to revert/rollback transactions. So we don't think it violates the release criteria or otherwise qualifies as a blocker. We also think it does not need a freeze exception - there is no great benefit to getting it in the release media, and any change would benefit from the extra time in testing. (adamw, 16:29:23)

  5. (2009451) Meeting link imported are truncated; results in invalid link (adamw, 16:30:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2009451 (adamw, 16:30:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/487 (adamw, 16:30:23)
    3. Proposed Blocker, gnome-calendar, NEW (adamw, 16:30:27)
    4. Ticket vote: FinalBlocker (+0,1,-3) (bcotton, -catanzaro, -imsedgar, -frantisekz) (adamw, 16:30:34)
    5. Ticket vote: FinalFreezeException (+4,0,-0) (+catanzaro, +imsedgar, +frantisekz, +bcotton) (adamw, 16:30:41)
    6. AGREED: 2009451 - RejectedBlocker (Final) AcceptedFreezeException (Final) - on balance, there's a consensus that this isn't quite serious enough to constitute "core functionality" for GNOME Calendar. however, it is definitely an annoying problem and would be good to have fixed for fresh installs, so it is accepted as a freeze exception issue (adamw, 16:48:52)

  6. (2010353) updates-testing repo can't be disabled (adamw, 16:48:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2010353 (adamw, 16:49:03)
    2. https://pagure.io/fedora-qa/blocker-review/issue/494 (adamw, 16:49:05)
    3. Proposed Blocker, gnome-software, NEW (adamw, 16:49:15)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+kparal, +sumantrom) (adamw, 16:49:15)
    5. AGREED: 2010353 - AcceptedBlocker (Final) - being able to enable updates-testing but not disable it again both looks bad and can potentially cause problems, so we agree that this violates "All applications that can be launched...after a default installation of Fedora Workstation on the x86_64 architecture must...withstand a basic functionality test." (adamw, 16:59:06)

  7. (2008537) 5.14.x defaults to acpi on aarch64 (adamw, 16:59:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2008537 (adamw, 16:59:09)
    2. https://pagure.io/fedora-qa/blocker-review/issue/492 (adamw, 16:59:17)
    3. Proposed Blocker, kernel, NEW (adamw, 16:59:23)
    4. Ticket vote: FinalBlocker (+0,0,-2) (-bcotton, -coremodule) (adamw, 16:59:28)
    5. Ticket vote: FinalFreezeException (+2,0,-0) (+bcotton, +coremodule) (adamw, 16:59:31)
    6. AGREED: 2008537 - punt (delay decision) on blocker, AcceptedFreezeException (Final) - we don't have a clear vote on whether this is serious enough to constitute a release blocker bug, but we definitely agree it's at least bad enough to grant a freeze exception, and expect the fix will land soon enough as to render the blocker question academic (adamw, 17:11:21)

  8. (2006746) Mouse cursor position offset changes randomly after changing resolution in a VM (adamw, 17:20:20)
    1. AGREED: 2006746 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this is rejected as a blocker on the basis that changing resolutions in a VM such that the bug happens is not commonly done (we may reconsider based on plausible arguments to the contrary). accepted as a freeze exception issue if the fix needs to be in the guest, so that release lives may be fixed (adamw, 17:29:04)

  9. (2009304) Mouse cursor offset in VMs with Wayland (but not X11), possibly due to mouse integration (adamw, 17:29:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2009304 (adamw, 17:29:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/486 (adamw, 17:29:22)
    3. Proposed Blocker, spice-vdagent, NEW (adamw, 17:29:25)
    4. Ticket vote: FinalBlocker (+3,0,-0) (+kparal, +bcotton, +coremodule) (adamw, 17:29:29)
    5. AGREED: 2009304 - AcceptedBlocker (Final) - in contrast to 2006746, this bug seems to happen on all boots of an F35 Workstation or KDE VM, and it causes substantial functionality issues, so we accept it as a sufficiently serious problem to constitute a violation of several graphical desktop usage requirements when running in a VM (adamw, 17:40:02)

  10. (2006393) [DNS over TLS] following connection to a wifi AP, internet is not available for ~30s (adamw, 17:41:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2006393 (adamw, 17:42:01)
    2. https://pagure.io/fedora-qa/blocker-review/issue/472 (adamw, 17:42:04)
    3. Proposed Blocker, systemd, NEW (adamw, 17:42:07)
    4. Ticket vote: FinalBlocker (+4,0,-0) (+imsedgar, +chrismurphy, +bcotton, +coremodule) (adamw, 17:42:10)
    5. AGREED: 2006393 - punt (delay decision) - there is a strong consensus that this ought to be a release blocker, but nobody has made a really plausible justification for it based on the release criteria. therefore, we punt on the decision but refer it to FESCo for consideration as a FESCo-declared blocker. we will also start a discussion about explicit (wireless) networking criteria for F36. (adamw, 18:06:52)

  11. Proposed Final freeze exceptions (adamw, 18:07:11)
    1. all proposed FEs are decided or decidable by ticket vote already, moving on (adamw, 18:09:59)

  12. Accepted Final blockers (adamw, 18:10:12)
    1. as a reminder, we are checking status, not re-voting here (unless we decide a re-vote is merited) (adamw, 18:10:31)

  13. (1997315) abrt-dbus segmentation faulted in abrt_p2_service_dbus when shutting down, rebooting, or logging out of Plasma (adamw, 18:10:40)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1997315 (adamw, 18:10:43)
    2. https://pagure.io/fedora-qa/blocker-review/issue/431 (adamw, 18:10:46)
    3. Accepted Blocker, abrt, ASSIGNED (adamw, 18:10:50)
    4. assignee said (last week) "Soon-ish -- I hope to have the fix ready early next week!", so we are awaiting a fix this week (adamw, 18:12:18)

  14. (2006028) Non-root user cannot join an Active Directory domain through Cockpit (adamw, 18:13:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2006028 (adamw, 18:13:56)
    2. https://pagure.io/fedora-qa/blocker-review/issue/465 (adamw, 18:13:57)
    3. Accepted Blocker, cockpit, ON_QA (adamw, 18:14:00)
    4. fix for this is in updates-testing, waiting karma or time to go stable, we don't have explicit confirmation of the fix in the update but it does look like stephen confirmed the same fix on the bug report (adamw, 18:15:58)

  15. (1991075) time is transiently incorrect when Automatic Time Zone is enabled (adamw, 18:18:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1991075 (adamw, 18:18:32)
    2. https://pagure.io/fedora-qa/blocker-review/issue/389 (adamw, 18:18:35)
    3. Accepted Blocker, geoclue2, NEW (adamw, 18:18:38)
    4. we don't have significant progress on this yet, but kalev will take a look at it tomorrow. it's worth noting that kamil and chris got somewhat different test results here - neither managed to see successful timezone updating on F35, but kamil says he couldn't get it to work on F34 either, whereas chris says it was working for him on F34. (adamw, 18:28:49)

  16. (1989726) [abrt] gnome-shell: cogl_texture_get_gl_texture(): gnome-shell killed by SIGSEGV (adamw, 18:29:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1989726 (adamw, 18:29:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/399 (adamw, 18:29:24)
    3. Accepted Blocker, mesa, NEW (adamw, 18:29:28)
    4. we are more or less at the mercy of Outside Forces on this one, and there doesn't seem to be much movement (adamw, 18:33:45)
    5. ACTION: adamw to prod a few folks to see if there's any hope of this being fixed in time for release (adamw, 18:33:59)

  17. (2001837) The switch for Fedora Third Party repositories does not switch them on. (adamw, 18:37:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2001837 (adamw, 18:38:00)
    2. https://pagure.io/fedora-qa/blocker-review/issue/455 (adamw, 18:38:04)
    3. Accepted Blocker, selinux-policy, ASSIGNED (adamw, 18:38:08)
    4. we are just waiting for the maintainer to fix this one, we pinged once but without response. will try again this week (adamw, 18:41:02)

  18. Open floor (adamw, 18:41:11)
    1. https://pagure.io/fesco/issue/2671 (cmurf[m], 18:49:23)


Meeting ended at 20:03:10 UTC (full logs).

Action items

  1. adamw to prod a few folks to see if there's any hope of this being fixed in time for release


Action items, by person

  1. adamw
    1. adamw to prod a few folks to see if there's any hope of this being fixed in time for release


People present (lines said)

  1. adamw (240)
  2. geraldosimiao (48)
  3. frantisekz (43)
  4. pwhalen (26)
  5. bcotton (23)
  6. coremodule (17)
  7. StephenGallagher (17)
  8. Southern_Gentlem (15)
  9. zodbot (12)
  10. cmurf[m] (8)
  11. Eighth_Doctor (6)
  12. mclasen (5)
  13. nirik (4)
  14. adamw_ (1)


Generated by MeetBot 0.3.