#fedora-blocker-review: F35-blocker-review

Meeting started by adamw at 16:00:10 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:24)
  2. Introduction (adamw, 16:06:08)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:06:15)
    2. We'll be following the process outlined at: (adamw, 16:06:19)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:06:29)
    4. The bugs up for review today are available at: (adamw, 16:06:29)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:06:30)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:06:33)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:06:38)
    8. https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria (adamw, 16:06:43)
    9. https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria (adamw, 16:06:46)
    10. for Beta, we have: (adamw, 16:06:51)
    11. 2 Proposed Blockers (adamw, 16:06:58)
    12. 5 Accepted Blockers (adamw, 16:07:02)
    13. 12 Accepted Freeze Exceptions (adamw, 16:07:07)
    14. for Final, we have: (adamw, 16:07:10)
    15. 3 Proposed Blockers (adamw, 16:07:24)
    16. I will secretarialize since we're a bit short today (adamw, 16:07:34)

  3. Proposed Beta blockers (adamw, 16:07:38)
  4. (2001591) IndexError: list index out of range (adamw, 16:07:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2001591 (adamw, 16:07:49)
    2. https://pagure.io/fedora-qa/blocker-review/issue/437 (adamw, 16:07:49)
    3. Proposed Blocker, anaconda, NEW (adamw, 16:07:49)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=2001591 (bittin, 16:08:05)
    5. AGREED: 2001591 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - this does not really count as a significant violation of the criterion cited, and we see no other criteria. But it's a relatively easily encounterable crash and the fix should be easy and safe, so we accept it as a Beta FE (adamw, 16:15:35)

  5. (2001261) qt5-qtwebengine rendering broken in F35 (adamw, 16:15:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2001261 (adamw, 16:15:46)
    2. https://pagure.io/fedora-qa/blocker-review/issue/433 (adamw, 16:15:51)
    3. Proposed Blocker, qt5-qtwebengine, MODIFIED (adamw, 16:15:56)
    4. Ticket vote: BetaBlocker (+0,0,-2) (-kparal, -lruzicka) (adamw, 16:16:02)
    5. Ticket vote: BetaFreezeException (+4,0,-0) (+churchyard, +kparal, +lruzicka, +adamwill) (adamw, 16:16:07)
    6. AGREED: 2001261 - RejectedBlocker (Beta) - this is an unfortunate bug and would be visible on KDE, but it does not affect any app that is required to work at Beta (as the default browser for KDE is Firefox). Note it has already been accepted as an FE so the fix will be pulled in as long as it causes no problems (adamw, 16:20:04)

  6. Proposed Final blockers (adamw, 16:20:15)
  7. (1997315) abrt-dbus segmentation faulted in abrt_p2_service_dbus when shutting down, rebooting, or logging out of Plasma (adamw, 16:20:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1997315 (adamw, 16:20:38)
    2. https://pagure.io/fedora-qa/blocker-review/issue/431 (adamw, 16:20:48)
    3. Proposed Blocker, abrt, NEW (adamw, 16:20:49)
    4. AGREED: 1997315 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - assuming a consequence of this bug is that the problem reporting tool does not work correctly, we agree it violates the "default application functionality" criterion. We also accept it as a Beta freeze exception as it is definitely desirable for crash reporting to work at Beta; of course, we'll only pull a fix that's sufficiently safe and tested (adamw, 16:30:54)

  8. (1991075) time is transiently incorrect when Automatic Time Zone is enabled (adamw, 16:31:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1991075 (adamw, 16:31:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/389 (adamw, 16:31:22)
    3. Proposed Blocker, gnome-settings-daemon, NEW (adamw, 16:31:26)
    4. Ticket vote: FinalBlocker (+3,0,-0) (+bcotton, +chrismurphy, +tablepc) (adamw, 16:31:33)
    5. AGREED: 1991075 - punt (delay decision) - nothing has really changed since we punted last time, so let's punt again. it's not urgent to make a call here (adamw, 16:37:07)

  9. (2000300) gsd-usb-protect dumps core on first boot (adamw, 16:37:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2000300 (adamw, 16:37:15)
    2. https://pagure.io/fedora-qa/blocker-review/issue/434 (adamw, 16:37:17)
    3. Proposed Blocker, gnome-settings-daemon, NEW (adamw, 16:37:25)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1937073 is the F34 bug (adamw, 16:40:08)
    5. AGREED: 1937073 - punt (delay decision) - this bug was proposed under the belief that the gsb-usb-protect crash causes the g-i-s startup delay and visible sadface screen, but in fact, we believe the g-i-s delay is caused by SELinux issues (that's 1997310). so we vote to punt on this to see how bad the consequences of the crash are after the g-i-s delay is fixed in SELinux policy. (adamw, 16:46:57)

  10. Open floor (adamw, 16:47:21)
    1. https://fedoramagazine.org/contribute-at-fedora-linux-35-audio-i18n-gnome-41-and-kernel-test-days/ (bittin, 16:48:57)
    2. https://fedoramagazine.org/contribute-at-fedora-linux-35-audio-i18n-gnome-41-and-kernel-test-days/ (bittin, 16:49:01)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1997992 (adamw, 16:49:36)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=1983861 (adamw, 16:49:51)
    5. Fedora 35 Beta Go/No Go Meeting on Thursday (bittin, 16:51:31)


Meeting ended at 16:55:44 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (133)
  2. geraldosimiao (29)
  3. bittin (27)
  4. bcotton (24)
  5. zodbot (8)
  6. kparal (7)


Generated by MeetBot 0.3.