#fedora-blocker-review: F36-blocker-review

Meeting started by adamw at 17:01:59 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:02:06)
  2. Introduction (adamw, 17:10:38)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:10:45)
    2. We'll be following the process outlined at: (adamw, 17:10:48)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:10:52)
    4. The bugs up for review today are available at: (adamw, 17:10:56)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:10:59)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:11:02)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 17:11:05)
    8. https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria (adamw, 17:11:08)
    9. https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria (adamw, 17:11:11)
    10. for Beta, we have: (adamw, 17:11:21)
    11. 2 Proposed Blockers (adamw, 17:11:27)
    12. 6 Accepted Blockers (adamw, 17:11:31)
    13. 1 Accepted Freeze Exceptions (adamw, 17:11:33)
    14. for Final, we have: (adamw, 17:11:41)
    15. 6 Proposed Blockers (adamw, 17:11:44)
    16. 2 Accepted Blockers (adamw, 17:11:47)
    17. coremodule will secretarialize (adamw, 17:13:36)

  3. Proposed Beta blockers (adamw, 17:14:02)
  4. (2032085) Some variants are missing /etc/resolv.conf symlink (use systemd-resolved) (adamw, 17:14:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2032085 (adamw, 17:14:12)
    2. https://pagure.io/fedora-qa/blocker-review/issue/581 (adamw, 17:14:15)
    3. Proposed Blocker, distribution, POST (adamw, 17:14:18)
    4. Ticket vote: BetaBlocker (+1,0,-3) (+sgallagh, -imsedgar, -nielsenb, -bcotton) (adamw, 17:14:21)
    5. AGREED: 2032085 - as per last week's meeting we don't think this is a blocker under the criteria but believe FESCo should consider it, a ticket has now been filed for FESCo: https://pagure.io/fesco/issue/2760 , so we will wait for them to consider it (adamw, 17:17:17)

  5. (2033130) exclude_from_weak_autodetect=true effectively renders rich weak dependencies useless (adamw, 17:17:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2033130 (adamw, 17:17:26)
    2. https://pagure.io/fedora-qa/blocker-review/issue/602 (adamw, 17:17:31)
    3. Proposed Blocker, dnf, NEW (adamw, 17:17:34)
    4. Ticket vote: BetaBlocker (+1,0,-0) (+churchyard) (adamw, 17:17:36)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2042808 (nielsenb, 17:20:05)
    6. https://fedoraproject.org/wiki/Changes/ExcludeFromWeakAutodetect is a Change for F36 to try and solve the "weak dependencies get reinstalled on update even if you specifically removed them before" problem. i.e., that's an RFE. but it turns out to *cause* an unforeseen problem in a more complex (but still fairly common) scenario (adamw, 17:26:49)
    7. AGREED: 2033130 - AcceptedBlocker (Beta) - this is accepted as a conditional violation of Basic criterion "The installed system must be able appropriately to install, remove, and update software...Appropriately means...broadly in line with the user's intent and typical expectations, and the project's intent as to which software should be provided from which repositories etc." (adamw, 17:37:37)

  6. Proposed Final blockers (adamw, 17:38:14)
  7. (2052872) abrt failed to create coredump (adamw, 17:39:03)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2052872 (adamw, 17:39:07)
    2. https://pagure.io/fedora-qa/blocker-review/issue/604 (adamw, 17:39:11)
    3. Proposed Blocker, abrt, NEW (adamw, 17:39:14)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+nielsenb) (adamw, 17:39:18)
    5. AGREED: 2052872 - AcceptedBlocker (Final) - this is accepted as a violation of "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test", generating a coredump is definitely basic functionality (adamw, 17:44:57)

  8. (2054226) Animated wallpapers are not correctly displayed in Gnome Shell 42. (adamw, 17:45:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2054226 (adamw, 17:45:55)
    2. https://pagure.io/fedora-qa/blocker-review/issue/607 (adamw, 17:45:59)
    3. Proposed Blocker, gnome-shell, NEW (adamw, 17:46:03)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+nielsenb) (adamw, 17:46:06)
    5. https://github.com/fedoradesign/backgrounds/commit/5aade4cc1ff3a982c589a49c11c45d6a99aa8ee7 (adamw, 17:49:49)
    6. https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4936 (lruzicka, 17:50:31)
    7. https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/2100/commits (nielsenb, 17:56:23)
    8. AGREED: 2054226 - mark as blocking existing Beta blocker 2052654 - we already have #2052654 as a beta blocker tracker for "36 backgrounds not yet present". the 36 backgrounds are animated (they're checked into git already) so this bug would stop them working, so we can simply consider this bug as blocking that tracker. this makes it effectively a blocker, as blocker status is transitive (adamw, 18:02:44)

  9. (2053627) Copy and paste do not work (adamw, 18:04:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2053627 (adamw, 18:04:31)
    2. https://pagure.io/fedora-qa/blocker-review/issue/605 (adamw, 18:04:36)
    3. Proposed Blocker, nautilus, NEW (adamw, 18:04:41)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+nielsenb) (adamw, 18:04:43)
    5. https://gitlab.gnome.org/GNOME/nautilus/-/issues/2149 (lruzicka, 18:08:05)
    6. AGREED: 2053627 - AcceptedBlocker (Final) - accepted as a violation of "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test" (adamw, 18:11:20)

  10. (2053790) Fedora look and feel is not fully applied on new installs (adamw, 18:11:28)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2053790 (adamw, 18:11:32)
    2. https://pagure.io/fedora-qa/blocker-review/issue/606 (adamw, 18:11:35)
    3. Proposed Blocker, plasma-workspace, NEW (adamw, 18:11:38)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-nielsenb) (adamw, 18:11:41)
    5. AGREED: 2053790 - punt (delay decision) - on the face of it this doesn't seem to violate criteria, but from meeting discussion it sounds like the bug may have significant practical consequences like unreadable text in default setups. we will ask the reporter to provide a bit more detail on the consequences, ideally with screenshots (adamw, 18:21:30)

  11. (2042877) crash happens on the newly installed system (adamw, 18:22:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2042877 (adamw, 18:22:11)
    2. https://pagure.io/fedora-qa/blocker-review/issue/595 (adamw, 18:22:14)
    3. Proposed Blocker, spice-vdagent, MODIFIED (adamw, 18:22:18)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+nielsenb) (adamw, 18:22:21)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2042877#c15 (nielsenb, 18:25:59)
    6. AGREED: 2042877 - AcceptedBlocker (Final) - accepted as a violation of "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop", it's not entirely clear whether this crash always triggers a notification but it seems to happen often enough to accept this (adamw, 18:34:09)

  12. (2006393) [DNS over TLS] following connection to a wifi AP, internet is not available for ~30s (adamw, 18:35:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2006393 (adamw, 18:35:59)
    2. https://pagure.io/fedora-qa/blocker-review/issue/579 (adamw, 18:36:03)
    3. Proposed Blocker, systemd, ASSIGNED (adamw, 18:36:06)
    4. AGREED: 2006393 - RejectedBlocker (Final) - this is still pretty bad if you're affected, but we think the reduction in the time it takes for the situation to resolve is sufficient that it no longer quite qualifies for release blocker status. we'll leave it up to the wisdom of the devs whether it's a better idea to revert the feature if it can't be fixed further (adamw, 18:50:26)

  13. Open floor (adamw, 18:50:38)


Meeting ended at 19:17:11 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (177)
  2. nielsenb (66)
  3. cmurf[m] (65)
  4. lruzicka (41)
  5. bcotton (20)
  6. coremodule (16)
  7. zodbot (11)
  8. Eighth_Doctor (8)
  9. copperi[m] (6)
  10. pwhalen (4)


Generated by MeetBot 0.4.