#fedora-blocker-review: F36-blocker-review

Meeting started by adamw at 17:00:08 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:00:14)
  2. Introduction (adamw, 17:04:55)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:04:57)
    2. We'll be following the process outlined at: (adamw, 17:05:01)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:05:05)
    4. The bugs up for review today are available at: (adamw, 17:05:08)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:05:10)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:05:13)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 17:05:16)
    8. https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria (adamw, 17:05:19)
    9. https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria (adamw, 17:05:23)
    10. for Beta, we have: (adamw, 17:05:33)
    11. 2 Proposed Blockers (adamw, 17:05:42)
    12. 8 Accepted Blockers (adamw, 17:05:42)
    13. 6 Proposed Freeze Exceptions (adamw, 17:05:44)
    14. 3 Accepted Freeze Exceptions (adamw, 17:05:48)
    15. for Final, we have: (adamw, 17:05:59)
    16. 7 Proposed Blockers (adamw, 17:06:00)
    17. 4 Accepted Blockers (adamw, 17:06:09)
    18. 1 Proposed Freeze Exceptions (adamw, 17:06:09)
    19. coremodule will secretarialize, thanks! (adamw, 17:06:18)

  3. Proposed Beta blockers (adamw, 17:06:34)
  4. (2057193) f36 composes still have firefox 96, f34 f35 have firefox 97 (adamw, 17:06:41)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057193 (adamw, 17:06:45)
    2. https://pagure.io/fedora-qa/blocker-review/issue/624 (adamw, 17:06:49)
    3. Proposed Blocker, firefox, NEW, depends on other bugs (adamw, 17:06:52)
    4. Ticket vote: BetaBlocker (+2,0,-0) (+bcotton, +nielsenb) (adamw, 17:06:57)
    5. Ticket vote: BetaFreezeException (+3,0,-0) (+churchyard, +imsedgar, +nielsenb) (adamw, 17:06:59)
    6. AGREED: 2057193 - AcceptedBlocker (Beta) - upgrade criterion footnote requires upgraded system to meet other release criteria, we consider this to violate Basic criterion footnote "The web browser must be able to download files, load extensions (if applicable), and log into FAS" and Beta criterion "All known bugs that can cause corruption of user data must be fixed or documented at Common F36 bugs" if Firefox downgraded on upgrade to (adamw, 17:26:41)
    7. for 2057193 we also cite the Beta blocker catch-all wording, that "A bug is considered a Beta blocker bug if ... Bug hinders execution of required Beta test plans or dramatically reduces test coverage" - we believe this bug would have that effect, as it would prevent people who would otherwise upgrade to the Beta and help test from doing so (adamw, 17:28:02)

  5. (2057719) After upgrade gnome-control-center to 42~beta-1.fc37 unable to configure VPN connection (adamw, 17:28:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057719 (adamw, 17:28:26)
    2. https://pagure.io/fedora-qa/blocker-review/issue/630 (adamw, 17:28:32)
    3. Proposed Blocker, gnome-control-center, NEW (adamw, 17:28:33)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+bcotton) (adamw, 17:28:43)
    5. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 17:28:45)
    6. AGREED: 2057719 - punt (delay decision) on blocker status, AcceptedFreezeException (Beta) - we do not have specific criteria for VPN connections, and trying to stretch existing criteria to fix this is difficult. we do have proposed specific criteria from 2020, so we will resurrect the discussion on those criteria and decide on blocker status when that's done. This is definitely serious enough to grant an FE, though (adamw, 17:45:38)

  6. Proposed Beta freeze exceptions (adamw, 17:46:02)
  7. (2058502) libyui-mga-gtk won't currently install on fc36 or Rawhide (adamw, 17:46:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2058502 (adamw, 17:46:18)
    2. https://pagure.io/fedora-qa/blocker-review/issue/634 (adamw, 17:46:23)
    3. Proposed Freeze Exceptions, libyui-mga-gtk, MODIFIED (adamw, 17:46:28)
    4. AGREED: 2058502 , 2046220 and 2044286 are all: AcceptedFreezeException (Beta) as they are fails-to-install bugs. We typically grant FEs for these to avoid upgrades of systems with these packages installed requiring the use of --allowerasing, as that can be dangerous and we want to avoid it where possible (adamw, 17:50:24)

  8. (2054921) dnf system-upgrade 35 to 36 fails with various pipewire wireplumber conflicts (adamw, 17:50:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2054921 (adamw, 17:50:41)
    2. https://pagure.io/fedora-qa/blocker-review/issue/612 (adamw, 17:50:43)
    3. Proposed Freeze Exceptions, pipewire, NEW (adamw, 17:50:48)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 17:50:54)
    5. AGREED: 2054921 - AcceptedFreezeException (Beta) - this seems like a tricky case to handle, but if there is in fact some way we can make it better, we think it's worth a freeze exception so that it reaches people upgrading before the Beta release (adamw, 18:08:49)

  9. (2057184) cgroupify: Error moving pid into new cgroup (11) (adamw, 18:09:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057184 (adamw, 18:09:10)
    2. https://pagure.io/fedora-qa/blocker-review/issue/623 (adamw, 18:09:15)
    3. Proposed Freeze Exceptions, uresourced, NEW (adamw, 18:09:18)
    4. AGREED: 2057184 - punt (delay decision) - we're not entirely sure how serious of a problem this is, and hence whether it's worth a freeze exception. We'll ask the maintainer for his opinion in the bug report and discuss this again next week or in the ticket (adamw, 18:35:03)

  10. Proposed Final blockers (adamw, 18:35:28)
  11. (2055908) bluetooth, cannot remove a bluetooth device (adamw, 18:35:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2055908 (adamw, 18:35:55)
    2. https://pagure.io/fedora-qa/blocker-review/issue/617 (adamw, 18:36:00)
    3. Proposed Blocker, gnome-control-center, NEW (adamw, 18:36:04)
    4. Ticket vote: FinalBlocker (+4,0,-0) (+adamwill, +lruzicka, +catanzaro, +nielsenb) (adamw, 18:36:08)
    5. AGREED: 2055908 - AcceptedBlocker (Final) - accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" (adamw, 18:44:12)

  12. (2058920) [abrt] gnome-control-center: cc_object_storage_create_dbus_proxy_finish(): gnome-control-center killed by SIGABRT (adamw, 18:44:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2058920 (adamw, 18:44:41)
    2. https://pagure.io/fedora-qa/blocker-review/issue/632 (adamw, 18:44:42)
    3. Proposed Blocker, gnome-control-center, NEW (adamw, 18:44:46)
    4. AGREED: 2058920 - punt (delay decision) - we don't have enough info on the causes, consequences or prevalence of this crash to make a decision yet. Chris will report it upstream and see if that gets us anywhere (adamw, 18:55:26)

  13. (2056927) Require authselect for use in scriptlets (adamw, 18:55:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2056927 (adamw, 18:55:36)
    2. https://pagure.io/fedora-qa/blocker-review/issue/622 (adamw, 18:55:41)
    3. Proposed Blocker, nss-mdns, NEW (adamw, 18:55:44)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+nielsenb) (adamw, 18:55:47)
    5. https://src.fedoraproject.org/rpms/authselect/pull-request/17 (Eighth_Doctor, 18:57:57)
    6. AGREED: 2056927 - AcceptedBlocker (Final) - this is accepted as a violation of "Printing must work in release-blocking desktops on at least one printer using...The generic IPP driver" (adamw, 19:08:16)

  14. (2057563) The About button sends Discover into loop and the application stops responding. (adamw, 19:09:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057563 (adamw, 19:09:30)
    2. https://pagure.io/fedora-qa/blocker-review/issue/627 (adamw, 19:09:33)
    3. Proposed Blocker, plasma-discover, NEW (adamw, 19:09:38)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+lruzicka, +nielsenb) (adamw, 19:09:41)
    5. AGREED: 2057563 - AcceptedBlocker (Final) - this is accepted as a violation of the default application functionality criterion, which requires that the KDE package manager (that's Discover) "must start successfully and withstand a basic functionality test" (adamw, 19:20:32)

  15. (2053790) Fedora look and feel is not fully applied on new installs (adamw, 19:21:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2053790 (adamw, 19:21:05)
    2. https://pagure.io/fedora-qa/blocker-review/issue/606 (adamw, 19:21:09)
    3. Proposed Blocker, plasma-workspace, MODIFIED (adamw, 19:21:14)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-nielsenb) (adamw, 19:21:17)
    5. AGREED: 2053790 - RejectedBlocker (Final) AcceptedFreezeException (Beta) - this doesn't really seem to violate any criteria as it stands (the elements are perfectly usable, they just don't look as intended), but we do grant it a Beta freeze exception as obviously we want things to look as intended for Beta if possible (adamw, 19:27:12)

  16. (2010595) Cannot install firmware if secureboot is enabled (adamw, 19:27:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2010595 (adamw, 19:27:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/635 (adamw, 19:27:32)
    3. Proposed Blocker, shim, NEW (adamw, 19:27:36)
    4. AGREED: 2010595 - punt (delay decision) - there was some support in principle for this being a blocker, but also some opposition, and it doesn't obviously violate the existing criteria. we will ask how software updates are affected if a firmware update is queued but fails (if the software update also does not happen in this case, that could be a blocker issue). someone may also choose to propose specific criteria for firmware updates (adamw, 19:45:08)

  17. (2054594) crash happens when try to set up a google or microsoft online account (adamw, 19:45:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2054594 (adamw, 19:45:18)
    2. https://pagure.io/fedora-qa/blocker-review/issue/609 (adamw, 19:45:24)
    3. Proposed Blocker, xdg-desktop-portal, NEW (adamw, 19:45:26)
    4. Ticket vote: FinalBlocker (+0,0,-2) (-nielsenb, -catanzaro) (adamw, 19:45:30)
    5. AGREED: 2054594 - RejectedBlocker (Final) - we agreed this would be a blocker issue if it were clearly reproducible, but so far other testers have not been able to reproduce it. We can reconsider this decision if we are able to pin the issue down more precisely and it still seems concerning (adamw, 19:50:00)
    6. AGREED: we will retitle the accepted FE https://bugzilla.redhat.com/show_bug.cgi?id=2049147 from "ship GNOME 42.rc in Fedora 36 beta" to "ship GNOME 42.beta or 42.rc in Fedora 36 beta" to make it clearer that we want to include 42.beta in F36 Beta if rc is not ready in time, beta still better than alpha (adamw, 19:53:42)

  18. Open floor (adamw, 19:54:02)


Meeting ended at 20:01:29 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (320)
  2. Eighth_Doctor (100)
  3. cmurf (78)
  4. geraldosimiao (36)
  5. bcotton (29)
  6. lruzicka (26)
  7. copperi[m] (18)
  8. zodbot (14)
  9. Southern_Gentlem (12)
  10. coremodule (11)
  11. pwhalen (5)
  12. frantisekz (4)
  13. OnuralpSezer[m] (2)


Generated by MeetBot 0.4.