#fedora-blocker-review: F36-blocker-review

Meeting started by adamw at 17:01:34 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 17:01:41)
  2. Introduction (adamw, 17:10:38)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 17:10:47)
    2. We'll be following the process outlined at: (adamw, 17:10:51)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 17:10:55)
    4. The bugs up for review today are available at: (adamw, 17:10:59)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 17:11:02)
    6. The criteria for release blocking bugs can be found at: (adamw, 17:11:04)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 17:11:08)
    8. https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria (adamw, 17:11:12)
    9. https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria (adamw, 17:11:14)
    10. for Beta, we have: (adamw, 17:11:19)
    11. 5 Proposed Blockers (adamw, 17:11:30)
    12. 7 Accepted Blockers (adamw, 17:11:30)
    13. 7 Proposed Freeze Exceptions (adamw, 17:11:34)
    14. 5 Accepted Freeze Exceptions (adamw, 17:11:34)
    15. for Final, we have: (adamw, 17:11:45)
    16. 2 Proposed Blockers (adamw, 17:11:54)
    17. 6 Accepted Blockers (adamw, 17:11:54)
    18. coremodule will secretarialize (adamw, 17:12:04)

  3. Proposed Beta blockers (adamw, 17:12:16)
  4. (2061440) bcm283x-firmware fails to boot on 32-bit arm (adamw, 17:12:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2061440 (adamw, 17:12:31)
    2. https://pagure.io/fedora-qa/blocker-review/issue/647 (adamw, 17:12:35)
    3. Proposed Blocker, bcm283x-firmware, ASSIGNED (adamw, 17:12:38)
    4. Ticket vote: BetaBlocker (+1,0,-0) (+bcotton) (adamw, 17:12:40)
    5. AGREED: 2061440 - AcceptedBlocker (Beta) - this violates "All release-blocking images must boot in their supported configurations" for the release-blocking minimal image on the release-blocking 32-bit Raspberry Pi platform (adamw, 17:16:37)

  5. (2060414) On Fedora 36 KDE, dnfdragora does not start. (adamw, 17:16:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2060414 (adamw, 17:16:51)
    2. https://pagure.io/fedora-qa/blocker-review/issue/642 (adamw, 17:16:56)
    3. Proposed Blocker, dnfdragora, NEW (adamw, 17:16:59)
    4. AGREED: 2060414 - AcceptedBlocker (Beta) - the criteria did not anticipate a desktop shipping two package managers, but a majority decided that in this case, one of them not working violates Beta criterion "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager)" (adamw, 17:38:21)

  6. (2060868) Cannot configure WPA2 Enterprise WiFi SSID (adamw, 17:38:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2060868 (adamw, 17:38:39)
    2. https://pagure.io/fedora-qa/blocker-review/issue/643 (adamw, 17:38:43)
    3. Proposed Blocker, libnma, NEW (adamw, 17:38:49)
    4. Ticket vote: BetaBlocker (+0,0,-4) (-imsedgar, -catanzaro, -nielsenb, -bcotton) (adamw, 17:38:54)
    5. Ticket vote: FinalBlocker (+4,0,-0) (+catanzaro, +imsedgar, +nielsenb, +bcotton) (adamw, 17:38:57)
    6. Ticket vote: BetaFreezeException (+2,0,-0) (+nielsenb, +bcotton) (adamw, 17:39:01)
    7. https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/ZK6FRRRWQNC3FQVX7ZTMUHQMPPEAZSJA/ (adamw, 17:43:34)
    8. AGREED: 2060868 - RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this does not violate the current Beta criteria, and there wasn't enough support for applying the proposed networking criteria that do cover it to F36 Beta, but it is bad enough to be an FE. For Final, it violates the default app functionality and panel criteria (adamw, 17:56:02)

  7. (2057719) VPN connection editors do not load in gnome-control-center Network pane (need porting to GTK4) (adamw, 17:56:17)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057719 (adamw, 17:56:22)
    2. https://pagure.io/fedora-qa/blocker-review/issue/630 (adamw, 17:56:25)
    3. Proposed Blocker, NetworkManager-openvpn, NEW (adamw, 17:56:29)
    4. Ticket vote: BetaBlocker (+0,1,-3) (bcotton, -imsedgar, -catanzaro, -nielsenb) (adamw, 17:56:31)
    5. Ticket vote: FinalBlocker (+4,0,-0) (+bcotton, +catanzaro, +imsedgar, +nielsenb) (adamw, 17:56:35)
    6. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 17:56:38)
    7. AGREED: 2057719 - RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - this does not violate the current Beta criteria, and there wasn't enough support for applying the proposed networking criteria that do cover it to F36 Beta, but it is bad enough to be an FE. For Final, it violates the default app functionality and panel criteria (adamw, 17:59:54)

  8. (2054016) SDDM in Fedora 36 - menus do not open properly and cause a strobe effect, plus minor cosmetic issues (adamw, 18:00:08)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2054016 (adamw, 18:00:13)
    2. https://pagure.io/fedora-qa/blocker-review/issue/645 (adamw, 18:00:15)
    3. Proposed Blocker, sddm, ON_QA (adamw, 18:00:20)
    4. Ticket vote: BetaBlocker (+0,0,-1) (-bcotton) (adamw, 18:00:23)
    5. Ticket vote: FinalBlocker (+1,0,-0) (+bcotton) (adamw, 18:00:26)
    6. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 18:00:29)
    7. AGREED: 2054016 - RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - doesn't quite seem to violate the Beta criteria, but bad enough to be worth fixing. 'Default keyboard layout is wrong' portion violates Final criterion "If a particular keyboard layout has been configured for the system, that keyboard layout must be used: ... When logging in via the default login manager for a release-blocking desktop" (adamw, 18:16:38)

  9. Proposed Beta freeze exceptions (adamw, 18:17:04)
  10. (2059685) Include PyPy 3 in the Fedora Python Classroom Lab 36 Beta (adamw, 18:17:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2059685 (adamw, 18:17:14)
    2. https://pagure.io/fedora-qa/blocker-review/issue/638 (adamw, 18:17:17)
    3. Proposed Freeze Exceptions, distribution, POST, depends on other bugs (adamw, 18:17:21)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 18:17:24)
    5. AGREED: 2059685 - AcceptedFreezeException (Beta) - giving spins their intended contents is a reasonable grounds for an FE and this should not hurt anything else (adamw, 18:20:41)

  11. (2059670) Make PyPy 3.9 the main pypy3 in Fedora 36 (adamw, 18:21:04)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2059670 (adamw, 18:21:08)
    2. https://pagure.io/fedora-qa/blocker-review/issue/637 (adamw, 18:21:11)
    3. Proposed Freeze Exceptions, pypy3.9, ON_QA (adamw, 18:21:16)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 18:21:19)
    5. AGREED: 2059670 - AcceptedFreezeException (Beta) - this is needed for 2059685 which we accepted, and again seems unlikely to hurt anything else important (adamw, 18:24:06)

  12. (2061392) Drop non-upstream chromium support patch (adamw, 18:24:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2061392 (adamw, 18:24:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/646 (adamw, 18:24:28)
    3. Proposed Freeze Exceptions, ffmpeg, ASSIGNED (adamw, 18:24:31)
    4. AGREED: 2061392 - AcceptedFreezeException (Beta) - it seems reasonable to get the desired ABI stable ASAP to prevent incompatibility with other builds existing for too long and too many things using the 'wrong' ABI (adamw, 18:37:01)

  13. (2059776) Bootloader install fails on ostree installs since Fedora-Rawhide-20220301.n.0 (adamw, 18:37:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2059776 (adamw, 18:37:16)
    2. https://pagure.io/fedora-qa/blocker-review/issue/640 (adamw, 18:37:19)
    3. Proposed Freeze Exceptions, grub2, NEW (adamw, 18:37:23)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 18:37:26)
    5. adamw has withdrawn the proposal for this bug as the broken grub2 has not yet been sent to F36 (adamw, 18:41:26)

  14. (2046850) prusa-slicer: FTBFS in Fedora rawhide/f36, fails to install (adamw, 18:41:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2046850 (adamw, 18:41:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/641 (adamw, 18:41:50)
    3. Proposed Freeze Exceptions, prusa-slicer, ON_QA, depends on other bugs (adamw, 18:41:55)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+bcotton) (adamw, 18:41:57)
    5. AGREED: 2046850 - AcceptedFreezeException (Beta) - this is accepted as we usually grant FEs to FTBFS/FTI bugs as it's always better to have installable packages in the frozen repos (adamw, 18:46:02)

  15. (2036866) qt6 not available on s390x (adamw, 18:46:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2036866 (adamw, 18:46:15)
    2. https://pagure.io/fedora-qa/blocker-review/issue/644 (adamw, 18:46:17)
    3. Proposed Freeze Exceptions, qt6-qtbase, ON_QA (adamw, 18:46:21)
    4. AGREED: 2036866 - AcceptedFreezeException (Beta) - this is accepted because we apparently care a lot about arch support, and definitely want people to be able to launch graphical applications with a bleeding-edge toolkit on their mainframes (adamw, 18:56:20)

  16. (2057184) cgroupify: Error moving pid into new cgroup (11) (adamw, 18:56:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2057184 (adamw, 18:56:35)
    2. https://pagure.io/fedora-qa/blocker-review/issue/623 (adamw, 18:56:39)
    3. Proposed Freeze Exceptions, uresourced, ON_QA (adamw, 18:56:41)
    4. just after we discussed this last week, the maintainer told cmurf the bug isn't a big deal and it's fine to fix it with an update (adamw, 19:02:17)
    5. AGREED: 2057184 - RejectedFreezeException (Beta) - per feedback from the maintainer, this is not a major bug and it's fine to fix it with an update (adamw, 19:05:07)

  17. Proposed Final blockers (adamw, 19:05:33)
  18. (2058920) [abrt] gnome-control-center: cc_object_storage_create_dbus_proxy_finish(): gnome-control-center killed by SIGABRT (adamw, 19:05:38)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2058920 (adamw, 19:05:42)
    2. https://pagure.io/fedora-qa/blocker-review/issue/632 (adamw, 19:05:46)
    3. Proposed Blocker, gnome-control-center, NEW (adamw, 19:05:49)
    4. Ticket vote: FinalBlocker (+0,0,-2) (-catanzaro, -nielsenb) (adamw, 19:05:53)
    5. https://retrace.fedoraproject.org/faf/reports/364456/ shows 2 reports, which are probably both chris (adamw, 19:14:09)
    6. AGREED: 2058920 - RejectedBlocker (Final) - this still doesn't seem clearly reproducible or commonly encountered at present. We will reconsider if clear steps to reproduce are found (adamw, 19:18:15)

  19. (2010595) Cannot install firmware if secureboot is enabled (adamw, 19:18:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2010595 (adamw, 19:18:29)
    2. https://pagure.io/fedora-qa/blocker-review/issue/635 (adamw, 19:18:32)
    3. Proposed Blocker, shim, NEW (adamw, 19:18:36)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+nielsenb) (adamw, 19:18:39)
    5. AGREED: 2010595 - punt (delay decision) - there hasn't been much movement on this from last week (info about how this affects software updates is not yet provided), so we will delay the decision again (adamw, 19:27:50)

  20. (2061528) Fedora IoT - Failed to start systemd-userdbd.service - User Database Manager (adamw, 19:30:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2061528 (adamw, 19:30:52)
    2. Proposed Blocker, systemd, NEW (adamw, 19:31:11)
    3. AGREED: 2061528 - RejectedBlocker (Final) AcceptedFreezeException (Beta) - as this seems to have no practical consequences and works on every boot after the first, we decided it's not a sufficient violation of the criterion to block the release on. However it is confounding to see on first boot, so we grant an FE to fix that for Beta if possible (adamw, 19:43:39)

  21. Open floor (adamw, 19:44:49)


Meeting ended at 19:53:32 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (312)
  2. nielsenb (84)
  3. lruzicka (51)
  4. Eighth_Doctor (45)
  5. cmurf (43)
  6. frantisekz (30)
  7. coremodule (29)
  8. bcotton (23)
  9. pwhalen (13)
  10. zodbot (12)
  11. copperi[m] (10)
  12. MichaelCatanzaro (3)
  13. OnuralpSezer[m] (2)
  14. kk4ewt (2)
  15. Southern_Gentlem (1)


Generated by MeetBot 0.4.