#fedora-blocker-review: F36-blocker-review

Meeting started by adamw at 16:01:17 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:26)
  2. Introduction (adamw, 16:12:38)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:12:44)
    2. We'll be following the process outlined at: (adamw, 16:12:50)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:12:51)
    4. The bugs up for review today are available at: (adamw, 16:12:54)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:12:57)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:12:59)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:13:02)
    8. https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria (adamw, 16:13:05)
    9. https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria (adamw, 16:13:08)
    10. for Beta, we have: (adamw, 16:13:20)
    11. 2 Proposed Blockers (adamw, 16:13:26)
    12. 4 Accepted Blockers (adamw, 16:13:29)
    13. 2 Proposed Freeze Exceptions (adamw, 16:13:33)
    14. 10 Accepted Freeze Exceptions (adamw, 16:13:33)
    15. for Final, we have: (adamw, 16:13:40)
    16. 7 Proposed Blockers (adamw, 16:13:50)
    17. 8 Accepted Blockers (adamw, 16:13:57)
    18. 3 Proposed Freeze Exceptions (adamw, 16:13:58)
    19. coremodule will secretarialize (adamw, 16:14:26)

  3. Proposed Beta blockers (adamw, 16:14:33)
  4. (2063156) Workstation Live is frozen in a VM with QXL video driver (Virtio works OK) (adamw, 16:14:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063156 (adamw, 16:14:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/656 (adamw, 16:14:50)
    3. Proposed Blocker, mutter, NEW (adamw, 16:14:53)
    4. Ticket vote: BetaBlocker (+1,0,-4) (+ngompa, -frantisekz, -chrismurphy, -nielsenb, -lruzicka) (adamw, 16:14:56)
    5. Ticket vote: BetaFreezeException (+1,0,-0) (+lruzicka) (adamw, 16:15:01)
    6. AGREED: 2063156 - RejectedBlocker (Beta) - this is pretty bad, but since it apparently doesn't happen consistently in the most common config (system virt session) and is easy to workaround (use virtio), we think it's not bad enough to block Beta (adamw, 16:34:43)

  5. Proposed Beta freeze exceptions (adamw, 16:35:12)
  6. (2063800) ImportError: No library named udev (adamw, 16:35:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063800 (adamw, 16:35:18)
    2. https://pagure.io/fedora-qa/blocker-review/issue/663 (adamw, 16:35:21)
    3. Proposed Freeze Exceptions, anaconda, NEW (adamw, 16:35:24)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+frantisekz) (adamw, 16:35:27)
    5. AGREED: 2063800 - AcceptedFreezeException (Beta) - failure to compose a non-release-blocking image is typically accepted as an FE issue, as we like to get all the images built for Beta if possible! (adamw, 16:39:08)

  7. (2037047) SELinux preventing systemd-network-generator from creating files in /run/systemd/network/ (adamw, 16:39:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2037047 (adamw, 16:39:57)
    2. https://pagure.io/fedora-qa/blocker-review/issue/651 (adamw, 16:40:00)
    3. Proposed Freeze exception, selinux-policy, ASSIGNED (adamw, 16:40:09)
    4. Ticket vote: BetaFreezeException (+1,0,-0) (+nielsenb) (adamw, 16:40:15)
    5. AGREED: 2037047 - AcceptedFreezeException (Beta) - this is accepted as a Beta FE as it seems likely someone might want to use this feature before an update is possible, and it'd be nice if we could make it work (adamw, 16:44:43)

  8. Proposed Final blockers (adamw, 16:45:00)
  9. (2059556) crash happens after quit from map (adamw, 16:46:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2059556 (adamw, 16:46:49)
    2. https://pagure.io/fedora-qa/blocker-review/issue/661 (adamw, 16:46:52)
    3. Proposed Blocker, gjs, NEW (adamw, 16:46:55)
    4. AGREED: 2059556 - RejectedBlocker (Final) - a crash on shutdown with no other ill effects does not violate the 'basic functionality' or 'no crash notifications on boot' criteria, so this is rejected (adamw, 16:53:27)

  10. (2060320) On Fedora 36 KDE, abrt starts with an empty window without any control widgets. (adamw, 16:54:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2060320 (adamw, 16:54:19)
    2. https://pagure.io/fedora-qa/blocker-review/issue/654 (adamw, 16:54:23)
    3. Proposed Blocker, gnome-abrt, ASSIGNED (adamw, 16:54:25)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+catanzaro, +nielsenb) (adamw, 16:54:29)
    5. AGREED: 2060320 - RejectedBlocker (Final) - this is awkward, but it only affects fairly specific cases (KDE at lower resolutions) and is easy enough to workaround by resizing the window; we feel documenting that would be sufficient for release (adamw, 17:05:17)

  11. (2063381) gnome-shell crash, clutter-actor.c:1275:clutter_actor_set_mapped: assertion failed: (!CLUTTER_ACTOR_IS_MAPPED (self)) (adamw, 17:06:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063381 (adamw, 17:06:33)
    2. https://pagure.io/fedora-qa/blocker-review/issue/658 (adamw, 17:06:36)
    3. Proposed Blocker, gnome-shell, NEW (adamw, 17:06:39)
    4. Ticket vote: BetaBlocker (+0,0,-1) (-catanzaro) (adamw, 17:06:48)
    5. Ticket vote: FinalBlocker (+0,0,-2) (-catanzaro, -nielsenb) (adamw, 17:06:51)
    6. https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/2231 (adamw, 17:11:09)
    7. https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/2299 (nielsenb, 17:11:57)
    8. AGREED: 2063381 - AcceptedBlocker (Final) AcceptedFreezeException (Beta) - we're not sure quite how common this is, but it's happened enough times to enough people to consider it a conditional violation of several criteria (e.g. the panel criterion) for now. we will backport the proposed fixes and do further testing to clarify the situation (adamw, 17:27:32)

  12. (2063156) Workstation Live is frozen in a VM with QXL video driver (Virtio works OK) (adamw, 17:27:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063156 (adamw, 17:27:54)
    2. https://pagure.io/fedora-qa/blocker-review/issue/656 (adamw, 17:27:57)
    3. Proposed Blocker, mutter, NEW (adamw, 17:28:00)
    4. AGREED: 2063381 - punt (delay decision) - we were not able to reach a clear decision at this time and with the information currently available. we'll aim to have more folks test and hopefully get feedback from the developers on what may be going on here (adamw, 17:39:28)

  13. (2010595) Cannot install firmware if secureboot is enabled (adamw, 17:39:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2010595 (adamw, 17:39:39)
    2. https://pagure.io/fedora-qa/blocker-review/issue/635 (adamw, 17:39:42)
    3. Proposed Blocker, shim, NEW (adamw, 17:39:45)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-nielsenb) (adamw, 17:39:48)
    5. AGREED: 2010595 - RejectedBlocker (Final) - this is a sad bug for affected owners, but firmware update functionality is not covered in the release criteria, and nothing that is covered in the criteria is broken by this bug (adamw, 17:49:01)

  14. (2063673) crash happens on the newly installed system (adamw, 17:49:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063673 (adamw, 17:49:12)
    2. https://pagure.io/fedora-qa/blocker-review/issue/662 (adamw, 17:49:15)
    3. Proposed Blocker, xdg-desktop-portal, NEW (adamw, 17:49:19)
    4. AGREED: 2063673 - RejectedBlocker (Final) - as described this doesn't seem to violate the criterion (there has to be a graphical notification of the crash for that), plus others do not seem to be able to reproduce it (adamw, 17:58:53)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2063961 (coremodule, 18:05:30)

  15. (2063961) Fedora ARM - Firefox fails to open on aarch64 Workstation (adamw, 18:08:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2063961 (adamw, 18:08:31)
    2. Proposed Blocker, firefox, NEW (adamw, 18:08:41)
    3. https://fedoraproject.org/wiki/Basic_Release_Criteria#Required_applications (cmurf, 18:09:15)
    4. AGREED: 2063961 - AcceptedBlocker (Beta) - accepted as a violation of Basic criterion "It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments" on aarch64. Note this bug is introduced by Firefox 98 which is not yet stable, but including 98 is itself a blocker (adamw, 18:13:37)

  16. Accepted Beta blockers (adamw, 18:19:33)
    1. 2016613 - PR is ready upstream, I will backport it after this meeting (adamw, 18:20:03)
    2. 2057193 - we have a Firefox 98 build and included it in Beta-1.1, but as per above it does not work on aarch64, so we'll need to fix that (adamw, 18:20:32)
    3. 2017043 - fix was included in GNOME 42-rc megaupdate which is on its way stable, would be good if someone can verify it (adamw, 18:21:39)

  17. (2018271) fedora-release-identity-cloud says "Cloud Edition", Cloud has not been an edition for years (adamw, 18:21:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2018271 (adamw, 18:21:53)
    2. https://pagure.io/fedora-qa/blocker-review/issue/578 (adamw, 18:21:57)
    3. Accepted Blocker, fedora-release, ASSIGNED (adamw, 18:22:01)
    4. a proposal has been made to amend the criteria to allow council to waive the 'edition' requirement (as council is responsible for branding), which will be applied and used by thursday if there are no substantial objections (adamw, 18:25:40)
    5. for the record, nobody opposed the proposal at this meeting (adamw, 18:28:05)
    6. the current plan to handle this bug is for the proposal to be applied and the bug waived as a blocker by council vote (adamw, 18:28:28)

  18. Open floor (adamw, 18:29:33)
    1. https://pagure.io/fedora-qa/blocker-review/issue/505 (geraldosimiao, 18:31:06)


Meeting ended at 18:40:20 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (238)
  2. cmurf (96)
  3. lruzicka2 (82)
  4. nielsenb (81)
  5. geraldosimiao (45)
  6. bcotton (19)
  7. zodbot (15)
  8. coremodule (15)
  9. pwhalen (11)
  10. Eighth_Doctor (9)
  11. Southern_Gentlem (3)
  12. copperi[m] (3)
  13. OnuralpSezer[m] (1)


Generated by MeetBot 0.4.