#fedora-blocker-review: F36-blocker-review

Meeting started by adamw at 16:09:55 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:09:56)
  2. Introduction (adamw, 16:19:18)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:19:24)
    2. We'll be following the process outlined at: (adamw, 16:19:27)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:19:30)
    4. The bugs up for review today are available at: (adamw, 16:19:33)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:19:37)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:19:40)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:19:44)
    8. https://fedoraproject.org/wiki/Fedora_36_Beta_Release_Criteria (adamw, 16:19:47)
    9. https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria (adamw, 16:19:49)
    10. For Final, we have: (adamw, 16:22:25)
    11. 4 Proposed Blockers (adamw, 16:22:26)
    12. 10 Accepted Blockers (adamw, 16:23:15)
    13. 5 Proposed Freeze Exceptions (adamw, 16:23:29)
    14. 12 Accepted Freeze Exceptions (adamw, 16:23:33)
    15. coremodule will secretarialize (adamw, 16:25:28)

  3. Proposed Final Blockers (adamw, 16:25:36)
  4. (2076364) [abrt] gjs: g_main_context_iterate.constprop.0(): gjs-console killed by SIGSEGV (adamw, 16:25:49)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2076364 (adamw, 16:25:54)
    2. Proposed Blocker, gjs, NEW (adamw, 16:25:58)
    3. AGREED: 2076364 - RejectedBlocker (Final) - a crash on exit does not seem serious enough to count as violating the "basic functionality" requirement; this is consistent with past decisions. Note, bug is already accepted as a freeze exception issue (adamw, 16:34:27)

  5. (2076596) The KDE ibus panel does not work as expected. (adamw, 16:35:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2076596 (adamw, 16:35:37)
    2. https://pagure.io/fedora-qa/blocker-review/issue/766 (adamw, 16:35:43)
    3. Proposed Blocker, ibus, NEW (adamw, 16:35:45)
    4. Ticket vote: FinalBlocker (+3,0,-0) (+kparal, +frantisekz, +lruzicka) (adamw, 16:35:46)
    5. AGREED: 2076596 - AcceptedBlocker (Final) - this is accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"; we also note it violates the spirit of the "keyboard layout configuration" criterion, which should be updated to require that switching work for default-switched configurations (adamw, 16:41:34)

  6. (2075989) libyui-mga-qt doesn't require libyui-qt (adamw, 16:41:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2075989 (adamw, 16:41:56)
    2. https://pagure.io/fedora-qa/blocker-review/issue/760 (adamw, 16:42:01)
    3. Proposed Blocker, libyui-mga-qt, MODIFIED (adamw, 16:42:03)
    4. Ticket vote: FinalBlocker (+5,0,-1) (+geraldosimiao, +bcotton, +nielsenb, +ngompa, +frantisekz, -kparal) (adamw, 16:42:07)
    5. ACTION: adamw to reconsider the "default application" wording in the package management criteria for Modern Times (adamw, 16:47:19)
    6. https://bugzilla.redhat.com/show_bug.cgi?id=2075976 (geraldosimiao, 16:59:32)
    7. AGREED: 2075989 - AcceptedBlocker (Final) - this is accepted as a violation of "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type" for dnfdragora in KDE at lower vertical resolutions (adamw, 17:06:24)

  7. (2074789) Basic graphics mode broken for X11 with Nvidia GPU and UEFI (adamw, 17:06:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2074789 (adamw, 17:06:42)
    2. https://pagure.io/fedora-qa/blocker-review/issue/749 (adamw, 17:06:43)
    3. Proposed Blocker, xorg-x11-server, POST (adamw, 17:06:46)
    4. Ticket vote: FinalBlocker (+0,0,-5) (-lruzicka, -geraldosimiao, -kparal, -bcotton, -frantisekz) (adamw, 17:06:49)
    5. Ticket vote: FinalFreezeException (+6,0,-0) (+asciiwolf, +geraldosimiao, +nielsenb, +kparal, +bcotton, +frantisekz) (adamw, 17:06:52)
    6. AGREED: 2074789 - AcceptedBlocker (Final) - this is accepted as a violation of "The generic video driver option...must function as intended...there must be no bugs that clearly prevent the installer or desktop from being reached in this configuration on...wide classes of hardware", affecting all cases where the UEFI simpledrm driver may kick in (adamw, 17:24:08)
    7. there are no outstanding proposed FEs, so let's move on to a review of: (adamw, 17:26:53)

  8. Accepted Blockers (adamw, 17:27:00)
  9. (2070764) selinux-policy is preventing flatpak from updating / installing / removing flatpaks (adamw, 17:27:54)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2070764 (adamw, 17:27:57)
    2. Accepted Blocker, container-selinux, ON_QA (adamw, 17:28:00)
    3. status on this bug is a bit complicated, we may be able to treat it as resolved from a blocker point of view (though bugs remain), but we will follow up further on the bug (adamw, 17:43:42)

  10. (2068470) online accounts: can't disable sync on items (adamw, 17:46:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2068470 (adamw, 17:46:32)
    2. Accepted Blocker, gnome-control-center, NEW (adamw, 17:46:36)
    3. this has been waiting for developer attention, but mcatanzaro has now volunteered so we hope it will move forward, thanks (adamw, 17:51:29)

  11. (2073708) pyanaconda.modules.common.errors.installation.StorageInstallationError: device is active (adamw, 17:52:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2073708 (adamw, 17:52:19)
    2. Accepted Blocker, plasma-desktop, NEW (adamw, 17:52:27)
    3. we think the issue here may be a KDE change in what kinds of devices it automounts, but we're not 100% sure, and will do some more investigation on that (adamw, 17:58:05)

  12. (2071259) gnome-initial-setup hangs when I try to setup a google/microsoft online account (adamw, 18:00:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2071259 (adamw, 18:00:39)
    2. Accepted Blocker, selinux-policy, ASSIGNED (adamw, 18:00:43)
    3. this is waiting on an selinux-policy build with a fix; zdenek seems to know what is needed, but build has not appeared yet (adamw, 18:04:42)

  13. Open floor (adamw, 18:04:53)


Meeting ended at 18:18:33 UTC (full logs).

Action items

  1. adamw to reconsider the "default application" wording in the package management criteria for Modern Times


Action items, by person

  1. adamw
    1. adamw to reconsider the "default application" wording in the package management criteria for Modern Times


People present (lines said)

  1. adamw (177)
  2. geraldosimiao (35)
  3. lruzicka (34)
  4. Eighth_Doctor (34)
  5. NishantMishra[m] (29)
  6. kparal (25)
  7. nirik (11)
  8. zodbot (9)
  9. OnuralpSezer[m] (8)
  10. coremodule (7)
  11. bcotton (6)
  12. pwhalen (5)
  13. OnuralpSezer[m]1 (5)
  14. Southern_Gentlem (2)
  15. MichaelCatanzaro (2)
  16. sgallagh (1)
  17. nirik[m] (1)


Generated by MeetBot 0.4.