16:01:04 <adamw> #startmeeting F37-blocker-review
16:01:04 <zodbot> Meeting started Mon Sep 12 16:01:04 2022 UTC.
16:01:04 <zodbot> This meeting is logged and archived in a public location.
16:01:04 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:01:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:04 <zodbot> The meeting name has been set to 'f37-blocker-review'
16:01:07 <adamw> #meetingname F37-blocker-review
16:01:07 <zodbot> The meeting name has been set to 'f37-blocker-review'
16:01:10 <adamw> #topic Roll Call
16:01:49 <bcotton> .hello2
16:01:50 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:58 * coremodule is here, willing to act as secretary.
16:02:20 <adamw> ahoyhoy folks, who's here for blocker fun
16:02:32 <lruzicka> .hello2
16:02:33 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
16:02:46 <coremodule> As usual, I go to lunch after the meeting so the secretarialization will take me an hour or so after the end of the meeting, unless it's urgent today.
16:02:47 <lruzicka> hoyda, hoyda
16:03:07 <lruzicka> coremodule, that's fine with me, thank you for doing it
16:04:55 <SouthernG[m]> .hello jbwillia
16:04:56 <zodbot> SouthernG[m]: jbwillia 'Ben Williams' <vaioof@gmail.com>
16:06:02 * kparal lurks
16:07:29 <adamw> coremodule: nope, not urgent today
16:07:38 <coremodule> perfection
16:08:32 <geraldosimiao> .hello geraldosimiao
16:08:33 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:12:44 <adamw> sorry, i'm still finishing out the qa meeting here
16:12:52 <adamw> #chair kparal coremodule
16:12:52 <zodbot> Current chairs: adamw coremodule kparal
16:12:58 <adamw> boilerplate time
16:16:06 <adamw> #topic Introduction
16:16:12 <adamw> Why are we here?
16:16:13 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:16:14 <adamw> #info We'll be following the process outlined at:
16:16:17 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:16:19 <adamw> #info The bugs up for review today are available at:
16:16:21 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:16:24 <adamw> #info The criteria for release blocking bugs can be found at:
16:16:26 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:16:29 <adamw> #link https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria
16:16:32 <adamw> #link https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria
16:16:48 <adamw> #info for Final, we have:
16:16:49 <adamw> #info 4 Proposed Blockers
16:16:50 <adamw> #info 14 Accepted Blockers
16:16:54 <adamw> #info 6 Proposed Freeze Exceptions
16:17:01 * cmurf la dee da's into the room
16:17:05 <adamw> #info coremodule will secretarialize
16:19:32 <adamw> let's start with:
16:19:35 <adamw> #topic Proposed Final blockers
16:19:41 <adamw> #topic (2106868) Project name and source repository changed to gnome-browser-connector
16:19:44 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2106868
16:19:47 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/903
16:19:50 <adamw> #info Proposed Blocker, chrome-gnome-shell, NEW
16:19:52 <adamw> #info Ticket vote: BetaBlocker (+1,0,-0) (+scottbeamer)
16:19:54 <adamw> #info Ticket vote: FinalBlocker (+2,0,-1) (+asciiwolf, +scottbeamer, -leigh123linux)
16:19:56 <adamw> #info Ticket vote: FinalFreezeException (+1,0,-1) (+asciiwolf, -leigh123linux)
16:20:36 <geraldosimiao> That's tricky, isn't?
16:21:22 * cmurf is skeptical we block on this
16:21:30 <cmurf> can't it just get fixed in a regular update?
16:21:43 <cmurf> we're not in freeze right now so FE doesn't matter
16:22:01 <geraldosimiao> cmurf: Me too
16:22:23 <cmurf> sounds like a packaging issue, not a QA issue
16:22:30 <adamw> i don't think we can plausibly block on any random shell extension being broken
16:22:56 <cmurf> that also isn't installed by default
16:23:10 <TheExorcist[m]> adamw: +1
16:23:35 <bcotton> i thought it was installed by default on Workstation?:
16:23:45 <cmurf> i'm not seeing it
16:23:57 <cmurf> i guess I could have removed it somehow but i don't recall doing that
16:24:06 <adamw> Michael Catanzaro: what is this thing anyway? are you familiar with it? is it importnat?
16:24:09 <adamw> i've never heard of it
16:24:19 <adamw> oh, wait
16:24:26 <adamw> is this the thing that lets you install extensions from a browser?
16:24:33 <MichaelCatanzaro> adamw: yes
16:24:45 <MichaelCatanzaro> I would say -1 blocker +1 FE
16:24:58 <MichaelCatanzaro> It's stretching the default application functionality criterion a bit too far
16:25:24 <adamw> ohh, yeah. okay. so it's more important than just some single random extension being broken. but still not exactly covered in the existing criteria...
16:26:05 <MichaelCatanzaro> If you consider shell extensions installation to be basic functionality, then it's a blocker. But I'd considre that to be an optional hidden extra
16:26:40 <MichaelCatanzaro> Presumably the FE is what is really desired here anyway?
16:27:31 <cmurf> ok chrome-gnome-shell-10.1-17.fc37.x86_64 is installed by default on F37 Workstation Live ISO
16:28:22 <cmurf> i guess i'm +1 FE, and if it doesn't get fixed oh well
16:29:06 <bcotton> -1 blocker, +1 FE
16:29:28 <bcotton> (knowing that we're still a few weeks from freeze)
16:29:58 <Southern_Gentlem> -1 fb +1 fe
16:30:04 <adamw> yeah, i'll give it an FE just in case
16:30:18 <lruzicka> -1 fb, +1 fe
16:30:21 <adamw> Michael Catanzaro: people *do* like extensions. how else can they install them if not this way?
16:30:24 <adamw> just want to be sure about this
16:31:15 <MichaelCatanzaro> adamw: I thought you could install them manually by downloading them and using the built-in Extensions app, but I don't see a way to do that
16:31:31 <MichaelCatanzaro> So, dunno
16:31:53 <adamw> honestly, if someone said 'let's have a criterion that it must be possible to install extensions', i don't think i'd vote against it
16:32:04 <adamw> anecdotally, a lot of people do seem to use them
16:32:10 <adamw> dash to dock and stuff
16:33:59 <geraldosimiao> -1 Blocker
16:33:59 <geraldosimiao> +1 FE
16:34:09 <adamw> so on the current criteria i'd have to be -1 here, but i kiiiinda do want to propose a criterion for this and see what people think
16:34:22 <adamw> i do feel like we'd get kinda shellacked if we released F37 and you can't install shell extensions
16:34:32 <adamw> that sounds like a bad scenario
16:34:54 <Southern_Gentlem> gnomeshell-extensions doesnt exist anylonger ?
16:34:56 <cmurf> ok so tentative +1 fb pending criterion
16:34:57 * bcotton nods
16:35:16 <bcotton> i'd be okay with a punt-for-criterion
16:35:24 <Southern_Gentlem> or the tweak-tool
16:35:41 <adamw> we have a kinda small set of packaged extensions, dunno how well they're kept up to date
16:35:49 <adamw> it doesn't cover anywhere near what's in the extensions.gnome.org repo though
16:36:04 <adamw> Southern_Gentlem: iirc from tweak tool you can enable or disable installed extensions, but not install new ones?
16:36:18 <Southern_Gentlem> i thought you could
16:36:58 <adamw> wanna check? i don't have it here, i'm on silverblue and there's no flatpak of it
16:37:05 <adamw> anyhow
16:37:22 <adamw> my proposal here is: punt on blocker decision and i'll propose a criterion and see what people think
16:37:29 <adamw> is that ok for folks?
16:37:41 <cmurf> ok
16:37:41 <cmurf> ack
16:38:16 <bcotton> ack
16:38:32 <Southern_Gentlem> since there is not criterion, skip for know and when wehave one we can relook
16:40:53 <adamw> proposed #agreed 2106868 - punt (delay decision) on blocker status, AcceptedFreezeException - we agreed that current criteria do not cover this, but it's a serious issue and we may want to cover it. adamw will propose a new criterion for discussion, blocker decision is delayed while we do that. We certainly agree it's important enough for a freeze exception
16:41:13 <bcotton> ack
16:41:24 <lruzicka> ack
16:41:41 <TheExorcist[m]> ack
16:42:14 <adamw> #agreed 2106868 - punt (delay decision) on blocker status, AcceptedFreezeException - we agreed that current criteria do not cover this, but it's a serious issue and we may want to cover it. adamw will propose a new criterion for discussion, blocker decision is delayed while we do that. We certainly agree it's important enough for a freeze exception
16:42:49 <adamw> #topic (2125569) Correct property name in GsRemovalDialog .ui file
16:42:53 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2125569
16:42:56 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/906
16:42:58 <adamw> #info Proposed Blocker, gnome-software, VERIFIED
16:43:01 <adamw> #info Ticket vote: FinalBlocker (+1,0,-0) (+gui1ty)
16:43:05 <adamw> #info Ticket vote: PreviousRelease (+1,0,-0) (+kparal)
16:45:20 <lruzicka> +1 Final Blocker
16:45:24 <TheExorcist[m]> +1 FB
16:46:41 <cmurf> should this be set to f37?
16:46:44 <cmurf> it's currently set to rawhide
16:47:17 <cmurf> this would also presumably be blockerpreviousrelease
16:47:34 <adamw> yeah
16:47:37 <adamw> +1 previousrelease
16:48:13 <cmurf> +1 blocker previousrelease
16:48:42 <bcotton> +1 previousrelease
16:49:46 <adamw> proposed #agreed 2125569 - AcceptedPreviousRelease - this is accepted as a violation of Beta criterion "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed". The updates for F35 and F36 need to go stable to consider this addressed
16:49:56 <adamw> aaaand here's the thing we should've blocked beta for? :D
16:50:15 <cmurf> ack
16:50:20 <lruzicka> ack
16:50:46 <lruzicka> adamw, this has been known before Beta though
16:50:58 <lruzicka> adamw, why did not we block then?
16:51:09 <cmurf> is there still time?
16:51:10 <lruzicka> has been -> was
16:51:17 <cmurf> make it a 0day blocker 😄
16:51:28 <cmurf> we release tomorrow
16:51:53 <adamw> i think it's not really that important for beta as you have to do all sorts of gymnastics to trigger an upgrade prompt in gnome-software at beta time
16:52:00 <adamw> in practice it's easier to just use dnf
16:52:05 <cmurf> ok
16:52:16 <adamw> but yeah, we should try and get the updates pushed stable for f35 and f36 asap.
16:52:18 <cmurf> mainly curious what it would look like to stop the train
16:52:22 <adamw> so test and karma
16:52:47 <adamw> cmurf: it's pretty much impossible. we have no process for it. in fact all the process docs say specifically you can't stop the train - once we sign off, we're releasing.
16:52:49 <bcotton> cmurf: it would mostly involve me ugly-crying
16:53:05 <adamw> if somebody discovered the signed-off kernel ate everyone's data, we would have to revisit this, but we have never reached that point yet. :P
16:54:26 <adamw> one more ack?
16:55:01 <bcotton> ack
16:55:05 <Penguinpee> .hello2 gui1ty
16:55:06 <zodbot> Penguinpee: Sorry, but user 'Penguinpee' does not exist
16:55:11 <Penguinpee> ack
16:55:23 <bcotton> or did i already? nope, just one ack
16:55:35 <Penguinpee> .hello gui1ty
16:55:36 <zodbot> Penguinpee: gui1ty 'None' <gui1ty@penguinpee.nl>
16:55:45 <Penguinpee> ack
16:56:33 <adamw> #agreed 2125569 - AcceptedPreviousRelease - this is accepted as a violation of Beta criterion "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed". The updates for F35 and F36 need to go stable to consider this addressed
16:56:39 <adamw> #topic (2124986) upowerd fail to initialize in kernel 5.19 printing a trace in kernel log
16:56:43 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2124986
16:56:47 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/901
16:56:49 <adamw> #info Proposed Blocker, kernel, MODIFIED
16:56:56 <adamw> '#info Ticket vote: BetaBlocker (+0,0,-3) (-bcotton, -adamwill, -geraldosimiao)
16:56:57 <adamw> #info Ticket vote: FinalBlocker (+2,0,-0) (+catanzaro, +gui1ty)
16:56:58 <adamw> grr
16:57:02 <adamw> oh well, that wasn't an important line
16:57:12 <adamw> this one should get closed out soon, so no need to kill ourselves on the voting
16:57:16 <adamw> just waiting for the update to go stable
17:00:07 <adamw> i guess i'll vote +1 as a conditional violation of the 'all services must start' criterion
17:00:08 <bcotton> i guess I''d be +1 blocker on this
17:00:24 <cmurf> i'm not seeing this
17:00:27 <cmurf> is it still an issue?
17:01:02 <cmurf> i'd say punt, see if it's not fixed in 5.19.8 and then next steps
17:01:30 <cmurf> i'm not on 5.19.8 and i'm not seeing it so in any case sounds like it's probably a conditional blocker
17:01:32 <adamw> it's fixed in 5.19.8
17:01:40 <adamw> cmurf: it is a conditional blocker. it depends on your hardware/
17:02:11 <cmurf> yeah so -1 fb for now
17:02:51 <lruzicka> I am on 19.8. and I am not seeing it
17:03:15 <lruzicka> -1 blocker
17:03:56 <Penguinpee> I guess whoever reported the bug would need to verify it on their hardware
17:04:19 <adamw> they already did
17:04:25 <adamw> that's why i said we don't need to kill ourselves voting for this
17:04:37 <adamw> it's fixed, we're just waiting for the update to hit stable
17:04:44 <adamw> but please just everybody vote something so we can move on thank you :D
17:04:45 <Penguinpee> Okay. Let's move on then.
17:05:17 <Southern_Gentlem> -1B
17:05:20 * Penguinpee voted already on the ticket
17:06:34 <adamw> proposed #agreed - 2124986 - punt (delay decision) - the vote here is kind of split, but in any case the bug will be closed soon as it's confirmed fixed in 5.19.8, so we'll just punt it and it should have gone away by next week
17:06:41 <bcotton> ack
17:06:58 <Penguinpee> ack
17:07:24 <lruzicka> ack
17:07:35 <copperi[m]> ack
17:08:38 <adamw> #agreed - 2124986 - punt (delay decision) - the vote here is kind of split, but in any case the bug will be closed soon as it's confirmed fixed in 5.19.8, so we'll just punt it and it should have gone away by next week
17:08:43 <adamw> #topic (2125252) try to disable a vpn channel,but failed
17:08:46 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2125252
17:08:48 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/904
17:08:51 <adamw> #info Proposed Blocker, NetworkManager-openvpn, NEW
17:08:56 <adamw> #info Ticket vote: FinalBlocker (+2,0,-0) (+asciiwolf, +gui1ty)
17:10:43 <bcotton> +1 blocker
17:12:30 <adamw> so, you can disconnect using control center, i just tested
17:12:39 <adamw> this is only broken through the top-right menu ("system menu").
17:13:36 <lruzicka> even so, that is basic functionality
17:13:37 <cmurf> +1 fb
17:13:42 <lruzicka> +1 blocker
17:14:41 <MichaelCatanzaro> +1 blocker
17:14:53 <adamw> ok
17:14:57 <copperi[m]> +1 blocker
17:14:57 <adamw> i'd say "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" is the best criterion...
17:15:15 <adamw> proposed #agreed 2125252 - AcceptedBlocker (Final) - this is accepted as a violation of Final criterion "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"
17:15:26 <lruzicka> ack
17:15:33 <Penguinpee> ack
17:16:27 <cmurf> ack
17:16:49 <copperi[m]> ack
17:17:08 <adamw> #agreed 2125252 - AcceptedBlocker (Final) - this is accepted as a violation of Final criterion "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"
17:17:29 <adamw> i guess we don't need to go through proposed FEs, really
17:17:48 <adamw> since freeze isn't for a bit
17:18:01 <adamw> #topic Open floor
17:18:13 <adamw> #info we will skip proposed FEs since freeze isn't till Oct 4th
17:18:51 <adamw> #info we have a lot of accepted blockers, some will clear on 0-day update push, we will review the rest next time
17:19:26 <adamw> any other business, folks?
17:19:53 <cmurf> negative
17:20:53 * bcotton has nothing
17:21:08 <lruzicka> nothing we could solve here :D
17:21:38 * Penguinpee shakes his head
17:22:26 <adamw> alllrighty
17:22:28 <adamw> thanks for coming everyone
17:24:52 <adamw> #endmeeting