16:01:03 <adamw> #startmeeting F37-blocker-review
16:01:03 <zodbot> Meeting started Mon Oct 10 16:01:03 2022 UTC.
16:01:03 <zodbot> This meeting is logged and archived in a public location.
16:01:03 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:01:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:03 <zodbot> The meeting name has been set to 'f37-blocker-review'
16:01:11 <adamw> #meetingname F37-blocker-review
16:01:11 <zodbot> The meeting name has been set to 'f37-blocker-review'
16:01:12 <adamw> #topic Roll Call
16:01:24 <adamw> coming at you live from brno...how's everybody blockering today?
16:01:38 <bcotton> .hello2
16:01:39 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:50 <bcotton> i'm blockertastic
16:02:06 * kparal is here
16:03:55 <adamw> blockeriffic
16:03:56 <adamw> coremodule: ahoy
16:04:11 <coremodule> ahoy, thanks for the ping
16:04:16 <bcotton> Happy Thanksgiving, adamw
16:04:29 <adamw> Ben Cotton (he/him): oh yeah, apparently
16:04:48 <adamw> i'll take a day off after f37 comes out or something
16:04:58 <bcotton> (offer not valid outside Canada, i guess)
16:06:38 <adamw> anybody else here
16:06:47 <davdunc[m> I am here for moral support. :)
16:07:59 <coremodule> I have an appointment in an hour (11am mst), so I will have to go early, but will finish the secretarialization when i get back
16:08:43 <adamw> woohoo, i love to be supported morally
16:09:09 <geraldosimiao> .hello geraldosimiao
16:09:10 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:09:57 <AllanDay[m]> i'm here for a short while
16:10:05 <adamw> alrighty
16:10:10 <adamw> we'll make it a short one and a good one
16:10:40 <adamw> #chair kparal bcotton
16:10:40 <zodbot> Current chairs: adamw bcotton kparal
16:10:41 <adamw> impending boilerplate alert
16:10:41 <adamw> #topic Introduction
16:10:41 <adamw> Why are we here?
16:10:41 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:10:43 <adamw> #info We'll be following the process outlined at:
16:10:45 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:10:49 <adamw> #info The bugs up for review today are available at:
16:10:55 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
16:10:58 <adamw> #info The criteria for release blocking bugs can be found at:
16:11:01 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:11:06 <adamw> #link https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria
16:11:08 <adamw> #link https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria
16:11:19 <adamw> #info for Final, we have:
16:11:21 <adamw> #info 2 Proposed Blockers
16:11:26 <adamw> #info 7 Accepted Blockers
16:11:30 <adamw> #info 1 Proposed Freeze Exceptions
16:11:33 <adamw> #info 14 Accepted Freeze Exceptions
16:11:40 <adamw> #info coremodule will secretarialize
16:11:43 <adamw> let's get started with...
16:11:46 <adamw> #topic Proposed Final blockers
16:11:54 <adamw> #topic (2133425) updates-testing should be disabled, fedora-release should have release >= 1
16:11:56 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2133425
16:11:59 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/963
16:12:02 <adamw> #info Proposed Blocker, fedora-repos, NEW
16:12:06 <adamw> #info Ticket vote: FinalBlocker (+3,0,-0) (+nielsenb, +adamwill, +kparal)
16:12:17 <adamw> this one's a standard one, might even be automatic, i should've checked, anyway it's an obvious +1
16:12:28 <kparal> ack
16:12:47 <coremodule> +1
16:13:01 <bcotton> +1
16:13:10 <geraldosimiao> +1
16:13:35 <adamw> proposed #agreed 2133425 - AcceptedBlocker (Final) - accepted as a clear violation of the Final "release identification" requirements
16:13:38 <coremodule> ack
16:13:47 <bcotton> ack
16:13:48 <geraldosimiao> Ack
16:14:16 <adamw> #agreed 2133425 - AcceptedBlocker (Final) - accepted as a clear violation of the Final "release identification" requirements
16:14:32 <adamw> #topic (2123998) Mesa 22.2.0~rc3 is built without support for common video codecs, missing mesa-va-drivers might cause issues
16:14:33 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2123998
16:14:34 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/949
16:14:35 <adamw> #info Proposed Blocker, mesa, ASSIGNED
16:14:41 <adamw> #info Ticket vote: FinalBlocker (+6,0,-0) (+bcotton, +geraldosimiao, +kparal, +asciiwolf, +gui1ty, +nielsenb)
16:14:46 <adamw> so, this one has been a bit of a rolling story, it looks like
16:14:56 <kparal> Yes, the situation changed
16:14:58 <adamw> current state seems to be "some systems don't work without mesa-va-drivers, we are not sure why"
16:15:02 <kparal> So far we've found 2 affected systems
16:15:09 <adamw> to be specific, two systems we know of. we're trying to debug jiri's ATM
16:16:06 <bcotton> in the interests of not flapping, i'm going to keep my +1 for now until we're more certain that this is a corner case
16:16:47 <kparal> I'm find with either. If we can't figure out the root cause, it will be a hard to fix exception.
16:16:56 <kparal> *fine
16:17:31 <adamw> i'm fine with either punting or accepting, either way we'll wind up reconsidering this at go/no-go i guess
16:19:28 <adamw> anyone else have a strong opinion? if not i'll just go with accepting on current votes
16:19:49 <geraldosimiao> Ack
16:19:50 <coremodule> no strong opinion here
16:20:04 <geraldosimiao> Me neither
16:20:47 <adamw> alrighty
16:20:49 <bcotton> ship^Wblock it!
16:22:05 <adamw> proposed #agreed 2123998 - AcceptedBlocker (Final) - this is accepted for the moment as a conditional violation of Basic "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility", on affected systems. note this is kind of a provisional determination and we expect to revisit this at
16:22:05 <adamw> go/no-go with more data
16:22:14 <bcotton> ack
16:22:23 <coremodule> ack
16:22:28 <geraldosimiao> Ack
16:22:50 <adamw> #agreed 2123998 - AcceptedBlocker (Final) - this is accepted for the moment as a conditional violation of Basic "A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility", on affected systems. note this is kind of a provisional determination and we expect to revisit this at go/no-go with
16:22:50 <adamw> more data
16:22:57 <adamw> #topic Proposed Final freeze exception
16:23:04 <adamw> #topic (2133285) Consider KDE Gear 22.08.1 pull into F37
16:23:09 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2133285
16:23:13 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/962
16:23:18 <adamw> #info Proposed Freeze Exceptions, LiveCD - KDE, MODIFIED
16:23:23 <adamw> #info Ticket vote: FinalFreezeException (+4,0,-0) (+thunderbirdtr, +nielsenb, +bcotton, +geraldosimiao)
16:23:32 <adamw> so this has +4, but it's quite new and it's a big update so i thought i'd hold it for the meeting
16:23:47 <adamw> anyone see any concerns with landing a giant job lot KDE app update?
16:24:36 <adamw> fixing searching in kmail seems like...a good idea...
16:24:39 <bcotton> makes sense. i was almost a -1 for that reason. kde point releases are generally fairly reliable
16:24:55 <geraldosimiao> No, gear is not like frameworks or qt5
16:25:40 <geraldosimiao> I mean, it's fine
16:26:25 <geraldosimiao> No regressions noted, all packages installed right
16:27:22 <adamw> proposed #agreed 2133285 - AcceptedFreezeException (Final) - we're obviously concerned about pulling in this much change late, but some of the fixes seem significant and this is a bugfix release, so it should make things better rather than the reverse, and KDE has a decent track record here
16:27:34 <bcotton> ack
16:27:49 <coremodule> ack
16:28:00 <kparal> ack
16:28:46 <geraldosimiao> Ack
16:29:00 <adamw> #agreed 2133285 - AcceptedFreezeException (Final) - we're obviously concerned about pulling in this much change late, but some of the fixes seem significant and this is a bugfix release, so it should make things better rather than the reverse, and KDE has a decent track record here
16:29:26 <adamw> ok, so, for the fun bit
16:29:34 <adamw> #topic Accepted Final blocker check-in
16:29:40 <adamw> so we have some awkward ones here
16:29:49 <adamw> #topic (2128662) Abrt does not report a segfault which is reported in journalctl.
16:29:54 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2128662
16:29:57 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/915
16:30:01 <adamw> #info Accepted Blocker, abrt, ASSIGNED
16:30:10 <adamw> so, this one is turning out to be only erratically reproducible
16:30:18 <adamw> kparal thought it had gone away, then yesterday it came back
16:30:36 <adamw> how's everyone else's experience with this? seeing it? not? not looking?
16:30:40 <adamw> i'm on silverblue, which does not appear to have abrt running at all...
16:30:57 <kparal> IIRC Jiri Eischmann mentioned to me that ABRT was not always seeing his crashes as well
16:31:08 <geraldosimiao> adamw: If I told you I hit this now with f36 too?
16:31:44 * Penguinpee sneaks in
16:31:48 <Penguinpee> .hello gui1ty
16:31:49 <zodbot> Penguinpee: gui1ty 'Sandro .' <gui1ty@penguinpee.nl>
16:32:42 <adamw> geraldosimiao: well that'd make it even more murky :P
16:33:03 <adamw> i'm kinda feeling like we have to make this a non-blocker or waive it if we can't even reproduce it reliably, but it's a tricky one
16:33:18 <geraldosimiao> adamw: Yeah, a mystery 😬
16:34:01 <Penguinpee> I actually saw it yesterday on f35
16:34:55 <Penguinpee> HexChat crashed and abrt was nowhere to be seen. I could report it using abrt, though.
16:35:06 <geraldosimiao> adamw: See the good side: if abrt don't show problems, people will say f37 have no bugs...
16:35:06 <adamw> like, the same thing? something crashed but abrt didn't notice? and restarting abrt made it start working again?
16:35:07 <geraldosimiao> 👀
16:35:31 <adamw> i don't think that's quite the same
16:35:31 <kparal> If you see it in ABRT interface, it's not the same thing
16:35:39 <Penguinpee> adamw: yes. abrt didn't notice, but had a record of it opening it manually.
16:35:52 <adamw> as i read this bug, while it's not working, abrt isn't catching crashes at all
16:36:52 <Penguinpee> That's not what I saw. Just no notification.
16:37:33 <adamw> ok,so that's dfiferent.
16:37:36 <adamw> anyhow, i guess we'll have to keep poking at this as best we can
16:37:58 <kparal> I'm fine with either keeping it as a blocker and then using a hard-to-fix exception, or removing the blocker status
16:38:02 <Penguinpee> first line in description: "Abrt does not show any notification"
16:38:10 <adamw> #info this is in an awkward state: testers are observing the bug periodically, but we can't reproduce it reliably or determine why it's happening. we'll continue trying to investigate it
16:38:13 <geraldosimiao> kparal: +1
16:38:20 <adamw> kparal: i think it's fine to leave that till go/no-go if it becomes necessary to do
16:38:48 <adamw> Penguinpee: the rest of that line: "nor does it show and report a simulated segfault"
16:38:57 <adamw> moving on...
16:39:04 <adamw> #topic (2129358) glibc 2.36+ breaks EAC with removal of DT_HASH (and other game libraries), making games fail to load
16:39:09 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2129358
16:39:11 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/920
16:39:14 <adamw> #info Accepted Blocker, glibc, POST
16:39:34 <adamw> so, this one...the idea of what to do seems clear, but carlos metaphorically took it away to poke at it 10 days ago and never came back
16:39:36 <Penguinpee> adamw: there was a segfault as reported in dmesg.
16:39:39 <adamw> i've needinfo'd him for an update
16:40:20 <adamw> any other notes on it?
16:40:27 <Penguinpee> nope
16:41:05 <bcotton> i nudged him in the PR, too
16:41:13 <adamw> #info this is waiting on Carlos, we've nudged him for an update
16:41:22 <adamw> #topic (2132769) Changes to recurring events don't redraw correctly
16:41:31 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2132769
16:41:33 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/959
16:41:34 <adamw> #info Accepted Blocker, gnome-calendar, NEW
16:41:41 <coremodule> I've got to run, once the meeting is complete and the logs are published, if someone else wants to mark the three bugs we discussed, that would help me, otherwise I'll do it when I get back in an hour(?)
16:41:41 <adamw> so, here we have a little mini-block of GNOME app blockers, again
16:41:48 <adamw> folks may remember this situation from last cycle...
16:41:54 <adamw> coremodule: i can do it
16:42:22 <coremodule> thanks adamw. I like to wait for meeting end so I can link the meeting minutes in the bug reports, or else I'd just do it now
16:42:30 <geraldosimiao> Yeah
16:42:44 <adamw> this and 2132772 are basically tied up in the same tricksy 'recurring event' code, aiui
16:42:51 <Penguinpee> yeah, looks like GNOME has outsourced QA to Fedora >-)
16:43:33 <adamw> so, i'm not sure we can do a lot in this meeting, the situation is basically understood
16:43:50 <adamw> desktop folks will see what they can do on these, but we may wind up talking about waiving them as hard-to-fix at the go/no-go
16:44:32 <geraldosimiao> Penguinpee: 😶
16:44:50 <adamw> #info the situation here is quite clear, we're just waiting to see if it turns out to be practical to fix this and the other GNOME app bugs in a reasonable time
16:45:01 <adamw> #topic (2132772) Editing a recurring event moves it forward in time
16:45:04 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2132772
16:45:09 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/960
16:45:12 <adamw> #info Accepted Blocker, gnome-calendar, NEW
16:45:15 <adamw> #info the situation here is quite clear, we're just waiting to see if it turns out to be practical to fix this and the other GNOME app bugs in a reasonable time
16:45:35 <adamw> #topic (2130657) Editing an existing contact's email address causes Contacts to display an empty "Unnamed Person" card, other edits made at the same time are lost
16:45:36 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130657
16:45:36 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/927
16:45:40 <adamw> #info Accepted Blocker, gnome-contacts, ASSIGNED
16:45:43 <adamw> this is in a similar box
16:46:09 <adamw> note i've narrowed the outstanding issue down to "any other edits made at the same time as the email address get thrown away"
16:46:22 <adamw> i'm gonna take a poke at this myself tonight/tomorrow, but dunno if i'll be able to spot it
16:46:53 <adamw> but it's a clear and 100% reproducible bug, just a case of what fixing it is going to look like
16:48:36 <adamw> #info similar to the two previous bugs, this is just waiting to be debugged and fixed
16:48:47 <adamw> #topic (2130661) Link Contacts feature completely broken
16:48:51 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2130661
16:49:03 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/926
16:49:04 <adamw> #info Accepted Blocker, gnome-contacts, NEW
16:49:06 <adamw> and this is similar again
16:51:22 <adamw> #info again, we are just waiting to see if this can be fixed, the bug is clearly identified
16:51:28 <adamw> #topic (2131837) On Screen Keyboard cannot type a space anywhere
16:51:32 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2131837
16:51:35 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/948
16:51:39 <adamw> #info Accepted Blocker, ibus-typing-booster, NEW
16:51:50 <adamw> and finally, another one similar. i'm curious why/when this broke though...
16:54:03 <kparal> I wonder if we should poke someone about this one. Components get shuffled, but is someone looking at the core issue?
16:54:03 <adamw> looks like mfabian did some debugging recently
16:54:12 <adamw> which seems to throw it back on gnome-shell
16:54:14 <geraldosimiao> As said in the comment upstream: "... it is lost when ibus-typing-booster was automatically enabled by gnome-shell but it works when ibus-typing-booster was manually enabled."
16:55:05 <kparal> I haven't seen the latest upstream updates before, Mike is looking at it, great
16:55:24 <matthiasc[m]> I pinged mfabian
16:55:24 <geraldosimiao> Yes
16:55:27 <matthiasc[m]> he's debugging it
16:56:02 <matthiasc[m]> its squarely a typing-booster issue
16:56:11 <adamw> #info again we ware waiting for debugging/fix on this, mfabian is working on it as we speak
16:56:30 <adamw> alright, that's a quick run through
16:56:42 <adamw> anyone have further notes on specific blockers or the general situation of all these gnome app blockers?
16:57:20 <Penguinpee> 😶
16:57:34 <geraldosimiao> No
16:58:30 <adamw> honestly...just mind gaming this...i'm not sure i'd want to do the path where we sign this off on thursday (assuming nothing else comes up). which would involve kicking out 2128662 and any gnome blockers that couldn't be fixed, probably kicking out the mesa problem if we can't identify that very quickly, probably throwing together the glibc change at the last minute, then hastily shipping with a mystery-meat bug in the recent mesa
16:58:31 <adamw> fiddling about, and a hastily-hacked glibc
16:58:34 <adamw> that doesn't sound like a winning strategy for a quality release to me
16:58:43 <bcotton> agreed
16:59:03 <bcotton> i certainly won't be pushing to cut an RC tomorrow
16:59:10 <adamw> also i dunno where test coverage is at
16:59:28 <adamw> this really-short amount of time allotted from beta to final always feels like a struggle to me\
16:59:31 <bcotton> well we know the gnome apps have been tested...
16:59:32 <Penguinpee> admw++
16:59:40 <adamw> hah, we could test 'em harder
16:59:46 <bcotton> is it really-short? we got beta out on the early target date
17:00:19 <matthiasc[m]> we did get a number of contacts and calendar fixes this cycle, so the testing wasn't in vain
17:00:27 <adamw> yep - and that gave us a whole month from beta release to final go/no-go
17:00:32 <bcotton> that said, we could certainly move the beta targets a week or two earlier
17:00:35 <adamw> woo...hoo?
17:01:01 <adamw> i guess this comes back to all the fun about gnome/kde release cycles and stuff too, sigh
17:01:17 <geraldosimiao> bcotton: +1
17:01:17 <bcotton> yeah, it's a tangled mess
17:02:19 <bcotton> feel free to #endmeeting if you want because we're off on quite a tangent, but i'm curious what you'd length of time you'd want to see in a perfect world where we don't have to worry about upstream schedules, etc
17:02:59 <adamw> ugh, i dunno. just More(tm) :D
17:03:09 <adamw> alrighty, let's call it, i've gotta go have dinner anyhow
17:03:24 <geraldosimiao> I would like to ask about https://pagure.io/fedora-qa/blocker-review/issue/937
17:03:26 <adamw> oh sure
17:03:35 <geraldosimiao> And #936 too
17:03:51 <geraldosimiao> Both about the background change
17:03:53 <adamw> my take on those is, we should leave f37 as it is
17:04:02 <adamw> don't take the change to webp or anything else associated with it
17:04:19 <adamw> i don't think it was a good idea to try and change the default background format this late in the cycle
17:04:19 <geraldosimiao> So obsolete the updates on testing?
17:04:20 <adamw> it's much more appropriate for rawhide
17:04:49 <geraldosimiao> Leave only the ones on stable?
17:04:52 <adamw> geraldosimiao: if luya really wants it i think it'd probably be ok to ship it post-release, at least it can't mess up any lives then, and we can fix any problems it causes with further updates (hopefully)
17:05:07 <adamw> but i definitely don't want to pull any of it through the freeze, speaking personally
17:05:31 <geraldosimiao> adamw: Ok, I can live with that yes
17:05:44 <adamw> as things stand none of it would get pulled through the freeze; 937 was accepted on the basis that if the default change got through the freeze, we'd need that fix for it. but that being accepted doesn't mean the default change is accepted as an FE.
17:05:57 <Penguinpee> adamw: "i've gotta go have dinner..." <- i thought you are in bc. a bit early for dinner over there.
17:05:58 <geraldosimiao> adamw: So then we must reject the FE?
17:05:58 <adamw> if anyone does want the default change in final, a bug specifically for that must be proposed as FE
17:06:10 <adamw> not as I read it, it can be an accepted FE but we just...don't pull anything.
17:06:24 <adamw> Penguinpee: i'm in europe (rh's brno office) this week
17:06:26 <bcotton> FEs are permission, not obligation
17:06:27 <adamw> same place as kparal etc.
17:06:41 <geraldosimiao> bcotton: Oh. Ok. Good point.
17:06:56 <adamw> i'll try and poke luya to make sure he's aware of all this
17:07:03 <adamw> and he has a chance to file an FE if he wants
17:07:26 <geraldosimiao> So, we just leave things as they are now.
17:07:35 <geraldosimiao> Ok
17:08:09 <adamw> that would be my preference, yeah, but i'm not the pope ;) if an FE for the default change gets proposed, we'll vote on it like normal
17:08:29 <geraldosimiao> The update on stable have the png background. Yes?
17:08:29 <adamw> and i get one vote like everyone else
17:08:32 <Penguinpee> adamw: in that case, enjoy your dinner! and the other fine offerings of our Czech friends
17:08:39 <adamw> the current state of stable is png-only, yes, aiui
17:09:06 <adamw> nothing from the whole 'add webp and make it the default' complex has made it to stable for f37 as far as i'm aware
17:09:11 <geraldosimiao> 👍🙂
17:09:35 <adamw> Penguinpee: thanks. since i'm vegetarian, eating in czech involves a lot of cheese. :P
17:10:40 <adamw> thanks for coming everyone, see you thursday for the go/no-go
17:10:45 <Penguinpee> adamw: i was referring to fluids...
17:10:47 <geraldosimiao> *adamw it's not the pope, but we consider his opinion in high regard
17:11:04 <jednorozec> adamw, try this one if you have time https://www.happycow.net/reviews/ti-ocsci-brno-103404
17:11:04 <geraldosimiao> 😁
17:11:13 <adamw> Penguinpee: hah, yes, those are handy :D
17:11:36 <adamw> jednorozec: ooh, don't think i've been there before. thanks for the tip
17:12:03 <bcotton> adamw: sometime ask me about the time Rebecca Fernandez et al tried to get a vegan dinner for her birthday in Brno :-)
17:12:49 <Penguinpee> bcotton: you all love a challenge at RH, don't you? ;)
17:12:51 <adamw> Ben Cotton (he/him): was that before brno went all hipster and you couldn't swing a beer mug without hitting a vegan cafe? :D
17:13:03 <adamw> there's a frickin' nespresso store now
17:13:07 <adamw> it's basically manhattan
17:13:09 <bcotton> adamw: apparently. we...struggled :-)
17:13:20 <adamw> #endmeeting