17:01:35 <adamw> #startmeeting F37-blocker-review
17:01:35 <zodbot> Meeting started Mon Nov  7 17:01:35 2022 UTC.
17:01:35 <zodbot> This meeting is logged and archived in a public location.
17:01:35 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:01:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:35 <zodbot> The meeting name has been set to 'f37-blocker-review'
17:01:36 <adamw> #meetingname F37-blocker-review
17:01:36 <zodbot> The meeting name has been set to 'f37-blocker-review'
17:01:38 <adamw> #topic Roll Call
17:01:40 <adamw> I don't have one, that's the problem
17:01:54 <Eighth_Doctor> adamw: call your MP then :)
17:01:55 <adamw> my province has literally passed a law to end DST which will only actually kick in when washington state and oregon do the same (this is true)
17:02:05 <adamw> so, you know, call YOUR congresscritter
17:02:24 <Eighth_Doctor> so then yeah, you should get the Oregonites and Washingtonites to contact their folks
17:02:29 <Eighth_Doctor> I live in CT, they have a bill already passed to switch when MA does
17:02:38 <Eighth_Doctor> and MA has one for NY
17:02:56 <geraldosimiao> .hello geraldosimiao
17:02:57 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
17:03:06 <Eighth_Doctor> .hello ngompa
17:03:07 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:03:16 * Eighth_Doctor is half-dead today, but he's quarter-present
17:03:25 <lruzicka> .hello2
17:03:26 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
17:03:54 <adamw> i did not realize the entirety of north america was a giant game of daylight savings time dominoes
17:04:47 <marcdeop[m]> .hello marcdeop
17:04:48 <zodbot> marcdeop[m]: marcdeop 'None' <fedora@marcdeop.com>
17:06:14 <cmurf> <adamw> "when will this dst madness end" <- I think they have to make it worse before they can get rid of it
17:06:32 <adamw> haha
17:06:38 <adamw> let's make the change random every year!
17:06:51 <adamw> 2024? oh, yeah, we go backwards 34 minutes and 27 seconds
17:07:08 <adamw> in 2025 we're gonna try a little experiment and move the clocks sideways instead
17:08:53 <Eighth_Doctor> <adamw> "i did not realize the entirety..." <- most of the US is in a chain reaction right now
17:09:42 <marcdeop[m]> adamw: As in threw hours? Hahaha
17:09:42 <Eighth_Doctor> that's why the Sunshine Protection Act is our best shot
17:09:43 <Eighth_Doctor> because all the other laws on the books won't ever take effect
17:10:12 <adamw> alright, alright, i hereby call this meeting of the fedora time enthusiasts to order
17:10:25 <adamw> #chair cmurf marcdeop
17:10:25 <zodbot> Current chairs: adamw cmurf marcdeop
17:10:39 <adamw> impending boilerplate alert
17:10:40 <adamw> #topic Introduction
17:10:40 <adamw> Why are we here?
17:10:42 <adamw> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
17:10:44 <adamw> #info We'll be following the process outlined at:
17:10:47 <adamw> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
17:10:50 <adamw> #info The bugs up for review today are available at:
17:10:52 <adamw> #link http://qa.fedoraproject.org/blockerbugs/current
17:10:54 <adamw> #info The criteria for release blocking bugs can be found at:
17:10:56 <adamw> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
17:11:00 <adamw> #link https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria
17:11:02 <adamw> #link https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria
17:11:05 * roshi[m] waves
17:11:16 <adamw> #info for Final, we have:
17:11:17 <adamw> #info 1 Proposed Blockers
17:11:21 <adamw> #info 2 Accepted Blockers
17:11:23 <adamw> #info 1 Proposed Freeze Exceptions
17:11:25 <adamw> #info 14 Accepted Freeze Exceptions
17:11:27 <adamw> ahoy roshi
17:11:42 <adamw> who wants to secretarialize?
17:12:09 <roshi[m]> On phone, so likely can't
17:12:09 <cmurf> wow this qualifies as a zomg moment
17:12:13 <cmurf> roshi is here
17:12:24 <adamw> let's party like it's...whenever roshi was here? i'm bad with...time
17:12:32 <roshi[m]> lol
17:12:34 * dustymabe misses roshi
17:12:44 <roshi[m]> I lost track of things with libera chat and freenode shenanigans
17:13:05 <roshi[m]> then Adam Miller pointed out that I can use teh matrix - so here I am again :)
17:13:40 <roshi[m]> dustymabe I miss you too bud - I joined the cloud channel, but I can't seem to get into the qa one or the infra one - I get 502 bad gateways
17:14:01 <roshi[m]> but anyways, I don't want to interrupt the blocker review
17:14:02 <roshi[m]> :)
17:14:59 <adamw> no no no, this is the time meeting
17:15:11 <adamw> alright, so, last week i lied and said i'd do it, then kamil did it
17:15:24 <adamw> so this week i'll lie and say i'll do it again
17:15:24 <OnuralpSezerhehi> .hello thunderbirdtr
17:15:24 <adamw> #info adamw will secretarialize (also he has a bridge to sell you)
17:15:24 <zodbot> OnuralpSezerhehi: thunderbirdtr 'Onuralp SEZER' <thunderbirdtr@gmail.com>
17:15:41 <adamw> let's get started with...
17:15:47 <adamw> #topic Proposed blocker
17:15:53 <adamw> #topic (2139552) The calendar events are displayed as many times as the calendar gets opened.
17:15:55 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2139552
17:15:58 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1006
17:16:01 <adamw> #info Proposed Blocker, gnome-calendar, NEW
17:16:04 <adamw> #info Ticket vote: FinalBlocker (+3,0,-5) (+lruzicka, +carlg, +catanzaro, -frantisekz, -augenauf, -nb, -geraldosimiao, -wayne6001)
17:16:31 <adamw> yeah, so, we keep poking this thing and it keeps metastasizing
17:16:44 <adamw> i soooooort of suspect this might be caused by our last blocker fix, somehow
17:16:54 <roshi[m]> looks resolved now?
17:17:20 <geraldosimiao> I can't reroduce this on the new rc 1.7 iso anymore
17:17:47 <geraldosimiao> and I can't explain why...
17:17:54 <adamw> well, my tentative theory is that maybe this only affects you if you hit the bug earlier and then affected events were 'fixed' by the code added in 1.3
17:18:01 <geraldosimiao> s/reroduce/reproduce/
17:18:10 <adamw> it's only a guess, but if that were the case, yeah, we shouldn't have to worry about it too much...
17:18:23 <lruzicka> I am not seeing it either, on my machine where I first spotted it.
17:18:37 <adamw> huh. weird
17:18:49 <adamw> i wonder if it somehow only happens at certain points in time?
17:18:57 <cmurf> i'm gonna go with -1 final blocker
17:19:03 <lruzicka> to be exact, I am not seeing it today ... but I am not aware of upgrading the calendar anyhow.
17:19:04 <adamw> let's see if i still have it...
17:19:10 <geraldosimiao> adamw: here whe go with time again...
17:19:18 <roshi[m]> time is a bear
17:19:31 <geraldosimiao> s/whe/we/
17:19:41 <cmurf> strikes me as conditional, and also it's not a data loss eating bug and not like you'll miss an appointment when it's repeated multiple times
17:19:49 <roshi[m]> I'm derelict in my duty, I'm still on F35 and things work fine :P
17:19:56 <cmurf> s////
17:20:13 <roshi[m]> if it's fixed, then it's not violating any criteria - at least until we have solid repro steps
17:20:13 <adamw> as for blockeriness, i did wonder what happens if the appointment has an alert set
17:20:19 <adamw> do you get multiple alerts? that would be annoying
17:20:24 <kernelbreaker[m]> I have a VM of the latest ISO open right now and I can't reproduce the bug
17:20:26 <lruzicka> Yeah, I have not lost anything so I would think this to be a more cosmetic one
17:20:38 <cmurf> multiple alerts would be annoying
17:20:44 <cmurf> i'm not sure it's blocker worthy though
17:21:07 <roshi[m]> especially if latest iso doesn't reproduce
17:21:55 <kernelbreaker[m]> Wait
17:22:01 <kernelbreaker[m]> not that quick 😆
17:22:04 <kernelbreaker[m]> I can see it
17:22:07 <lruzicka> cmurf, I have never seen any multiple alerts ... however I think there could have been none due
17:22:10 <adamw> hmm, it mostly doesn't seem to be happening on my test laptop either. except it seems like one appointment duplicated itself once, but it's sticking at two. mystereeerious
17:22:14 <adamw> but yeah, i guess -1.
17:22:32 <lruzicka> -1
17:23:11 <roshi[m]> -1 without solid reproduction
17:23:22 <adamw> proposed #agreed 2139552 - RejectedBlocker (Final) - overall we think the fairly low impact of this bug and the difficulty in reproducing it consistently make it not qualify as a "basic functionality" failure, so it's rejected as a blocker
17:23:25 <lruzicka> ack
17:23:42 <kernelbreaker[m]> adamw: Sorry for interrupting but to reproduce it I just clicked on event the date in the month view on the right
17:24:48 <geraldosimiao> ack
17:24:52 <adamw> but when it was happening to me before i didn't need to clcik anything
17:24:59 <adamw> and a bunch of appointments were duplicating themselves
17:25:09 <roshi[m]> ack
17:25:13 <kernelbreaker[m]> yup that's not happening now
17:25:21 <kernelbreaker[m]> I certainly need to clicck
17:25:24 <kernelbreaker[m]> s/clicck/click/
17:25:38 <geraldosimiao> kernelbreaker[m]: I do the same here at the VM and the bug doesn't happen.
17:25:43 <adamw> #agreed 2139552 - RejectedBlocker (Final) - overall we think the fairly low impact of this bug and the difficulty in reproducing it consistently make it not qualify as a "basic functionality" failure, so it's rejected as a blocker
17:25:44 <Southern_Gentlem> .hello2 jbwillia
17:25:45 <zodbot> Southern_Gentlem: Sorry, but user 'Southern_Gentlem' does not exist
17:25:54 <adamw> #topic Proposed freeze exceptions
17:25:54 <Southern_Gentlem> .hello jbwillia
17:25:54 <geraldosimiao> ack
17:25:54 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@gmail.com>
17:26:00 <adamw> #topic (2117209) libvirt-daemon can requires gettext-runtime
17:26:01 <lruzicka> let's do the Go/No go, too.
17:26:03 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=2117209
17:26:07 <adamw> #link https://pagure.io/fedora-qa/blocker-review/issue/1003
17:26:10 <adamw> #info Proposed Freeze Exceptions, libvirt, ON_QA
17:26:12 <adamw> #info Ticket vote: FinalFreezeException (+1,0,-4) (+gui1ty, -adamwill, -somethingsomethingfedora, -geraldosimiao, -augenauf)
17:26:19 <adamw> yeah, still -1 for me
17:26:21 <kernelbreaker[m]> geraldosimiao: 🤔
17:26:21 <cmurf> yeah can we ship it today? 😛
17:26:23 <lruzicka> -1
17:26:27 <adamw> the proposed benefit here just isn't worth a freeze break
17:26:47 <cmurf> -1 FE
17:26:58 <cmurf> fix it with an update day of release
17:27:00 <lruzicka> also, we would need to do another RC and this would bring us in a time pressure
17:27:03 <roshi[m]> -1
17:27:05 <geraldosimiao> cmurf: +1 to that :)
17:27:41 <kernelbreaker[m]> +1 from me too lol
17:27:49 <adamw> lruzicka: we wouldn't do that anyway, we don't do a new RC only for FE issues. this would only get pulled in if we had to do a new one for another blocker or something
17:28:09 <lruzicka> But there is an announcement I should make: today a new DSL modem arrived and my broadband is threetimes broader :D
17:28:24 <adamw> proposed #agreed 2117209 - RejectedFreezeException (Final) - the benefit here is just too small to be worth a freeze exception and potential breakage, so this is rejected.
17:28:25 <lruzicka> Composes, here I come to download you.
17:28:28 <lruzicka> ack
17:28:29 <roshi[m]> ack
17:28:33 <cmurf> ack
17:28:37 <adamw> yay, for the bands broad
17:28:53 <geraldosimiao> ack
17:29:54 <Southern_Gentlem> ack
17:29:54 <adamw> #agreed 2117209 - RejectedFreezeException (Final) - the benefit here is just too small to be worth a freeze exception and potential breakage, so this is rejected.
17:29:54 <adamw> alright, so, a quick accepted blocker review
17:29:57 <adamw> #topic Accepted blocker review
17:30:10 <adamw> #info 2135772 is VERIFIED, fix is in RC-1.7, no problems there
17:31:57 <adamw> on 2136234 , we have this from pbrobinson in the kernel channel earlier - "the 6.0.7-301.fc37.aarch64 kernel looks good for me on the rpi4/workstation"
17:32:01 <adamw> and that was indeed the kernel in RC-1.7, so i think we're good there
17:32:13 <roshi[m]> sweet
17:32:29 <jforbes> wheee
17:32:47 <geraldosimiao> adamw: really? thats great news
17:33:09 <adamw> it'd be great if someone could just confirm for safety that the actual RC-1.7 images work on a Pi 4
17:33:31 <roshi[m]> alas I don't have a Pi 4
17:33:42 <kernelbreaker[m]> I do have a pi 4
17:33:46 <kernelbreaker[m]> I can try
17:33:46 <adamw> #info 2136234 - pbrobinson said on IRC that the kernel from RC-1.7 works OK on an rpi4, would be good to have double confirmation from someone else using the RC-1.7 images on a pi 4
17:33:48 <geraldosimiao> no, no PI4 here
17:34:16 <adamw> i've added a note to the bug, hopefully someone will confirm there and we can set VERIFIED
17:34:24 <adamw> but overall, we're looking good here
17:34:29 <adamw> now nobody touch nothing
17:34:35 <lruzicka> Roger.
17:34:39 <adamw> #topic Open floor
17:34:49 <adamw> mattdm: bcotton_ so at this point, i kinda feel like we can say the shiny new stuff looks good and push it stable, wdyt?
17:35:02 * roshi[m] touches everything as instructed
17:35:14 <lruzicka> I need to rush. Take care and thanks for testing.
17:35:29 <adamw> thanks lruzicka
17:36:32 <cmurf> shut down the rhbz
17:36:33 * roshi[m] uploaded an image: (724KiB) < https://libera.ems.host/_matrix/media/v3/download/confuser.co/UGUEiLyptLHcPTyqxORrDYao/tenor_gif8133423278237147570.gif >
17:36:38 <cmurf> secure the kparal
17:37:08 <geraldosimiao> that's important 😂😂
17:37:31 * roshi[m] checks to see if he still has the kparal cage keys....
17:37:55 <adamw> roshi: if you do, throw them away
17:38:09 <roshi[m]> but of course
17:38:38 <OnuralpSezerhehi> What about copies ? :)
17:38:46 <bcotton> adamw: I'm on board
17:38:46 <roshi[m]> sssh
17:38:57 <roshi[m]> it's all blockchain related so it's totally secure
17:39:43 <roshi[m]> base64 encrypted blcokchain NFTs are how you release the kparal
17:39:54 <OnuralpSezerhehi> lol
17:39:55 <adamw> wait, we uploaded kpral's consciousness to the blockchain now?
17:40:03 <OnuralpSezerhehi> uh oh
17:40:13 <OnuralpSezerhehi> he knows
17:40:14 <roshi[m]> how else do you think you mine a whole block?
17:41:44 <adamw> heh
17:41:55 <adamw> alrighty, i'll chase mattdm up somewhere else before i push shiny things stable
17:41:58 <adamw> anything else, folks?
17:42:04 * roshi[m] has nothing
17:42:39 <adamw> looks like we could still use some more test coverage
17:42:39 * kernelbreaker[m] I haz nothing either
17:42:58 * kernelbreaker[m] * haz nothing either
17:43:00 * OnuralpSezerhehi has nothing
17:43:07 <roshi[m]> times haven't changed, adamw saying more tests are good
17:43:23 <OnuralpSezerhehi> adamw need more miner (testers)
17:43:26 <adamw> =)
17:43:38 <adamw> if folks with working arm boxes can knock out some arm tests this week it'd be great
17:43:46 <cmurf> more cowbell!
17:43:47 <adamw> i'll try and fill in some random cells today...
17:43:53 * OnuralpSezerhehi will check with nvidia jetson
17:44:18 * kernelbreaker[m] will check with RasberryPi 4
17:45:09 <adamw> would be good to fill out https://fedoraproject.org/wiki/Test_Results:Fedora_37_RC_1.7_Installation#AArch64_disk_images (check the images actually work on real HW) and some of the boxes in https://fedoraproject.org/wiki/Test_Results:Fedora_37_RC_1.7_Desktop (probably don't need to run all of those, just a few)
17:47:32 <cmurf> also might be a good idea to make sure macs can boot our installer media
17:47:35 <cmurf> if that hasn't happened in a while
17:50:00 <adamw> yeah, indeed
17:50:03 <adamw> i don't have one of those either!
17:50:37 <cmurf> my old one is in a box 1500 miles away
17:50:48 <Southern_Gentlem> i will try later
17:51:04 <roshi[m]> it'll only take you 300 hours to walk there at 5 mph cmurf
17:51:13 <Southern_Gentlem> i have respin today i will test on my mac to see if it boots
17:52:45 <cmurf> yeah if it boots we're 1/2 way there, i guess there could still be some sort of bug related to partitioning since it's still different for macs
17:52:50 <adamw> roshi: that's some pretty fast walking
17:53:02 <cmurf> yeah that ain't happening
17:53:24 <roshi[m]> you dare, doubt the cmurf?!
17:53:39 <cmurf> yes
17:53:46 <cmurf> interest level in that kind of walk is low
17:54:31 <roshi[m]> interest? I'm talking raw capability!
17:54:56 <cmurf> negative ghostrider the pattern is full
17:55:38 <cmurf> these are the discussions that keep people around in case adam has more to cover while he's updating various bits 😛
17:56:10 <roshi[m]> glad to fill my old role
17:56:17 <roshi[m]> buying adamw time to do stuff
17:56:30 <roshi[m]> no one else stepped up!?
17:59:42 <Eighth_Doctor> <cmurf> "yeah if it boots we're 1/2 way..." <- I'm pretty sure dropping the MacEFI partition caused regressions here
18:00:36 <adamw> alrighty, welp, let's get to testing
18:00:43 <adamw> see you all on thursday for the go/no-go
18:00:45 <adamw> thanks everyone!
18:00:53 <roshi[m]> o/
18:00:56 <adamw> #endmeeting