#fedora-blocker-review: F38-blocker-review

Meeting started by adamw at 16:00:23 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:28)
  2. Introduction (adamw, 16:07:04)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:17)
    2. We'll be following the process outlined at: (adamw, 16:07:17)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:18)
    4. The bugs up for review today are available at: (adamw, 16:07:21)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:24)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:29)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:30)
    8. https://fedoraproject.org/wiki/Fedora_38_Beta_Release_Criteria (adamw, 16:07:35)
    9. https://fedoraproject.org/wiki/Fedora_38_Final_Release_Criteria (adamw, 16:07:37)
    10. for Final, we have: (adamw, 16:07:47)
    11. 2 Proposed Blockers (adamw, 16:07:59)
    12. 7 Accepted Blockers (adamw, 16:08:11)
    13. 2 Proposed Freeze Exceptions (adamw, 16:08:37)
    14. 6 Accepted Freeze Exceptions (adamw, 16:08:38)
    15. coremodule will secretarialize (adamw, 16:08:39)

  3. Proposed Final blockers (adamw, 16:09:05)
  4. (2177153) MaxCrashReportsSize claims to be 5000 MB but is 1000 MB (adamw, 16:09:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2177153 (adamw, 16:09:05)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1104 (adamw, 16:09:06)
    3. Proposed Blocker, abrt, NEW (adamw, 16:09:07)
    4. Ticket vote: FinalBlocker (+4,1,-2) (+augenauf, +bcotton, +lruzicka, +nielsenb, geraldosimiao, -catanzaro, -frantisekz) (adamw, 16:09:09)
    5. AGREED: 2177153 - punt (delay decision) - we don't have a clear enough vote here. We'll delay the decision in the hopes of getting more votes and/or a fix (adamw, 16:26:14)

  5. (2180277) gnome-shell crashes and sysops happens when users logout (adamw, 16:26:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2180277 (adamw, 16:26:54)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1123 (adamw, 16:26:54)
    3. Proposed Blocker, gnome-shell, NEW (adamw, 16:26:55)
    4. Ticket vote: FinalBlocker (+1,0,-5) (+geraldosimiao, -adamwill, -frantisekz, -bcotton, -nielsenb, -lruzicka) (adamw, 16:26:57)
    5. Ticket vote: FinalFreezeException (+7,0,-0) (+adamwill, +frantisekz, +bcotton, +catanzaro, +nielsenb, +lruzicka, +tablepc) (adamw, 16:26:59)
    6. https://fedoraproject.org/wiki/Fedora_38_Final_Release_Criteria#SELinux_and_crash_notifications (geraldosimiao, 16:28:23)
    7. AGREED: 2180277 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this doesn't violate the release criteria, but it's a polish issue you can run into before updating so we agree it deserves an FE (adamw, 16:34:29)

  6. Proposed Final freeze exceptions (adamw, 16:35:01)
    1. 2179591 was accepted as a blocker by ticket vote so we'll skip that one (adamw, 16:35:38)

  7. (2179854) Qt 5 render the Bold style CJK character very thick with Noto CJK variable fonts (adamw, 16:35:44)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2179854 (adamw, 16:35:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1130 (adamw, 16:35:50)
    3. Proposed Freeze Exceptions, qt5-qtbase, MODIFIED (adamw, 16:36:09)
    4. AGREED: 2179854 - AcceptedFreezeException (Final) - this is accepted as a clear visual quality issue that will be encountered on live boots by CJK users (adamw, 16:43:06)

  8. Accepted Final blockers (adamw, 16:43:53)
    1. we are just checking in on these, not voting again (unless we decide it's merited) (adamw, 16:43:54)

  9. (2170878) Insecure installed RPMs (like Google Chrome) prevent system updates in F38, can't be removed (adamw, 16:44:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2170878 (adamw, 16:44:23)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1039 (adamw, 16:44:23)
    3. Accepted Blocker, crypto-policies, ASSIGNED (adamw, 16:44:24)
    4. this is being handled, probably it will be flipped back CLOSED and a common bugs note added. see https://bugzilla.redhat.com/show_bug.cgi?id=2170878#c129 (adamw, 16:46:45)

  10. (2171350) anaconda failed to detect the fcoe target(only affects ixgbe) (adamw, 16:47:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2171350 (adamw, 16:47:14)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1041 (adamw, 16:47:17)
    3. Accepted Blocker, kernel, NEW (adamw, 16:47:23)
    4. this one seems to be getting shopped around maintainers to find one who'll take responsibility for it (adamw, 16:47:37)
    5. i've pinged jforbes, he'll take a look when he has a minute (adamw, 16:49:15)

  11. (2176782) The kernel sometimes does not initialize SimpleDRM when booting in basic graphics mode on BIOS, causing SDDM to fail (adamw, 16:51:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2176782 (adamw, 16:51:37)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1086 (adamw, 16:51:38)
    3. Accepted Blocker, kernel, POST (adamw, 16:51:40)
    4. this bug sort of exposes lots of things to think about, but for the immediate future we have a plan that should...probably work. it'd be good if more folks can test booting an F38 KDE live in basic graphics mode with vga=791 and see if it works for them (adamw, 16:54:38)

  12. (2179591) Logging out of Plasma 5.27.3 on Wayland as the second user on the system resulted in a black screen (adamw, 16:56:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2179591 (adamw, 16:56:13)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1122 (adamw, 16:56:13)
    3. Accepted Blocker, kwin, NEW, depends on other bugs (adamw, 16:56:15)
    4. we have a possible theory of what causes this bug and a fix for it (an SELinux denial and an selinux-policy update), but the problem is not reliably reproducible so confirming the fix is a bit difficult (adamw, 16:58:08)
    5. we'll continue to look into this one as it's a bit slippery (adamw, 17:04:10)

  13. (2172956) Update hostkey migration to support OSTree systems and dynamically detect hostkey location (adamw, 17:04:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2172956 (adamw, 17:04:15)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1050 (adamw, 17:04:18)
    3. Accepted Blocker, openssh, MODIFIED (adamw, 17:04:21)
    4. work is ongoing to clean this up, just need to ensure the right changes are included in the update (adamw, 17:06:08)

  14. (2174563) Virtual keyboard (on-screen) not working at sddm-wayland-plasma (adamw, 17:07:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2174563 (adamw, 17:08:00)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1061 (adamw, 17:08:02)
    3. Accepted Blocker, sddm, NEW (adamw, 17:08:24)
    4. this one is tricky, and apparently making it work on wayland the way it works on X.org (you click the virtual keyboard button, and you get a virtual keyboard) is not simple. we will continue to evaluate the options here (adamw, 17:18:10)

  15. (2113005) Live image made with BOOTX64.EFI from latest shim-x64-15.6-2 fails to boot on some boards (adamw, 17:22:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2113005 (adamw, 17:22:31)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1087 (adamw, 17:22:35)
    3. Accepted Blocker, shim, NEW (adamw, 17:22:37)
    4. https://techcommunity.microsoft.com/t5/hardware-dev-center/updated-uefi-signing-requirements/ba-p/1062916 (geraldosimiao, 17:24:17)
    5. AIUI, this is still blocked on kernel support for NX, for which https://lkml.org/lkml/2023/3/14/390 seems to be the most recent patch series proposal ATM (v5). we may well have to waive it at this point (adamw, 17:32:29)

  16. Open floor (adamw, 17:34:11)


Meeting ended at 17:54:53 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (157)
  2. geraldosimiao (45)
  3. frantisekz (21)
  4. marcdeop[m] (20)
  5. zodbot (13)
  6. lruzicka (13)
  7. aleasto (7)
  8. coremodule (1)
  9. kparal (1)
  10. marcdeop (0)


Generated by MeetBot 0.4.