#fedora-blocker-review: F38-blocker-review

Meeting started by adamw at 16:01:10 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:16)
  2. Introduction (adamw, 16:06:45)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:06:51)
    2. We'll be following the process outlined at: (adamw, 16:06:53)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:06:55)
    4. The bugs up for review today are available at: (adamw, 16:06:58)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:01)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:03)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:06)
    8. https://fedoraproject.org/wiki/Fedora_38_Beta_Release_Criteria (adamw, 16:07:09)
    9. https://fedoraproject.org/wiki/Fedora_38_Final_Release_Criteria (adamw, 16:07:11)
    10. for Final, we have: (adamw, 16:07:25)
    11. 2 Proposed Blockers (adamw, 16:07:29)
    12. 3 Accepted Blockers (adamw, 16:07:32)
    13. 3 Proposed Freeze Exceptions (adamw, 16:07:34)
    14. 6 Accepted Freeze Exceptions (adamw, 16:07:41)
    15. coremodule will secretarialize (adamw, 16:07:47)

  3. Proposed Final blockers (adamw, 16:07:54)
  4. (2180849) Gnome desktop notifications shown at the wrong times (adamw, 16:07:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2180849 (adamw, 16:08:01)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1134 (adamw, 16:08:05)
    3. Proposed Blocker, gnome-shell, NEW (adamw, 16:08:06)
    4. Ticket vote: FinalBlocker (+0,0,-1) (-frantisekz) (adamw, 16:08:10)
    5. AGREED: 2180849 - RejectedBlocker (Final) - it was agreed this is just too much of a corner case to constitute a violation of the panel or update notification criteria, so it's rejected (adamw, 16:15:26)

  5. (2183034) packages with file capabilities fail to install in podman on F38 host (adamw, 16:15:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2183034 (adamw, 16:15:36)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1132 (adamw, 16:15:38)
    3. Proposed Blocker, podman, NEW (adamw, 16:15:40)
    4. Ticket vote: FinalBlocker (+1,0,-3) (+sumantrom, -nielsenb, -geraldosimiao, -frantisekz) (adamw, 16:15:43)
    5. AGREED: 2183034 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this is rejected as we really do not have the framework in place to treat toolbox as release blocking for now (see tickets). it's accepted as an FE, though, as it would definitely be good to have it working at release for the increasingly popular immutable editions (adamw, 16:29:55)

  6. Proposed Final freeze exceptions (adamw, 16:30:16)
  7. (2183038) Rebuild to pull in cryptographic fixes for RPM (bug 2170878) (adamw, 16:30:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2183038 (adamw, 16:30:24)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1135 (adamw, 16:30:26)
    3. Proposed Freeze Exceptions, fedora-toolbox, ON_QA (adamw, 16:30:29)
    4. AGREED: 2170878 - AcceptedFreezeException (Final) - obviously it'd be good to have the known cryptographic issues fixed in the toolbox image too (adamw, 16:35:06)

  8. (2184091) LLVM 16 pull Into Fedora 38 (FreezeException) (adamw, 16:35:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2184091 (adamw, 16:35:15)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1136 (adamw, 16:35:18)
    3. Proposed Freeze Exceptions, llvm, NEW (adamw, 16:35:21)
    4. https://pagure.io/fesco/issue/2958#comment-843760 (bcotton, 16:39:51)
    5. AGREED: 2184091 - punt (delay decision) - we do not have a clear vote on this (we are at +2 / -3 for a total of -1), so we will punt it. note this is effectively close to a rejection, as we are very unlikely to accept this later if we don't accept it now. (adamw, 17:07:03)

  9. (2176759) Some apps take much longer to start in Plasma in F38 than F37 if xdg-desktop-portal-gnome is installed (adamw, 17:07:09)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2176759 (adamw, 17:07:12)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1133 (adamw, 17:07:14)
    3. Proposed Freeze Exceptions, xdg-desktop-portal-gnome, POST (adamw, 17:07:17)
    4. Ticket vote: FinalFreezeException (+2,0,-0) (+adamwill, +geraldosimiao) (adamw, 17:07:19)
    5. AGREED: 2176759 - AcceptedFreezeException - This is behavior that would be good to fix for the live images. (adamw, 17:13:41)
    6. AGREED: 2176759 - AcceptedFreezeException - This is behavior that would be good to fix for the live images. (bcotton, 17:13:44)

  10. Accepted Final blockers (adamw, 17:14:10)
  11. (2171350) anaconda failed to detect the fcoe target(only affects ixgbe) (adamw, 17:14:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2171350 (adamw, 17:14:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1041 (adamw, 17:14:23)
    3. Accepted Blocker, kernel, NEW (adamw, 17:14:26)
    4. this is pending re-testing with different hardware, it may not be a blocker in the end. see details in bug (adamw, 17:15:32)

  12. (2179591) Logging out of Plasma 5.27.3 on Wayland as the second user on the system resulted in a black screen (adamw, 17:17:57)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2179591 (adamw, 17:18:00)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1122 (adamw, 17:18:03)
    3. Accepted Blocker, plasma-workspace, NEW, depends on other bugs (adamw, 17:18:06)
    4. this is still under investigation, but it seems difficult to reproduce reliably and debug. we will continue to work on it (adamw, 17:29:11)

  13. (2113005) Live image made with BOOTX64.EFI from latest shim-x64-15.6-2 fails to boot on some boards (adamw, 17:31:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2113005 (adamw, 17:31:14)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1087 (adamw, 17:31:17)
    3. Accepted Blocker, shim, NEW (adamw, 17:31:20)
    4. this is still waiting on the upstream NX patches, which AFAICS haven't moved since mid-March. we will likely have to waive it (adamw, 17:34:47)
    5. https://lkml.org/lkml/2023/3/14/390 (adamw, 17:36:33)

  14. Open floor (adamw, 17:39:04)


Meeting ended at 17:45:55 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (168)
  2. Eighth_Doctor (53)
  3. kparal (34)
  4. frantisekz (26)
  5. bcotton (25)
  6. lruzicka (21)
  7. TheExorcist[m] (20)
  8. zodbot (19)
  9. geraldosimiao (18)
  10. marcdeop[m] (10)
  11. davdunc[m (7)
  12. jforbes (4)
  13. SumantroMukherje (3)
  14. coremodule (2)


Generated by MeetBot 0.4.